You are not logged in.

Dear visitor, welcome to VDR Portal. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

941

Tuesday, January 11th 2011, 2:48am

Quoted

Original von m.Rcu
[...] aber der eigentlich Fehler war das xorg-update unter gentoo. ...


Ich würde empfehlen nach einem Update von xorg auch die Treiber neu zu bauen. ;)

Source code

1
emerge -av $(qlist -IC x11-drivers)

:!: Hier nicht klicken!!



dreipo.cc

"Ubuntu" -- An african Word, meaning: "Gentoo is too hard for me".

my VDR


Gen2VDR V4.3PO

VDR: vdr-2.1.6
Mainboard: ASUS P8Z77-V LX2
CPU: i7-3770K
RAM: 16G
System HDD: OCZ-VERTEX4 SSD, 120 GB
Video HDD: WD Caviar Green, 3 TB
BD-ROM: Samsung SH-B123L
Gehäuse: Thermaltake DH202 Touch (VM90051N2Z)
DVB: DD Cine S2 V6.5 & DuofleX C/T
IR/FB: yaUSBIR v3 ; Harmony 885

herrlado

Professional

Posts: 721

Location: Kassel

Occupation: Softwareentwickler

  • Send private message

942

Monday, January 17th 2011, 12:39am

Funktioniert denn das Autocrop Plugin nicht beim Abspielen von Aufnahmen?

Gruß,
Lado

herrlado's VDR

ASUS P8H77-M LE, 4GB DDR3-1333, Core i3 2100T / Asus NVidia GT 610 (mit 1GB RAM ) / yaVDR 0.5 (testing-vdr, testing-xbmc) / 3.5.0-27er Kernel / TeVii S480 & TT S2-1600 / softhddevice / yaUsbIR V3 mit Logitech Harmony 600 / Samsung UE40B8000 über HDMI / 50Hz / 13.0°,19.2°,28.2°,42.0°

943

Monday, January 17th 2011, 10:04am

Quoted

Original von herrlado
Funktioniert denn das Autocrop Plugin nicht beim Abspielen von Aufnahmen?


ja, funktioniert perfekt - auch bei aufnahmen ;)

gruß, ciax
Lascala LC17 - tribute to viking ;o) + atric IR / AMD X2 BE-2400 / DVB-S2 TT3200 + DigitalDevices CineS2 (defekt) / yavdr stable / output: graphTFT-fe via 6.4" TFT & DVB-S/S2 via FullHD / NVidia GT220 passiv

herrlado

Professional

Posts: 721

Location: Kassel

Occupation: Softwareentwickler

  • Send private message

944

Monday, January 17th 2011, 10:28am

Quoted

Originally posted by ciax

Quoted

Original von herrlado
Funktioniert denn das Autocrop Plugin nicht beim Abspielen von Aufnahmen?


ja, funktioniert perfekt - auch bei aufnahmen ;)

gruß, ciax


Hmm danke. Dann muss ich was falsch gemacht haben.

Gruß,
Lado

herrlado's VDR

ASUS P8H77-M LE, 4GB DDR3-1333, Core i3 2100T / Asus NVidia GT 610 (mit 1GB RAM ) / yaVDR 0.5 (testing-vdr, testing-xbmc) / 3.5.0-27er Kernel / TeVii S480 & TT S2-1600 / softhddevice / yaUsbIR V3 mit Logitech Harmony 600 / Samsung UE40B8000 über HDMI / 50Hz / 13.0°,19.2°,28.2°,42.0°

945

Friday, January 21st 2011, 5:41pm

rnissl-patches

Hallo,

von Reinhard Nißl wurde ein Satz interessanter Patches für die xinelib bereitgestellt mit denen einige Abspielprobleme insbesondere von ARD/ZDF HD Aufnahmen beseitigt oder zumindestens verbessert werden.
Ich habe immer mal wieder Aufnahmen von besagten Sendern die beim Abspielen mit xineliboutput oder xine einfach stehen bleiben.
Im xine Log werden dann "vpts/clock error" Meldungen ausgegeben.
Workaround war bisher einfach ein wenig weiterzuspringen in der Aufnahme.

Mit den Patches von Reinhard laufen meine Testaufnahmen jetzt alle bezüglich der Bildes einwandfrei durch. Es kommt nur noch beim Ton zu kurzen Aussetzern bei besagten Problemstellen.

Ich habe die Patches im git Repository in einem eigenen Branch mit Namen "rnissl-patches" hochgeladen. Der Branch beinhaltet natürlich auch den vdpau-extensions-patch. Mit dem stream-start-patch vertragen sich Reinhards Patches überigens nicht so richtig. Meine Testaufnahmen bleiben dann wieder hängen.

In der xine config Datei werten die Patches ein neues Parameter aus das folgendermaßen von Hand gesetzt werden muss:

# disable decoder flush at discontinuity
# bool, default: 0
engine.decoder.disable_flush_at_discontinuity:1

Eine nähere Beschreibung zu den Patches könnt Ihr den commit-Meldungen im git entnehmen.

Gruss
durchflieger
Server: Asus M3N-H/HDMI, AMD X2 5600+, 4GB RAM, 500GB+1,5TB Samsung HD, 2xTevii S470, 1xTT-S3200, Ubuntu/V12.04, vdr 1.7.27
Client1: ZOTAC ION-ITX B, 2GB RAM, Diskless/Netboot per PXE, Xubuntu/V12.04, vdr 1.7.27+softhddevice, XBMC V12.1, LG42LC2R LCD-TV
Client2: Wie 1 aber ZOTAC ION-ITX E , DFAtmo, 2xDF10CH 19 Kanal Atmolight, LG37LC2R LCD-TV


946

Saturday, January 22nd 2011, 12:35pm

This post has been edited 1 times, last edit by "hotzenplotz5" (Jan 22nd 2011, 12:35pm)


947

Saturday, January 22nd 2011, 3:10pm

Hallo, mit den neuen Patches sind die Störungen, die man sonst ohne stream-start.patch hatte, bei mir nicht mehr da!
Falls es eine Rolle spielt, ich habe zusätzlich zu engine.decoder.disable_flush_at_discontinuity:1 noch engine.decoder.disable_flush_from_video_out:1 gesetzt.
Vielen Dank an Reinhard!
Jörg

Mein VDR

Asrock M3A770DE, Sempron 140 @ DualCore, 3 x TT S2-1600, GT520
openSuse 13.1 64bit, Kernel 3.14.13 + BER/UNC-Patch für stv090x, nvidia 340.24, vdr 2.1.6 mit Patchen (checkts, naludump, statusleds, ...)

948

Saturday, January 22nd 2011, 4:59pm

Source code

1
2
3
# disable decoder flush from video out
# bool, default: 0
engine.decoder.disable_flush_from_video_out:1
Der Parameter verhindert das Spulen von SkyHD und HD+ Aufnahmen :(

Gruß
iNOB

Mein VDR

Hartware: Gehäuse: Ahanix MCE 302, Mobo: Kontron 986LCD-M/mITX, CPU: Intel Core2 Duo Mobile T7400 2,16GHz, 2GB RAM, SAT: Digital Devices DuoFlex S2 miniPCIe, Graka: ASUS EN210 Silent 1GD3, 4x2TB 3,5" WD HD, 1x DVD-Brenner Pioneer, Atric IR-Einschalter+Empfänger, FB One-For-All URC-7960, SoundGraph iMON LCD ( MFP5I, 15c2:0038 )
Weichware: Wheezy (x86_64), Kernel 3.8.13, NVidia v340.17, VDR 2.1.6 gepatched

949

Saturday, January 22nd 2011, 6:05pm

Hat eigentlich schon mal jemand Erfahrungen mit dem vdpau_progressive_detection Patch von Seite 45 gesammelt?

Mein VDR

Asrock M3A770DE, Sempron 140 @ DualCore, 3 x TT S2-1600, GT520
openSuse 13.1 64bit, Kernel 3.14.13 + BER/UNC-Patch für stv090x, nvidia 340.24, vdr 2.1.6 mit Patchen (checkts, naludump, statusleds, ...)

rnissl

Intermediate

Posts: 554

Location: Kulz / Thanstein

Occupation: Software-Entwickler

  • Send private message

950

Saturday, January 22nd 2011, 9:59pm

Hi,

Quoted

Original von iNOB

Source code

1
2
3
# disable decoder flush from video out
# bool, default: 0
engine.decoder.disable_flush_from_video_out:1
Der Parameter verhindert das Spulen von SkyHD und HD+ Aufnahmen :(


Was bedeutet spulen?
Welches plugin (vdr-xine)?

Bye.
--
Dipl.-Inform. (FH) Reinhard Nissl
mailto:rnissl@gmx.de

951

Saturday, January 22nd 2011, 10:31pm

Jepp... xine als Frontend. Beim Spulen > vorwärts bleibt Bild und die Zeitanzeige stehen, sonst passiert nix. Beim Spulen < rückwärts läuft die Zeitanzeige und das Bild bleibt stehen. Beim Drücken von Play wird das Bild aktualisiert und die Aufnahme wird abgespielt. Schaltet man "engine.decoder.disable_flush_from_video_out:0" aus, funktioniert das Spulen mit Bildaktualisierung vorwärts und rückwärts.

Springen funktioniert unabhängig vom genannten Parameter.

Gruß
iNOB

Mein VDR

Hartware: Gehäuse: Ahanix MCE 302, Mobo: Kontron 986LCD-M/mITX, CPU: Intel Core2 Duo Mobile T7400 2,16GHz, 2GB RAM, SAT: Digital Devices DuoFlex S2 miniPCIe, Graka: ASUS EN210 Silent 1GD3, 4x2TB 3,5" WD HD, 1x DVD-Brenner Pioneer, Atric IR-Einschalter+Empfänger, FB One-For-All URC-7960, SoundGraph iMON LCD ( MFP5I, 15c2:0038 )
Weichware: Wheezy (x86_64), Kernel 3.8.13, NVidia v340.17, VDR 2.1.6 gepatched

This post has been edited 1 times, last edit by "iNOB" (Jan 22nd 2011, 10:34pm)


952

Saturday, January 22nd 2011, 10:51pm

Quoted

Original von iNOB
Jepp... xine als Frontend. Beim Spulen > vorwärts bleibt Bild und die Zeitanzeige stehen, sonst passiert nix. Beim Spulen < rückwärts läuft die Zeitanzeige und das Bild bleibt stehen. Beim Drücken von Play wird das Bild aktualisiert und die Aufnahme wird abgespielt. Schaltet man "engine.decoder.disable_flush_from_video_out:0" aus, funktioniert das Spulen mit Bildaktualisierung vorwärts und rückwärts.

Springen funktioniert unabhängig vom genannten Parameter.

Gruß
iNOB


Nabend,

die Aussage kann ich voll und ganz bestätigen.

Auch xine als Frontend mit aktueller xine-lib-1.2 und vdpauextension-patch-Vers. 20.

Gruß
Wolfgang
Hardware: -
Software: -

rnissl

Intermediate

Posts: 554

Location: Kulz / Thanstein

Occupation: Software-Entwickler

  • Send private message

953

Sunday, January 23rd 2011, 1:26am

Hi,

hab' gerade die H.264 stillimages in xine-lib ausgebessert. Bei mir Spulen solche HD Aufnahmen problemlos. Bin aber zu faul, um nochmals die Korrektur rauszunehmen.

Bitte mal mit den Patches auf xine-devel probieren.

Bye.
--
Dipl.-Inform. (FH) Reinhard Nissl
mailto:rnissl@gmx.de

954

Sunday, January 23rd 2011, 11:17am

@rnissl
vielen Dank für die Patches! Hab mal alles was es auf xine-dev gibt reingepatcht. Das Einpendeln (Klötzchen beim Umschalten/Spulen) geht mit gesetztem "engine.decoder.disable_flush_from_video_out:1" fast gegen Null. :respekt

Leider ändern die Patches nichts an dem oben erwähnten Spulproblem bei SkyHD und HD+ Aufnahmen. Hängt das eventuell auch mit dem Jump & Play Patch zusammen? Meine Einstellungen:

Mehrtstufiger Vor- und Rücklauf = ja
Sprungweite in Sekunden = 360
Jump Seconds slow = 60
Jump Seconds Repeat = 300

Gruß
iNOB

Mein VDR

Hartware: Gehäuse: Ahanix MCE 302, Mobo: Kontron 986LCD-M/mITX, CPU: Intel Core2 Duo Mobile T7400 2,16GHz, 2GB RAM, SAT: Digital Devices DuoFlex S2 miniPCIe, Graka: ASUS EN210 Silent 1GD3, 4x2TB 3,5" WD HD, 1x DVD-Brenner Pioneer, Atric IR-Einschalter+Empfänger, FB One-For-All URC-7960, SoundGraph iMON LCD ( MFP5I, 15c2:0038 )
Weichware: Wheezy (x86_64), Kernel 3.8.13, NVidia v340.17, VDR 2.1.6 gepatched

This post has been edited 1 times, last edit by "iNOB" (Jan 23rd 2011, 11:40am)


955

Monday, January 24th 2011, 11:05am

hallo,

Quoted

Original von rnissl
Hi,

hab' gerade die H.264 stillimages in xine-lib ausgebessert. Bei mir Spulen solche HD Aufnahmen problemlos. Bin aber zu faul, um nochmals die Korrektur rauszunehmen.

Bitte mal mit den Patches auf xine-devel probieren.

Bye.


sind damit die patches vom 22./23.1.2011 gemeint? (http://sourceforge.net/mailarchive/forum…1101&viewday=22)

am 23.1.2011 sind auch noch andere patches eingeflossen (Julian Scheel: http://sourceforge.net/mailarchive/forum…1101&viewday=23). im "head/master" sind aber nur die 3 änderungen von rnissl eingeflossen :schiel

im "git" vom guten durchflieger ist noch der stand zuvor enthalten (http://projects.vdr-developer.org/git/?p…/rnissl-patches).

gruß, ciax
Lascala LC17 - tribute to viking ;o) + atric IR / AMD X2 BE-2400 / DVB-S2 TT3200 + DigitalDevices CineS2 (defekt) / yavdr stable / output: graphTFT-fe via 6.4" TFT & DVB-S/S2 via FullHD / NVidia GT220 passiv

fnu

Moderator

Posts: 8,139

Location: Böblingen

  • Send private message

956

Monday, January 24th 2011, 11:32am

@ciax

Nur das ich Deine Frage verstehe, wenn ich die summary von df's git hier anschaue sind Patches von rnissl drin, oder?

Nur die letzten o.a. fehlen?

Regards
fnu
Gib HD+/CI+ keine Chance! >> HowTo: APT Pinning <<

>>click<< for my VDR stuff

[¹] Modu CD21, MeanWell (80W)/LC-Power (75W), Futaba MDM166A, Intel DH77EB, G1610, 4GB DDR3, Intel 313 SSD 24GB, WD20EFRX 2TB, Zotac GT630 ('GK208'), SHDD, L4M Twin S2 (V5.6)/FlexS2 (4x DVB-S2), rt Unicable®, CIR, Ubuntu LTS 12.04.4, VDR 2.1.6 (x64, 44W)
[²] Modu CD21, MeanWell (80W)/PicoPSU (90W), Futaba MDM166A, ASRock Q1900M, 2GB DDR3, Intel 320 SSD 40GB, WD10JFCX, Palit GT630 ('GK208'), SHDD, Octopus Net SAT>IP, rt Unicable®, mceusb, Ubuntu Trusty, VDR 2.1.6 (x64, 24W)
[³] Cooler Master Elite 360, Xilence SPS-XP250.SFX (250W), Intel DH77KC, Xeon E3-1245v2, 8GB DDR3, Intel 313 SSD 24GB (Sys & HostCache), HP SA P400 256MB BBWC, 4x WD7500BPKX@Backpl., L4M Twin S2 (V5.4), VMWare ESXi 5.5 (6 VM)(x64, 45W)

957

Monday, January 24th 2011, 11:39am

Quoted

Original von fnu
@ciax

Nur die letzten o.a. fehlen?


ja, nur die letzten (von Reinhard Nißl) fehlen, die aber in den offiziellen "master" geflossen sind. Julian Scheel hat auch noch "vdpau"-spezifische nachgeschoben .. oder wurden die von Reinhard nur verfiziert. ich blick eben nicht ganz durch :monster1

gruß, ciax
Lascala LC17 - tribute to viking ;o) + atric IR / AMD X2 BE-2400 / DVB-S2 TT3200 + DigitalDevices CineS2 (defekt) / yavdr stable / output: graphTFT-fe via 6.4" TFT & DVB-S/S2 via FullHD / NVidia GT220 passiv

958

Monday, January 24th 2011, 11:59am

Mahlzeit,

ich helfe mal ein bisschen, was hier liegt:

http://projects.vdr-developer.org/git/?p…b.git;a=summary

ist Stand von Debian-hg von gestern Abend.

Was hier liegt hat die ersten 4 Patches von Reinhard, aber nicht die letzten drei vom Master (debian-hg):

http://projects.vdr-developer.org/git/?p…/rnissl-patches

=> hier ist aber der vdpauextension-Patch drinnen.

Die anderen beiden sind jeweils ohne alle 7 Patches von Reinhard.

Gruß
Wolfgang
Hardware: -
Software: -

959

Monday, January 24th 2011, 12:48pm

danke für die aufklärung Wolfgang,

mich irritiert nur, daß die von Julian Scheel eingelieferten patches u.a. genau die gleiche bezeichnung haben, wie die von Reinhard Nißl. im master-tree ist dann der "commiter" wieder Reinhard. naja egal, durchflieger zieht das sicher wie immer sauber nach .. :)

gruß, ciax

ps: danke für all die arbeit an der xine-lib und den ausgabe-plugins - es läuft jetzt ziemlich rund (das mit dem spulen bei sky-aufnahmen - berichtet von iNOB und Wolfgang - muß ich erst noch gegechecken ...).
Lascala LC17 - tribute to viking ;o) + atric IR / AMD X2 BE-2400 / DVB-S2 TT3200 + DigitalDevices CineS2 (defekt) / yavdr stable / output: graphTFT-fe via 6.4" TFT & DVB-S/S2 via FullHD / NVidia GT220 passiv

mgoeben

Intermediate

Posts: 212

Location: Höhr-Grenzhausen

  • Send private message

960

Monday, January 24th 2011, 1:17pm

Hi, ich habe mal eine Frage zu den Konfigurationsmöglichkeiten, es gibt mindestens 4 verschiedene, aber welche wann gebraucht wird, ist mir unklar.

(1) /etc/vdr/setup.conf xineliboutput.*
(2) /etc/vdr/setup.conf xine.*
(3) /etc/vdr/plugins/xineliboutput/config
(4) <userhome>/.xine/.config

Ich frage deshalb, da ich ewig Probleme damit hatte über hdmi Dolby auszugeben, und schlussendlich lag es daran dass (3) andere Einstellungen als (4) hatte. Und ich fälschlicherweise davon ausgegangen war dass (3) keine Auswirkung auf die Ausgabe des Tons hat.
(1) und (2) habe ich mal aufgeführt, weil mich wundert, dass ich allen Anleitungen zufolge erstmal ein paar dieser Einstellungen in meine setup.conf kopieren muss, anstatt dass sie beim ersten Laden des Plugins gesetzt werden. xine.* wundert mich da ich ja das xine Plugin hier nicht einsetze.

Marco
Mein aktueller HD VDR:
Hardware: Gehäuse: JCP-MI-105.B, MB Zotac IONITX A, 2 x TT DVB-S2-3600, LCD l4m320t, HD WD EVDS 2TB, Atric Einschalter, Logitech Harmony 700
Software: Gentoo, vdr-1.7.17, xine-lib 1.2 mit df-osd-handling-patch-alter-vdpau-h264-decoder Patch, xineliboutput-cvs + vdr-sxfe

This post has been edited 2 times, last edit by "mgoeben" (Jan 24th 2011, 1:21pm)