Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: VDR Portal. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

Beiträge: 9 067

Wohnort: Schwabenländle

Beruf: Bootmanager

  • Nachricht senden

941

Dienstag, 11. Januar 2011, 02:48

Zitat

Original von m.Rcu
[...] aber der eigentlich Fehler war das xorg-update unter gentoo. ...


Ich würde empfehlen nach einem Update von xorg auch die Treiber neu zu bauen. ;)

Quellcode

1
emerge -av $(qlist -IC x11-drivers)

Beiträge: 747

Wohnort: Kassel

Beruf: Softwareentwickler

  • Nachricht senden

942

Montag, 17. Januar 2011, 00:39

Funktioniert denn das Autocrop Plugin nicht beim Abspielen von Aufnahmen?

Gruß,
Lado

herrlado(DJ9LK)'s VDR

ASUS P8H77-M LE, 4GB DDR3-1333, Core i3 2100T / Asus NVidia GT 610 (mit 1GB RAM ) / yaVDR 0.5 (testing-vdr, testing-xbmc) / 3.5.0-27er Kernel / TeVii S480 & TT S2-1600 / softhddevice / yaUsbIR V3 mit Logitech Harmony 600 / Samsung UE40B8000 über HDMI / 50Hz / 13.0°,19.2°,28.2°,42.0°

943

Montag, 17. Januar 2011, 10:04

Zitat

Original von herrlado
Funktioniert denn das Autocrop Plugin nicht beim Abspielen von Aufnahmen?


ja, funktioniert perfekt - auch bei aufnahmen ;)

gruß, ciax
Lascala LC17 - tribute to viking ;o) + atric IR / AMD X2 BE-2400 / OctopusNet S4 / yavdr-(testing) vdr / output: graphTFT-fe via 6.4" TFT & DVB-S/S2 via FullHD / NVidia GT220 passiv

Beiträge: 747

Wohnort: Kassel

Beruf: Softwareentwickler

  • Nachricht senden

944

Montag, 17. Januar 2011, 10:28

Zitat

Originally posted by ciax

Zitat

Original von herrlado
Funktioniert denn das Autocrop Plugin nicht beim Abspielen von Aufnahmen?


ja, funktioniert perfekt - auch bei aufnahmen ;)

gruß, ciax


Hmm danke. Dann muss ich was falsch gemacht haben.

Gruß,
Lado

herrlado(DJ9LK)'s VDR

ASUS P8H77-M LE, 4GB DDR3-1333, Core i3 2100T / Asus NVidia GT 610 (mit 1GB RAM ) / yaVDR 0.5 (testing-vdr, testing-xbmc) / 3.5.0-27er Kernel / TeVii S480 & TT S2-1600 / softhddevice / yaUsbIR V3 mit Logitech Harmony 600 / Samsung UE40B8000 über HDMI / 50Hz / 13.0°,19.2°,28.2°,42.0°

945

Freitag, 21. Januar 2011, 17:41

rnissl-patches

Hallo,

von Reinhard Nißl wurde ein Satz interessanter Patches für die xinelib bereitgestellt mit denen einige Abspielprobleme insbesondere von ARD/ZDF HD Aufnahmen beseitigt oder zumindestens verbessert werden.
Ich habe immer mal wieder Aufnahmen von besagten Sendern die beim Abspielen mit xineliboutput oder xine einfach stehen bleiben.
Im xine Log werden dann "vpts/clock error" Meldungen ausgegeben.
Workaround war bisher einfach ein wenig weiterzuspringen in der Aufnahme.

Mit den Patches von Reinhard laufen meine Testaufnahmen jetzt alle bezüglich der Bildes einwandfrei durch. Es kommt nur noch beim Ton zu kurzen Aussetzern bei besagten Problemstellen.

Ich habe die Patches im git Repository in einem eigenen Branch mit Namen "rnissl-patches" hochgeladen. Der Branch beinhaltet natürlich auch den vdpau-extensions-patch. Mit dem stream-start-patch vertragen sich Reinhards Patches überigens nicht so richtig. Meine Testaufnahmen bleiben dann wieder hängen.

In der xine config Datei werten die Patches ein neues Parameter aus das folgendermaßen von Hand gesetzt werden muss:

# disable decoder flush at discontinuity
# bool, default: 0
engine.decoder.disable_flush_at_discontinuity:1

Eine nähere Beschreibung zu den Patches könnt Ihr den commit-Meldungen im git entnehmen.

Gruss
durchflieger
Server: Asus M3N-H/HDMI, AMD X2 5600+, 4GB RAM, 500GB+1,5TB Samsung HD, 2xTevii S470, 1xTT-S3200, Ubuntu/V12.04, vdr 1.7.27
Client1: ZOTAC ION-ITX B, 2GB RAM, Diskless/Netboot per PXE, Xubuntu/V12.04, vdr 1.7.27+softhddevice, XBMC V12.1, LG42LC2R LCD-TV
Client2: Wie 1 aber ZOTAC ION-ITX E , DFAtmo, 2xDF10CH 19 Kanal Atmolight, LG37LC2R LCD-TV


946

Samstag, 22. Januar 2011, 12:35

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »hotzenplotz5« (22. Januar 2011, 12:35)


947

Samstag, 22. Januar 2011, 15:10

Hallo, mit den neuen Patches sind die Störungen, die man sonst ohne stream-start.patch hatte, bei mir nicht mehr da!
Falls es eine Rolle spielt, ich habe zusätzlich zu engine.decoder.disable_flush_at_discontinuity:1 noch engine.decoder.disable_flush_from_video_out:1 gesetzt.
Vielen Dank an Reinhard!
Jörg

Mein VDR

Asrock M3A770DE, Sempron 140 @ DualCore, 3 x TT S2-1600, GT520
openSuse 42.2 64bit, Kernel 4.4.36 mit dddvb 0.9.26, nvidia 375.20, vdr 2.2.0 mit Patchen (checkts, naludump, statusleds, ...)

948

Samstag, 22. Januar 2011, 16:59

Quellcode

1
2
3
# disable decoder flush from video out
# bool, default: 0
engine.decoder.disable_flush_from_video_out:1
Der Parameter verhindert das Spulen von SkyHD und HD+ Aufnahmen :(

Gruß
iNOB

Mein VDR

Hartware: Gehäuse: Ahanix MCE 302, Mobo: Kontron 986LCD-M/mITX, CPU: Intel Core2 Duo Mobile T7400 2,16GHz, 2GB RAM, SAT: Digital Devices DuoFlex S2 miniPCIe, Graka: ASUS GeForce GT 730 ( GK208 ) Silent, 4x4TB 3,5" WD Red HD, 1x DVD-Brenner Pioneer, Atric IR-Einschalter+Empfänger, FB One-For-All URC-7960, SoundGraph iMON LCD ( MFP5I, 15c2:0038 )
Weichware: Jessie (x86_64), Kernel 3.16, NVidia v364.19, VDR 2.2.0 gepatched

949

Samstag, 22. Januar 2011, 18:05

Hat eigentlich schon mal jemand Erfahrungen mit dem vdpau_progressive_detection Patch von Seite 45 gesammelt?

Mein VDR

Asrock M3A770DE, Sempron 140 @ DualCore, 3 x TT S2-1600, GT520
openSuse 42.2 64bit, Kernel 4.4.36 mit dddvb 0.9.26, nvidia 375.20, vdr 2.2.0 mit Patchen (checkts, naludump, statusleds, ...)

rnissl

Fortgeschrittener

Beiträge: 555

Wohnort: Kulz / Thanstein

Beruf: Software-Entwickler

  • Nachricht senden

950

Samstag, 22. Januar 2011, 21:59

Hi,

Zitat

Original von iNOB

Quellcode

1
2
3
# disable decoder flush from video out
# bool, default: 0
engine.decoder.disable_flush_from_video_out:1
Der Parameter verhindert das Spulen von SkyHD und HD+ Aufnahmen :(


Was bedeutet spulen?
Welches plugin (vdr-xine)?

Bye.
--
Dipl.-Inform. (FH) Reinhard Nissl
mailto:rnissl@gmx.de

951

Samstag, 22. Januar 2011, 22:31

Jepp... xine als Frontend. Beim Spulen > vorwärts bleibt Bild und die Zeitanzeige stehen, sonst passiert nix. Beim Spulen < rückwärts läuft die Zeitanzeige und das Bild bleibt stehen. Beim Drücken von Play wird das Bild aktualisiert und die Aufnahme wird abgespielt. Schaltet man "engine.decoder.disable_flush_from_video_out:0" aus, funktioniert das Spulen mit Bildaktualisierung vorwärts und rückwärts.

Springen funktioniert unabhängig vom genannten Parameter.

Gruß
iNOB

Mein VDR

Hartware: Gehäuse: Ahanix MCE 302, Mobo: Kontron 986LCD-M/mITX, CPU: Intel Core2 Duo Mobile T7400 2,16GHz, 2GB RAM, SAT: Digital Devices DuoFlex S2 miniPCIe, Graka: ASUS GeForce GT 730 ( GK208 ) Silent, 4x4TB 3,5" WD Red HD, 1x DVD-Brenner Pioneer, Atric IR-Einschalter+Empfänger, FB One-For-All URC-7960, SoundGraph iMON LCD ( MFP5I, 15c2:0038 )
Weichware: Jessie (x86_64), Kernel 3.16, NVidia v364.19, VDR 2.2.0 gepatched

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »iNOB« (22. Januar 2011, 22:34)


952

Samstag, 22. Januar 2011, 22:51

Zitat

Original von iNOB
Jepp... xine als Frontend. Beim Spulen > vorwärts bleibt Bild und die Zeitanzeige stehen, sonst passiert nix. Beim Spulen < rückwärts läuft die Zeitanzeige und das Bild bleibt stehen. Beim Drücken von Play wird das Bild aktualisiert und die Aufnahme wird abgespielt. Schaltet man "engine.decoder.disable_flush_from_video_out:0" aus, funktioniert das Spulen mit Bildaktualisierung vorwärts und rückwärts.

Springen funktioniert unabhängig vom genannten Parameter.

Gruß
iNOB


Nabend,

die Aussage kann ich voll und ganz bestätigen.

Auch xine als Frontend mit aktueller xine-lib-1.2 und vdpauextension-patch-Vers. 20.

Gruß
Wolfgang
Hardware: -
Software: -

rnissl

Fortgeschrittener

Beiträge: 555

Wohnort: Kulz / Thanstein

Beruf: Software-Entwickler

  • Nachricht senden

953

Sonntag, 23. Januar 2011, 01:26

Hi,

hab' gerade die H.264 stillimages in xine-lib ausgebessert. Bei mir Spulen solche HD Aufnahmen problemlos. Bin aber zu faul, um nochmals die Korrektur rauszunehmen.

Bitte mal mit den Patches auf xine-devel probieren.

Bye.
--
Dipl.-Inform. (FH) Reinhard Nissl
mailto:rnissl@gmx.de

954

Sonntag, 23. Januar 2011, 11:17

@rnissl
vielen Dank für die Patches! Hab mal alles was es auf xine-dev gibt reingepatcht. Das Einpendeln (Klötzchen beim Umschalten/Spulen) geht mit gesetztem "engine.decoder.disable_flush_from_video_out:1" fast gegen Null. :respekt

Leider ändern die Patches nichts an dem oben erwähnten Spulproblem bei SkyHD und HD+ Aufnahmen. Hängt das eventuell auch mit dem Jump & Play Patch zusammen? Meine Einstellungen:

Mehrtstufiger Vor- und Rücklauf = ja
Sprungweite in Sekunden = 360
Jump Seconds slow = 60
Jump Seconds Repeat = 300

Gruß
iNOB

Mein VDR

Hartware: Gehäuse: Ahanix MCE 302, Mobo: Kontron 986LCD-M/mITX, CPU: Intel Core2 Duo Mobile T7400 2,16GHz, 2GB RAM, SAT: Digital Devices DuoFlex S2 miniPCIe, Graka: ASUS GeForce GT 730 ( GK208 ) Silent, 4x4TB 3,5" WD Red HD, 1x DVD-Brenner Pioneer, Atric IR-Einschalter+Empfänger, FB One-For-All URC-7960, SoundGraph iMON LCD ( MFP5I, 15c2:0038 )
Weichware: Jessie (x86_64), Kernel 3.16, NVidia v364.19, VDR 2.2.0 gepatched

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »iNOB« (23. Januar 2011, 11:40)


955

Montag, 24. Januar 2011, 11:05

hallo,

Zitat

Original von rnissl
Hi,

hab' gerade die H.264 stillimages in xine-lib ausgebessert. Bei mir Spulen solche HD Aufnahmen problemlos. Bin aber zu faul, um nochmals die Korrektur rauszunehmen.

Bitte mal mit den Patches auf xine-devel probieren.

Bye.


sind damit die patches vom 22./23.1.2011 gemeint? (http://sourceforge.net/mailarchive/forum…1101&viewday=22)

am 23.1.2011 sind auch noch andere patches eingeflossen (Julian Scheel: http://sourceforge.net/mailarchive/forum…1101&viewday=23). im "head/master" sind aber nur die 3 änderungen von rnissl eingeflossen :schiel

im "git" vom guten durchflieger ist noch der stand zuvor enthalten (http://projects.vdr-developer.org/git/?p…/rnissl-patches).

gruß, ciax
Lascala LC17 - tribute to viking ;o) + atric IR / AMD X2 BE-2400 / OctopusNet S4 / yavdr-(testing) vdr / output: graphTFT-fe via 6.4" TFT & DVB-S/S2 via FullHD / NVidia GT220 passiv

956

Montag, 24. Januar 2011, 11:32

@ciax

Nur das ich Deine Frage verstehe, wenn ich die summary von df's git hier anschaue sind Patches von rnissl drin, oder?

Nur die letzten o.a. fehlen?

Regards
fnu
>> HowTo: APT Pinning <<

>>click<< for my VDR stuff

[¹] Modu CD21, MeanWell (80W)/LC-Power (75W), Futaba MDM166A, Intel DH77EB, G1610T, 2x1GB DDR3, Intel 313 SSD 24GB, WD20EFRX 2TB, Zotac GT630 ('GK208'), SHDD, Octopus Net SAT>IP (DVBS2-8), Jultech JESS, CIR, Ubuntu LTS 14.04.3, VDR 2.2.0 (x64, 35W)
[²] Modu CD21, MeanWell (80W)/PicoPSU (90W), Futaba MDM166A, ASRock Q1900M, 2x1GB DDR3, Intel 320 SSD 40GB, WD10JFCX, Palit GT630 ('GK208'), SHDD, Octopus Net SAT>IP (DVBS2-8), Jultech JESS, mceusb, Ubuntu LTS 14.04.3, VDR 2.2.0 (x64, 22W)
[³] HP ProLiant ML10 v2, Xeon E3-1225v3, 2x8GB DDR3 ECC, Intel 320 SSD 120GB (Sys & HostCache), HPVSA B120i, HPSA P420 256MB BBWC, 4x WD7500BPKX, 5x WD1003FBYX, VMWare ESXi 6.0 (6 VM)(x64, 48W)

957

Montag, 24. Januar 2011, 11:39

Zitat

Original von fnu
@ciax

Nur die letzten o.a. fehlen?


ja, nur die letzten (von Reinhard Nißl) fehlen, die aber in den offiziellen "master" geflossen sind. Julian Scheel hat auch noch "vdpau"-spezifische nachgeschoben .. oder wurden die von Reinhard nur verfiziert. ich blick eben nicht ganz durch :monster1

gruß, ciax
Lascala LC17 - tribute to viking ;o) + atric IR / AMD X2 BE-2400 / OctopusNet S4 / yavdr-(testing) vdr / output: graphTFT-fe via 6.4" TFT & DVB-S/S2 via FullHD / NVidia GT220 passiv

958

Montag, 24. Januar 2011, 11:59

Mahlzeit,

ich helfe mal ein bisschen, was hier liegt:

http://projects.vdr-developer.org/git/?p…b.git;a=summary

ist Stand von Debian-hg von gestern Abend.

Was hier liegt hat die ersten 4 Patches von Reinhard, aber nicht die letzten drei vom Master (debian-hg):

http://projects.vdr-developer.org/git/?p…/rnissl-patches

=> hier ist aber der vdpauextension-Patch drinnen.

Die anderen beiden sind jeweils ohne alle 7 Patches von Reinhard.

Gruß
Wolfgang
Hardware: -
Software: -

959

Montag, 24. Januar 2011, 12:48

danke für die aufklärung Wolfgang,

mich irritiert nur, daß die von Julian Scheel eingelieferten patches u.a. genau die gleiche bezeichnung haben, wie die von Reinhard Nißl. im master-tree ist dann der "commiter" wieder Reinhard. naja egal, durchflieger zieht das sicher wie immer sauber nach .. :)

gruß, ciax

ps: danke für all die arbeit an der xine-lib und den ausgabe-plugins - es läuft jetzt ziemlich rund (das mit dem spulen bei sky-aufnahmen - berichtet von iNOB und Wolfgang - muß ich erst noch gegechecken ...).
Lascala LC17 - tribute to viking ;o) + atric IR / AMD X2 BE-2400 / OctopusNet S4 / yavdr-(testing) vdr / output: graphTFT-fe via 6.4" TFT & DVB-S/S2 via FullHD / NVidia GT220 passiv

mgoeben

Fortgeschrittener

Beiträge: 212

Wohnort: Höhr-Grenzhausen

  • Nachricht senden

960

Montag, 24. Januar 2011, 13:17

Hi, ich habe mal eine Frage zu den Konfigurationsmöglichkeiten, es gibt mindestens 4 verschiedene, aber welche wann gebraucht wird, ist mir unklar.

(1) /etc/vdr/setup.conf xineliboutput.*
(2) /etc/vdr/setup.conf xine.*
(3) /etc/vdr/plugins/xineliboutput/config
(4) <userhome>/.xine/.config

Ich frage deshalb, da ich ewig Probleme damit hatte über hdmi Dolby auszugeben, und schlussendlich lag es daran dass (3) andere Einstellungen als (4) hatte. Und ich fälschlicherweise davon ausgegangen war dass (3) keine Auswirkung auf die Ausgabe des Tons hat.
(1) und (2) habe ich mal aufgeführt, weil mich wundert, dass ich allen Anleitungen zufolge erstmal ein paar dieser Einstellungen in meine setup.conf kopieren muss, anstatt dass sie beim ersten Laden des Plugins gesetzt werden. xine.* wundert mich da ich ja das xine Plugin hier nicht einsetze.

Marco
Mein aktueller HD VDR:
Hardware: Gehäuse: JCP-MI-105.B, MB Zotac IONITX A, 2 x TT DVB-S2-3600, LCD l4m320t, HD WD EVDS 2TB, Atric Einschalter, Logitech Harmony 700
Software: Gentoo, vdr-1.7.17, xine-lib 1.2 mit df-osd-handling-patch-alter-vdpau-h264-decoder Patch, xineliboutput-cvs + vdr-sxfe

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »mgoeben« (24. Januar 2011, 13:21)


Immortal Romance Spielautomat