Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: VDR Portal. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

221

Samstag, 18. Juli 2009, 10:05

RE: Version v8 der Patches

Zitat

Original von gda

Zitat

Original von durchflieger
Falls Ihr Probleme mit stockender Videowiedergabe bei aktiven grabbing habt dann setzt mal die Queuelänge um eins höher. Hierzu neues Parameter video.output.vdpau_display_queue_length verändern.

Das hilft tatsächlich, das Ruckeln, während die Fernbedienung im Live-Plugin aktiv ist, ist weg.
Danke durchflieger.

Gerald

Ich setze zur Zeit xine-vdpau r275 + xineliboutput 1.0.4 + nvidia 185.18.40 mit vdpau_display_queue_lenghth = 4 ein.
Ich habe den Eindruck das die Videowiedergabe generell damit wieder so flüssig läuft wie noch zu Zeiten mir r262 und 180.51.
Server: Asus M3N-H/HDMI, AMD X2 5600+, 4GB RAM, 500GB+1,5TB Samsung HD, 2xTevii S470, 1xTT-S3200, Ubuntu/V12.04, vdr 1.7.27
Client1: ZOTAC ION-ITX B, 2GB RAM, Diskless/Netboot per PXE, Xubuntu/V12.04, vdr 1.7.27+softhddevice, XBMC V12.1, LG42LC2R LCD-TV
Client2: Wie 1 aber ZOTAC ION-ITX E , DFAtmo, 2xDF10CH 19 Kanal Atmolight, LG37LC2R LCD-TV


222

Samstag, 18. Juli 2009, 12:37

RE: Version v8 der Patches

Zitat

Original von durchflieger
Ich setze zur Zeit xine-vdpau r275 + xineliboutput 1.0.4 + nvidia 185.18.40 mit vdpau_display_queue_lenghth = 4 ein.
Ich habe den Eindruck das die Videowiedergabe generell damit wieder so flüssig läuft wie noch zu Zeiten mir r262 und 180.51.

Mit r273 und 185.18.14 habe ich ganz schlechte Erfahrungen gemacht. Meinst du r275 reißt es wieder heraus? 185.18.40 kenne ich noch gar nicht.

Gerald

HP Proliant MicroServer Gen8, Xeon E3-1230, 12 GB RAM, 3xWD red 2TB im RAID 5, 2xSundtek MediaTV Home DVB-C/T, L4M TWIN-C/T, Ubuntu Server 14.04.1, Plex Media Server
Samsung UE55H6470

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »gda« (18. Juli 2009, 12:40)


223

Samstag, 18. Juli 2009, 12:48

RE: Version v8 der Patches

Zitat

Original von gda

Zitat

Original von durchflieger
Ich setze zur Zeit xine-vdpau r275 + xineliboutput 1.0.4 + nvidia 185.18.40 mit vdpau_display_queue_lenghth = 4 ein.
Ich habe den Eindruck das die Videowiedergabe generell damit wieder so flüssig läuft wie noch zu Zeiten mir r262 und 180.51.

Mit r273 und 185.18.14 habe ich ganz schlechte Erfahrungen gemacht. Meinst du r275 reißt es wieder heraus? 185.18.40 kenne ich noch gar nicht.

Gerald


nvidia 185.18.14 ist es auch
Also ich denke an r275 liegts nicht. Ich muss wohl noch mal mit normaler display queue length 2 probieren ob es wirklich einen Unterschied gibt.
Server: Asus M3N-H/HDMI, AMD X2 5600+, 4GB RAM, 500GB+1,5TB Samsung HD, 2xTevii S470, 1xTT-S3200, Ubuntu/V12.04, vdr 1.7.27
Client1: ZOTAC ION-ITX B, 2GB RAM, Diskless/Netboot per PXE, Xubuntu/V12.04, vdr 1.7.27+softhddevice, XBMC V12.1, LG42LC2R LCD-TV
Client2: Wie 1 aber ZOTAC ION-ITX E , DFAtmo, 2xDF10CH 19 Kanal Atmolight, LG37LC2R LCD-TV


224

Dienstag, 21. Juli 2009, 01:04

Ich möchte von VDR 1.7.0 auf VDR 1.7.8 umsteigen, weil VDR 1.7.0 HD-Aufnahmen in PES afzeichnet, und VDR 1.7.1 und höher in TS. Ich habe jetzt in folgendem Forum eine xineliboutput gefunden, die mit VDR 1.7.8 kompatibel ist.

Quellcode

1
2
Beitrag 21 von hos_me ganz unten:
Link entfernt.

Leider muss auch diese gepatcht werden, damit im VDRAdmin im Menü "Fernseher" ein Bild angezeight wird. Der hier veröffentlichte Patch funktioniert aber nicht so ohne Weiteres. Ich bin noch zu neu auf dem Gebiet, um das auf die Reihe zu bekommen und wäre daher sehr dankbar für jede Form der Hilfe.

Gruß
Gerd
HW: Asus A8N-SLI Premium | Athlon 64 3700+ | Hauppauge WinTV Nova-HD-S2 | 1Gb Kingston RAM |

SW: Ubuntu 12.04 | VDR 2.0.2 | NVIDIA Treiber | xine-lib-1.2 | Xineliboutput Plugin (1.0.90-cvs) | Live Plugin (0.3.0) | xmltv2vdr (0.2.0pre) | scheduler-Plugin (0.1.6) | epgsearch-Plugin (1.0.1.beta5) | markad-Plugin (0.1.5pre ) | extrecmenu (1.2.2)

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »Gerdchen03« (21. Juli 2009, 09:44)


225

Dienstag, 21. Juli 2009, 09:29

xinelibout liefert fuer normal n bild in vdradmin oder live.

und entferne so nen zwielichten link hier.

xineliboutput ausn cvs is doch von haus aus kompatibel mit vdr 1.7.8
2003 - 2011 - R.I.P.

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »wilderigel« (21. Juli 2009, 09:29)


226

Dienstag, 21. Juli 2009, 09:49

Hallo wilderigel,

ich finde gerade den Thread nicht mehr, aber mir wurde mitgeteilt, dass xinelibputput 1.0.4 mit VDR 1.7.8 nicht kompatibel sei. Nach der Installation erhalte ich kein Bild, und immer die Meldung:
[5639] [input_vdr] TCP: Buffer too small (8192 ; incoming frame 14080 bytes)
Wenn ich die Version aus dem entfernten Link verwende, klappt der Empfang. Nur im VDRAdmin erhalte ich wieder kein Bild wenn ich auf Fernseher klicke und der Befehl vdr-sxfe --fullscreen xvdr://localhost:37890 stürzt ab.

Gruß
Gerd
HW: Asus A8N-SLI Premium | Athlon 64 3700+ | Hauppauge WinTV Nova-HD-S2 | 1Gb Kingston RAM |

SW: Ubuntu 12.04 | VDR 2.0.2 | NVIDIA Treiber | xine-lib-1.2 | Xineliboutput Plugin (1.0.90-cvs) | Live Plugin (0.3.0) | xmltv2vdr (0.2.0pre) | scheduler-Plugin (0.1.6) | epgsearch-Plugin (1.0.1.beta5) | markad-Plugin (0.1.5pre ) | extrecmenu (1.2.2)

227

Dienstag, 21. Juli 2009, 09:56

1.0.4 eh nicht.
cvs version wie auch im wiki beschrieben:
http://vdr-wiki.de/wiki/index.php/Xineli…in#CVS_Snapshot
2003 - 2011 - R.I.P.

228

Dienstag, 21. Juli 2009, 11:36

cool, danke. Es klappt. Allerdings schmiert vdr-sxfe immer noch mit folgender Fehlermeldung ab, wenn ich Im VDRAdmin auf den Fernseher klicke:

Quellcode

1
2
[6702] [vdr-fe]    fe_grab: grabbing failed (unsupported image format 1095779414)
Improper call to JPEG library in state 100
HW: Asus A8N-SLI Premium | Athlon 64 3700+ | Hauppauge WinTV Nova-HD-S2 | 1Gb Kingston RAM |

SW: Ubuntu 12.04 | VDR 2.0.2 | NVIDIA Treiber | xine-lib-1.2 | Xineliboutput Plugin (1.0.90-cvs) | Live Plugin (0.3.0) | xmltv2vdr (0.2.0pre) | scheduler-Plugin (0.1.6) | epgsearch-Plugin (1.0.1.beta5) | markad-Plugin (0.1.5pre ) | extrecmenu (1.2.2)

229

Dienstag, 21. Juli 2009, 11:39

Hast du den Patch aus diesem Thread hier angewendet?

230

Dienstag, 21. Juli 2009, 11:43

Ich hab mir gerade folgende Datei heruntergeladen:
xineliboutput-head-vdpau-support-v8.diff
wenn ich die aber in /usr/local/src/vdr-1.7.8/PLUGINS/src/xineliboutput ausführe, kommen bloß Fehlermeldungen.
HW: Asus A8N-SLI Premium | Athlon 64 3700+ | Hauppauge WinTV Nova-HD-S2 | 1Gb Kingston RAM |

SW: Ubuntu 12.04 | VDR 2.0.2 | NVIDIA Treiber | xine-lib-1.2 | Xineliboutput Plugin (1.0.90-cvs) | Live Plugin (0.3.0) | xmltv2vdr (0.2.0pre) | scheduler-Plugin (0.1.6) | epgsearch-Plugin (1.0.1.beta5) | markad-Plugin (0.1.5pre ) | extrecmenu (1.2.2)

NemoN

Profi

Beiträge: 665

Wohnort: Hamburg (Neu Wulmstorf)

Beruf: QA Engineer

  • Nachricht senden

231

Dienstag, 21. Juli 2009, 11:47

Fehlermeldungen

Zitat

... kommen bloß Fehlermeldungen.


welche?

232

Dienstag, 21. Juli 2009, 11:47

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
root@VDR-1:/usr/local/src/vdr-1.7.8/PLUGINS/src/xineliboutput# patch –p0 <xineliboutput-head-vdpau-support-v8.diff
patching file –p0
Patch attempted to create file –p0, which already exists.
Hunk #1 FAILED at 1.
1 out of 1 hunk FAILED -- saving rejects to file –p0.rej
patching file config.c
Hunk #1 FAILED at 434.
Hunk #2 FAILED at 563.
Hunk #3 FAILED at 845.
3 out of 3 hunks FAILED -- saving rejects to file config.c.rej
patching file config.h
Reversed (or previously applied) patch detected!  Assume -R? [n] y
Hunk #1 succeeded at 322 (offset 1 line).
can't find file to patch at input line 98
Perhaps you should have used the -p or --strip option?
The text leading up to this was:
--------------------------
|diff -Naurb -x '.[a-zA-Z]*' -x CVS -x debian xineliboutput-head-orig/po/de_DE.po xineliboutput-head/po/de_DE.po
|--- xineliboutput-head-orig/po/de_DE.po	2009-01-08 11:58:33.000000000 +0000
|+++ xineliboutput-head/po/de_DE.po	2009-07-15 16:09:42.000000000 +0000
--------------------------
File to patch: 
Skip this patch? [y] 
Skipping patch.
2 out of 2 hunks ignored
patching file setup_menu.c
Hunk #1 succeeded at 586 (offset -4 lines).
Hunk #2 succeeded at 845 (offset -6 lines).
patching file xine_frontend.c
Hunk #1 succeeded at 1837 with fuzz 2 (offset 68 lines).
Hunk #2 FAILED at 1929.
1 out of 2 hunks FAILED -- saving rejects to file xine_frontend.c.rej
patching file xine_frontend_main.c
patching file xine_post_autocrop.c
Hunk #2 FAILED at 41.
Hunk #3 FAILED at 208.
Hunk #4 FAILED at 254.
Hunk #5 FAILED at 717.
Hunk #6 FAILED at 761.
Hunk #7 FAILED at 998.
Hunk #8 FAILED at 1076.
Hunk #9 FAILED at 1088.
Hunk #10 FAILED at 1104.
Hunk #11 FAILED at 1112.
Hunk #12 FAILED at 1174.
Hunk #13 FAILED at 1206.
Hunk #14 FAILED at 1215.
Hunk #15 FAILED at 1416.
Hunk #16 FAILED at 1436.
Hunk #17 FAILED at 1517.
Hunk #18 FAILED at 1576.
Hunk #19 FAILED at 1605.
Hunk #20 FAILED at 1632.
Hunk #21 FAILED at 1661.
Hunk #22 FAILED at 1683.
Hunk #23 FAILED at 1720.
Hunk #24 FAILED at 1735.
23 out of 24 hunks FAILED -- saving rejects to file xine_post_autocrop.c.rej
HW: Asus A8N-SLI Premium | Athlon 64 3700+ | Hauppauge WinTV Nova-HD-S2 | 1Gb Kingston RAM |

SW: Ubuntu 12.04 | VDR 2.0.2 | NVIDIA Treiber | xine-lib-1.2 | Xineliboutput Plugin (1.0.90-cvs) | Live Plugin (0.3.0) | xmltv2vdr (0.2.0pre) | scheduler-Plugin (0.1.6) | epgsearch-Plugin (1.0.1.beta5) | markad-Plugin (0.1.5pre ) | extrecmenu (1.2.2)

233

Dienstag, 21. Juli 2009, 11:58

Was ist denn das für ein Zeichen vor dem p0? Ein Minuszeichen ist das aber nicht.

Gerald

HP Proliant MicroServer Gen8, Xeon E3-1230, 12 GB RAM, 3xWD red 2TB im RAID 5, 2xSundtek MediaTV Home DVB-C/T, L4M TWIN-C/T, Ubuntu Server 14.04.1, Plex Media Server
Samsung UE55H6470

234

Dienstag, 21. Juli 2009, 12:14

Danke, das war schon mal ein wichtiger Punkt. man, durch Copy Paste schleicht sich so ein Scheiß schon mal ein.
Jetzt werden aber Dateien nicht gefunden:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
|--- xineliboutput-head-orig/config.c

|--- xineliboutput-head-orig/config.h

|--- xineliboutput-head-orig/po/de_DE.po

|--- xineliboutput-head-orig/setup_menu.c

|--- xineliboutput-head-orig/xine_frontend.c

|--- xineliboutput-head-orig/xine_frontend_main.c

|--- xineliboutput-head-orig/xine_post_autocrop.c


xineliboutput habe ich mit folgendem Befehl installiert:

Quellcode

1
cvs -z3 -d:pserver:anonymous@xineliboutput.cvs.sourceforge.net:/cvsroot/xineliboutput co vdr-xineliboutput
HW: Asus A8N-SLI Premium | Athlon 64 3700+ | Hauppauge WinTV Nova-HD-S2 | 1Gb Kingston RAM |

SW: Ubuntu 12.04 | VDR 2.0.2 | NVIDIA Treiber | xine-lib-1.2 | Xineliboutput Plugin (1.0.90-cvs) | Live Plugin (0.3.0) | xmltv2vdr (0.2.0pre) | scheduler-Plugin (0.1.6) | epgsearch-Plugin (1.0.1.beta5) | markad-Plugin (0.1.5pre ) | extrecmenu (1.2.2)

235

Dienstag, 21. Juli 2009, 12:28

Wenn ich mir den Output von deinem Patch-Versuch so ansehe, dann bin ich der Meinung, dass es -p1 statt -p0 sein müsste.

Gerald

HP Proliant MicroServer Gen8, Xeon E3-1230, 12 GB RAM, 3xWD red 2TB im RAID 5, 2xSundtek MediaTV Home DVB-C/T, L4M TWIN-C/T, Ubuntu Server 14.04.1, Plex Media Server
Samsung UE55H6470

236

Dienstag, 21. Juli 2009, 12:31

-p0 scheint zu stimmen. Andernfalls kommen jede Menge Hunks
HW: Asus A8N-SLI Premium | Athlon 64 3700+ | Hauppauge WinTV Nova-HD-S2 | 1Gb Kingston RAM |

SW: Ubuntu 12.04 | VDR 2.0.2 | NVIDIA Treiber | xine-lib-1.2 | Xineliboutput Plugin (1.0.90-cvs) | Live Plugin (0.3.0) | xmltv2vdr (0.2.0pre) | scheduler-Plugin (0.1.6) | epgsearch-Plugin (1.0.1.beta5) | markad-Plugin (0.1.5pre ) | extrecmenu (1.2.2)

237

Dienstag, 21. Juli 2009, 12:37

Zitat

Original von Gerdchen03
-p0 scheint zu stimmen. Andernfalls kommen jede Menge Hunks

Völliger Unsinn. Wenn bei -p1 Hunks Failed kommen, dann heißt das, dass die Quellen nicht zum Patch passen, aber auch dass er die Dateien immerhin gefunden hat. Wenn bei -p0 keine Dateien gefunden werden, dann kann er auch nicht patchen.

Gerald

HP Proliant MicroServer Gen8, Xeon E3-1230, 12 GB RAM, 3xWD red 2TB im RAID 5, 2xSundtek MediaTV Home DVB-C/T, L4M TWIN-C/T, Ubuntu Server 14.04.1, Plex Media Server
Samsung UE55H6470

238

Dienstag, 21. Juli 2009, 12:40

Zitat

Original von Gerdchen03

Quellcode

1
2
3
root@VDR-1:/usr/local/src/vdr-1.7.8/PLUGINS/src/xineliboutput# patch –p0 <xineliboutput-head-vdpau-support-v8.diff
patching file –p0
Patch attempted to create file –p0, which already exists.

Diese Ausgabe beweist, dass du mindestens zweimal in das selbe Verzeichnis reingepatched hast. Ich hoffe das war eine Ausnahme und du patchet sonst immer in ein frisches Verzeichnis.

Gerald

HP Proliant MicroServer Gen8, Xeon E3-1230, 12 GB RAM, 3xWD red 2TB im RAID 5, 2xSundtek MediaTV Home DVB-C/T, L4M TWIN-C/T, Ubuntu Server 14.04.1, Plex Media Server
Samsung UE55H6470

239

Dienstag, 21. Juli 2009, 12:53

OK, danke, das wars. Ich hab das Verzeichnis gelöscht, frisch gepatched, und schon bekam ich keine Fehlermeldung mehr

Update:
der Patch läuft zwar ohne Fehler durch, aber vdr-sxfe schmiert noch immer ab, wenn ich im VDRAdmin auf Fernseher klicke. Die Fehlermeldung lautet noch immer:

Quellcode

1
2
[4192] [vdr-fe]    fe_grab: grabbing failed (unsupported image format 1095779414)
Improper call to JPEG library in state 100
HW: Asus A8N-SLI Premium | Athlon 64 3700+ | Hauppauge WinTV Nova-HD-S2 | 1Gb Kingston RAM |

SW: Ubuntu 12.04 | VDR 2.0.2 | NVIDIA Treiber | xine-lib-1.2 | Xineliboutput Plugin (1.0.90-cvs) | Live Plugin (0.3.0) | xmltv2vdr (0.2.0pre) | scheduler-Plugin (0.1.6) | epgsearch-Plugin (1.0.1.beta5) | markad-Plugin (0.1.5pre ) | extrecmenu (1.2.2)

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Gerdchen03« (21. Juli 2009, 15:20)


240

Mittwoch, 22. Juli 2009, 14:41

Hallo,

ich habe hier folgendes problem:
Das croppen (16:9 > 4:3) funktioniert wunderbar, allerdings ist das Bild extrem verzerrt, wenn ich von einem 4:3 Sender auf einen 16:9 umschalte bzw. wenn z.b. auf pro7 die werbung (welche ja auf 16:9 gesendet wird) anfängt.
Hat sonst noch jemand dieses Problem ?
Ich habe mittlerweile einige Konstellationen von "xine-vdpau" (1.1.16 und 1.2) und xineliboutput (1.0.4 und 1.0.99-cvs) probiert...ohne Erfolg.
Meine Aktuelle Konfiguration:
Ubuntu 9.04 (Kernel 2.6.28-11)
s2-liplianum
xine-lib-1.2 + vdpau r275 + crop v8
vdr-1.7.7 + extensions72
xineliboutput (1.0.99-cvs + crop v8
NVIDIA Treiber 190... (der neueste beta halt...)

Wäre super, wenn jemand ne Lösung dafür hat.
Im Logfile finde ich diesbezüglich keine Ausgaben.

Gruß
Daniel

PS: xineliboutput-Video-Einstellung steht auf "Automatik" (ich habe auch schon "Anamorph" probiert, mit dem selben ergebnis).
Ich habe gerade festgestellt, dass das Bild wieder korrekt skaliert wird, wenn ich in die Einstellungen des xineliboutput-Plugins unter "Video" das Seitenverhältnis auf irgendeinen Wert und anschließend wieder auf "Automatik" stelle... Ich möchte dies aber nicht jedes mal tun...
VDR:
Hardware: Asus AT5IONT-I // 1024MB Kingston ValueRAM PC3-8500 // Samsung F3 Ecogreen 1000GB // TBS 6920
Software: Ubuntu 10.04 LTS // s2-liplianin // vdr-1.7.16 // xbmc

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »vyu« (22. Juli 2009, 14:49)


Immortal Romance Spielautomat