You are not logged in.

Dear visitor, welcome to VDR Portal. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

921

Saturday, January 8th 2011, 1:20pm

ich bin mir nicht sicher ob es mit deinem patch in libxine zu tun hat,
da sich ja in libxine upstream recht wenig tut.

aber das war bei v19 schon so.

edit : lockdisplay hatte ich getestet mit #undefine und #define
aber verhalten bleibt gleich.

ich bin mir auch nicht sicher ob es mit xineliboutput irgendwann mal eine änderung gab, welches eben das ganze "auslöst".

am liebsten würde ich gerade in die ecke kriechen ... weil das sieht nach arbeit aus, um rauszufinden ab/mit welcher version das passiert.

This post has been edited 3 times, last edit by "hotzenplotz5" (Jan 8th 2011, 1:23pm)


922

Saturday, January 8th 2011, 1:24pm

Quoted

Original von hotzenplotz5
ich bin mir nicht sicher ob es mit deinem patch in libxine zu tun hat,
da sich ja in libxine upstream recht wenig tut.

aber das war bei v19 schon so.

edit : lockdisplay hatte ich getestet mit #undefine und #define
aber verhalten bleibt gleich.

ich bin mir auch nicht sicher ob es mit xineliboutput irgendwann mal eine änderung gab, welches eben das ganze "auslöst".

am liebsten würde ich gerade in die ecke kriechen ... weil das sieht nach arbeit aus, um rauszufinden ab/mit welcher version das passiert.

Tritt das Problem denn ohne Patch nicht auf?
Server: Asus M3N-H/HDMI, AMD X2 5600+, 4GB RAM, 500GB+1,5TB Samsung HD, 2xTevii S470, 1xTT-S3200, Ubuntu/V12.04, vdr 1.7.27
Client1: ZOTAC ION-ITX B, 2GB RAM, Diskless/Netboot per PXE, Xubuntu/V12.04, vdr 1.7.27+softhddevice, XBMC V12.1, LG42LC2R LCD-TV
Client2: Wie 1 aber ZOTAC ION-ITX E , DFAtmo, 2xDF10CH 19 Kanal Atmolight, LG37LC2R LCD-TV


923

Saturday, January 8th 2011, 1:25pm

das werde ich jetzt als nächstes testen.

924

Saturday, January 8th 2011, 1:40pm

Erweiterungen im autocrop xine plugin

Quoted

Original von steffen_b

Quoted

Originally posted by durchflieger
Ich selber habe das Problem nicht da ich bei mir eine gepachte Variante einsetzen die den AVARDS Algorithmus nutzt und damit die neuen Codestellen meidet. Leider hat der Algorithmus damals keinen Einzug ins Entwicklerrepository gefunden.


Dürfen wir daran teilhaben durchflieger ? Ich würde das gerne mal probieren. Fehlt mir schon ein Stück weit der autocrop und wenn es einen besseren Algorithmus gibt : haben wollen !

Danke !

Steffen


So phintuka war so nett meine Patches bezüglich des autocrop während der letzten Tage in sein cvs zu übernehmen:)
Weiterhin ist natürlich auch der autocrop-fix.patch eingeflossen :)

Hier ein wenig Beschreibung zu den Neuerungen zum autcrop:

Das autocrop plugin erhält jetzt den AVARDS-Algorithmus zur Analyse des Bildinhalt auf letter box format.
Im Gegensatz zum Standard-Algorithmus des plugin wertet dieser nur die Graustufen (Y-Kanal) des Bild aus und bestimmt den Grautone der letter box mittels eines Histogramm.
Die Logoerkennung erkennt bei abgeschalteter automatischer Untertitelerkennung auch Logos im unteren Bildbereich. Desweiteren wird das Senderlogo horizontal an beliebiger Stelle erkannt und nicht nur in den Seitenbereichen.

Mit der neuen Funktion overscan compensation kann das aufzommen eines letter box Bild verringert werden.
Das ist nützlich bei TV-Geräten die ein overscan haben.

Folgende neue autocrop post plugin Parameter gibt es:

Source code

1
2
3
use_avards_analysis      Standard 0    0 -> Standard Algorithmus,  1 -> AVARDS
bar_tone_tolerance       Standard 0    Erlaubte Abweichung vom ermittelten Grauton die noch als letter box gewertet wird.
overscan_compensate      Standard 0    Prozentwert zur Basis 1000 bezogen auf die Bildhöhe. 31 enspricht z.b. 3.1%


Die Parameter müssen als Aufrufparameter dem xineliboutput mitgegeben werden da diese bisher nicht im VDR OSD-Setup des plugin berücksichtigt sind. Zum Beispiel:

vdr-sxfe -post="autocrop:use_avards_analysis=1,overscan_compensate=30"

Viel Spass beim ausprobieren!

Gruss
durchflieger
Server: Asus M3N-H/HDMI, AMD X2 5600+, 4GB RAM, 500GB+1,5TB Samsung HD, 2xTevii S470, 1xTT-S3200, Ubuntu/V12.04, vdr 1.7.27
Client1: ZOTAC ION-ITX B, 2GB RAM, Diskless/Netboot per PXE, Xubuntu/V12.04, vdr 1.7.27+softhddevice, XBMC V12.1, LG42LC2R LCD-TV
Client2: Wie 1 aber ZOTAC ION-ITX E , DFAtmo, 2xDF10CH 19 Kanal Atmolight, LG37LC2R LCD-TV


lostinspc

Professional

Posts: 571

Location: Stuttgart

  • Send private message

925

Saturday, January 8th 2011, 1:51pm

RE: Erweiterungen im autocrop xine plugin

Quoted

Originally posted by durchflieger
Die Parameter müssen als Aufrufparameter dem xineliboutput mitgegeben werden da diese bisher nicht im VDR OSD-Setup des plugin berücksichtigt sind. Zum Beispiel:

vdr-sxfe -post="autocrop:use_avards_analysis=1,overscan_compensate=30"

Viel Spass beim ausprobieren!

Gruss
durchflieger


Danke, das fehlte mir noch, habe grade versucht aus dem Quelltext schlau zu werden wie man es aktiviert ....

Grüße, Peter
SW: vdr-latest, softhddevice -git, arch x86_64
HW: 1x Cine C/T V6 + DuoFlex C/C2/T/T2 V3, Asus P5G41-M, 2 GB, Pentium 6300, Asus G210 passiv, 60 GB Samsung SSD 470, 3TB WD AV GP (WD30EURS) , Silverstonetek LaScala 10M, LG LM 669S, 1920x1080@50
VDR-User #81

926

Saturday, January 8th 2011, 5:31pm

@durchflieger

Quoted

Tritt das Problem denn ohne Patch nicht auf?


ich hatte gehofft der patch wäre schuld :unsch
leider ist das eben wieder passiert.
libxine ohne deinen patch und aktuelles xineliboutput.
etwas anders war die ankündigung. das bild flackerte erst heftig.
osd war noch da, top zeigt nix "verdächtiges".
nach einem neustart von openbox (frontend wird dabei auch neu gestartet)
war das flackern weg, aber das osd auch.

hm .. das ganze bei phintuka mal melden....

edit: ok das mag damit evtl. zusammenhängen:

Quoted

write_osd_command: socket buffer full, OSD send skipped


das hab ich dazu gefunden :
http://www.mail-archive.com/vdr@linuxtv.org/msg11034.html
sollte aber drin sein ...

This post has been edited 3 times, last edit by "hotzenplotz5" (Jan 8th 2011, 6:28pm)


927

Sunday, January 9th 2011, 5:14pm

RE: Erweiterungen im autocrop xine plugin

Quoted

Original von durchflieger
[..]
So phintuka war so nett meine Patches bezüglich des autocrop während der letzten Tage in sein cvs zu übernehmen:)
Weiterhin ist natürlich auch der autocrop-fix.patch eingeflossen :)
[..]
Viel Spass beim ausprobieren!

Gruss
durchflieger


:tup - fette DANKE für deinen einsatz durchflieger! :]

gruß, ciax
Lascala LC17 - tribute to viking ;o) + atric IR / AMD X2 BE-2400 / DVB-S2 TT3200 + DigitalDevices CineS2 (defekt) / yavdr stable / output: graphTFT-fe via 6.4" TFT & DVB-S/S2 via FullHD / NVidia GT220 passiv

928

Sunday, January 9th 2011, 5:29pm

RE: Erweiterungen im autocrop xine plugin

Quoted

Original von ciax

Quoted

Original von durchflieger
[..]
So phintuka war so nett meine Patches bezüglich des autocrop während der letzten Tage in sein cvs zu übernehmen:)
Weiterhin ist natürlich auch der autocrop-fix.patch eingeflossen :)
[..]
Viel Spass beim ausprobieren!

Gruss
durchflieger


:tup - fette DANKE für deinen einsatz durchflieger! :]

gruß, ciax


Servus,

jepp, das muß auch mal gesagt werden und dem schließe ich mich an!

Gruß
Wolfgang
Hardware: -
Software: -

929

Sunday, January 9th 2011, 6:24pm

Ich sage auch dankeschön für den prima Patch, hab allerdings auch eine Frage hierzu. Wenn ich xine mit dem avards_algo verwende, wie kann ich das langsame Aufzoomen in der Befehlszeile verhindern?

Die folgende Befehleszeile funzt bei mir nicht:

Source code

1
xine -G 1920x1080 -B -V vdpau -A alsa --post vdr --post vdr_video --post vdr_audio --post autocrop:use_avards_analysis=1,overscan_compensate=30,soft_start_step=0 --aspect-ratio=auto --verbose=2 --no-logo --no-splash vdr:/tmp/vdr-xine/stream#demux:mpeg_pes > /var/log/xine.log");
Thx
iNOB

Mein VDR

Hartware: Gehäuse: Ahanix MCE 302, Mobo: Kontron 986LCD-M/mITX, CPU: Intel Core2 Duo Mobile T7400 2,16GHz, 2GB RAM, SAT: Digital Devices DuoFlex S2 miniPCIe, Graka: ASUS EN210 Silent 1GD3, 4x2TB 3,5" WD HD, 1x DVD-Brenner Pioneer, Atric IR-Einschalter+Empfänger, FB One-For-All URC-7960, SoundGraph iMON LCD ( MFP5I, 15c2:0038 )
Weichware: Wheezy (x86_64), Kernel 3.8.13, NVidia v340.24, VDR 2.1.6 gepatched

lostinspc

Professional

Posts: 571

Location: Stuttgart

  • Send private message

930

Sunday, January 9th 2011, 7:17pm

Quoted

Originally posted by iNOB
Wenn ich xine mit dem avards_algo verwende, wie kann ich das langsame Aufzoomen in der Befehlszeile verhindern?


Versuchs mal mit soft_start=0 statt soft_start_step=0, ymmv.

Grüße, Peter
SW: vdr-latest, softhddevice -git, arch x86_64
HW: 1x Cine C/T V6 + DuoFlex C/C2/T/T2 V3, Asus P5G41-M, 2 GB, Pentium 6300, Asus G210 passiv, 60 GB Samsung SSD 470, 3TB WD AV GP (WD30EURS) , Silverstonetek LaScala 10M, LG LM 669S, 1920x1080@50
VDR-User #81

931

Sunday, January 9th 2011, 7:28pm

Quoted

Original von iNOB
Ich sage auch dankeschön für den prima Patch, hab allerdings auch eine Frage hierzu. Wenn ich xine mit dem avards_algo verwende, wie kann ich das langsame Aufzoomen in der Befehlszeile verhindern?

Die folgende Befehleszeile funzt bei mir nicht:

Source code

1
xine -G 1920x1080 -B -V vdpau -A alsa --post vdr --post vdr_video --post vdr_audio --post autocrop:use_avards_analysis=1,overscan_compensate=30,soft_start_step=0 --aspect-ratio=auto --verbose=2 --no-logo --no-splash vdr:/tmp/vdr-xine/stream#demux:mpeg_pes > /var/log/xine.log");
Thx
iNOB

Mach aus "soft_start_step" nur "soft_start" dann gehts.
Wenn du es nicht so eilig hast kannst du auch warten bis phintunka meinen heute eingereichten Patch bezüglich des autocrop osd setup übernommen hat.
Dann kann alles zum autocrop wieder über das OSD eingestellt werden :)

Gruss
durchflieger
Server: Asus M3N-H/HDMI, AMD X2 5600+, 4GB RAM, 500GB+1,5TB Samsung HD, 2xTevii S470, 1xTT-S3200, Ubuntu/V12.04, vdr 1.7.27
Client1: ZOTAC ION-ITX B, 2GB RAM, Diskless/Netboot per PXE, Xubuntu/V12.04, vdr 1.7.27+softhddevice, XBMC V12.1, LG42LC2R LCD-TV
Client2: Wie 1 aber ZOTAC ION-ITX E , DFAtmo, 2xDF10CH 19 Kanal Atmolight, LG37LC2R LCD-TV


932

Sunday, January 9th 2011, 8:38pm

Funktioniert prima! :)

Quoted

Dann kann alles zum autocrop wieder über das OSD eingestellt werden

Mag für xineliboutput zutreffen, aber doch wohl weniger für xine, oder? :schiel

Thx
iNOB

Mein VDR

Hartware: Gehäuse: Ahanix MCE 302, Mobo: Kontron 986LCD-M/mITX, CPU: Intel Core2 Duo Mobile T7400 2,16GHz, 2GB RAM, SAT: Digital Devices DuoFlex S2 miniPCIe, Graka: ASUS EN210 Silent 1GD3, 4x2TB 3,5" WD HD, 1x DVD-Brenner Pioneer, Atric IR-Einschalter+Empfänger, FB One-For-All URC-7960, SoundGraph iMON LCD ( MFP5I, 15c2:0038 )
Weichware: Wheezy (x86_64), Kernel 3.8.13, NVidia v340.24, VDR 2.1.6 gepatched

933

Monday, January 10th 2011, 9:17am

Quoted

Original von iNOB
Funktioniert prima! :)

Quoted

Dann kann alles zum autocrop wieder über das OSD eingestellt werden

Mag für xineliboutput zutreffen, aber doch wohl weniger für xine, oder? :schiel

Thx
iNOB

Ja ja nur für xineliboutput.
Server: Asus M3N-H/HDMI, AMD X2 5600+, 4GB RAM, 500GB+1,5TB Samsung HD, 2xTevii S470, 1xTT-S3200, Ubuntu/V12.04, vdr 1.7.27
Client1: ZOTAC ION-ITX B, 2GB RAM, Diskless/Netboot per PXE, Xubuntu/V12.04, vdr 1.7.27+softhddevice, XBMC V12.1, LG42LC2R LCD-TV
Client2: Wie 1 aber ZOTAC ION-ITX E , DFAtmo, 2xDF10CH 19 Kanal Atmolight, LG37LC2R LCD-TV


934

Monday, January 10th 2011, 2:54pm

RE: Erweiterungen im autocrop xine plugin

Quoted

Original von durchflieger

Die Parameter müssen als Aufrufparameter dem xineliboutput mitgegeben werden da diese bisher nicht im VDR OSD-Setup des plugin berücksichtigt sind. Zum Beispiel:

vdr-sxfe -post="autocrop:use_avards_analysis=1,overscan_compensate=30"



Für dass aktuelle xineliboutput aus dem cvs wird das -post Parameter nicht mehr benötigt! Alles lässt sich jetzt im VDR OSD im Setup einstellen :)

Viel Spass damit!

Gruss
durchflieger
Server: Asus M3N-H/HDMI, AMD X2 5600+, 4GB RAM, 500GB+1,5TB Samsung HD, 2xTevii S470, 1xTT-S3200, Ubuntu/V12.04, vdr 1.7.27
Client1: ZOTAC ION-ITX B, 2GB RAM, Diskless/Netboot per PXE, Xubuntu/V12.04, vdr 1.7.27+softhddevice, XBMC V12.1, LG42LC2R LCD-TV
Client2: Wie 1 aber ZOTAC ION-ITX E , DFAtmo, 2xDF10CH 19 Kanal Atmolight, LG37LC2R LCD-TV

This post has been edited 1 times, last edit by "durchflieger" (Jan 10th 2011, 2:54pm)


935

Monday, January 10th 2011, 2:57pm

RE: Erweiterungen im autocrop xine plugin

Quoted

Original von durchflieger

Quoted

Original von durchflieger

Die Parameter müssen als Aufrufparameter dem xineliboutput mitgegeben werden da diese bisher nicht im VDR OSD-Setup des plugin berücksichtigt sind. Zum Beispiel:

vdr-sxfe -post="autocrop:use_avards_analysis=1,overscan_compensate=30"



Für dass aktuelle xineliboutput aus dem cvs wird das -post Parameter nicht mehr benötigt! Alles lässt sich jetzt im VDR OSD im Setup einstellen :)

Viel Spass damit!

Gruss
durchflieger


Die Nutzung der --post Parameter beim Startauruf für das xine-plugin ist aber trotzdem noch möglich?

Gruß
Wolfgang
Hardware: -
Software: -

936

Monday, January 10th 2011, 3:07pm

RE: Erweiterungen im autocrop xine plugin

Quoted

Original von wbreu

Quoted

Original von durchflieger

Quoted

Original von durchflieger

Die Parameter müssen als Aufrufparameter dem xineliboutput mitgegeben werden da diese bisher nicht im VDR OSD-Setup des plugin berücksichtigt sind. Zum Beispiel:

vdr-sxfe -post="autocrop:use_avards_analysis=1,overscan_compensate=30"



Für dass aktuelle xineliboutput aus dem cvs wird das -post Parameter nicht mehr benötigt! Alles lässt sich jetzt im VDR OSD im Setup einstellen :)

Viel Spass damit!

Gruss
durchflieger


Die Nutzung der --post Parameter beim Startauruf für das xine-plugin ist aber trotzdem noch möglich?

Gruß
Wolfgang

Ja klar. An dem xine post plugin hat sich nichts geändert dadurch.
Im xine-ui kann man sich überigens im post plugin panel auch die aktuell möglichen Parameter anschauen.

Gruss
durchflieger
Server: Asus M3N-H/HDMI, AMD X2 5600+, 4GB RAM, 500GB+1,5TB Samsung HD, 2xTevii S470, 1xTT-S3200, Ubuntu/V12.04, vdr 1.7.27
Client1: ZOTAC ION-ITX B, 2GB RAM, Diskless/Netboot per PXE, Xubuntu/V12.04, vdr 1.7.27+softhddevice, XBMC V12.1, LG42LC2R LCD-TV
Client2: Wie 1 aber ZOTAC ION-ITX E , DFAtmo, 2xDF10CH 19 Kanal Atmolight, LG37LC2R LCD-TV


937

Monday, January 10th 2011, 9:45pm

mit dem 19'er patch läuft soweit alles sehr gut (alle alten bugs sind nun behoben)

da unter gentoo nun auch ein xorg-server update dazu kam, muss nun LOCKDISPLAY aktiviert werden (hatte ich bei 1.7'er xorg auch schon aktiv ohne Einschränkungen).

aber mit der 1.9'er habe ich mit en aktuellen xine-lib / xineliboutput version so ein flackern oben im Bild. Sieht aus wie ein V-sync Problem (10-20% des Bildes von oben scheinen immer nicht zum rest des bildes zu passen, sind leicht versetzt.) Das tritt vor allem bei schnellen Schwenks auf.

Ist das noch jemandem aufgefallen oder habe ich da nur lokal ein Problem ?
VDR: VDR-1.7.23@vdpau ,softhddevice, s2-liplianin Treiber (hg), 1 x TT-S3600, 1 x TT-S3650
System: 3.2.5 (+stb0899patches + pctv452e usb patch), Glibc 2.13,nvidia-drivers 290.10

938

Monday, January 10th 2011, 9:49pm

Quoted

Original von m.Rcu
mit dem 19'er patch läuft soweit alles sehr gut (alle alten bugs sind nun behoben)

da unter gentoo nun auch ein xorg-server update dazu kam, muss nun LOCKDISPLAY aktiviert werden (hatte ich bei 1.7'er xorg auch schon aktiv ohne Einschränkungen).

aber mit der 1.9'er habe ich mit en aktuellen xine-lib / xineliboutput version so ein flackern oben im Bild. Sieht aus wie ein V-sync Problem (10-20% des Bildes von oben scheinen immer nicht zum rest des bildes zu passen, sind leicht versetzt.) Das tritt vor allem bei schnellen Schwenks auf.

Ist das noch jemandem aufgefallen oder habe ich da nur lokal ein Problem ?


haste den 20er patch probiert

habe auch gentoo und den effekt aktuell nicht .. hatte so einen effekt unter ubuntu mit eingeschalteten desktop effekten

gentoo läuft hier auf einem ion und einem core2quad mit gt220 .. beides aktuell super

danke an alle
VDR Server: 1,8 core2 Duo, 3x TT-S3200, Gentoo, VDR 1.7.22
VDR Client 1: Zotac ION, Gentoo, streamdev, VDR 1.7.22
VDR Client 2: Nvidia 9500GT, Gentoo aktuell yavdr (zum Testen), streamdev, VDR 1.7.22
VDR Client 3: Nvidia GT220 passiv, Gentoo, streamdev, VDR 1.7.28

939

Monday, January 10th 2011, 10:21pm

ja habe den 20'er jetzt aktiv.

aber der eigentlich Fehler war das xorg-update unter gentoo. die xorg.conf wird nun nicht mehr gelesen, nur noch die configs in /etc/X11/xorg.conf.d

habe nur die alte config etwas aufgeteilt und dort abgelegt (womit das compsite nun wieder aus ist)

nun ist das flackern weg !! :ghost

danke für den Hinweis
VDR: VDR-1.7.23@vdpau ,softhddevice, s2-liplianin Treiber (hg), 1 x TT-S3600, 1 x TT-S3650
System: 3.2.5 (+stb0899patches + pctv452e usb patch), Glibc 2.13,nvidia-drivers 290.10

lostinspc

Professional

Posts: 571

Location: Stuttgart

  • Send private message

940

Monday, January 10th 2011, 10:34pm

Quoted

Originally posted by m.Rcu
aber der eigentlich Fehler war das xorg-update unter gentoo. die xorg.conf wird nun nicht mehr gelesen, nur noch die configs in /etc/X11/xorg.conf.d

Jetzt hast Du mich ja doch leicht verunsichert. Habe hier auch aktuelles gentoo mit xorg 1.92 am laufen.

Hab deswegen mal schnell im xorg.log nachgeschaut: Bei mir wird nach wie vor /etc/X11/xorg.conf verwendet.

Quoted


habe nur die alte config etwas aufgeteilt und dort abgelegt (womit das compsite nun wieder aus ist)

nun ist das flackern weg !!


Schön das es bei Dir wieder funktioniert.

Grüße, Peter
SW: vdr-latest, softhddevice -git, arch x86_64
HW: 1x Cine C/T V6 + DuoFlex C/C2/T/T2 V3, Asus P5G41-M, 2 GB, Pentium 6300, Asus G210 passiv, 60 GB Samsung SSD 470, 3TB WD AV GP (WD30EURS) , Silverstonetek LaScala 10M, LG LM 669S, 1920x1080@50
VDR-User #81