You are not logged in.

Dear visitor, welcome to VDR Portal. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

21

Monday, December 12th 2011, 2:32pm

Habt Ihr schon TCP verwendet bzw getestet? Ich habe nie Pipes versucht.

Johns
Sag mir, wo die Developer sind. Wo sind sie geblieben? . . . . . . . . . . . . . . . . . . . . SoftHdDevice - A software and GPU emulated HD output device plugin.
Sag mir, wo die Developer sind. Was ist geschehn?

Client0: Crown CW02 MSI_C847MS-E33 Zotac_GT640_passiv Cine-S2 iMon-MCE / streamdev softhddevice
Client1: Lian_Li_PC-Q09FB ASRock_H67M-ITX/HT I3-2100 ASUS_ENGT520_passiv / streamdev softhddevice
Test: Lian_Li_PC-Q09R Asus C60M1-I / streamdev
Server0: Dockstar TT-S2-3600-USB / streamdev
Server2: Lian_Li_PC-Q07R Intel_DH61DL G620 WD20EARX 90W PicoPSU Cine-S2+DuoFlex-S2+DuoFlex-CT / streamdev / 22 Watt Verbrauch

22

Monday, December 12th 2011, 5:20pm

Hmm... ich starte das Ganze mit dem runvdr-extrem Script z.B. so:

Source code

1
nice --5 xine -f -B -G 1360x768 -V vdpau -A alsa --post vdr --post vdr_video --post vdr_audio --post autocrop:use_avards_analysis=1,overscan_compensate=30,soft_start=0 --aspect-ratio=auto --verbose=2 --no-gui --no-logo --no-splash vdr://tmp/vdr-xine/stream#demux:mpeg_pes 1> /var/log/xine.log

Die von dir vorgeschlagene Variante über TCP funktioniert doch nur mit xineliboutput und vdr-sxfe, oder seh ich da was falsch? Zumindest hab ich das nur mit letztgenannten hinbekommen....?!

Gruß
iNOB

Mein VDR

Hartware: Gehäuse: Ahanix MCE 302, Mobo: Kontron 986LCD-M/mITX, CPU: Intel Core2 Duo Mobile T7400 2,16GHz, 2GB RAM, SAT: Digital Devices DuoFlex S2 miniPCIe, Graka: ASUS EN210 Silent 1GD3, 4x2TB 3,5" WD HD, 1x DVD-Brenner Pioneer, Atric IR-Einschalter+Empfänger, FB One-For-All URC-7960, SoundGraph iMON LCD ( MFP5I, 15c2:0038 )
Weichware: Wheezy (x86_64), Kernel 3.8.13, NVidia v340.17, VDR 2.1.6 gepatched

23

Tuesday, December 13th 2011, 9:26am

hier auch gleiches Problem (kurzes Standbild und dann schneller Vorlauf) mit dem VDR aus der Signatur.
HW: Gigabyte EP41-UD3L | Core2Duo 7400 | 2GB Kingston | MSI N220GT-MD1GZ (passiv) | L4M-Twin S2 ver 6.5 mit Flex S2 | Silverstone LC16M mit iMON VFD | Samsung LE46B750
SW: Xubuntu 14.04 3.13.0-24 | NVIDIA 304.117 | vdr 2.1.6 | softhddevice | inputlirc | lcdproc

24

Tuesday, December 13th 2011, 9:30am

Das Problem ist existent auf ATOM-Boards mit ION-Chipsatz und auf Systemen mit GT210 Grakas. Würde mich wundern, wen das auf einem System mit GT430 anders wäre.

Gruß
iNOB

Karte ist gestern geliefert worden (allerdings bin ich nicht der Tester) am WE wissen wir hoffentlich mehr.

im Erfolgsfall geb ich dann eine meiner Asus GT520 ab, dann bin ich gleich das Servus TV Problem mit los :)
CKone: yavdr 0.5/2.0.6 auf Intel DH67BL, Intel Celeron G540, 2x 2GB Kingston DDR3, Zotac GT630 1GB, S2-1600, Ocz Agility 3 60GB, LG GH24NS DVD, 11.6" Selbstbau TFT, Harmony 700, CIR Selbstbau - das Ganze im Silverstone SST-SG03B
CKtwo: yavdr 0.5/2.0.6 auf ASUS M4A78LT-M LE, Athlon II X2 240, 2x 2GB Corsair DDR3, ASUS ENGT430 1GB, TT S2-1600, Ocz Vertex 2 50 GB, 92 Kanal Seduatmo, Harmony 700, atric rev5
Proliant: precise server/yavdr 0.5 testing auf HP Proliant N40L, 2x 4GB ECC DDR3, 2x DD CINE-S2, Ocz Onyx 32GB, 3x WD Red WD30EFRX 3TB in SW Raid5

25

Tuesday, December 13th 2011, 2:04pm

Ich bin gespannt. Wenn die 430er klappt muss ich mir was einfallen lassen...

26

Thursday, December 15th 2011, 7:09pm

also ich hab jetzt auch seit heute ne passive Asus GT430 in meiner Hauptmaschine, der Kollege hat ne Sparkle wegen der LP Option.

Bis jetzt super:
kein Ruckeln,
temperaturen auf 1080i temp spatial marginal niedriger als mit mit G210(128-bit Memory Inteface) und auch GT520,
zum erstenmal kein Ruckeln auf zeitlich/räumlich in xbmc,
anders als mit der GT520 funkioniert Servus TV nicht nur manchmal

...man merkt auch am sichtbar weniger ruckelnden anthra das die GraKa wesentlich mehr Dampf hat!

ich beobachte das weiter, am WE hab ich bestimmt einen sichereren Eindruck. Ich lass die Karte in jedem Fall drin, eine meiner beiden GT520 steht ab sofort zum Verkauf

Christian
CKone: yavdr 0.5/2.0.6 auf Intel DH67BL, Intel Celeron G540, 2x 2GB Kingston DDR3, Zotac GT630 1GB, S2-1600, Ocz Agility 3 60GB, LG GH24NS DVD, 11.6" Selbstbau TFT, Harmony 700, CIR Selbstbau - das Ganze im Silverstone SST-SG03B
CKtwo: yavdr 0.5/2.0.6 auf ASUS M4A78LT-M LE, Athlon II X2 240, 2x 2GB Corsair DDR3, ASUS ENGT430 1GB, TT S2-1600, Ocz Vertex 2 50 GB, 92 Kanal Seduatmo, Harmony 700, atric rev5
Proliant: precise server/yavdr 0.5 testing auf HP Proliant N40L, 2x 4GB ECC DDR3, 2x DD CINE-S2, Ocz Onyx 32GB, 3x WD Red WD30EFRX 3TB in SW Raid5

27

Tuesday, December 20th 2011, 6:24pm

@ckone
Ruckelte das Wochenende? ;)

Sent from my Galaxy Nexus using Tapatalk

28

Tuesday, December 20th 2011, 8:04pm

also es ist subjektiv fast weg, sagen wir es hat sich von 95% auf 99% perfekt verbessert! :mua

XBMC in jedem Fall ist, wenn auch weiterhin etwas unergonomisch, mit temp spatial jetzt auch Bildtechnisch ne xine Alternative, dazu reicht die GT520 einfach nicht...

Temperaturtechnisch würd ich sagen ein hauch kühler als die GT520 (5-8Grad), wobei das auch damit zusammen hängen kann das ich die Netze vor den Lüftern ausgesaugt hab :mua

Ich hab zwischenzeitlich auch die Zweitaschine mit ner GT430 ausgestattet und würde sagen das wir abgesehen von noad/markad gerade ganz nah an der Perfektion eines alten SD FF vdr kratzen....
CKone: yavdr 0.5/2.0.6 auf Intel DH67BL, Intel Celeron G540, 2x 2GB Kingston DDR3, Zotac GT630 1GB, S2-1600, Ocz Agility 3 60GB, LG GH24NS DVD, 11.6" Selbstbau TFT, Harmony 700, CIR Selbstbau - das Ganze im Silverstone SST-SG03B
CKtwo: yavdr 0.5/2.0.6 auf ASUS M4A78LT-M LE, Athlon II X2 240, 2x 2GB Corsair DDR3, ASUS ENGT430 1GB, TT S2-1600, Ocz Vertex 2 50 GB, 92 Kanal Seduatmo, Harmony 700, atric rev5
Proliant: precise server/yavdr 0.5 testing auf HP Proliant N40L, 2x 4GB ECC DDR3, 2x DD CINE-S2, Ocz Onyx 32GB, 3x WD Red WD30EFRX 3TB in SW Raid5

rudirabbit

Professional

Posts: 1,344

Occupation: Kfz Elektroniker

  • Send private message

29

Wednesday, December 21st 2011, 7:30pm

Hi,
Ich hab zwischenzeitlich auch die Zweitaschine mit ner GT430 ausgestattet und würde sagen das wir abgesehen von noad/markad gerade ganz nah an der Perfektion eines alten SD FF vdr kratzen....
Genau so schaut's aus, der VDR wird immer perfekter :tup
Was ich ehrlich gesagt nicht verstehe, eine schwächere Graka zu verbauen, nur weil die etwas weniger Strom zieht.
Preis/Leistungmässig ist die GT430 gerade das optimale - mit meiner alten GT220 habe ich allerdings auch keine Probleme.

BTW: Kann mir jemand verraten woher diese Log's (VDR Log LEVEL 3) kommen :

Source code

1
2
3
4
Dec 21 19:14:12 linux-q7w9 vdr: [2154] [demux_vdr] ts2es: no payload, size 0
Dec 21 19:14:13 linux-q7w9 vdr: [2154] [demux_vdr] ts2es: no payload, size 0
Dec 21 19:14:29 linux-q7w9 vdr: [2154] [demux_vdr] ts2es: no payload, size 0
Dec 21 19:14:34 linux-q7w9 vdr: [2154] [demux_vdr] ts2es: no payload, size 0

Dies habe ich schon länger auf diversen Systemen (bei Log Level3), Der VDR läuft prima - nur müllt dies den Log voll.

Gruß Rudi
VDR 1 (SD) : ASRock A330 GC, 1 GB RAM, TT- FF Karte rev. 2.3, 7'' TFT, Lirc X10 - Selbstbau Gehäuse - Suse 11.3 (64) vdr-1.7.10 diverse Plugins
VDR 2 (HD) : MSI G41M-P25, 2 GB RAM, E6700 2x3.20GHz, Gainward GT220, 2TB HD, Lirc X10, TT S2-3600 USB, TT S2-1600, - Suse 11.3 (64) NvidiaTreiber 260.19 vdr-1.7.18 - xineliboutplugin 1.0.90 cvs, xine-lib 1.1.90 , s2-liplianin DVB Treiber

fnu

Moderator

Posts: 8,153

Location: Böblingen

  • Send private message

30

Thursday, December 22nd 2011, 12:12am

Was ich ehrlich gesagt nicht verstehe, eine schwächere Graka zu verbauen, nur weil die etwas weniger Strom zieht.
Preis/Leistungmässig ist die GT430 gerade das optimale - mit meiner alten GT220 habe ich allerdings auch keine Probleme.

Dem kann ich nur beipflichten, die in den letzten Posts beschriebene Experience habe ich seit ich G96 basierte Grafikkarten (32 Cuda Cores) einsetze. Niemals ruckelndes OSD, immer temporal_spatial bei 1080i, tolles Bild und das die Unterschiede in der Leistungsaufnahmen eher gering denn wirklich groß sind haben wir schon 2009/2010 beschrieben. Wobei eine vernünftige CPU schon auch wichtig ist.

Wenn ich aktuell eine Grafikkarten kaufen müßte, würde ich wohl auch eine passive GT430 oben auf den Liste stehen. Die Pro-Version davon habe ich bereits auch hier ab und am im VDR Betrieb, Quadro 600 ...

Regards
fnu
Gib HD+/CI+ keine Chance! >> HowTo: APT Pinning <<

>>click<< for my VDR stuff

[¹] Modu CD21, MeanWell (80W)/LC-Power (75W), Futaba MDM166A, Intel DH77EB, G1610, 4GB DDR3, Intel 313 SSD 24GB, WD20EFRX 2TB, Zotac GT630 ('GK208'), SHDD, L4M Twin S2 (V5.6)/FlexS2 (4x DVB-S2), rt Unicable®, CIR, Ubuntu LTS 12.04.4, VDR 2.1.6 (x64, 44W)
[²] Modu CD21, MeanWell (80W)/PicoPSU (90W), Futaba MDM166A, ASRock Q1900M, 2GB DDR3, Intel 320 SSD 40GB, WD10JFCX, Palit GT630 ('GK208'), SHDD, Octopus Net SAT>IP, rt Unicable®, mceusb, Ubuntu Trusty, VDR 2.1.6 (x64, 24W)
[³] Cooler Master Elite 360, Xilence SPS-XP250.SFX (250W), Intel DH77KC, Xeon E3-1245v2, 8GB DDR3, Intel 313 SSD 24GB (Sys & HostCache), HP SA P400 256MB BBWC, 4x WD7500BPKX@Backpl., L4M Twin S2 (V5.4), VMWare ESXi 5.5 (6 VM)(x64, 45W)

This post has been edited 2 times, last edit by "fnu" (Dec 30th 2011, 5:35pm)


rudirabbit

Professional

Posts: 1,344

Occupation: Kfz Elektroniker

  • Send private message

31

Sunday, December 25th 2011, 7:03pm

Hi,
Wegen der Log Einträge

Source code

1
Dec 25 18:27:12 linux-q7w9 vdr: [1403] [demux_vdr] ts2es: no payload, size 0

Es passiert in dieser Funktion in der Datei (ts2es.c) vom xineliboutput plugin

Source code

1
 buf_element_t *ts2es_put(ts2es_t *this, uint8_t *data, fifo_buffer_t *src_fifo)

Dort wird unter anderem dies geprüft:

Source code

1
2
3
4
  if (!ts_HAS_PAYLOAD(data)) {
LOGDBG("ts2es: no payload, size %d", bytes);
return NULL;
  }

Also die Frage: (!ts_HAS_PAYLOAD(data)) wird mit true beantwortet, warum ist dies so ?
Ich habe keine Probleme mit Rucklern etc. - aber der Log wird vollgemüllt.
Oder stimmt was mit der Funktion ts_HAS_PAYLOAD nicht ?

Gruß - und frohes Fest
VDR 1 (SD) : ASRock A330 GC, 1 GB RAM, TT- FF Karte rev. 2.3, 7'' TFT, Lirc X10 - Selbstbau Gehäuse - Suse 11.3 (64) vdr-1.7.10 diverse Plugins
VDR 2 (HD) : MSI G41M-P25, 2 GB RAM, E6700 2x3.20GHz, Gainward GT220, 2TB HD, Lirc X10, TT S2-3600 USB, TT S2-1600, - Suse 11.3 (64) NvidiaTreiber 260.19 vdr-1.7.18 - xineliboutplugin 1.0.90 cvs, xine-lib 1.1.90 , s2-liplianin DVB Treiber

32

Friday, December 30th 2011, 5:31pm

@ iNOB und CKone: Welchen Wert hat bei euch video.processing.ffmpeg_thread_count in der xine config? Ändert sich die Dauer der Hänger, wenn ihr von 1 auf 2 oder umgekehrt geht?
Bei mir habe ich mit 2 ffmpeg Threads deutlich längere Hänger als mit 1 Thread, und im log stehen mit 2 Threads auch zwei hohe Werte (2 x 1-2 Sekunden im Abstand von 1-2 Sekunden, mit 1 Thread nur ein weniger hoher Wert (1 x 0,4 Sekunden).
(Mit 1 Thread habe ich allerdings erst ein Ergebnis, mit 2 Threads schon viele.)

Mein VDR

Asrock M3A770DE, Sempron 140 @ DualCore, 3 x TT S2-1600, GT520
openSuse 13.1 64bit, Kernel 3.14.13 + BER/UNC-Patch für stv090x, nvidia 340.24, vdr 2.1.6 mit Patchen (checkts, naludump, statusleds, ...)

33

Friday, December 30th 2011, 11:54pm

Bist du sicher das Xine ffmpeg verwendet?
Ich habe das so verstanden, daß xine seinen eigenen h264 Parser hat. Von diesem gibt es zwei Varianten.
Bei Verwendung von Hardwaredecodern, ist es besser nur einen Thread zuverwenden.

Johns

34

Saturday, December 31st 2011, 2:00am

Du meinst, dass mit vdpau der Wert von video.processing.ffmpeg_thread_count egal ist, weil ffmpeg nicht verwendet wird?
Ich logge seit längerem die Hänger mit, und seit ich kürzlich von 2 auf 1 gegangen bin, war mein (mit 1 bisher einziger) Hänger kürzer.
Könnte Zufall sein, oder an was anderem liegen. Ich werde es weiter beobachten. Wäre interessant, ob es bei anderen einen Unterschied macht.
Auf die Idee bin ich dadurch gekommen, was du in softhddevice - Software VDPAU/VA-VAPI/CPU Decoder und Ausgabe Plugin geschrieben hast. Das war auch mit vdpau.
Zitat von »jrie«
Ab und zu mal sehe ich beim Starten das:
[NULL @ 0xb2d00480] insufficient thread locking around avcodec_open/close()


Dies scheint aber ein ffmpeg Problem zusein, da ich selber nur einen Thread verwende und nur dieser ffmpeg aufruft.
Ich habe mal ffmpeg auf einen Thread begrenzt.

Mein VDR

Asrock M3A770DE, Sempron 140 @ DualCore, 3 x TT S2-1600, GT520
openSuse 13.1 64bit, Kernel 3.14.13 + BER/UNC-Patch für stv090x, nvidia 340.24, vdr 2.1.6 mit Patchen (checkts, naludump, statusleds, ...)

35

Saturday, December 31st 2011, 1:25pm

Du meinst, dass mit vdpau der Wert von video.processing.ffmpeg_thread_count egal ist, weil ffmpeg nicht verwendet wird?


Ja, aber hängt von den Prioritäten in config bzw. config_xineliboutput ab:
engine.decoder_priorities.ffmpegvideo
engine.decoder_priorities.vdpau_h264
engine.decoder_priorities.vdpau_h264_alter

Wenn du "engine.decoder_priorities.ffmpegvideo" verändert hast, dann kann auch ffmpeg verwendet werden. Aber normal wird "h264_alter" verwendet.

Johns

36

Saturday, December 31st 2011, 4:00pm

Die priorities sind bei mir alle auskommentiert, also auf default, und der vdpau_h264_alter wird verwendet. Also wohl andere Ursache.

Mein VDR

Asrock M3A770DE, Sempron 140 @ DualCore, 3 x TT S2-1600, GT520
openSuse 13.1 64bit, Kernel 3.14.13 + BER/UNC-Patch für stv090x, nvidia 340.24, vdr 2.1.6 mit Patchen (checkts, naludump, statusleds, ...)

rudirabbit

Professional

Posts: 1,344

Occupation: Kfz Elektroniker

  • Send private message

37

Saturday, December 31st 2011, 6:26pm

Bei mir steht dies im Log:

Source code

1
Dec 31 17:58:47 linux-q7w9 vdr: [1684] [demux_vdr] Using H.264  decoder "vdpau_h264_alter" (FFmpeg)


Also hat der "vdpau_h264_alter" Parser doch was mit FFmpeg tun ?
VDR 1 (SD) : ASRock A330 GC, 1 GB RAM, TT- FF Karte rev. 2.3, 7'' TFT, Lirc X10 - Selbstbau Gehäuse - Suse 11.3 (64) vdr-1.7.10 diverse Plugins
VDR 2 (HD) : MSI G41M-P25, 2 GB RAM, E6700 2x3.20GHz, Gainward GT220, 2TB HD, Lirc X10, TT S2-3600 USB, TT S2-1600, - Suse 11.3 (64) NvidiaTreiber 260.19 vdr-1.7.18 - xineliboutplugin 1.0.90 cvs, xine-lib 1.1.90 , s2-liplianin DVB Treiber