You are not logged in.

Dear visitor, welcome to VDR Portal. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

81

Thursday, December 15th 2011, 12:26pm


Zumindest hat es mich davor bewahrt , neue TV-Karten zu bestellen , denn das tlw. langsame und buggy Umschaltverhalten hier
liegt definitiv nicht an der Skystar HD ;).
Mit deinem Ausgabeplugin erfolgt das ja fast in Echtzeit , also kann der Tuner garnicht sooo schlecht/langsam sein :D


Da wirst du etwas überlistet. Ich zeige noch die gepufferten Bilder wärend umgeschaltet wird. Dadurch kommt einen die Pause kürzer vor bzw. das Umschalten schneller.
Ich werde heute mal eine neue Video/Audio Synchronisation versuchen. Da wird bis Video und Audio zusammenpassen das Video langsamer abgespielt. Damit ist dann die Pause am Anfang weg, läuft aber ca. 1/2 - 1 Sekunde in Zeitlupe.

Für SuSE bzw. xcb-util 0.3.6 habe ich dann auch eine Abfrage drin, sollte dann ohne Änderung funktionieren.

Johns
Sag mir, wo die Developer sind. Wo sind sie geblieben? . . . . . . . . . . . . . . . . . . . . SoftHdDevice - A software and GPU emulated HD output device plugin.
Sag mir, wo die Developer sind. Was ist geschehn?

Client0: Crown CW02 MSI_C847MS-E33 Zotac_GT640_passiv Cine-S2 iMon-MCE / streamdev softhddevice
Client1: Lian_Li_PC-Q09FB ASRock_H67M-ITX/HT I3-2100 ASUS_ENGT520_passiv / streamdev softhddevice
Test: Lian_Li_PC-Q09R Asus C60M1-I / streamdev
Server0: Dockstar TT-S2-3600-USB / streamdev
Server2: Lian_Li_PC-Q07R Intel_DH61DL G620 WD20EARX 90W PicoPSU Cine-S2+DuoFlex-S2+DuoFlex-CT / streamdev / 22 Watt Verbrauch

jsffm

Professional

Posts: 1,568

Location: Frankfurt/M

  • Send private message

82

Thursday, December 15th 2011, 7:12pm

Nach den vielen Verbesserungen hab ich auch nochmal getestet:

Aufzeichnungen in SD funktionieren, HD führt bei mir zum Crash.
Nach Neustart ist das plugin nicht mehr primary Device und muss nachgeführt werden.
Synchronität funktioniert manchmal gut, meist aber daneben, vor Allem nach Springen in Aufnahmen.

Deutlicher Fortschritt, gute Arbeit!

MfG,

jsffm

Mein VDR

VDR1 Mediaportal mit QVT-Board, Intel 810 Chipsatz, Pentium III 1,1 Ghz, 256 Mb Ram, WDC WD5000AAKB, DVB-S TT 1.5, Nova-S, Digidish 33, Gentoo Kernel 2.6.31, VDR 1.4.7
VDR2 Asrock M3N78D, Athlon X2 240e, 8 Gb Ram, Geforce GT 430, SL DVB-T, AirStar 2, MSI DIGIVOX Duo, PVR 350, Gentoo Kernel 3.10.17, VDR 2.0.6, softhddevice
VDR3 MC-1200, M3N78-EM, Athlon X2 235e, 2G Ram, WD20EARS, Mystique SaTiX-S2 Dual (v2), TT Budget S2-1600, Nova-TD Stick, Gentoo Kernel 3.9.11-r1, VDR 2.0.4, softhddevice
TV TX-37LZD85F, AV VSX-S500 - Consono 35


vdr-User-# 755 to_h264 chk_r

83

Thursday, December 15th 2011, 10:59pm

Du meinst Wiedergabe von HD Aufzeichnung?

Im Setup Menu oder setup.conf kannst MakePrimary setzten.

Im GIT gibts aktuelle Version mit neuen Audio/Video Sync Code. Viel besser wirds wohl nicht gehen,
Alle 10s gibts im syslog den aktuellen Stand.

Alte xcb-utils sollten nun automatisch erkannt werden, hoffe, ich habe die richtigen Namen genommen.

So nun habe ich mal wieder die Schnautze voll von VA-API, der Müll will einfach nicht.
Ich baue nun auch hier VDPAU ein.

Johns
Sag mir, wo die Developer sind. Wo sind sie geblieben? . . . . . . . . . . . . . . . . . . . . SoftHdDevice - A software and GPU emulated HD output device plugin.
Sag mir, wo die Developer sind. Was ist geschehn?

Client0: Crown CW02 MSI_C847MS-E33 Zotac_GT640_passiv Cine-S2 iMon-MCE / streamdev softhddevice
Client1: Lian_Li_PC-Q09FB ASRock_H67M-ITX/HT I3-2100 ASUS_ENGT520_passiv / streamdev softhddevice
Test: Lian_Li_PC-Q09R Asus C60M1-I / streamdev
Server0: Dockstar TT-S2-3600-USB / streamdev
Server2: Lian_Li_PC-Q07R Intel_DH61DL G620 WD20EARX 90W PicoPSU Cine-S2+DuoFlex-S2+DuoFlex-CT / streamdev / 22 Watt Verbrauch

jsffm

Professional

Posts: 1,568

Location: Frankfurt/M

  • Send private message

84

Thursday, December 15th 2011, 11:05pm

Du meinst Wiedergabe von HD Aufzeichnung?
Genau.

Mein VDR

VDR1 Mediaportal mit QVT-Board, Intel 810 Chipsatz, Pentium III 1,1 Ghz, 256 Mb Ram, WDC WD5000AAKB, DVB-S TT 1.5, Nova-S, Digidish 33, Gentoo Kernel 2.6.31, VDR 1.4.7
VDR2 Asrock M3N78D, Athlon X2 240e, 8 Gb Ram, Geforce GT 430, SL DVB-T, AirStar 2, MSI DIGIVOX Duo, PVR 350, Gentoo Kernel 3.10.17, VDR 2.0.6, softhddevice
VDR3 MC-1200, M3N78-EM, Athlon X2 235e, 2G Ram, WD20EARS, Mystique SaTiX-S2 Dual (v2), TT Budget S2-1600, Nova-TD Stick, Gentoo Kernel 3.9.11-r1, VDR 2.0.4, softhddevice
TV TX-37LZD85F, AV VSX-S500 - Consono 35


vdr-User-# 755 to_h264 chk_r

85

Friday, December 16th 2011, 7:13am

Danke für die Berücksichtigung von Suse/alte xcb-icccm. Jetzt kommt allerdings "undefined symbol: xcb_icccm_set_wm_protocols".
An meinem VDR PC hängt keine Maus, aber ich sehe immer den Mauscursor in der Mitte, lässt sich da was machen?
Abspielen von SD und HD Aufnahmen geht bei mir.
Ich bin schon auf die vdpau Version gespannt.
Jörg

Mein VDR

Asrock M3A770DE, Sempron 140 @ DualCore, 3 x TT S2-1600, GT520
openSuse 13.1 64bit, Kernel 3.14.17 + BER/UNC-Patch für stv090x, nvidia 340.32, vdr 2.1.6 mit Patchen (checkts, naludump, statusleds, ...)

fnu

Moderator

Posts: 8,265

Location: Böblingen

  • Send private message

86

Friday, December 16th 2011, 3:54pm

@johns

Konnte meinen Monitor in 50Hz Mode zwingen, gar nicht so einfach, der Nvidia-Treiber will ausschließlich mit den EDID Modes arbeiten und ignoriert jede "xrandr" Einmischung. Hab dann meine VDR xorg.conf hergenommen und angepasst, siehe Anhang falls es jemand benötigt.

Findings für LiveTV:
  • Video 100% rund bei 50Hz Ausgabe
  • Ton bei SD synchron, bei HD leider nicht
  • 720P Bild erwartungsgemäß sehr gut
  • 1080i Bild ok mit "Bob", hier könnte man sogar erstmal mit leben, weil keine Skalierung nötig
  • 576i Bild ausreichend, recht grob und verrauscht, weil auch noch skaliert. Hier wäre die Qualität "temporal_spatial" der Nvidia Ausgabe wünschenswert.
Hatte aber vorher nochmal mit der Ausgabe über Intel getestet, aber das war mein letzter Test, das Bild kann man IMHO nicht anschauen und ist mir kein weiteren Mühen wert. Ich zweifel auch dran das ein etwas besserer Software-Deinterlacer hier ein akzeptables Ergebnis im Vergleich zu VDPAU bringt. Evtl. ändert sich ja mal was, wenn Intel auf das Angebot von Nvidia einsteigt, siehe hier.

Wahrscheinlich tausche ich eher das Intel Brett wieder gegen ein AMD MoBo, dann kann ich wenigstens mal testen ob Radeon@VA-API mit softhddevice funktioniert.

Generell denke ich liegt die Messlatte bei VDPAU's "temporal" für HD und "temporal_spatial" für SD. Keine Ahnung wie schwierig eine Umsetzung/Nutzung hier ist, reden ist immer leicht, es scheint ja aktuell ein Software-Deinterlacer genutzt zu werden?

Auch komme ich mit den plugin-settings im OSD nicht klar, irgendwie wird mir jedesmal was anderes angezeigt wenn ich da rein gehe, obwohl die Parameter in der setup.conf sich nie ändern?

Kann mir jemand einen Tip geben, warum ich per streamdev "AnixeHD" nicht auf der softhddevice-Maschine angezeigt bekomme? Ton ist da, aber kein Bild, die senden in 1280x1080i ...

Regards
fnu
fnu has attached the following file:
  • xorg.conf (2.01 kB - 46 times downloaded - latest: Aug 12th 2014, 12:09am)
Gib HD+/CI+ keine Chance! >> HowTo: APT Pinning <<

>>click<< for my VDR stuff

[¹] Modu CD21, MeanWell (80W)/LC-Power (75W), Futaba MDM166A, Intel DH77EB, G1610, 4GB DDR3, Intel 313 SSD 24GB, WD20EFRX 2TB, Zotac GT630 ('GK208'), SHDD, L4M Twin S2 (V5.6)/FlexS2 (4x DVB-S2), rt Unicable®, CIR, Ubuntu LTS 12.04.4, VDR 2.1.6 (x64, 44W)
[²] Modu CD21, MeanWell (80W)/PicoPSU (90W), Futaba MDM166A, ASRock Q1900M, 2GB DDR3, Intel 320 SSD 40GB, WD10JFCX, Palit GT630 ('GK208'), SHDD, Octopus Net SAT>IP, rt Unicable®, mceusb, Ubuntu LTS 14.04, VDR 2.1.6 (x64, 24W)
[³] Cooler Master Elite 360, Xilence SPS-XP250.SFX (250W), Intel DH77KC, Xeon E3-1245v2, 8GB DDR3, Intel 313 SSD 24GB (Sys & HostCache), HP SA P400 256MB BBWC, 4x WD7500BPKX@Backpl., L4M Twin S2 (V5.4), VMWare ESXi 5.5 (6 VM)(x64, 45W)

This post has been edited 1 times, last edit by "fnu" (Dec 16th 2011, 4:27pm)


87

Friday, December 16th 2011, 4:28pm

@fnu:
Bei mir funktioniert xrandr mit den Nvidia-Treibern ohne Probleme.

Probier es doch mal mit folgenden Optioonen:

Source code

1
2
Option "ExactModeTimingsDVI" "True"
Option "ModeValidation" "NoVesaModes,NoXServerModes"
Dr. Brömme grübelt:
Acht Wochen, nachdem man ihm beim Kölner Straßenkarneval einen Gratiskorn angeboten hatte,
dämmert ihm langsam, dass er einem hinterlistigen Alaafisten aufgesessen ist.

fnu

Moderator

Posts: 8,265

Location: Böblingen

  • Send private message

88

Friday, December 16th 2011, 4:34pm

Bei mir funktioniert xrandr mit den Nvidia-Treibern ohne Probleme.

Danke, ja kann sein, das es mit den Parameter

Source code

1
Option "ExactModeTimingsDVI" "True"

auch bei mir funktioniert hätte. Hatte ich vorher auch nicht drin, erst jetzt in der angepassten "xorg.conf". Aber ich habe ja eine dauerhafte Lösung gefunden, die ich auch für alle Grafikkarten nehmen kann.

Regards
fnu
Gib HD+/CI+ keine Chance! >> HowTo: APT Pinning <<

>>click<< for my VDR stuff

[¹] Modu CD21, MeanWell (80W)/LC-Power (75W), Futaba MDM166A, Intel DH77EB, G1610, 4GB DDR3, Intel 313 SSD 24GB, WD20EFRX 2TB, Zotac GT630 ('GK208'), SHDD, L4M Twin S2 (V5.6)/FlexS2 (4x DVB-S2), rt Unicable®, CIR, Ubuntu LTS 12.04.4, VDR 2.1.6 (x64, 44W)
[²] Modu CD21, MeanWell (80W)/PicoPSU (90W), Futaba MDM166A, ASRock Q1900M, 2GB DDR3, Intel 320 SSD 40GB, WD10JFCX, Palit GT630 ('GK208'), SHDD, Octopus Net SAT>IP, rt Unicable®, mceusb, Ubuntu LTS 14.04, VDR 2.1.6 (x64, 24W)
[³] Cooler Master Elite 360, Xilence SPS-XP250.SFX (250W), Intel DH77KC, Xeon E3-1245v2, 8GB DDR3, Intel 313 SSD 24GB (Sys & HostCache), HP SA P400 256MB BBWC, 4x WD7500BPKX@Backpl., L4M Twin S2 (V5.4), VMWare ESXi 5.5 (6 VM)(x64, 45W)

89

Friday, December 16th 2011, 6:11pm

Auch komme ich mit den plugin-settings im OSD nicht klar, irgendwie wird mir jedesmal was anderes angezeigt wenn ich da rein gehe, obwohl die Parameter in der setup.conf sich nie ändern?
so gehts:
1. settings ändern
2. vdr neu starten
3. Änderungen sichtbar
ohne 2. sieht es so aus, als ob er die Änderungen nicht übernimmt (außer man schaut in der setup.conf nach)

Mein VDR

Asrock M3A770DE, Sempron 140 @ DualCore, 3 x TT S2-1600, GT520
openSuse 13.1 64bit, Kernel 3.14.17 + BER/UNC-Patch für stv090x, nvidia 340.32, vdr 2.1.6 mit Patchen (checkts, naludump, statusleds, ...)

fnu

Moderator

Posts: 8,265

Location: Böblingen

  • Send private message

90

Friday, December 16th 2011, 6:55pm

@jrie

Ok, danke, aber ich wollte gar nichts ändern, bin nur immer mal wieder in die Settings rein und jedesmal steht was anderes drin, hab wirklich oft nachgeschaut. Dachte schon der zeigt dynamisch an, was er grad bei welchem Sender macht, kann aber wohl nicht sein ... ;)

Ist auch nicht so wichtig, solange die Settings der setup.conf gelten, ist ja noch in der Entwicklung. Ich wäre mehr an einem Feedback bzgl. "AnixeHD" via streamdev interessiert, dann hätte ich einen weiteren 1080i Sender zum Test ... :arme

Regards
fnu
Gib HD+/CI+ keine Chance! >> HowTo: APT Pinning <<

>>click<< for my VDR stuff

[¹] Modu CD21, MeanWell (80W)/LC-Power (75W), Futaba MDM166A, Intel DH77EB, G1610, 4GB DDR3, Intel 313 SSD 24GB, WD20EFRX 2TB, Zotac GT630 ('GK208'), SHDD, L4M Twin S2 (V5.6)/FlexS2 (4x DVB-S2), rt Unicable®, CIR, Ubuntu LTS 12.04.4, VDR 2.1.6 (x64, 44W)
[²] Modu CD21, MeanWell (80W)/PicoPSU (90W), Futaba MDM166A, ASRock Q1900M, 2GB DDR3, Intel 320 SSD 40GB, WD10JFCX, Palit GT630 ('GK208'), SHDD, Octopus Net SAT>IP, rt Unicable®, mceusb, Ubuntu LTS 14.04, VDR 2.1.6 (x64, 24W)
[³] Cooler Master Elite 360, Xilence SPS-XP250.SFX (250W), Intel DH77KC, Xeon E3-1245v2, 8GB DDR3, Intel 313 SSD 24GB (Sys & HostCache), HP SA P400 256MB BBWC, 4x WD7500BPKX@Backpl., L4M Twin S2 (V5.4), VMWare ESXi 5.5 (6 VM)(x64, 45W)

91

Friday, December 16th 2011, 8:39pm

So jetzt hat mir dieses Scheiss Board doch die Antwort gekillt.

Nun habe ich keinen Bock nochmal eine 1/2 Stunde Text zuschreiben,

Kurzform:

Ruft das Setupmenu nicht automatisch nach dem Speichern cMenuSetupPage::SetupParse auf?
Ansonsten können die meisten Parameter von der Software sowieso erst nach einem Restart geändert werden.

AnixeHD funktioniert bei mir, bis auf Fehler in VA-API (NVidia droppt Frames, Intel verdoppelt welche) und deshalb mache ich erstmal mit VDPAU weiter.
Obwohl ich mir da noch einen Großteil noch erlesen bzw. abschauen muss.

Johns
Sag mir, wo die Developer sind. Wo sind sie geblieben? . . . . . . . . . . . . . . . . . . . . SoftHdDevice - A software and GPU emulated HD output device plugin.
Sag mir, wo die Developer sind. Was ist geschehn?

Client0: Crown CW02 MSI_C847MS-E33 Zotac_GT640_passiv Cine-S2 iMon-MCE / streamdev softhddevice
Client1: Lian_Li_PC-Q09FB ASRock_H67M-ITX/HT I3-2100 ASUS_ENGT520_passiv / streamdev softhddevice
Test: Lian_Li_PC-Q09R Asus C60M1-I / streamdev
Server0: Dockstar TT-S2-3600-USB / streamdev
Server2: Lian_Li_PC-Q07R Intel_DH61DL G620 WD20EARX 90W PicoPSU Cine-S2+DuoFlex-S2+DuoFlex-CT / streamdev / 22 Watt Verbrauch

fnu

Moderator

Posts: 8,265

Location: Böblingen

  • Send private message

92

Friday, December 16th 2011, 8:44pm

Ruft das Setupmenu nicht automatisch nach dem Speichern cMenuSetupPage::SetupParse auf?

Würde bedeuten, der VDR macht was falsch?

Wie gesagt ich habe nichts geändert, noch möchte ich was ändern. Aber annähernd jedesmal wenn ich in die Settings geguckt habe stand da etwas anderes, in allen möglichen Kombinationen ... ?

Kann man überhaupt was sinnvoll ausser "Main Device = 1|0" ändern?

Regards
fnu

PS.: Sorry, falsch zitiert ...
Gib HD+/CI+ keine Chance! >> HowTo: APT Pinning <<

>>click<< for my VDR stuff

[¹] Modu CD21, MeanWell (80W)/LC-Power (75W), Futaba MDM166A, Intel DH77EB, G1610, 4GB DDR3, Intel 313 SSD 24GB, WD20EFRX 2TB, Zotac GT630 ('GK208'), SHDD, L4M Twin S2 (V5.6)/FlexS2 (4x DVB-S2), rt Unicable®, CIR, Ubuntu LTS 12.04.4, VDR 2.1.6 (x64, 44W)
[²] Modu CD21, MeanWell (80W)/PicoPSU (90W), Futaba MDM166A, ASRock Q1900M, 2GB DDR3, Intel 320 SSD 40GB, WD10JFCX, Palit GT630 ('GK208'), SHDD, Octopus Net SAT>IP, rt Unicable®, mceusb, Ubuntu LTS 14.04, VDR 2.1.6 (x64, 24W)
[³] Cooler Master Elite 360, Xilence SPS-XP250.SFX (250W), Intel DH77KC, Xeon E3-1245v2, 8GB DDR3, Intel 313 SSD 24GB (Sys & HostCache), HP SA P400 256MB BBWC, 4x WD7500BPKX@Backpl., L4M Twin S2 (V5.4), VMWare ESXi 5.5 (6 VM)(x64, 45W)

This post has been edited 1 times, last edit by "fnu" (Dec 16th 2011, 8:53pm)


93

Friday, December 16th 2011, 8:55pm

Edit auf das Zitat:
Zumindest hätte ich das so erwartet.

Das klingt nach alter Version. Thu Dec 15 16:02:32 2011 +0100 habe ich es eingebaut.

Also er sollte keine Zufallwerte mehr anzeigen. Aber beim zweitenmal Menu anzeigen wieder die ersten.

Also der Deinterlacer Bob / Weave sind drin, alle anderen Zukunftsmusic.
Und das Skalieren geht auch, aber nicht alle haben mit jeder Hardware eine Funktion.

Diese Werte werden aber nur beim Öffnen von mir ausgewertet. ich muss da die Logik ändern um die im Laufenden Betrieb umzuschalten.

Johns
Sag mir, wo die Developer sind. Wo sind sie geblieben? . . . . . . . . . . . . . . . . . . . . SoftHdDevice - A software and GPU emulated HD output device plugin.
Sag mir, wo die Developer sind. Was ist geschehn?

Client0: Crown CW02 MSI_C847MS-E33 Zotac_GT640_passiv Cine-S2 iMon-MCE / streamdev softhddevice
Client1: Lian_Li_PC-Q09FB ASRock_H67M-ITX/HT I3-2100 ASUS_ENGT520_passiv / streamdev softhddevice
Test: Lian_Li_PC-Q09R Asus C60M1-I / streamdev
Server0: Dockstar TT-S2-3600-USB / streamdev
Server2: Lian_Li_PC-Q07R Intel_DH61DL G620 WD20EARX 90W PicoPSU Cine-S2+DuoFlex-S2+DuoFlex-CT / streamdev / 22 Watt Verbrauch

fnu

Moderator

Posts: 8,265

Location: Böblingen

  • Send private message

94

Friday, December 16th 2011, 9:00pm

Das klingt nach alter Version. Thu Dec 15 16:02:32 2011 +0100 habe ich es eingebaut.

Hmpf, ja vmtl., da kommt man vor lauter Bauen nimmer zum testen ... ;D

Diese Werte werden aber nur beim Öffnen von mir ausgewertet. ich muss da die Logik ändern um die im Laufenden Betrieb umzuschalten.

Ja, passt schon, ein Neustart wäre nicht so schlimm, man ändert ja nur bei Tests öfter, dananch nimmer ... aber welche der Skalierungen gehen denn mit VDPAU?

Regards
fnu
Gib HD+/CI+ keine Chance! >> HowTo: APT Pinning <<

>>click<< for my VDR stuff

[¹] Modu CD21, MeanWell (80W)/LC-Power (75W), Futaba MDM166A, Intel DH77EB, G1610, 4GB DDR3, Intel 313 SSD 24GB, WD20EFRX 2TB, Zotac GT630 ('GK208'), SHDD, L4M Twin S2 (V5.6)/FlexS2 (4x DVB-S2), rt Unicable®, CIR, Ubuntu LTS 12.04.4, VDR 2.1.6 (x64, 44W)
[²] Modu CD21, MeanWell (80W)/PicoPSU (90W), Futaba MDM166A, ASRock Q1900M, 2GB DDR3, Intel 320 SSD 40GB, WD10JFCX, Palit GT630 ('GK208'), SHDD, Octopus Net SAT>IP, rt Unicable®, mceusb, Ubuntu LTS 14.04, VDR 2.1.6 (x64, 24W)
[³] Cooler Master Elite 360, Xilence SPS-XP250.SFX (250W), Intel DH77KC, Xeon E3-1245v2, 8GB DDR3, Intel 313 SSD 24GB (Sys & HostCache), HP SA P400 256MB BBWC, 4x WD7500BPKX@Backpl., L4M Twin S2 (V5.4), VMWare ESXi 5.5 (6 VM)(x64, 45W)

95

Friday, December 16th 2011, 10:05pm

Es sollten nur Normal und HQ gehen

Habe heute nen update gemacht, entweder gab es da was neues (zumindest ffmpeg 0.9 und neuen Intel), aber wenn ich meinen Hack wiederrausnehme, klappt VDPAU sehr gut.
Vielleicht doch nur temporal spatial in den vdpau-driver einbauen.

Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
diff --git a/video.c b/video.c
index 0e437d8..96e4c01 100644
--- a/video.c
+++ b/video.c
@@ -2520,7 +2520,7 @@ static void VaapiDisplayFrame(void)
        // deinterlace and full frame rate
        // VDPAU driver only display a frame, if a full frame is put
        // INTEL driver does the same, but only with 1080i
-       if (decoder->Interlaced
+       if (0 && decoder->Interlaced
            // FIXME: buggy libva-driver-vdpau, buggy libva-driver-intel
            && (VaapiBuggyVdpau || (0 && VaapiBuggyIntel
                    && decoder->InputHeight == 1080))


Johns
Sag mir, wo die Developer sind. Wo sind sie geblieben? . . . . . . . . . . . . . . . . . . . . SoftHdDevice - A software and GPU emulated HD output device plugin.
Sag mir, wo die Developer sind. Was ist geschehn?

Client0: Crown CW02 MSI_C847MS-E33 Zotac_GT640_passiv Cine-S2 iMon-MCE / streamdev softhddevice
Client1: Lian_Li_PC-Q09FB ASRock_H67M-ITX/HT I3-2100 ASUS_ENGT520_passiv / streamdev softhddevice
Test: Lian_Li_PC-Q09R Asus C60M1-I / streamdev
Server0: Dockstar TT-S2-3600-USB / streamdev
Server2: Lian_Li_PC-Q07R Intel_DH61DL G620 WD20EARX 90W PicoPSU Cine-S2+DuoFlex-S2+DuoFlex-CT / streamdev / 22 Watt Verbrauch

fnu

Moderator

Posts: 8,265

Location: Böblingen

  • Send private message

96

Friday, December 16th 2011, 10:16pm

@johns

Hab grad nomm'l den letzten git Stand von heute morgen rein gewürgt, aber das Problem mit der wirren OSD Setting Anzeige besteht immer noch. Wäre auch nicht so schlimm, kann ich irgendwo nachlesen wie die Parameter in setup.conf dazu lauten?

Beim anderen kann ich nicht folgen? Bzw., das ist nur eine Zeile Code-Änderung, ausprobieren?

Regards
fnu
Gib HD+/CI+ keine Chance! >> HowTo: APT Pinning <<

>>click<< for my VDR stuff

[¹] Modu CD21, MeanWell (80W)/LC-Power (75W), Futaba MDM166A, Intel DH77EB, G1610, 4GB DDR3, Intel 313 SSD 24GB, WD20EFRX 2TB, Zotac GT630 ('GK208'), SHDD, L4M Twin S2 (V5.6)/FlexS2 (4x DVB-S2), rt Unicable®, CIR, Ubuntu LTS 12.04.4, VDR 2.1.6 (x64, 44W)
[²] Modu CD21, MeanWell (80W)/PicoPSU (90W), Futaba MDM166A, ASRock Q1900M, 2GB DDR3, Intel 320 SSD 40GB, WD10JFCX, Palit GT630 ('GK208'), SHDD, Octopus Net SAT>IP, rt Unicable®, mceusb, Ubuntu LTS 14.04, VDR 2.1.6 (x64, 24W)
[³] Cooler Master Elite 360, Xilence SPS-XP250.SFX (250W), Intel DH77KC, Xeon E3-1245v2, 8GB DDR3, Intel 313 SSD 24GB (Sys & HostCache), HP SA P400 256MB BBWC, 4x WD7500BPKX@Backpl., L4M Twin S2 (V5.4), VMWare ESXi 5.5 (6 VM)(x64, 45W)

97

Friday, December 16th 2011, 10:18pm

Vielleicht doch nur temporal spatial in den vdpau-driver einbauen.

Denk an die armen Leute mit ION1 und Geforce N210 Karten - temporal wär da auch ganz praktisch... :unsch
yaVDR-Doku

Meine VDRs

VDR 1: Point of View Ion-330-1 (Intel Atom 330@1,6 GHz). 2GB, 4TB HDD, KNC One DVB-C, Sundtek MediaTV Pro (DVB-C), Atric IR-Einschalter Rev.5, yaVDR 0.5 testing
VDR 2: Acer Revo 3610, 4GB Ram, 1x HDD 320 GB, Pinnacle PCTV SAT 452e, Medion X10, YaVDR 0.5
VDR 3: Intel DH67BL, Celeron 540, 4 GB Ram, POV Geforce 210 512 MB, 500 GB, DD Duo-flex CT, Arch LInux, VDR 2.1.6, CIR-Empfänger
Client 1: Raspberry Pi Model B, Arch Linux ARM, VDR 2.1.6
vdr-epg-daemon + MariaDB auf Cubietruck mit 32 GB SSD, Arch Linux ARM, optional Sundtek MediaTV Pro III + VDR 2.1.6
Ceterum censeo enchiridia esse lectitanda.

fnu

Moderator

Posts: 8,265

Location: Böblingen

  • Send private message

98

Friday, December 16th 2011, 10:28pm

Denk an die armen Leute mit ION1 und Geforce N210 Karten - temporal wär da auch ganz praktisch... :unsch

Kauft Euch gescheite Hardware ... :ausheck ... mein GT218GL kann auch temporal_spatial in HD, ..., aber da fällt er mir in 2 Wochen wohl "well done" aus der Kiste ... ;D

Regards
fnu
Gib HD+/CI+ keine Chance! >> HowTo: APT Pinning <<

>>click<< for my VDR stuff

[¹] Modu CD21, MeanWell (80W)/LC-Power (75W), Futaba MDM166A, Intel DH77EB, G1610, 4GB DDR3, Intel 313 SSD 24GB, WD20EFRX 2TB, Zotac GT630 ('GK208'), SHDD, L4M Twin S2 (V5.6)/FlexS2 (4x DVB-S2), rt Unicable®, CIR, Ubuntu LTS 12.04.4, VDR 2.1.6 (x64, 44W)
[²] Modu CD21, MeanWell (80W)/PicoPSU (90W), Futaba MDM166A, ASRock Q1900M, 2GB DDR3, Intel 320 SSD 40GB, WD10JFCX, Palit GT630 ('GK208'), SHDD, Octopus Net SAT>IP, rt Unicable®, mceusb, Ubuntu LTS 14.04, VDR 2.1.6 (x64, 24W)
[³] Cooler Master Elite 360, Xilence SPS-XP250.SFX (250W), Intel DH77KC, Xeon E3-1245v2, 8GB DDR3, Intel 313 SSD 24GB (Sys & HostCache), HP SA P400 256MB BBWC, 4x WD7500BPKX@Backpl., L4M Twin S2 (V5.4), VMWare ESXi 5.5 (6 VM)(x64, 45W)

99

Friday, December 16th 2011, 10:33pm

softhddevice.Deinterlace = 0
0 = bob, 1 = weave, 2 = temporal, 3 = temporal_spatial, 4 = software
(nur 0 und 1 bis jetzt)

softhddevice.MakePrimary = 1
0 = keine Veränderung, 1 softhddevice wird primary beim Start

softhddevice.Scaling = 0

0 = Normal, 1 = Fast, 2 = HQ, 3 = anamorphic

3 geht zwar, aber dann müsste man noch die 4:3 Ausgabe als 16:9 ausgeben.

Ja, wäre nur das "0 && " einzufügen, scheint mit dem neuen Audio Sync Version besser zusein.

ob nun temporal oder sonst so, wäre alles die Gleiche Arbeit.

Johns
Sag mir, wo die Developer sind. Wo sind sie geblieben? . . . . . . . . . . . . . . . . . . . . SoftHdDevice - A software and GPU emulated HD output device plugin.
Sag mir, wo die Developer sind. Was ist geschehn?

Client0: Crown CW02 MSI_C847MS-E33 Zotac_GT640_passiv Cine-S2 iMon-MCE / streamdev softhddevice
Client1: Lian_Li_PC-Q09FB ASRock_H67M-ITX/HT I3-2100 ASUS_ENGT520_passiv / streamdev softhddevice
Test: Lian_Li_PC-Q09R Asus C60M1-I / streamdev
Server0: Dockstar TT-S2-3600-USB / streamdev
Server2: Lian_Li_PC-Q07R Intel_DH61DL G620 WD20EARX 90W PicoPSU Cine-S2+DuoFlex-S2+DuoFlex-CT / streamdev / 22 Watt Verbrauch

fnu

Moderator

Posts: 8,265

Location: Böblingen

  • Send private message

100

Friday, December 16th 2011, 11:06pm

@johns

Ok, danke, hab jetzt Scaling auf HQ direkt in der setup.conf gesetzt, SD sieht besser aus, nicht mehr ganz so grob und verrauscht.

Habe den Code Schnippsel übernommen und ja, HD Ton immer noch asynchron, etwas vorraus und bei manchen SD Sender wird's auch wieder leicht asynchron ... eben grad bei 3sat "Cleaner" z.B., aber das ist das beste SD Bild bisher, cool.

Regards
fnu
Gib HD+/CI+ keine Chance! >> HowTo: APT Pinning <<

>>click<< for my VDR stuff

[¹] Modu CD21, MeanWell (80W)/LC-Power (75W), Futaba MDM166A, Intel DH77EB, G1610, 4GB DDR3, Intel 313 SSD 24GB, WD20EFRX 2TB, Zotac GT630 ('GK208'), SHDD, L4M Twin S2 (V5.6)/FlexS2 (4x DVB-S2), rt Unicable®, CIR, Ubuntu LTS 12.04.4, VDR 2.1.6 (x64, 44W)
[²] Modu CD21, MeanWell (80W)/PicoPSU (90W), Futaba MDM166A, ASRock Q1900M, 2GB DDR3, Intel 320 SSD 40GB, WD10JFCX, Palit GT630 ('GK208'), SHDD, Octopus Net SAT>IP, rt Unicable®, mceusb, Ubuntu LTS 14.04, VDR 2.1.6 (x64, 24W)
[³] Cooler Master Elite 360, Xilence SPS-XP250.SFX (250W), Intel DH77KC, Xeon E3-1245v2, 8GB DDR3, Intel 313 SSD 24GB (Sys & HostCache), HP SA P400 256MB BBWC, 4x WD7500BPKX@Backpl., L4M Twin S2 (V5.4), VMWare ESXi 5.5 (6 VM)(x64, 45W)