You are not logged in.

Dear visitor, welcome to VDR Portal. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

izeman

Master

Posts: 1,710

Location: Österreich

  • Send private message

521

Sunday, January 29th 2012, 3:35pm

Quoted from "gda"

Du willst mich veräppeln, oder? Mit den yaVDR-Source-Paketen auf deinem System passiert überhaupt nicht, sie werden nicht verändert.

jeden anderen. aber NICHT DICH gerald. :) ne im ernst: ich wollte nur sicher gehen, weil ja bei einem yavdr system das system nicht mehr funktionsfaehig ist, nach einem upgrade auf oneiric. dass es sich mit den sourcen anders verhaelt war mir schon klar. aber sicher ist sicher :)
produktiv: asus p5n7a-vm, 1x tt-6400, 1x skystar dvb-s2, 8gig boot-ssd, 7" samsung u7, yavdr 0.5, atric 1.5 ir einschalter
testing: zotac ion-f itx, 2x tt s2-3600 usb (netceiver mit 2x dvb-s2), 60gig boot-hd, (level one usb-eth), yavdr 0.2 unstable
tv: lg 60pk-550 full-hd amp: yamaha rx-v367

522

Sunday, January 29th 2012, 3:42pm

Eine Letzte Idee habe ich noch.

Hast du "-x" beim Plugin also bei -P"softhddevice -g 0x576+0+0 -a hw:NVidia,7 -x"?
Du hast aber X bereits gestartet? Dann kommen auch keine Video Meldungen!

Johns
Sag mir, wo die Developer sind. Wo sind sie geblieben? . . . . . . . . . . . . . . . . . . . . SoftHdDevice - A software and GPU emulated HD output device plugin.
Sag mir, wo die Developer sind. Was ist geschehn?

Client0: Crown CW02 MSI_C847MS-E33 Zotac_GT640_passiv Cine-S2 iMon-MCE / streamdev softhddevice
Client1: Lian_Li_PC-Q09FB ASRock_H67M-ITX/HT I3-2100 ASUS_ENGT520_passiv / streamdev softhddevice
Test: Lian_Li_PC-Q09R Asus C60M1-I / streamdev
Server0: Dockstar TT-S2-3600-USB / streamdev
Server2: Lian_Li_PC-Q07R Intel_DH61DL G620 WD20EARX 90W PicoPSU Cine-S2+DuoFlex-S2+DuoFlex-CT / streamdev / 22 Watt Verbrauch

izeman

Master

Posts: 1,710

Location: Österreich

  • Send private message

523

Sunday, January 29th 2012, 3:49pm

tut auch nicht. ich mach mal ein release-upgrade. mal sehen. vielleicht hilft es ja :)
produktiv: asus p5n7a-vm, 1x tt-6400, 1x skystar dvb-s2, 8gig boot-ssd, 7" samsung u7, yavdr 0.5, atric 1.5 ir einschalter
testing: zotac ion-f itx, 2x tt s2-3600 usb (netceiver mit 2x dvb-s2), 60gig boot-hd, (level one usb-eth), yavdr 0.2 unstable
tv: lg 60pk-550 full-hd amp: yamaha rx-v367

Atechsystem

Professional

Posts: 1,113

Location: NRW

Occupation: Informationstechniker

  • Send private message

524

Sunday, January 29th 2012, 5:25pm

@izeman

Da kommt nichts mit video? Geht das nur an die TT-6400?

@fnu

Da meckerst du beim Falschen. Ich kann ja nichts dafür das Intel seit 4 Jahren nicht in der Lage ist gescheite funktionierende Treiber abzuliefern.
Dies ist das erste Mal, das etwas stabil und ansehnlich läuft.

Johns
Hallo,

ich habe Kontakt mit dem vaapi Programmierer aufgenommen und er will sich z.B. um das Deinterlacingproblem bei Clarkdale kümmern. Ausserdem werde ich in Zukunft weitere Probleme an die Intel-gfx Mailingliste schicken. Es tut sich was :)

Gruß
Atech
HTPC:
Softtware: Archlinux mit VDR aus Archvdr repo (1.7.31 mit softhddevice) und xbmc 12.2 Frodo stable
Hardware: Coolermaster 260 mit Core I3 540, 4 GB Kingst. Ram, GA.H55M-D2H, PCIe 16X RiserCard, NVIDIA 430GT, TT3600USB, Satix S2 Sky V2 USB, Samsung SSD 640, WD Blue 1TB (WD10TP), IR Einschalter, imon Display, mce FB und 12 Kanal Atmolight (4 Led Streifen) über DFatmo und Boblight

izeman

Master

Posts: 1,710

Location: Österreich

  • Send private message

525

Sunday, January 29th 2012, 8:41pm

habe positives zu vermelden. ich hab schon mal ein bild :)
hab auf oneiric upgegraded, und jetzt kommt auch mit der 6400 ein bild. wenn auch ziemlich ruckelig das ganze, und hier so nicht brauchbar. aber auch die schnell laeufts mal.
werde morgen weitertesten ...

danke fuer eure hilfe!
produktiv: asus p5n7a-vm, 1x tt-6400, 1x skystar dvb-s2, 8gig boot-ssd, 7" samsung u7, yavdr 0.5, atric 1.5 ir einschalter
testing: zotac ion-f itx, 2x tt s2-3600 usb (netceiver mit 2x dvb-s2), 60gig boot-hd, (level one usb-eth), yavdr 0.2 unstable
tv: lg 60pk-550 full-hd amp: yamaha rx-v367

helau

Sage

Posts: 5,083

Location: Northern Black Forest

  • Send private message

526

Sunday, January 29th 2012, 11:58pm

Hallo
Gibts auch die Moeglichkeit softhddevice im suspended mode zu starten ?
Ich moechte X selbst starten und erst wenn X oben ist die X Ausgabe aktivieren.
Natuerlich geht das mit svdrpsend suspend direkt nach dem Start, aber das ist doch eher unschoen.
Soll ich nen Feature Request dafuer stellen ?!
Gen2VDR / alcd / admin / yacoto - Features & Bugs - HW: Zotac Geforce 9300 MoBo / Cine-S2 im Activy Gehaeuse
und her mit den Logs :)

527

Monday, January 30th 2012, 10:09am

Moin,

Auf diese Idee bin ich noch nicht gekommen.
Ich will zwar einbauen, daß wenn X11 später startet, das Plugin sich automatisch mit X11 verbindet, bzw. wenn X11 abstürzt oder beendet wird, dies das Plugin nicht aus dem Takt bringt, aber dies hatte ich nicht geplant.

Danke für den Vorschlag, werde mir den Patch ansehen.
Johns
Sag mir, wo die Developer sind. Wo sind sie geblieben? . . . . . . . . . . . . . . . . . . . . SoftHdDevice - A software and GPU emulated HD output device plugin.
Sag mir, wo die Developer sind. Was ist geschehn?

Client0: Crown CW02 MSI_C847MS-E33 Zotac_GT640_passiv Cine-S2 iMon-MCE / streamdev softhddevice
Client1: Lian_Li_PC-Q09FB ASRock_H67M-ITX/HT I3-2100 ASUS_ENGT520_passiv / streamdev softhddevice
Test: Lian_Li_PC-Q09R Asus C60M1-I / streamdev
Server0: Dockstar TT-S2-3600-USB / streamdev
Server2: Lian_Li_PC-Q07R Intel_DH61DL G620 WD20EARX 90W PicoPSU Cine-S2+DuoFlex-S2+DuoFlex-CT / streamdev / 22 Watt Verbrauch

gda

Im Forum Zuhause

Posts: 13,168

Location: HH

  • Send private message

528

Monday, January 30th 2012, 10:10am

Hallo
Gibts auch die Moeglichkeit softhddevice im suspended mode zu starten ?
Ich moechte X selbst starten und erst wenn X oben ist die X Ausgabe aktivieren.
Natuerlich geht das mit svdrpsend suspend direkt nach dem Start, aber das ist doch eher unschoen.
Soll ich nen Feature Request dafuer stellen ?!

Das ist eine sehr schicke Idee +1. Das würde ein separates Frontend tatsächlich unnötig machen (von remote Szenarien mal abgesehen).

Gerald

HP Proliant MicroServer Gen8, Xeon E3-1230, 12 GB RAM, 3xWD red 2TB im RAID 5, 2xSundtek MediaTV Home DVB-C/T, L4M TWIN-C/T, Ubuntu Server 12.04.2, Plex Media Server
Zbox HD-ID40, OpenELEC 4.0.2, PLEXBMC

gda

Im Forum Zuhause

Posts: 13,168

Location: HH

  • Send private message

529

Monday, January 30th 2012, 10:14am

Ich will zwar einbauen, daß wenn X11 später startet, das Plugin sich automatisch mit X11 verbindet, bzw. wenn X11 abstürzt oder beendet wird, dies das Plugin nicht aus dem Takt bringt, aber dies hatte ich nicht geplant.

Das ist ja noch schicker, cool! Wann? :D. Aber da du dann pollen müsstest (oder nicht?) wäre ein SIgnal von außen auch nicht so übel. (DBUS ;))

Gerald

HP Proliant MicroServer Gen8, Xeon E3-1230, 12 GB RAM, 3xWD red 2TB im RAID 5, 2xSundtek MediaTV Home DVB-C/T, L4M TWIN-C/T, Ubuntu Server 12.04.2, Plex Media Server
Zbox HD-ID40, OpenELEC 4.0.2, PLEXBMC

530

Monday, January 30th 2012, 12:31pm

Bitte kein DBUS. Schon weil das auf vielen VDRs garnicht installiert ist. Im Bereich VDR ist "SVDRP" das Mittel der Wahl.

helau

Sage

Posts: 5,083

Location: Northern Black Forest

  • Send private message

531

Monday, January 30th 2012, 12:52pm

Ich will zwar einbauen, daß wenn X11 später startet, das Plugin sich automatisch mit X11 verbindet, bzw. wenn X11 abstürzt oder beendet wird, dies das Plugin nicht aus dem Takt bringt, aber dies hatte ich nicht geplant.

Das muss aus meiner Sicht nicht sein dass Du Dich um X kuemmerst, das macht meine Distrie ganz prima. Und sie kann softhddevice immer mittels svdrp mit diesen Infos "fuettern"...
Gen2VDR / alcd / admin / yacoto - Features & Bugs - HW: Zotac Geforce 9300 MoBo / Cine-S2 im Activy Gehaeuse
und her mit den Logs :)

gda

Im Forum Zuhause

Posts: 13,168

Location: HH

  • Send private message

532

Monday, January 30th 2012, 1:33pm

Quoted from "johns"


Ich will zwar einbauen, daß wenn X11 später startet, das Plugin sich automatisch mit X11 verbindet, bzw. wenn X11 abstürzt oder beendet wird, dies das Plugin nicht aus dem Takt bringt, aber dies hatte ich nicht geplant.

Das muss aus meiner Sicht nicht sein dass Du Dich um X kuemmerst, das macht meine Distrie ganz prima. Und sie kann softhddevice immer mittels svdrp mit diesen Infos "fuettern"...

Stimmt, ist nicht wirklich nötig, das haben wir sowieso schon drin. Das Plugin könnte eher unnötig dazwischenfunken.

Gerald

HP Proliant MicroServer Gen8, Xeon E3-1230, 12 GB RAM, 3xWD red 2TB im RAID 5, 2xSundtek MediaTV Home DVB-C/T, L4M TWIN-C/T, Ubuntu Server 12.04.2, Plex Media Server
Zbox HD-ID40, OpenELEC 4.0.2, PLEXBMC

CafeDelMar

Professional

Posts: 653

Location: Augsburg

  • Send private message

533

Monday, January 30th 2012, 1:53pm

Ich will zwar einbauen, daß wenn X11 später startet, das Plugin sich automatisch mit X11 verbindet, bzw. wenn X11 abstürzt oder beendet wird, dies das Plugin nicht aus dem Takt bringt, aber dies hatte ich nicht geplant.


Fände ich super, dann verhält es sich ja im Prinzip wie vdr-sxfe bei XineLibOutput bzw. eigentlich noch viel besser.

CafeDelMar

EDIT: Kann man ja sicher optional gestalten, so dass es nicht gegen andere Mechanismen läuft.

534

Monday, January 30th 2012, 5:13pm

Hallo
Gibts auch die Moeglichkeit softhddevice im suspended mode zu starten ?
Ich moechte X selbst starten und erst wenn X oben ist die X Ausgabe aktivieren.
Natuerlich geht das mit svdrpsend suspend direkt nach dem Start, aber das ist doch eher unschoen.
Soll ich nen Feature Request dafuer stellen ?!


Ist nun im GIT. Was mir aufgefallen ist, das nun aber LiveTV ins nichts gespielt wird.
Sollte man nun den Dummy Player starten, wobei desen Nebeneffekte noch nicht bekannt sind.
Eine bessere Lösung LiveTv Ausgabe abzuschalten habe ich noch nicht gefunden.

Johns
Sag mir, wo die Developer sind. Wo sind sie geblieben? . . . . . . . . . . . . . . . . . . . . SoftHdDevice - A software and GPU emulated HD output device plugin.
Sag mir, wo die Developer sind. Was ist geschehn?

Client0: Crown CW02 MSI_C847MS-E33 Zotac_GT640_passiv Cine-S2 iMon-MCE / streamdev softhddevice
Client1: Lian_Li_PC-Q09FB ASRock_H67M-ITX/HT I3-2100 ASUS_ENGT520_passiv / streamdev softhddevice
Test: Lian_Li_PC-Q09R Asus C60M1-I / streamdev
Server0: Dockstar TT-S2-3600-USB / streamdev
Server2: Lian_Li_PC-Q07R Intel_DH61DL G620 WD20EARX 90W PicoPSU Cine-S2+DuoFlex-S2+DuoFlex-CT / streamdev / 22 Watt Verbrauch

Posts: 5,027

Location: Main-Spessart

  • Send private message

535

Monday, January 30th 2012, 8:15pm

Seit den letzten paar Änderungen ist das A/V-Delay wieder total unerträglich geworden. Weg war es ja noch nie.
VDR4Arch-Next --> Lian-Li PC-C37B | ASRock Q1900M | 4GB RAM | SanDisk SDSSDP064G | Samsung HD155UI | DD Cine S2 V6.2 | ZOTAC GT630 (Rev. 2) Zone Edition

536

Monday, January 30th 2012, 8:27pm

Source code

1
2
softhddevice.AudioDelay = 0
+n or -n ms


Sollte bei einem hohen Wert der gebraucht wird, das Bild anfangen zuzucken (meist Nick/CC), muß ich was am Source ändern.
(oder selbst: in audio.c static const int AudioBufferTime = 450; ///< audio buffer time in ms)

Johns
Sag mir, wo die Developer sind. Wo sind sie geblieben? . . . . . . . . . . . . . . . . . . . . SoftHdDevice - A software and GPU emulated HD output device plugin.
Sag mir, wo die Developer sind. Was ist geschehn?

Client0: Crown CW02 MSI_C847MS-E33 Zotac_GT640_passiv Cine-S2 iMon-MCE / streamdev softhddevice
Client1: Lian_Li_PC-Q09FB ASRock_H67M-ITX/HT I3-2100 ASUS_ENGT520_passiv / streamdev softhddevice
Test: Lian_Li_PC-Q09R Asus C60M1-I / streamdev
Server0: Dockstar TT-S2-3600-USB / streamdev
Server2: Lian_Li_PC-Q07R Intel_DH61DL G620 WD20EARX 90W PicoPSU Cine-S2+DuoFlex-S2+DuoFlex-CT / streamdev / 22 Watt Verbrauch

Posts: 5,027

Location: Main-Spessart

  • Send private message

537

Monday, January 30th 2012, 11:15pm

Hmm, jetzt ist es wieder weg... Manchmal ist es da und manchmal nicht. Ich beobachte das mal weiter, vielleicht finde ich irgendeine Regel.
VDR4Arch-Next --> Lian-Li PC-C37B | ASRock Q1900M | 4GB RAM | SanDisk SDSSDP064G | Samsung HD155UI | DD Cine S2 V6.2 | ZOTAC GT630 (Rev. 2) Zone Edition

gda

Im Forum Zuhause

Posts: 13,168

Location: HH

  • Send private message

538

Monday, January 30th 2012, 11:28pm

Ist nun im GIT. Was mir aufgefallen ist, das nun aber LiveTV ins nichts gespielt wird.
Sollte man nun den Dummy Player starten, wobei desen Nebeneffekte noch nicht bekannt sind.
Eine bessere Lösung LiveTv Ausgabe abzuschalten habe ich noch nicht gefunden.


Kann man sich da was aus dem Suspendoutput-Plugin borgen?

Gerald

HP Proliant MicroServer Gen8, Xeon E3-1230, 12 GB RAM, 3xWD red 2TB im RAID 5, 2xSundtek MediaTV Home DVB-C/T, L4M TWIN-C/T, Ubuntu Server 12.04.2, Plex Media Server
Zbox HD-ID40, OpenELEC 4.0.2, PLEXBMC

helau

Sage

Posts: 5,083

Location: Northern Black Forest

  • Send private message

539

Monday, January 30th 2012, 11:48pm

Hallo,

Danke fuer den Suspend Start !
Wegen den schwarzen Balken noch was:
Es waere doch sehr gut wenn man 4:3 Sendungen aufzoomen koennte.
Ich habe hier nen Aufnahmeschnipsel:
www.gen2vdr.org/tmp/k11.tgz

Einer 4:3 Sendung welche auch oben schwarze Balken hat. Das sieht nun einfach ein wenig klein aus mit Balken auf allen 4 Seiten ;)
Gen2VDR / alcd / admin / yacoto - Features & Bugs - HW: Zotac Geforce 9300 MoBo / Cine-S2 im Activy Gehaeuse
und her mit den Logs :)

This post has been edited 1 times, last edit by "helau" (Jan 31st 2012, 9:25am)


helau

Sage

Posts: 5,083

Location: Northern Black Forest

  • Send private message

540

Tuesday, January 31st 2012, 8:58am

P.S. Das Problem, dass AV bei manchen Sendern oder auch Aufnahmen nicht immer ganz passt, ist mir auch schon aufgefallen, mit xine hatte ich dies nicht.
Ein genereller Versatz hilft dabei aber gar nichts, da dies unregelmaessig auftritt.
Gen2VDR / alcd / admin / yacoto - Features & Bugs - HW: Zotac Geforce 9300 MoBo / Cine-S2 im Activy Gehaeuse
und her mit den Logs :)