You are not logged in.

Dear visitor, welcome to VDR Portal. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

UFO

Sage

  • "UFO" started this thread

Posts: 5,124

Location: Großherzogthum Baden

  • Send private message

61

Friday, February 4th 2011, 12:25am

Quoted

Original von walter-
I had some feedback from Ralph:

"Using "cat" to write to sec0 is a bad idea. The data written
to sec0 has to be aligned to TS packets."

=> I am now wondering if this test (cat ../dvr0 > ../sec0 > file.ts) is a good approach.

Ok, you might try something like

Source code

1
dd bs=188 if=/dev/dvb/.../dvr0 of=/dev/dvb/.../sec0

But that was not the reason why your tests failed. See below.

Quoted


If not, any other idea's on how to test?

Note: at the end there could be many different reasons for
for my issues (CAM not right version, CAM not compatible, some HW issue, Smartcard not 'activated',....).

Meanwhile I did some tests with the CI and found that it does not work anymore. :(

I bisected the code and tracked down the problem to changeset 15183:2919e655e7f3.
Unfortunately I introduced a bug when I rearranged the code to get rid of the dummy device nodes.

Please update the driver from http://linuxtv.org/hg/~endriss/v4l-dvb and try again.
Sorry for the mess. :wand

CU
Oliver
VDR Remote Control Plugin (Version 0.5.0): http://www.escape-edv.de/endriss/vdr
FAQ zum Remote Control Plugin: http://www.escape-edv.de/endriss/vdr/FAQ
Aktuelle Treiber: http://www.vdr-portal.de/board18-vdr-har…-s2-6400-teil-3
Full-TS-Mod für SD full-featured Karten: http://www.escape-edv.de/endriss/dvb-full-ts-mod bzw. hier
SDRAM-Erweiterung für SD full-featured Karten: http://www.escape-edv.de/endriss/dvb-mem-mod

62

Friday, February 4th 2011, 1:22am

Quoted

Please update the driver from http://linuxtv.org/hg/~endriss/v4l-dvb and try again.
Sorry for the mess.


at least you fixed the issue ;-). Great job I would say.

Quoted


But that was not the reason why your tests failed. See below.


I got confused on your comment; what were you refering to? To your little bug or to something else?


I will test again this weekend.

Walter

UFO

Sage

  • "UFO" started this thread

Posts: 5,124

Location: Großherzogthum Baden

  • Send private message

63

Friday, February 4th 2011, 3:14am

Quoted

Original von walter-

Quoted


But that was not the reason why your tests failed. See below.


I got confused on your comment; what were you refering to? To your little bug or to something else?

I was referring to my bug.

CU
Oliver
VDR Remote Control Plugin (Version 0.5.0): http://www.escape-edv.de/endriss/vdr
FAQ zum Remote Control Plugin: http://www.escape-edv.de/endriss/vdr/FAQ
Aktuelle Treiber: http://www.vdr-portal.de/board18-vdr-har…-s2-6400-teil-3
Full-TS-Mod für SD full-featured Karten: http://www.escape-edv.de/endriss/dvb-full-ts-mod bzw. hier
SDRAM-Erweiterung für SD full-featured Karten: http://www.escape-edv.de/endriss/dvb-mem-mod

64

Friday, February 4th 2011, 10:35am

Quoted


Meanwhile I did some tests with the CI and found that ...


Hi Oliver,

short side question: if you are testing, how do you test exactly? Do you use specific tools? What CAM module do you use, which pay subsciption, which video player?

(maybe I should take the opotunity and write in German)

Walter

UFO

Sage

  • "UFO" started this thread

Posts: 5,124

Location: Großherzogthum Baden

  • Send private message

65

Friday, February 4th 2011, 1:13pm

Quoted

Original von walter-
short side question: if you are testing, how do you test exactly? Do you use specific tools? What CAM module do you use, which pay subsciption, which video player?

I tested without CAM. In this case the CI runs in loopback mode.

Terminal 1:
zap -enable_dvr_out -adapter 0 "Das Erste"

Terminal 2:
dd bs=188 if=/dev/dvb/adapter0/dvr0 of=/dev/dvb/adapter2/sec0

Terminal 3:
dd bs=188 if=/dev/dvb/adapter2/sec0 of=test.ts

Later:
mplayer test.ts

Quoted


(maybe I should take the opotunity and write in German)

If you prefer... ;)

CU
Oliver
VDR Remote Control Plugin (Version 0.5.0): http://www.escape-edv.de/endriss/vdr
FAQ zum Remote Control Plugin: http://www.escape-edv.de/endriss/vdr/FAQ
Aktuelle Treiber: http://www.vdr-portal.de/board18-vdr-har…-s2-6400-teil-3
Full-TS-Mod für SD full-featured Karten: http://www.escape-edv.de/endriss/dvb-full-ts-mod bzw. hier
SDRAM-Erweiterung für SD full-featured Karten: http://www.escape-edv.de/endriss/dvb-mem-mod

66

Friday, February 4th 2011, 2:22pm

Quoted

"dd bs=188 if=/dev/dvb/adapter0/dvr0 of=/dev/dvb/adapter2/sec0"


=> This will copy the data from dvr0 to sec0 in packages of 188bytes.
Are they then alligned? I mean; the dd command doesn't really care if the 188 bytes start at package start. So it all depends on dvr0 if the data is alligned. Do you know if dvr0 is sending the data alligned? (was this reasoning making any sence?).

schon wieder nicht auf Deutsch... ;-). Wobei ich sagen muss das Deutsch schon meine vierte sprache ist.

Walter

67

Friday, February 4th 2011, 9:27pm

I tested now again with the new version of http://linuxtv.org/hg/~endriss/v4l-dvb

The result is 'better', but not good yet.

using dd to copy between dvr0, sec0 and a file...

=> result is now a stream that is "interpretable" by ffmpeg. But the file contains a lot of errors. So sec0 is not really in lookback mode.

The result with mplayer looks more like 'scrambeled' tv. Directly viewing from dvr0 works ok.

Note: dd bs=188 if=/dev/dvb/adapter0/sec0 of=test.ts

=> this command uses 100% of one of the 4 CPU's; strange....

I will test once with cat out of sec0 to see if the high CPU is causing issues

This post has been edited 2 times, last edit by "walter-" (Feb 4th 2011, 9:30pm)


68

Friday, February 4th 2011, 9:40pm

testing with "cat /dev/dvb/adapter0/sec0 > test.ts" gives same result (but without the high CPU usage).

Final result:
Testing with the current version from the repository

=> there is a better signal out of sec0, ffmpeg can see there is something inside.
=> but stream has so many errors that it is not usable.

Walter

69

Friday, February 4th 2011, 9:51pm

ffmpeg output:
many errors like this:

Quoted

[mpeg2video @ 0x984cf70]ac-tex damaged at 25 8
[mpeg2video @ 0x984cf70]00 motion_type at 15 9
[mpeg2video @ 0x984cf70]invalid cbp at 16 12
[mpeg2video @ 0x984cf70]00 motion_type at 7 13
[mpeg2video @ 0x984cf70]ac-tex damaged at 39 14
[mpeg2video @ 0x984cf70]ac-tex damaged at 13 15
[mpeg2video @ 0x984cf70]00 motion_type at 33 17
[mpeg2video @ 0x984cf70]ac-tex damaged at 22 17
[mpeg2video @ 0x984cf70]invalid cbp at 38 19
[mpeg2video @ 0x984cf70]ac-tex damaged at 2 20
[mpeg2video @ 0x984cf70]00 motion_type at 23 22
[mpeg2video @ 0x984cf70]00 motion_type at 21 23
[mpeg2video @ 0x984cf70]00 motion_type at 11 27
[mpeg2video @ 0x984cf70]ac-tex damaged at 7 28
[mpeg2video @ 0x984cf70]ac-tex damaged at 13 30
[mpeg2video @ 0x984cf70]ac-tex damaged at 17 31
[mpeg2video @ 0x984cf70]00 motion_type at 40 32
[mpeg2video @ 0x984cf70]ac-tex damaged at 7 35
[mpeg2video @ 0x984cf70]Warning MVs not available
[mpeg2video @ 0x984cf70]concealing 1365 DC, 1365 AC, 1365 MV errors
[mp3 @ 0x981c7e0]incorrect frame size


and then finally:

Quoted

Input #0, mpegts, from 'test.ts':
Duration: 08:46:09.30, start: 60386.503656, bitrate: 219 kb/s
Program 28106 Das Erste
Metadata:
name : Das Erste
provider_name : ARD
Program 28107 Bayerisches FS Sud
Metadata:
name : Bayerisches FS Sud
provider_name : ARD
Stream #0.14[0xc9]: Video: mpeg2video, yuv420p, 720x576 [PAR 64:45 DAR 16:9], 15000 kb/s, 32.56 fps, 25 tbr, 90k tbn, 50 tbc
Stream #0.18[0xca](deu): Audio: mp2, 48000 Hz, 2 channels, s16, 192 kb/s
Stream #0.6[0xcb](mis): Audio: mp2, 48000 Hz, 2 channels, s16, 192 kb/s
Stream #0.7[0xcc](ger): Subtitle: 0x0006
Stream #0.17[0xce](deu): Audio: ac3, 48000 Hz, stereo, s16, 384 kb/s
Program 28108 hr-fernsehen
Metadata:
name : hr-fernsehen
provider_name : ARD
Stream #0.15[0x12d]: Video: mpeg2video, yuv420p, 720x576 [PAR 64:45 DAR 16:9], 15000 kb/s, 37.88 fps, 25 tbr, 90k tbn, 50 tbc
Program 28110 Bayerisches FS Nord
Metadata:
name : Bayerisches FS Nord
....

70

Friday, February 4th 2011, 9:59pm

Quoted

dd bs=188 if=/dev/dvb/adapter0/dvr0 of=/dev/dvb/adapter2/sec0


how did you manage to have sec0 on adapter2? I only have one adapter (adapter0)

Walter

UFO

Sage

  • "UFO" started this thread

Posts: 5,124

Location: Großherzogthum Baden

  • Send private message

71

Friday, February 4th 2011, 11:29pm

Quoted

Original von walter-

Quoted

"dd bs=188 if=/dev/dvb/adapter0/dvr0 of=/dev/dvb/adapter2/sec0"


=> This will copy the data from dvr0 to sec0 in packages of 188bytes.
Are they then alligned? I mean; the dd command doesn't really care if the 188 bytes start at package start. So it all depends on dvr0 if the data is alligned. Do you know if dvr0 is sending the data alligned? (was this reasoning making any sence?).


Yes, data from dvr consists of 188 byte TS packets.

CU
Oliver
VDR Remote Control Plugin (Version 0.5.0): http://www.escape-edv.de/endriss/vdr
FAQ zum Remote Control Plugin: http://www.escape-edv.de/endriss/vdr/FAQ
Aktuelle Treiber: http://www.vdr-portal.de/board18-vdr-har…-s2-6400-teil-3
Full-TS-Mod für SD full-featured Karten: http://www.escape-edv.de/endriss/dvb-full-ts-mod bzw. hier
SDRAM-Erweiterung für SD full-featured Karten: http://www.escape-edv.de/endriss/dvb-mem-mod

UFO

Sage

  • "UFO" started this thread

Posts: 5,124

Location: Großherzogthum Baden

  • Send private message

72

Friday, February 4th 2011, 11:35pm

Quoted

Original von walter-
I tested now again with the new version of http://linuxtv.org/hg/~endriss/v4l-dvb

The result is 'better', but not good yet.

using dd to copy between dvr0, sec0 and a file...

=> result is now a stream that is "interpretable" by ffmpeg. But the file contains a lot of errors. So sec0 is not really in lookback mode.

Did you test with CAM or without CAM?

Quoted


The result with mplayer looks more like 'scrambeled' tv. Directly viewing from dvr0 works ok.

Note: dd bs=188 if=/dev/dvb/adapter0/sec0 of=test.ts

=> this command uses 100% of one of the 4 CPU's; strange....

Confirmed. Try a larger block size, for example bs=18800 for the sec -> file transfer.

CU
Oliver
VDR Remote Control Plugin (Version 0.5.0): http://www.escape-edv.de/endriss/vdr
FAQ zum Remote Control Plugin: http://www.escape-edv.de/endriss/vdr/FAQ
Aktuelle Treiber: http://www.vdr-portal.de/board18-vdr-har…-s2-6400-teil-3
Full-TS-Mod für SD full-featured Karten: http://www.escape-edv.de/endriss/dvb-full-ts-mod bzw. hier
SDRAM-Erweiterung für SD full-featured Karten: http://www.escape-edv.de/endriss/dvb-mem-mod

UFO

Sage

  • "UFO" started this thread

Posts: 5,124

Location: Großherzogthum Baden

  • Send private message

73

Friday, February 4th 2011, 11:41pm

Quoted

Original von walter-

Quoted

dd bs=188 if=/dev/dvb/adapter0/dvr0 of=/dev/dvb/adapter2/sec0


how did you manage to have sec0 on adapter2? I only have one adapter (adapter0)

Module parameter "one_adapter=0" activates multiple adapter mode,
but it should not have any impact otherwise.

CU
Oliver
VDR Remote Control Plugin (Version 0.5.0): http://www.escape-edv.de/endriss/vdr
FAQ zum Remote Control Plugin: http://www.escape-edv.de/endriss/vdr/FAQ
Aktuelle Treiber: http://www.vdr-portal.de/board18-vdr-har…-s2-6400-teil-3
Full-TS-Mod für SD full-featured Karten: http://www.escape-edv.de/endriss/dvb-full-ts-mod bzw. hier
SDRAM-Erweiterung für SD full-featured Karten: http://www.escape-edv.de/endriss/dvb-mem-mod

74

Saturday, February 5th 2011, 12:17pm

Quoted

Originally posted by UFO

Did you test with CAM or without CAM?



tested with CAM, will test without CAM later.

Walter

75

Saturday, February 5th 2011, 2:39pm

Quoted

Originally posted by digibert

Quoted

Original von walter-
ps: how do I nicely stop "zap"? Ctrl-C is not working....


That is strange here it terminates on CTRL-C.


=> I now tested zap without CAM; then Ctrl-C works to stop zap. Strange....

Walter

76

Saturday, February 5th 2011, 3:44pm

I now tested without the CAM; and then it works.

Great! We have a CI module that can play FTA without a CAM (forgive me if you interpret this as cynical ;-).

Let me do some more test with the CAM inserted and see where I get...

Walter

77

Saturday, February 5th 2011, 4:16pm

Oliver,

short other question: when running zap... and tuning to a pay channel: should that be enough to get your smartcard activated?
I still don't know if my smartcard is activated; I am paying my subscription thought.... ;-). Do you know if you can see the activation state of your smartcard.

Walter

78

Saturday, February 5th 2011, 5:05pm

short update:

=> I tested with a pay channel:

Result is also a bit better: I get some screen which is almost readable. At least I can see the channelname.... But there is no usable sound.

Result is also not stable: sometimes mplayer, ffmpeg get something out the stream, sometimes they don't recognize anything.

The result is the same with FTA channels.

Walter

UFO

Sage

  • "UFO" started this thread

Posts: 5,124

Location: Großherzogthum Baden

  • Send private message

79

Sunday, February 6th 2011, 4:43am

Quoted

Original von walter-
short other question: when running zap... and tuning to a pay channel: should that be enough to get your smartcard activated?
I still don't know if my smartcard is activated; I am paying my subscription thought.... ;-). Do you know if you can see the activation state of your smartcard.

Sorry, I don't know.

First of all, you should verify that your CAM/subscription is really working.
Could you test with a receiver, which is known to work?

CU
Oliver
VDR Remote Control Plugin (Version 0.5.0): http://www.escape-edv.de/endriss/vdr
FAQ zum Remote Control Plugin: http://www.escape-edv.de/endriss/vdr/FAQ
Aktuelle Treiber: http://www.vdr-portal.de/board18-vdr-har…-s2-6400-teil-3
Full-TS-Mod für SD full-featured Karten: http://www.escape-edv.de/endriss/dvb-full-ts-mod bzw. hier
SDRAM-Erweiterung für SD full-featured Karten: http://www.escape-edv.de/endriss/dvb-mem-mod

80

Sunday, February 6th 2011, 8:48am

=> I checked yesterday evening and my smartcard is ok. The subscription/card activation works (test with a DVB-S set of 'TV-Vlaanderen'). No new activation was needed.

Walter

This post has been edited 1 times, last edit by "walter-" (Feb 6th 2011, 3:12pm)