Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: VDR Portal. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Mittwoch, 4. Februar 2009, 21:06

eHD: vdr-1.7.4 und truecolor.diff

Moin,

hat hier schon jemand ne functionierenden truecolor patch fuer den vdr-1.7.4?

Cheers :prost2

/bin/joerg

free-x

Fortgeschrittener

Beiträge: 391

Wohnort: OWL

Beruf: Systemingenieur

  • Nachricht senden

3

Freitag, 13. Februar 2009, 11:57

hi,

habe mitlerweile meine suse 10.2 mit s2-liplianin, vdr 1.7.4 und dem patch am laufen (vdr 1.7.4 nur testweise, produktiv noch 1.7.0)
ich gebe mal einfach ein paar kommentare ab

- dem patch oben fehlen die Make.common und die debugmacros.h, die müssen auch im vdr verzeichnis liegen (muss man dann halt von hand einkopieren)
- es gibt darin wieder überreste von anderen patches (pin und yaepg) was zu rejects beim extension patch 66 führt (sind aber leicht aufzulösen, btw. habe ich nur dvdfriendly names und graphtft aktiviert)
- im xinemediaplayer plugin muss man eine variable im quelltext ändern, FRAMESPERSEC -> DEFAULTFRAMESPERSECOND (könnte ich auch als patch hier reinstellen)
- die anderen plugins von rmm die ich nutze (dvdswitch, internetradio, ...) laufen wie immer wenn man das xinemediaplayer aktiv hat
- PES aufnahmen vom "alten vdr" laufen, sowohl SDTV als auch HDTV
- die neuen *.TS aufnahmen lassen sich mit vlc direkt wiedergeben (sd und hd getestet)
- keine gravierenden probleme beim normale TV aber reproduzierbar beim umschalten zweimal ton-/bildaussetzer, einmal nach 1s und nochmal nach 4-5s

großes manko das aber nicht mit der eHD zu tun hat, graphtft compiliert nicht mehr unter vdr 1.7.4, liegt an den änderungen beim remux (die variable wie beim xinemediaplayer kann man da zwar auch anpassen aber dann kommen noch andere meldungen die man nicht ohnen c++ kenntnisse beheben kann)

edit: habe eine tt3200 und eine nova-hd-s2 mit der eHD am laufen
edit2:graphtft tuts jetzt, habe in der transfer.c des plugins die definition der variable _remux auskommentiert, das plugin compiliert und funktioniert auch

Dieser Beitrag wurde bereits 4 mal editiert, zuletzt von »IG88« (18. Februar 2009, 11:06)


free-x

Fortgeschrittener

Beiträge: 391

Wohnort: OWL

Beruf: Systemingenieur

  • Nachricht senden

4

Freitag, 13. Februar 2009, 13:27

kann ich nur bestätigen

Benutze eHD mit 1.7.4 seit einer woche
T90: 28.2E-19.2E-S13E-S9E-S4.8E-S4W
VDR#1: Ubuntu 8.04+VDR-1.7.15+S2API+eHD TeVii S650
VDR#2: Ubuntu 8.04+ArVDR 0.7 SS1 Rev.1.3
VDR#3: Ubuntu 10.04+VDR-1.7.18+S2API+VDPAU(GeForce 8400 GS)+xine-0.9.4 TT S2-3200
RuVDRWiki

5

Mittwoch, 18. Februar 2009, 06:54

@free-x

Hast du bei dir auch Probleme mit der Wiedergabe von Aufnahmen bei der 1.7.4

Bei mir hängt sich der hdplayer auf der Karte auf, wenn ich Aufnahmen mit DD abspielen will. Starte ich dann den hdplayer auf der Karte neu, bzw. kille die hängende Instanz, läuft die Wiedergabe weiter, Das einfrieren tritt dann immer wieder während der Wiedergabe auf.

6

Mittwoch, 18. Februar 2009, 19:34

hi,

ich habe hier keine problme mit dd
geht bei alten pes und bei neuen ts aufnahmen aufnahmen
bei mir ist alles aus dem testing und auf dem stand von letzter woche

7

Donnerstag, 19. Februar 2009, 06:42

Hi IG88,

wie sehen den deine reelbox Einstellungen aus ?

8

Donnerstag, 19. Februar 2009, 09:31

Moin,

Zitat

es gibt darin wieder überreste von anderen patches (pin und yaepg) was zu rejects beim extension patch 66 führt ...

habe da ( http://vdr-portal.de/board/thread.php?po…9110#post709110 ) eine angepasste Version angehängt.

Der Patch muss in der Make.config aktiviert werden.

Gruß
Marc
>>>> x-vdr <<<< Installations-Skript für einen VDR mit Debian als Basis

9

Donnerstag, 19. Februar 2009, 17:33

@ALT255
benutze den spdif der eHD, bild 1080i

reelbox.Ac3 = 1
reelbox.Aspect = 0
reelbox.AudioMix = 0
reelbox.AudioOverHD = 1
reelbox.AudioOverHDMI = 0
reelbox.Brightness = 54
reelbox.Colour = 450
reelbox.Contrast = 115
reelbox.Deint = 0
reelbox.DelayAc3 = -25
reelbox.DelayStereo = 0
reelbox.DisplayType = 0
reelbox.Flicker = 0
reelbox.Framerate = 0
reelbox.Gamma = 59
reelbox.HDAM = 4
reelbox.HDAPort = 0
reelbox.HDAspect = 1
reelbox.HDauto_format = 0
reelbox.HDdeint = 1
reelbox.HDDisplayType = 1
reelbox.HDDM = 0
reelbox.HDfb = 0
reelbox.HDIntProg = 1
reelbox.HDnorm = 0
reelbox.HDoutput = 1
reelbox.HDResolution = 0
reelbox.Norm = 0
reelbox.Overscan = 1
reelbox.Resolution = 1
reelbox.Scartmode = 0
reelbox.Sharpness = 128
reelbox.UseHdExt = 1
reelbox.VMM = 0
reelbox.VSM = 0

10

Sonntag, 22. Februar 2009, 14:03

Hab deine Einstellungen jetzt mal getestet.
Leider bleibt der Player weiterhin mitten in der Wiedergabe stehen.
Wenn ich das ts File dann über den xinemediaplayer abspiele läuft es problemlos.

Am problematischsten sind Aufnahmen von Pro7.
Gibt es wirklich niemand anderen der damit Probleme hat ?

11

Sonntag, 22. Februar 2009, 17:14

hi,

mit einer pro sieben aufnahme kann ich das auch sehen, wenn ich bei der aufnahme von mpeg ton auf ac3 wechse bleibt die ehd hängen
passiert aber nicht bei live tv, nur bei einer ts aufnahme von pro sieben
wenn ich eine aufnahme von Astra HD+ mache (nur eine dd tonspur) geht das replay

vieleicht ein bug beim umschalten der tonspur im replay?

12

Sonntag, 22. Februar 2009, 17:28

In etwa so ist es auch bei mir. Allerdings passiert es auch sehr selten bei Aufnahmen ohne DD.
Bin aktuell wieder zurück bei 1.7.1, weil s2 einfach noch nicht stabil ist im Vergleich zu multiproto.

Immortal Romance Spielautomat