You are not logged in.

Dear visitor, welcome to VDR Portal. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

41

Friday, June 10th 2005, 1:06pm

mhm, was es natuerlich erklaeren koennte.

na, dann testma halt mal vlc auf linux. aufm mac hat lvc nichts angezeigt.
selbes thema - mpeg2 erkannt.


-- randy

42

Friday, June 10th 2005, 3:05pm

Quoted

Original von randy
fyi: mit dvbsnoop seh ich auch die streams, danke bodyguard. danke szap und
einem cat hab ich wohl auch eine art mpeg4 avc stream auf die platte gezaubert,
nur erkennts mein mplayer noch nicht. ac3 sieht er und will auch spielen.

sprich - es bleibt spannend :)

-- randy


Bitte, kannst du uns erklären wie "eine art mpeg4 avc stream auf die platte" zu bekommen ?
Meine mplayer ist mit "svn co svn://svn.videolan.org/x264/trunk x264" compiliert und ich wäre sehr froh es zum probieren :)

Danke sehr
Grégoire

43

Friday, June 10th 2005, 4:22pm

szap -r "dpv.tv11" (das ist der sender mit scan gefunden)
und dann ein "cat /dev/dvb/adapter0/dvr0 > /tmp/premiere.ts";

mit szap und dvbsnoop kannst du den stream analysieren.

evtl probierst mal die h264 samples? ftp://ftp.mplayerhq.hu/MPlayer/samples/h264

HD-h264.ts ist ein rip von dem premiere ts.

-- randy

44

Friday, June 10th 2005, 4:24pm

Danke für den Hinweis - muss das auch gleich am WE testen...
yaVDR 0.5.0a
Intel Core2Duo E6750, Asus P5Q,
Gainward GT 240 512MB GDDR5, Hauppauge HVR-4000 & Nova-S2-HD, 4 GByte RAM
an Panasonic TX-P42GW10 und Onkyo TX-SR508

besse

Trainee

Posts: 79

Location: Saarland

  • Send private message

45

Friday, June 10th 2005, 6:18pm

@ randy:

wie sieht denn bei dir der Eintrag in der channels.conf von scan aus?

Irgendwie findet der bei mir den Kanal nicht wenn ich scan laufen lasse (habe ./scan dvb-s/Astra-19.2E > scan.conf probiert). Muss man da noch irgendwelche besonderen Parameter mit übergeben?

46

Friday, June 10th 2005, 7:06pm

DPC.TV10:11914:h:0:27500:511:512:128
DPC.TV11:11914:h:0:27500:767:772:129



-- randy

47

Friday, June 10th 2005, 11:36pm

Danke sehr, ich habe 62 Sekunden genommen : 119Mb...
Ich probiere es mit mplayer es abzuspielen, mit mplayer -vo xv -xineramascreen 1 -ao alsa -ac hwac3 - < /tmp/premiere.ts und ich verstehe nicht wiese es gibt :
...
VIDEO MPEG2(pid=767)AUDIO A52(pid=772) NO SUBS (yet)! PROGRAM N. 0
...
Jetzt probiere ich es auch mit porjectx es zum demuxen, projectx glaubt auch es ist mpeg2 ? Und gibt mir :
-> dropping video data, GOP larger than 6MB
-> dropping video data, GOP larger than 6MB
...

Und ich bekomme "nur" eine premiere.ac3
die 2.9Mb ist.

Ich hoffe wir werden es schaffen es wirlich zum probieren :)
Grégoire

This post has been edited 1 times, last edit by "Grégoire" (Jun 11th 2005, 12:08am)


48

Saturday, June 11th 2005, 8:35am

genau, das ich auch mein problem. mplayer und vlc "erkennen" nur einen
mpeg2 stream in den ts, obwohl der header ja mpeg4 avc ist...

ABER ich weiss evtl an was das liegt: der "originale" windows rip hat nciht
nur pid 767 (mpeg4 avc) und 772 (ac3), sondern noch zusaetzlich 0 (pat)
und 98 (pmt);

in dieser ist verzeichnet (siehe post von bodyguard) was das fuer ein
stream ist und das nutzt mplayer wohl. zumindest sehe ich den mpeg4 "windows"
rip mit mplayer - und er erkennt "VIDEO H264(pid=767)...".

ich weiss nur noch nicht so recht, wie die zusaetzlichen 2 pids mitkommen
koennten.dvbstream kann afaik mehr pids demuxxen, aber das tuned bei mir
nicht (und nimmt keinen stdin).


-- randy

49

Saturday, June 11th 2005, 10:45am

Hier ein Patch fuer szap, mit dem man die pmt-pid auf der Kommandozeile angeben kann. Falls angegeben werden zusaetzliche Filter fuer pat und pmt gesetzt und damit erkennt dann mplayer den Premiere Stream auch korrekt als H.264.

Ach ja, pmt-pid wird mit -p uebergeben, also: szap -r -p 98 DPC.TV11
Keef has attached the following file:
  • szap-pmt.diff (4.36 kB - 679 times downloaded - latest: Yesterday, 5:49pm)

This post has been edited 1 times, last edit by "Keef" (Jun 11th 2005, 11:00am)


Dr.Nop

Professional

Posts: 941

Location: Baden

  • Send private message

50

Saturday, June 11th 2005, 11:45am

Poste doch den Patch bitte auf der DVB Mailingliste, dann stehen die Chancen gut, dass er offiziell aufgenommen wird.

51

Saturday, June 11th 2005, 12:26pm

Grossartig : jetzt habe ich die x264 Erkennung im mplayer, leider kann ich es noch nicht spielen ? Ist es noch FTA ?
Grégoire

52

Saturday, June 11th 2005, 1:07pm

Quoted

Original von Dr.Nop
Poste doch den Patch bitte auf der DVB Mailingliste, dann stehen die Chancen gut, dass er offiziell aufgenommen wird.


wir wollen noch pat/pmt autoscan einbauen (das man die pmt nicht haendisch
angeben muss). danach kommt sicher richtung ml :)

-- randy

53

Saturday, June 11th 2005, 1:23pm

Quoted

Original von Grégoire
Grossartig : jetzt habe ich die x264 Erkennung im mplayer, leider kann ich es noch nicht spielen ? Ist es noch FTA ?


Es scheint noch FTA zu sein, aber ich bekomme auch kein richtiges Bild (teilweise ist ein Premiere Bild mit Premiere HD Logo zu erkennen). Da ich aber noch nie was mit H264 gemacht habe, kann es gut an meinem mplayer liegen (und an meinem 1.4Ghz Prozessor, der deutlich zu langsam sein duerfte :) ).
Der Patch war eigentlich nur dazu gedacht, dass randy nicht weiter rumheult, dass er das unter Linux nicht aufzeichnen kann :P

Matthias

besse

Trainee

Posts: 79

Location: Saarland

  • Send private message

54

Saturday, June 11th 2005, 2:03pm

Danke randy für die Einträge!

Hab jetzt mal was aufgenommen.

Nachdem ich den ts-stream mit "BBDMUX.EXE premiere_hdtv_ac3.ts 0x02FF test.h264" demuxt habe konnte ich die Datei mit dem Moonlight Elecard MPEG Player 3.0 unter Windows abspielen. Ruckelt leider gewaltig :( - Habe nen A64 3200+

Gruß,
besse

55

Saturday, June 11th 2005, 8:23pm

So,

umgearbeiteter Patch, der die PMT-PID direkt aus der PAT herausliest. Der Code ist zusammengesucht aus scan.c, ich bin nur fuer die Fehler verantwortlich. Wichtig ist, dass die channels.conf, die szap verwendet korrekte Werte fuer die session_id hat, ansonsten wird die PMT-PID nicht gefunden. Die Beispiele-Dateien im szap Verzeichnis sind in der Beziehung nicht korrekt, scan erzeugt aber das korrekte Format. Die session_id muss direkt nach der Audio-PID kommen, die Beispieldateien haben da noch eine 1 dazwischen.

Die Option -p setzt jetzt auch -r automatisch, d.h. ein szap -p dpc.tv10 reicht.

Ciao,
Matthias
Keef has attached the following file:
  • szap-autopmt.diff (6.88 kB - 693 times downloaded - latest: Jul 31st 2014, 10:35pm)

This post has been edited 1 times, last edit by "Keef" (Jun 11th 2005, 8:24pm)


56

Saturday, June 11th 2005, 8:41pm

Quoted

Original von Keef
So,

umgearbeiteter Patch, der die PMT-PID direkt aus der PAT herausliest. Der Code ist zusammengesucht aus scan.c, ich bin nur fuer die Fehler verantwortlich. Wichtig ist, dass die channels.conf, die szap verwendet korrekte Werte fuer die service_id hat, ansonsten wird die PMT-PID nicht gefunden. Die Beispiele-Dateien im szap Verzeichnis sind in der Beziehung nicht korrekt, scan erzeugt aber das korrekte Format. Die session_id muss direkt nach der Audio-PID kommen, die Beispieldateien haben da noch eine 1 dazwischen.

Die Option -p setzt jetzt auch -r automatisch, d.h. ein szap -p dpc.tv10 reicht.

Ciao,
Matthias

besse

Trainee

Posts: 79

Location: Saarland

  • Send private message

57

Sunday, June 12th 2005, 1:23pm

bekommt ihr Sound abgespielt bei den Aufnahmen?

Bei mir erkennt er nen "AC3: 2.0 (stereo) 48000 Hz 384.0 kbit/s"
aber da kommt irgendwie kein Ton. AC3Filter is definitiv richtig eingestellt.

58

Sunday, June 12th 2005, 1:28pm

Auch kein Ton hier, weder beim direkt abspielen, noch bei nem selber aufgenommenen stream, noch bei dem Premiere-Sample von der mplayer-Seite.

besse

Trainee

Posts: 79

Location: Saarland

  • Send private message

59

Sunday, June 12th 2005, 1:41pm

schon seltsam mit dem Ton.

Kann der VDR eigentlich grundsätzlich als ts-stream aufnehmen?
Wenn ja dann müsste es ja eigentlich möglich sein den so zu modifzieren, dass er premiere hd aufnehmen kann.