You are not logged in.

Dear visitor, welcome to VDR Portal. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Posts: 5,034

Location: Main-Spessart

  • Send private message

641

Sunday, May 29th 2011, 12:58pm

Wo hast du die Firmware her? War die letzte nicht 1.07?
VDR4Arch-Next --> Lian-Li PC-C37B | ASRock Q1900M | 4GB RAM | SanDisk SDSSDP064G | Samsung HD155UI | DD Cine S2 V6.2 | ZOTAC GT630 (Rev. 2) Zone Edition

642

Sunday, May 29th 2011, 1:00pm

Wo hast du die Firmware her? War die letzte nicht 1.07?

Artefakte bei Technotrend DVB-S2 6400 HD-FF: Interrupts

mein VDR Stuff... :)

Thermaltake DH101: M2N68 Plus - 1 x HD-FF-6400 - 1 x L4MV6.2
angeschlossen über (SCR Inverto Black Unicable Multiswitch UST111-CUO10-8PP an Selfsat DQ)
yavdr-0.5 - vdr-2.1.6 - Plugins: dvbhddevice - targavfd - skinnopacity - osdteletext - xmltv2vdr
Scaleo Evi: NVidia G210 - 1 x L4M V6.2 TwinS2
angeschlossen am Legacy Ausgang vom Inverto Black Unicable Multiswitch UST111-CUO10-8PP
yavdr-0.5 - vdr-2.1.6 - Plugins: softhddevice-git - dm140vfd - skinnopacity - osdteletext
RaspberryPi mit rpihddevice Plugin (NEU!) / cubieboard2 mit vdr-2.1.6 + softhddevice-git (vdpau) / OdroidU3 CE als "DesktopPC" .... :D

spitzb

Intermediate

Posts: 488

Location: Rheda-wiedenbrück

Occupation: IT

  • Send private message

643

Sunday, May 29th 2011, 1:01pm

Wo hast du die Firmware her? War die letzte nicht 1.07?
Guck mal in den Interrupts - Thread. Da hat powarman die angekündigt.

Bei mir ist zwar die Interrupt-Rate deutlich gesunken, die Kaltstart - Probleme bestehen aber weiter. Bisher 5 x Kaltstart mit 5x Probleme.

Jeweils hat ein VDR . Neustart ohne Treiber - reload geholfen.

Falk

Posts: 5,034

Location: Main-Spessart

  • Send private message

644

Sunday, May 29th 2011, 1:02pm

Ahh, Mist überlesen. Danke
VDR4Arch-Next --> Lian-Li PC-C37B | ASRock Q1900M | 4GB RAM | SanDisk SDSSDP064G | Samsung HD155UI | DD Cine S2 V6.2 | ZOTAC GT630 (Rev. 2) Zone Edition

Frodo

Professional

Posts: 1,632

Location: Hessen

  • Send private message

645

Sunday, May 29th 2011, 2:01pm

Kaltstart Probleme habe ich seit 1.07 keine mehr. Allerdings habe ich 12 Sekunden Wartezeit vor dem Start des VDRs eingebaut.

Mit der 1.07 hatte ich gestern abend Probleme bei zwei gleichzeitigen Aufnahmen. Hierbei hatte ich per Fernbedienung auf einen Sender umgeschaltet der nicht auf den 2 Transpondern lag, das führte dazu das beide Aufnahmen wegen TS Fehler fehlerhaft wurden erst ein neustarten des VDRs behob das Problem.
Gruß
Frodo

Meine VDR Hardware


YaVDR 0.5: TT S2-6400 und Sundtek SkyTV Ultimate (DVB-S/S2), Zotac H77ITX-C-E, Geforce 620, SilverStone ML02B-MXR, IMON LCD, softhddevice / dvbhddevice
YaVDR 0.5: Sat>IP (OctopusNet) über vtunerc, Zotac D2550ITX, Geforce 610, IMON VFD, softhddevice
YaVDR 0.5: Cine S2 V6, Intel DQ67SW, Geforce 210, SilverStone LC16M, IMON VFD, softhddevice
YaVDR 0.5: TT S2-3200, Intel DH67BL, Geforce 430, softhddevice
YaVDR 0.5: TT S2-6400, Intel DH67CF, dvbhddevice
Test HD TV-Karten: TT S2-3200, Sundtek SkyTV Ultimate (DVB-S/S2) , TeVii S480, TT-connect CT-3650 CI

646

Sunday, May 29th 2011, 2:23pm

Kaltstart Probleme habe ich seit 1.07 keine mehr. Allerdings habe ich 12 Sekunden Wartezeit vor dem Start des VDRs eingebaut.

Mit der 1.07 hatte ich gestern abend Probleme bei zwei gleichzeitigen Aufnahmen. Hierbei hatte ich per Fernbedienung auf einen Sender umgeschaltet der nicht auf den 2 Transpondern lag, das führte dazu das beide Aufnahmen wegen TS Fehler fehlerhaft wurden erst ein neustarten des VDRs behob das Problem.

passt zum Interrupt-Thread. Probier' auch mal die 1.08er Firmware (heute), die könnte das Problem beheben. Ich muss da jetzt auch mal probieren...
HD-VDR
Hardware: TT S2-6400, aktuelles Debian; DVB-Treiber aus dem CVS, VDR und DVBHdDevice aus dem CVS bzw. latest; Intel DH67BL mit Core i3 2.4GHz (alt: ASUS AT5ION-T mit Intel D525)

spitzb

Intermediate

Posts: 488

Location: Rheda-wiedenbrück

Occupation: IT

  • Send private message

647

Monday, May 30th 2011, 11:18am

Nachdem mein VDR den gestrigen Tag ohne Probleme lief. Ist heute Morgen irgendetwas sehr schief gegangen. Zu diesem Zeitpunkt lief der VDR nur im Leerlauf vor sich hin.

Vielleicht können die Treiber - Experten etwas mit dem Auszug aus dem Syslog anfangen:


May 30 07:50:15 vdr kernel: BUG: unable to handle kernel paging request at 0000000001ec8cd0
May 30 07:50:15 vdr kernel: IP: [<ffffffffa02674f8>] dvb_osd_ioctl+0x2f6/0x7c2 [saa716x_ff]
May 30 07:50:15 vdr kernel: PGD 1389dd067 PUD 13385c067 PMD 117c2e067 PTE 8000000113b19065
May 30 07:50:15 vdr kernel: Oops: 0003 [#1] SMP
May 30 07:50:15 vdr kernel: last sysfs file: /sys/devices/system/cpu/cpu1/cache/index2/shared_cpu_map
May 30 07:50:15 vdr kernel: CPU 0
May 30 07:50:15 vdr kernel: Modules linked in: snd_pcm_oss snd_mixer_oss snd_seq snd_seq_device ipv6 cpufreq_conservative cpufreq_userspace cpufreq_powersave acpi_cpufreq fuse loop dm_mod ndiswrapper isl6423 stv6110x stv090x ds3000 snd_hda_codec_realtek cx23885 ir_core cx2341x v4l2_common joydev videodev v4l1_compat snd_hda_intel snd_hda_codec v4l2_compat_ioctl32 lirc_imon snd_hwdep videobuf_dma_sg snd_pcm videobuf_dvb videobuf_core snd_timer lirc_dev saa716x_ff btcx_risc snd iTCO_wdt ohci1394 saa716x_core usb_storage sr_mod tveeprom i2c_i801 rtc_cmos ieee1394 iTCO_vendor_support e1000e soundcore cdrom rtc_core intel_agp dvb_core button snd_page_alloc i2c_core rtc_lib serio_raw pcspkr sg usbhid hid sd_mod crc_t10dif ehci_hcd uhci_hcd usbcore edd ext3 mbcache jbd fan ide_pci_generic ide_core ata_generic ahci pata_jmicron libata scsi_mod thermal processor thermal_sys hwmon
May 30 07:50:15 vdr kernel: Pid: 3489, comm: vdr Tainted: P 2.6.30.2-0.1-default #1
May 30 07:50:15 vdr kernel: RIP: 0010:[<ffffffffa02674f8>] [<ffffffffa02674f8>] dvb_osd_ioctl+0x2f6/0x7c2 [saa716x_ff]
May 30 07:50:15 vdr kernel: RSP: 0018:ffff88012a5e7c68 EFLAGS: 00010287
May 30 07:50:15 vdr kernel: RAX: 000000000000000a RBX: 00000000000000f7 RCX: 000000000000000a
May 30 07:50:15 vdr kernel: RDX: 0000000000000600 RSI: ffff880139ce123c RDI: 0000000001ec8cd0
May 30 07:50:15 vdr kernel: RBP: ffff88012a5e7d78 R08: 0000000000000282 R09: 0000000300000044
May 30 07:50:15 vdr kernel: R10: 0000000000000001 R11: 0000000000000002 R12: ffff8801364fc000
May 30 07:50:15 vdr kernel: R13: ffff880139ce1000 R14: ffff880139ce1220 R15: ffff88012a5e7d18
May 30 07:50:15 vdr kernel: FS: 00007fa0402e7700(0000) GS:ffff880028022000(0000) knlGS:0000000000000000
May 30 07:50:15 vdr kernel: CS: 0010 DS: 0000 ES: 0000 CR0: 0000000080050033
May 30 07:50:15 vdr kernel: CR2: 0000000001ec8cd0 CR3: 0000000136cd5000 CR4: 00000000000406e0
May 30 07:50:15 vdr kernel: DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
May 30 07:50:15 vdr kernel: DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
May 30 07:50:15 vdr kernel: Process vdr (pid: 3489, threadinfo ffff88012a5e6000, task ffff8801304901c0)
May 30 07:50:15 vdr kernel: Stack:
May 30 07:50:15 vdr kernel: 0000000200000000 0000000000000000 0000000000000000 ffff88000002d808
May 30 07:50:15 vdr kernel: 0000000000000001 000000012a5e7ee8 ffff88012a5e7db8 ffff880139ce13a8
May 30 07:50:15 vdr kernel: ffff88000001cc00 ffff88000001cc00 ffff88000001cc00 ffff88000002d800
May 30 07:50:15 vdr kernel: Call Trace:
May 30 07:50:15 vdr kernel: [<ffffffff802c280d>] ? __mem_cgroup_try_charge+0xe5/0x188
May 30 07:50:15 vdr kernel: [<ffffffff80252104>] ? autoremove_wake_function+0x0/0x38
May 30 07:50:15 vdr kernel: [<ffffffff8020c5ae>] ? invalidate_interrupt1+0xe/0x20
May 30 07:50:15 vdr kernel: [<ffffffffa01922e4>] dvb_usercopy+0xc9/0x12f [dvb_core]
May 30 07:50:15 vdr kernel: [<ffffffffa0267202>] ? dvb_osd_ioctl+0x0/0x7c2 [saa716x_ff]
May 30 07:50:15 vdr kernel: [<ffffffffa0192372>] dvb_generic_ioctl+0x28/0x2a [dvb_core]
May 30 07:50:15 vdr kernel: [<ffffffff802d2149>] vfs_ioctl+0x5f/0x78
May 30 07:50:15 vdr kernel: [<ffffffff802d2597>] do_vfs_ioctl+0x435/0x471
May 30 07:50:15 vdr kernel: [<ffffffff8036654b>] ? __up_read+0x92/0x9b
May 30 07:50:15 vdr kernel: [<ffffffff802551cf>] ? up_read+0x9/0xb
May 30 07:50:15 vdr kernel: [<ffffffff802d2628>] sys_ioctl+0x55/0x77
May 30 07:50:15 vdr kernel: [<ffffffff8020ba6b>] system_call_fastpath+0x16/0x1b
May 30 07:50:15 vdr kernel: Code: 85 3c 03 00 00 85 c0 74 47 48 8b 8d 20 ff ff ff 49 8d b5 3c 02 00 00 8b 51 18 48 8b 79 10 39 d0 76 07 48 63 ca f3 a4 eb 27 89 c1 <f3> a4 41 8b 85 3c 03 00 00 48 8b 95 20 ff ff ff 89 42 18 eb 10
May 30 07:50:15 vdr kernel: RIP [<ffffffffa02674f8>] dvb_osd_ioctl+0x2f6/0x7c2 [saa716x_ff]
May 30 07:50:15 vdr kernel: RSP <ffff88012a5e7c68>
May 30 07:50:15 vdr kernel: CR2: 0000000001ec8cd0
May 30 07:50:15 vdr kernel: ---[ end trace 69073ce6ed5d9018 ]---


Falk

powarman

Professional

Posts: 609

Location: Erfurt

Occupation: Software-Entwickler

  • Send private message

648

Monday, May 30th 2011, 9:07pm

Können die Leute von euch mit Kaltstartproblemen mal folgenden Patch probieren? Wichtig ist dabei, dass mindestens FPGA 1.07 benutzt wird.
powarman has attached the following file:

spitzb

Intermediate

Posts: 488

Location: Rheda-wiedenbrück

Occupation: IT

  • Send private message

649

Monday, May 30th 2011, 9:27pm

@powarman

Bei mir hat es leider nicht geholfen. Patch installiert, 2 x Neustart, 2x Probleme. Beide Male alle Probleme weg, nach VDR - Neustart ohne den Treiber neu zu laden.

Falk

spitzb

Intermediate

Posts: 488

Location: Rheda-wiedenbrück

Occupation: IT

  • Send private message

650

Tuesday, May 31st 2011, 1:27pm

@powarman

Ich habe noch mal ein paar Versuche angestellt. Ich habe dazu auch vorsichtshalber das Plugin, dessen Name nicht genannt wird, weg gelassen, damit es von daher keine Einflüsse geben kann (BTW die gleiche Testreihe hatte exakt gleiche Ergebnisse mit dem Plugin)

Alle Versuche wurden mit der neuesten Firmware und mit dem neuesten Treiber + gestrigem Patch durchgeführt.
System ist ein Intel Board DG43NB. OS ist SuSE Linux kernel 2.6.30-2.
Bei einem VDR - Restart wird der Treiber NICHT neu geladen.

1) Nach einem Kaltstart des Systems (Power on) sind regelmäßig BEIDE Tuner gestört. Umschalten ändert nichts, Tunerwechsel über femon auch nicht. VDR - Restart hilft zuverlässig. Danach sind beide Tuner ok.

2) Nach einem Warmstart des Rechners (reboot ohne Power off) ist regelmäßig nur EIN Tuner gestört. Weiteres Verhalten siehe 1)

3) Wenn VDR die zusätzlich vorhandene TeVii S2-470 zuerst belegt, gibt es einen deutlichen Versatz zwischen Bild und Ton (immer Digitalton, in diesem Fall ARD/ZDF HD mit DD2.0). Das kann durch einfaches Umschalten sicher behoben werden.

Außer den hier beschriebenen Problemen beim Kaltstart läuft das Ganze sehr stabil. Ganz sporadisch ( < 1x pro Woche) produziert der Treiber mal einen Kernel-Oops. Auch bei gleichzeitigen Aufzeichnungen habe ich keine Probleme feststellen können.

Was gelegentlich zu Artefakten führt, ist extremes Zappen, bei dem häufig weiter gezappt wird, bevor sich das Bild stabilisiert hat.

Wenn ich noch etwas ausprobieren soll, immer her mit den Infos. Diese Woche kann ich hemmungslos spielen, ohne dass ich Krach mit der Regierung bekomme ;D

Falk

651

Tuesday, May 31st 2011, 7:53pm

@spitzb
Hilft Dir zufällig UFO's Patch #2?
HD-VDR
Hardware: TT S2-6400, DD Cine S2 V6, ASUS P8H67-M Rev.3, Intel Core i3-2100T, 2x1GB RAM, SSD 40GB Intel X25-V, 2TB, Western Digital WD20EARS, Silverstone Grandia GD04
Projektor: Epson LH-TW5500 LPE
Audio: Onkyo TX-SR309, HECO Superior
Software: Ubuntu 12.04 64bit, vdr 2.0.0, osdteletext, femon, markad, dvbhddevice, remote, streamdev-server
Status:läuft 1a

Frodo

Professional

Posts: 1,632

Location: Hessen

  • Send private message

652

Tuesday, May 31st 2011, 8:12pm

Also bei mir läuft der VDR mit Ufos zweitem Patch und älterem Treiberstand stabil, zumindest was Artefakte und das Einschaltverhalten betrifft.

Mit dem neuen Treiber von Powarman läuft es nicht so rund, da kann es passieren das ausser dem OSD kein Bild und Ton kommt, es hilft auch nicht den VDR samt Module neu zustarten.
Ich hatte erst UFOs Treiber Quelle verwendet und bekam gar kein Bild und Ton, mit Powarmans klappe es dann wenn auch mit Ausfällen.

Bei der Firmware, Loader usw. setze ich alle aktuellen Versionen ein.
Gruß
Frodo

Meine VDR Hardware


YaVDR 0.5: TT S2-6400 und Sundtek SkyTV Ultimate (DVB-S/S2), Zotac H77ITX-C-E, Geforce 620, SilverStone ML02B-MXR, IMON LCD, softhddevice / dvbhddevice
YaVDR 0.5: Sat>IP (OctopusNet) über vtunerc, Zotac D2550ITX, Geforce 610, IMON VFD, softhddevice
YaVDR 0.5: Cine S2 V6, Intel DQ67SW, Geforce 210, SilverStone LC16M, IMON VFD, softhddevice
YaVDR 0.5: TT S2-3200, Intel DH67BL, Geforce 430, softhddevice
YaVDR 0.5: TT S2-6400, Intel DH67CF, dvbhddevice
Test HD TV-Karten: TT S2-3200, Sundtek SkyTV Ultimate (DVB-S/S2) , TeVii S480, TT-connect CT-3650 CI

653

Tuesday, May 31st 2011, 9:56pm

ich kann Frodos "Variante" bestätigen. Bei mir läuft es auch stabil mit UFO's Patch #2 und seinem Treiber (25.05.11):
http://linuxtv.org/hg/~endriss/media_build_experimental

root@hd-vdr:~# modinfo saa716x_ff
filename: /lib/modules/2.6.38-8-server/kernel/drivers/media/common/saa716x/saa716x_ff.ko
license: GPL
author: Manu Abraham
description: SAA716x FF driver
srcversion: 442342AA7F02B3AAA742B5E

Meine Firmware ist auch auf dem aktuellen Stand, habe eben noch das streamdev-server Plugin installiert... funzt.
HD-VDR
Hardware: TT S2-6400, DD Cine S2 V6, ASUS P8H67-M Rev.3, Intel Core i3-2100T, 2x1GB RAM, SSD 40GB Intel X25-V, 2TB, Western Digital WD20EARS, Silverstone Grandia GD04
Projektor: Epson LH-TW5500 LPE
Audio: Onkyo TX-SR309, HECO Superior
Software: Ubuntu 12.04 64bit, vdr 2.0.0, osdteletext, femon, markad, dvbhddevice, remote, streamdev-server
Status:läuft 1a

spitzb

Intermediate

Posts: 488

Location: Rheda-wiedenbrück

Occupation: IT

  • Send private message

654

Tuesday, May 31st 2011, 10:35pm

@spitzb
Hilft Dir zufällig UFO's Patch #2?
Hm. Der scheint jetzt tatsächlich was zu bringen. 2 x Kaltstart ohne Probleme. Das behalte ich jetzt mal im Auge.

Falk

Posts: 5,034

Location: Main-Spessart

  • Send private message

655

Wednesday, June 1st 2011, 1:48pm

Bei mir ist es mal wieder stabil. Bei mir war eindeutig das veränderte dvbhddevice-Plugin schuld. Mit dem Originalen funktioniert alles stabil.
VDR4Arch-Next --> Lian-Li PC-C37B | ASRock Q1900M | 4GB RAM | SanDisk SDSSDP064G | Samsung HD155UI | DD Cine S2 V6.2 | ZOTAC GT630 (Rev. 2) Zone Edition

656

Wednesday, June 1st 2011, 4:17pm

Bei mir ist es mal wieder stabil. Bei mir war eindeutig das veränderte dvbhddevice-Plugin schuld. Mit dem Originalen funktioniert alles stabil.


Auch, wenn Du nach dem Start zwei Aufzeichnungen beginnst, die auf versch. Transpondern liegen? Nur dann ist es ja vergleichbar.

657

Thursday, June 2nd 2011, 10:05am

Hi,

kann den Treiber immer noch nicht übersetzen. Habe folgendes gemacht:

Source code

1
2
3
4
5
6
7
8
cd /usr/local/src/dvb
make distclean 
make menuconfig

< >   Technisat/B2C2 FlexCopII(b) and FlexCopIII adapters
< >   FireDTV and FloppyDTV

make && make install



Und dann kommt eine weitere Fehlermeldung:

Source code

1
2
3
4
5
6
7
8
9
/usr/local/src/v4l-dvb-saa716x/v4l/bttv-i2c.c: In function 'init_bttv_i2c_ir':
/usr/local/src/v4l-dvb-saa716x/v4l/bttv-i2c.c:437:3: error: too few arguments to function 'i2c_new_probed_device'
include/linux/i2c.h:296:1: note: declared here
make[3]: *** [/usr/local/src/v4l-dvb-saa716x/v4l/bttv-i2c.o] Fehler 1
make[2]: *** [_module_/usr/local/src/v4l-dvb-saa716x/v4l] Error 2
make[2]: Leaving directory `/usr/src/linux-headers-2.6.38-8-generic'
make[1]: *** [default] Fehler 2
make[1]: Verlasse Verzeichnis '/usr/local/src/v4l-dvb-saa716x/v4l'
make: *** [all] Fehler 2


Hier weiß ich nicht was ich abwählen soll? Wollte mal dieses Modul deaktivieren:

-M- BT8xx based PCI cards

das geht aber nicht?
Hardware VDR: OrigenAE S16V, Seasonic Platinum Series Fanless 400 ATX, Intel® DH77EB, Intel Celeron G1620T (FC-LGA4, Ivy Bridge), Dynatron K-618, Kingston 4GB Kit HyperX PC3-10667 DDR3-1333 CL7, Kingston SSDNow V300 2,5" SSD 60 GB, Western Digital WD20EFRX 2 TB, LG GH20NS10, Digital Devices Cine S2 V6.5 + DuoFlex S2 (Bundle)

Softwareversionen können in den untigen Step-by-Step HowTos nachgesehen werden:
Ubuntu HD VDR mittels SoftHDDevice und VDPAU
Raspbian VDR Streaming Client mittels Streamdev und rpihddevice

658

Thursday, June 2nd 2011, 10:15am

Hi,

kann den Treiber immer noch nicht übersetzen. Habe folgendes gemacht:

Und dann kommt eine weitere Fehlermeldung:

Source code

1
2
3
4
5
6
7
8
9
/usr/local/src/v4l-dvb-saa716x/v4l/bttv-i2c.c: In function 'init_bttv_i2c_ir':
/usr/local/src/v4l-dvb-saa716x/v4l/bttv-i2c.c:437:3: error: too few arguments to function 'i2c_new_probed_device'
include/linux/i2c.h:296:1: note: declared here
make[3]: *** [/usr/local/src/v4l-dvb-saa716x/v4l/bttv-i2c.o] Fehler 1
make[2]: *** [_module_/usr/local/src/v4l-dvb-saa716x/v4l] Error 2
make[2]: Leaving directory `/usr/src/linux-headers-2.6.38-8-generic'
make[1]: *** [default] Fehler 2
make[1]: Verlasse Verzeichnis '/usr/local/src/v4l-dvb-saa716x/v4l'
make: *** [all] Fehler 2


Hier weiß ich nicht was ich abwählen soll? Wollte mal dieses Modul deaktivieren:

-M- BT8xx based PCI cards

das geht aber nicht?
Du kannst es ja mal wie ich es auf folgendem Link beschrieben habe versuchen, hatte die gleiche Meldungen:
[gelöst] TT S2-6400 - Betrieb unter Fedora 15beta - Treiber kann nicht kompiliert werden']
[gelöst] TT S2-6400 - Betrieb unter Fedora 15beta - Treiber kann nicht kompiliert werden[/url]

Source code

1
2
3
4
5
6
7
8
cd /usr/local/src
git clone git://linuxtv.org/media_build.git
cd media_build/linux/
wget http://www.aregel.de/file_download/6/linux-media.tar.bz2
make untar
cd ..
make
make install
Gruß MartinKG
Fedora 20 mit vdr-2.0.5 unter x86_64
Technotrend S2-6400 über hdmi an SyncMaster P2450 angeschlossen.

Posts: 5,034

Location: Main-Spessart

  • Send private message

659

Thursday, June 2nd 2011, 3:05pm

Ich habe mal ein Skript geschrieben, welches ausschließlich den Treiber baut, der für die S2-6400 notwendig ist. Anders als bei dem üblichen Weg wird hier der Treiber nicht gegen den alten v4l-Stand von powarman gebaut, sondern gegen den Kernel Source.

Das Skript muss als Root ausgeführt werden. Es läd den Treiber selbstständig aus dem Repository von powarman. Bei einem erneuten Start wird der bereits heruntergeladene Treiber nur aktualisiert. Der Treiber wird kompiliert und automatisch installiert. Wenn ihr Patches auf den Treiber anwenden wollt müsst ihr das ebenfalls im Skript tun. Die dafür notwendige Stelle ist entsprechend kommentiert.

Der Kernel-Source wird in /lib/modules/$(uname -r)/source erwartet. Dort ist er in Archlinux und Slackware hinverlinkt. Daher scheint das ein allgemeingültiger Pfad zu sein. Falls das in einem anderen System nicht so ist ist dort eben ein Symlink notwendig.


Dadurch, dass man das Skript einfach nur ausführen muss, denke ich, dass es ideal für das Howto im Wiki sein könnte. Desweiteren finde ich es schön, dass nur 2 Kernelmodule hinzugefügt werden und keine schon vorhandenen verändert.


Ich hoffe es bringt euch was. Ich nutze es hier sehr erfolgreich
Copperhead has attached the following file:
VDR4Arch-Next --> Lian-Li PC-C37B | ASRock Q1900M | 4GB RAM | SanDisk SDSSDP064G | Samsung HD155UI | DD Cine S2 V6.2 | ZOTAC GT630 (Rev. 2) Zone Edition

Posts: 5,034

Location: Main-Spessart

  • Send private message

660

Friday, June 3rd 2011, 4:59pm

29mal runtergeladen und keine sagt was?


@UFO: Ist dein Patch #2 mehr ein Experiment, oder ist das so fertig? Ich frage, weil ich mit dem originalen dvbhddevice-Plugin keinerlei Probleme mehr habe. Sollte ich den Patch trotzdem anwenden?
VDR4Arch-Next --> Lian-Li PC-C37B | ASRock Q1900M | 4GB RAM | SanDisk SDSSDP064G | Samsung HD155UI | DD Cine S2 V6.2 | ZOTAC GT630 (Rev. 2) Zone Edition