Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: VDR Portal. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

41

Sonntag, 19. April 2009, 00:29

scanned der mit s2scan hier bei jemandem ordentlich?
bei mir hört der immer auf nach nen paar sendern...
VFL WOLFSBURG!!!

Beiträge: 611

Wohnort: Erfurt

Beruf: Software-Entwickler

  • Nachricht senden

42

Sonntag, 19. April 2009, 11:27

hast Du -n als Parameter angegeben? Ansonsten scannt er nur einen Transponder...

Beiträge: 611

Wohnort: Erfurt

Beruf: Software-Entwickler

  • Nachricht senden

43

Sonntag, 19. April 2009, 12:04

Ich habe eben einen Suchlauf auf Astra 19.2 gemacht und komme auf 1526 gefundene Kanäle, wovon 1222 in der Liste landen, also TV/Radio Kanäle sind.

Sieht erstmal gut aus, gibt es andere Erfolgsmeldungen?

Grüße
Andreas

44

Dienstag, 21. April 2009, 04:57

Hi, sorry für das späte Feedback. Das er nicht alle Transponder gescanned hat war mein Fehler hatte das -n vergessen. Ansonsten funktioniert sie soweit, nur klappt das bei mir nicht so recht mit den beiden DVB Karten. Irgenwas stimmt da nicht ich bekomm immer nen 'Kanal nicht Verfügbar' . Hab schon VDR 1.7.0 bis 1.7.5 durch. Wenn ich das richtig verstehe dann liegt das daran das sich entweder meine Nova S Plus als DVB-S2 Karte ausgibt oder die TT S2 nicht als DVB-S2 Karte. Wär nett wenn du mal schauen könntest :)

MfG
Micha
VFL WOLFSBURG!!!

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »thizroxx« (21. April 2009, 07:34)


Beiträge: 611

Wohnort: Erfurt

Beruf: Software-Entwickler

  • Nachricht senden

45

Dienstag, 21. April 2009, 08:26

ok ich guck mal.

EDIT: in stv090x.c in stv0900_ops innerhalb .info nach .name einfügen:

Quellcode

1
2
3
4
5
	.caps			= FE_CAN_FEC_1_2 | FE_CAN_FEC_2_3 |
				  FE_CAN_FEC_3_4 | FE_CAN_FEC_5_6 |
				  FE_CAN_FEC_7_8 | FE_CAN_QPSK    |
				  FE_CAN_2G_MODULATION |
				  FE_CAN_FEC_AUTO

dann sollte sich die Karte als S2-fähig melden. Patch folgt heute Abend.

Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von »powarman« (21. April 2009, 08:52)


moviemax

Schüler

Beiträge: 64

Wohnort: süden

Beruf: Hach, ja auch

  • Nachricht senden

46

Dienstag, 21. April 2009, 10:21

Bei mir klappt es auch sehr gut.
Es wurden auch so ca. 1220 Services in die Liste eingetragen.
2x TT-C 1501 +1x TT-S2-1600 an Q6600
1x Reelbox light

Beiträge: 611

Wohnort: Erfurt

Beruf: Software-Entwickler

  • Nachricht senden

47

Dienstag, 21. April 2009, 18:58

Hier der Patch, mit dem die Capabilities gesetzt werden.
»powarman« hat folgende Datei angehängt:

48

Dienstag, 21. April 2009, 19:55

Vielen Dank Powarman! Die Karte funkt nun 1a =) Nun muss nur noch Vdpau gescheit laufen...

MfG
Micha
VFL WOLFSBURG!!!

Beiträge: 611

Wohnort: Erfurt

Beruf: Software-Entwickler

  • Nachricht senden

49

Donnerstag, 23. April 2009, 23:54

Manu hat jetzt alle meine Patches in sein Repository übernommen, sollte also ab jetzt mit dem aktuellen Stand von http://www.jusst.de/hg/v4l-dvb/ funtionieren.

Grüße
Andreas

Beiträge: 611

Wohnort: Erfurt

Beruf: Software-Entwickler

  • Nachricht senden

50

Freitag, 24. April 2009, 07:12

"Eben noch bei Manu und jetzt schon auf unserer Showbühne" :). Ist jetzt auch schon in http://linuxtv.org/hg/v4l-dvb/ drin. Das ging aber schnell.

51

Freitag, 24. April 2009, 13:26

Hi,
hat von Euch jemand die Hauppauge Nova-HD-S2 und die TT S2-1600 und kann was über die Umschaltzeiten und Tuningverhalten im Vergleich sagen? Wenn die Umschaltzeiten der S2-1600 nämlich ähnlich sind würde ich mir gerne das Geld für die Nova sparen.

Gruß Darkstar.
Hardware: Seagate Dockstar@1500MHz, GSS Box DSI 400 SAT>IP Server, VDR 2.1.6 mit Streamdev-Server
Videoausgabe: RaspberryPi mit MLD-4.0.1-RPi an LG 42LM660

moviemax

Schüler

Beiträge: 64

Wohnort: süden

Beruf: Hach, ja auch

  • Nachricht senden

52

Freitag, 24. April 2009, 13:29

in habe ich auch noch was verbessert.
Da soll noch einer sagen die Open Source Doku ist schlecht. ;)

Jedoch ist mir in Bezug auf i2c was aufgefallen:

i2c tab:
i2c-0 smbus SMBus I801 adapter at 0500
i2c-1 i2c TT-Budget C-1501 PCI
i2c-2 i2c TT-Budget S2-1600 PCI
i2c-3 i2c NVIDIA i2c adapter
i2c-4 i2c NVIDIA i2c adapter
i2c-5 i2c NVIDIA i2c adapter


Achtung "wer das auf dem falschen i2c bus ausführt kann sich seine Hardware verschießen!"

i2cdetect -y 2 -a

Quellcode

1
2
3
4
5
6
7
8
9
10
root@Pluto:ttpci # i2cdetect -y -a 2     
 0  1  2  3  4  5  6  7  8  9  a  b  c  d  e  f
00: -- -- -- -- -- -- -- -- 08 -- -- -- -- -- -- -- 
10: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- 
20:-- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- 
30: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- 
40: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- 
50: 50 51 52 53 54 55 56 57 -- -- -- -- -- -- -- -- 
60: -- -- -- -- -- -- -- -- 68 -- -- -- -- -- -- -- 
70: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --


wie im treiber nicht schwer rauszulesen:

Intersil: x08 (LNB)
ttpci-eprom 0x50
stv0903 0x68
stv06110 0x60 ???? wo ist der ?

Das eigentliche Problem:


root@Pluto:ttpci # i2cdump -y -f 2 0x68

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
No size specified (using byte-data access)                             
     0  1  2  3  4  5  6  7  8  9  a  b  c  d  e  f    0123456789abcdef
00: 20 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00     ...............
10: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00    ................
20: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00    ................
30: 00 47 82 24 00 00 00 00 00 00 00 00 00 00 00 00    .G?$............
40: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00    ................
50: 00 4e 7f 64 00 00 00 00 00 00 00 00 00 00 00 00    .N?d............
60: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00    ................
70: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00    ................
80: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00    ................
90: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00    ................
a0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00    ................
b0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00    ................
c0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00    ................
d0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00    ................
e0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00    ................
f0: 53 54 00 00 00 00 00 00 00 00 00 00 00 00 00 00    ST..............


es müssten doch viel mehr daten vorhanden sein ?

bei der TT_1501 sieht es so aus:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
root@Pluto:ttpci # i2cdump -y -f 1 0x0c
No size specified (using byte-data access)
     0  1  2  3  4  5  6  7  8  9  a  b  c  d  e  f    0123456789abcdef
00: 2b 30 93 1a 62 46 7f 1a 43 6a ed 1b 1e 88 e2 40    +0??bF??Cj?????@
10: b8 bf a1 01 00 00 00 56 12 00 7d c8 b0 fb a7 7f    ????...V?.}?????
20: 04 01 00 1f 00 00 00 00 0a 80 0c a1 0d f6 30 00    ??.?....??????0.
30: 00 00 00 04 00 ff 00 11 a5 2b 3e ff 00 00 00 00    ...?...??+>.....
40: 00 20 ff e0 00 00 ff e0 00 60 ff 60 01 60 f9 e0    . .?...?.`.`?`??
50: 3a a0 02 60 fc c0 ff 40 fe 80 fe e0 ff 00 ff 20    :??`??.@????...
60: 02 e0 01 a0 01 e0 01 20 01 40 00 e0 00 00 00 00    ??????? ?@.?....
70: 00 00 00 00 eb 02 00 00 46 00 00 00 c3 4a 7e 02    ....??..F...?J~?
80: 00 00 ff e0 00 20 ff c0 00 60 ff 80 01 20 fd 20    ...?. .?.`.?? ?
90: 00 00 fa 00 02 20 00 80 00 e0 00 60 ff c0 00 c0    ..?.? .?.?.`.?.?
a0: ff c0 fe 40 ff c0 ff 00 00 c0 ff 20 00 80 ff c0    .??@.?...?. .?.?
b0: ff e0 00 00 6a 19 44 3c e6 ff 00 ff ff 00 a3 02    .?..j?D<?.....??
c0: 10 20 80 05 00 5b b5 cf 00 00 0f 26 00 00 00 00    ? ??.[??..?&....
d0: 00 00 20 00 25 7f 7f 7f 00 00 00 00 80 80 80 80    .. .%???....????
e0: 00 25 00 00 00 00 07 00 00 00 00 00 00 00 00 00    .%....?.........
f0: 00 00 00 00 00 00 00 00 00 00 f0 00 f0 00 c0 c0    ..........?.?.??


Wie kann man auf die register z.b. 0xf40e (DEMOD) zugreifen ?
vielleicht hat jemand noch ne idee wie ich den stv0903 über den i2c steuern kann
gruß moviemax
2x TT-C 1501 +1x TT-S2-1600 an Q6600
1x Reelbox light

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »moviemax« (24. April 2009, 14:01)


Beiträge: 611

Wohnort: Erfurt

Beruf: Software-Entwickler

  • Nachricht senden

53

Freitag, 24. April 2009, 15:25

Zitat

Original von moviemax
stv06110 0x60 ???? wo ist der ?


Der Tuner hängt am I2C Repeater des Demodulators, man muss den erst per Register durchschalten.

Zitat


Wie kann man auf die register z.b. 0xf40e (DEMOD) zugreifen ?
vielleicht hat jemand noch ne idee wie ich den stv0903 über den i2c steuern kann


Du musst erst die 16-bit Register-Adresse (0xf40e) schreiben und dann kannst Du das eine Register lesen oder schreiben.

Grüße
Andreas

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »powarman« (24. April 2009, 15:27)


54

Freitag, 24. April 2009, 18:27

Zitat

Original von Darkstar
Hi,
hat von Euch jemand die Hauppauge Nova-HD-S2 und die TT S2-1600 und kann was über die Umschaltzeiten und Tuningverhalten im Vergleich sagen? Wenn die Umschaltzeiten der S2-1600 nämlich ähnlich sind würde ich mir gerne das Geld für die Nova sparen.

Gruß Darkstar.


Ich hab die Karte und bin zufrieden mit den Umschaltzeiten und Tuningprobleme hab ich auch keine. Das einzige was nicht hinhaut ist das Femon Plugin das zeigt beim SNR 0 an.
VFL WOLFSBURG!!!

moviemax

Schüler

Beiträge: 64

Wohnort: süden

Beruf: Hach, ja auch

  • Nachricht senden

55

Samstag, 25. April 2009, 22:37

Hi,
Gerade illegaler weiße ne Flach DVB-S Antenne vor`s Fenster montiert. ;)
scan-2 sagt:
dumping lists (1325 services)
Done.

real 6m27.832s
user 0m0.036s
sys 0m0.912s

Da kann man nicht meckern umschaltzeiten sind gut.

moviemax
2x TT-C 1501 +1x TT-S2-1600 an Q6600
1x Reelbox light

56

Montag, 27. April 2009, 16:50

@powarman

Zitat

Original von powarman
Aus eigener Erfahrung kann ich sagen, dass der STV090x ein Riesenfortschritt gegenüber dem STB0899 ist. Eigentlich der erste Demodulator von ST, der mich wirklich überzeugt hat. Lockzeiten sollten im Bereich von 200 ms liegen

Grüße
Andreas


Kann man es mit irgendwelche Software feststellen/messen? Wie kommst du an 200 ms?


Danke.

moviemax

Schüler

Beiträge: 64

Wohnort: süden

Beruf: Hach, ja auch

  • Nachricht senden

57

Montag, 27. April 2009, 17:25

Zitat

Aus eigener Erfahrung kann ich sagen, dass der STV090x ein Riesenfortschritt gegenüber dem STB0899 ist. Eigentlich der erste Demodulator von ST, der mich wirklich überzeugt hat. Lockzeiten sollten im Bereich von 200 ms liegen


kann mich powerman nur anschliesen! Der stv090x rockt.

Sag mal sollte bei der Initialsierung des stv090x bit8 des I2CCFG ( 0xf129) Registers auf 1 gesetzt werden ? I2c fastmode.
2x TT-C 1501 +1x TT-S2-1600 an Q6600
1x Reelbox light

Beiträge: 611

Wohnort: Erfurt

Beruf: Software-Entwickler

  • Nachricht senden

58

Montag, 27. April 2009, 20:49

Zitat

Original von neptunvasja
Kann man es mit irgendwelche Software feststellen/messen? Wie kommst du an 200 ms?

wir setzen den auch auf unseren Boxen ein, und da hab ichs einfach gemessen...

lässt sich noch ein wenig beschleunigen, wenn mann den I2C Bus statt mit 100kHz z.B. mit 200kHz betreibt, aber mehr als 250 sollte man nicht einstellen, dann bekommt der Tuner Probleme und kriegt vielleicht nicht alles mit.

Grüße
Andreas

Beiträge: 611

Wohnort: Erfurt

Beruf: Software-Entwickler

  • Nachricht senden

59

Montag, 27. April 2009, 20:50

Zitat

Original von moviemax
Sag mal sollte bei der Initialsierung des stv090x bit8 des I2CCFG ( 0xf129) Registers auf 1 gesetzt werden ? I2c fastmode.

Es ist bit 3, das wird schon eingestellt, ist der empfohlene Wert laut Datenblatt.

moviemax

Schüler

Beiträge: 64

Wohnort: süden

Beruf: Hach, ja auch

  • Nachricht senden

60

Dienstag, 28. April 2009, 02:24

Bedeutet das, dass man die register nur über I2C 10 bit adressierung
ansprechen kann. Bei mit klappt das nicht mit dem standard smbus_data_write / read nicht so richtig.

Falls es so ist habe ich das Posting von Linus gefunden:

http://git.kernel.org/?p=linux/kernel/gi…n-bit-addresses

moviemax
2x TT-C 1501 +1x TT-S2-1600 an Q6600
1x Reelbox light

Immortal Romance Spielautomat