Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: VDR Portal. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

Leo

Fortgeschrittener

Beiträge: 221

Wohnort: Görwihl

Beruf: IT Developer

  • Nachricht senden

61

Mittwoch, 23. März 2016, 20:48

Plex 0.9.16 break streamdev Channel plugin

Hallo,

habe Plex auf Version 0.9.16 upgedatet. Dann geht das Plex streamdev Channel plugin nicht mehr (Live TV). Mit der Version 0.9.15.6.1714-7be11e1_i386.deb
geht es noch.

Kennt man das Problem ?

Danke und Gruss
Leo
Hardware: Asus P5G41T-M LX, Gigabyte GeForce GT220, Digital Devices Cine S2 V6 & TechnoTrend Budget S2-1600, Hama MCE Remote Control
Software: yaVDR 0.6 & neuste updates (
ppa:yavdr/stable-vdr)

62

Donnerstag, 24. März 2016, 13:04

Hi,

ich hatte das neulich auch bemerkt ... ich schaue mir das nach Ostern mal an, falls ein anderer einen Fix findet - posten bzw. ein Pullrequest via github, dann mache ich eine neue Version (hab eh noch 1-2 mehr Sachen in der Pipeline dafür).

VG,
Alex
VDR1: Asus Z87, 8GB Ram, MSI GT210, 3 x Cinergy 1200 DVB-C, Ubuntu 14.04. + yaVDR 0.61, Plex+vdrstuff
VDR2: QNAP TS-251+, 6TB, via Sat>IP mit VDR1

Leo

Fortgeschrittener

Beiträge: 221

Wohnort: Görwihl

Beruf: IT Developer

  • Nachricht senden

63

Donnerstag, 24. März 2016, 16:25

Hi,

ich hatte das neulich auch bemerkt ... ich schaue mir das nach Ostern mal an, falls ein anderer einen Fix findet - posten bzw. ein Pullrequest via github, dann mache ich eine neue Version (hab eh noch 1-2 mehr Sachen in der Pipeline dafür).

VG,
Alex

Danke und Gruss
Leo
Hardware: Asus P5G41T-M LX, Gigabyte GeForce GT220, Digital Devices Cine S2 V6 & TechnoTrend Budget S2-1600, Hama MCE Remote Control
Software: yaVDR 0.6 & neuste updates (
ppa:yavdr/stable-vdr)

somebody101

Fortgeschrittener

Beiträge: 455

Wohnort: Weiterstadt, nähe Frankfurt

  • Nachricht senden

64

Samstag, 16. April 2016, 20:47

Hi Alex,

hast du hier "zufällig" schon Neuigkeiten? ;-)
Irgendwie klappt der Weg zurück auf ältere Plex-Versionen, um das Plex-Plugin weiter zu nutzen, nicht wirklich gescheit... hmm...

so long
rob.
VDR1: HP-Microserver N40L mit mit yavdr 0.6 (headless) und 3 USB Empfängern (pctv 461e)
VDR2: MacMini mit yavdr 0.6 und TT-3600 (USB)
VDR3 - VDR5: Raspberry Pi3 mit USB Empfänger (pctv461e) und MLD

65

Montag, 4. Juli 2016, 12:04

habe Plex auf Version 0.9.16 upgedatet. Dann geht das Plex streamdev Channel plugin nicht mehr (Live TV). Mit der Version 0.9.15.6.1714-7be11e1_i386.deb
geht es noch.


Hallo,

Mich hat es nun auch erwischt nachdem ich auf Version 1.0.0.2261 upgraded habe bekomme ich kein leider kein Live TV Bild mehr. Hat jemand dafür evetl. schon einen fix?
WZ: yaVDR (0.5): Gigabyte GA-MA78GM-S2H / AMD 240e / LianLi PC-C50B / atric & Harmony 650 / 2GB G.Skill 800 / 2x TT S2-1600 1x TT S2-3600 / 60GB OCZ Vertex2 / Gainward G210 passiv
AZ: yaVDR (0.5): PoV 330-1 (Atom/ION) / MS-Tech MC-1200/ 2GB Kingston VR 800 / TT S2-1600 / OCZ SSD Onyx 32GB / atric & Harmony 600
EZ: Raspberry Pi - OpenElec
HL: GA-MA78GM-S2H / AMD 5050e (@1.1V) / 2x DVBSky S952 Dual / 64 GB SanDisk SDSSDP-064G-G25 / 4 GB RAM / BQT E9
NAS: Synology DS-1511+ (DSM 4.2) / 5x2TB Samsung F4 / Raid 5 / Smargo / Oscam / APC Back-Ups cs 350

66

Montag, 4. Juli 2016, 12:17

Hi,

nur kurzes Erwartungshaltungsmanagment ... Ich komme privat zu nichts gerade. Evtl. mal in den Sommerferien. Irgendwas hat sich an der Pluginstruktur geändert bei Plex, und das müsste halt nachgezogen werden, aber was hat sich mir noch nicht erschlossen beim Lesen... Das Playerobjekt braucht eine andere Klasse o.ä.

VG,
Alex
VDR1: Asus Z87, 8GB Ram, MSI GT210, 3 x Cinergy 1200 DVB-C, Ubuntu 14.04. + yaVDR 0.61, Plex+vdrstuff
VDR2: QNAP TS-251+, 6TB, via Sat>IP mit VDR1

67

Donnerstag, 28. Juli 2016, 19:01

Zwischenstand

Moin,

Ich habe jetzt mal die letzten Tage (vergeblich) rumgewühlt.... Mir scheint es so, als wenn der Transcoder in Plex sich geändert hat und mit dem TS-Stream vom Streamdev nicht mehr klar kommt.

Ich habe im Plex-Forum um Hilfe gefragt... andere Plugins, wie die zu MythTV und TVHeadend scheinen noch zu laufen und damit klar zu kommen ... Kann hier einer Python, also so richtig?

Ich hab das damals nur zusammen "geklaut" per cut&paste und so lange geändert, bis es ging ;-)

Hier der Link zum Plex Forum: https://forums.plex.tv/discussion/226784…r-plugin#latest

Mehr, sobald sich da was tut bzw. ich mich mehr eingelesen habe.

VG,
Alex
VDR1: Asus Z87, 8GB Ram, MSI GT210, 3 x Cinergy 1200 DVB-C, Ubuntu 14.04. + yaVDR 0.61, Plex+vdrstuff
VDR2: QNAP TS-251+, 6TB, via Sat>IP mit VDR1

68

Donnerstag, 28. Juli 2016, 19:22

Nachklang:

Mit Plex Media player und der iOS App geht es bei mir jetzt (mit TS als Streamart). Code ist eingecheckt:

https://github.com/Jondalar/plex-vdr-live.bundle


Was nicht geht, ist Safari und Chrome bei mir. Allerdings habe ich macOS Sierra laufen und kann nicht mit was anderem testen... Ich vermute jetzt, dass es Streamingprofile geben muss innerhalb von Plex, mal schauen ob ich bei den anderen Streaming Channels dazu was finde.

Bitte Rückmeldung hierher.

VG,
Alex
VDR1: Asus Z87, 8GB Ram, MSI GT210, 3 x Cinergy 1200 DVB-C, Ubuntu 14.04. + yaVDR 0.61, Plex+vdrstuff
VDR2: QNAP TS-251+, 6TB, via Sat>IP mit VDR1

Leo

Fortgeschrittener

Beiträge: 221

Wohnort: Görwihl

Beruf: IT Developer

  • Nachricht senden

69

Donnerstag, 28. Juli 2016, 20:30

Nachklang:

Mit Plex Media player und der iOS App geht es bei mir jetzt (mit TS als Streamart). Code ist eingecheckt:

https://github.com/Jondalar/plex-vdr-live.bundle


Was nicht geht, ist Safari und Chrome bei mir. Allerdings habe ich macOS Sierra laufen und kann nicht mit was anderem testen... Ich vermute jetzt, dass es Streamingprofile geben muss innerhalb von Plex, mal schauen ob ich bei den anderen Streaming Channels dazu was finde.

Bitte Rückmeldung hierher.

VG,
Alex
Hallo Alex,

habe das Plugin upgedatet (__init__.py - 0.0.3 alpha). Meine Plex Server Version ist 1.0.2.2413
Leider geht das Streaming mit der Plex App auf dem ipad nicht.

Bei der Plex Version 0.9.15.6 ging das Streaming noch, mit der __init__.py version 0.0.2 alpha und auch 0.0.3 alpha


Sorry nachdem ich nochmals alles neu gestartet habe scheint es zu gehen auf dem iPad ;-) Vielen Dank

Danke und Gruss
Leo
Hardware: Asus P5G41T-M LX, Gigabyte GeForce GT220, Digital Devices Cine S2 V6 & TechnoTrend Budget S2-1600, Hama MCE Remote Control
Software: yaVDR 0.6 & neuste updates (
ppa:yavdr/stable-vdr)

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Leo« (28. Juli 2016, 20:57)


70

Donnerstag, 28. Juli 2016, 20:57

habe das Plugin upgedatet (__init__.py - 0.0.3 alpha). Meine Plex Server Version ist 1.0.2.2413
Leider geht das Streaming mit der Plex App auf dem ipad nicht.
Hi,

Mistkrams ... Ich hasse dieses Framework, die Doku dazu ist echt bescheiden. Da lobe ich mir das vdr-wiki usw. Kannst Du mir das log vom Plugin und vom Plex Media Server bitte schicken?


Ich bezweifele zwar, dass ich viel helfen kann, aber wer weiss. Und:
1) starte den plexmediaserver einmal durch bitte, bevor Du logst
2) stell den Stream in den Settings auf "original" falls er dir (sieht aus wie ein Mischpult-Icon) das anbietet.


VG,
Alex
VDR1: Asus Z87, 8GB Ram, MSI GT210, 3 x Cinergy 1200 DVB-C, Ubuntu 14.04. + yaVDR 0.61, Plex+vdrstuff
VDR2: QNAP TS-251+, 6TB, via Sat>IP mit VDR1

71

Donnerstag, 28. Juli 2016, 20:59

Sorry nachdem ich nochmals alles neu gestartet habe scheint es zu gehen auf dem iPad ;-) Vielen Dank
Hahaha... da war ich wohl schneller :-) Sehr gut. Plex lädt die Channels ins Cache und kompiliert die PythonScripte (laut log und Doku), daher macht es Sinn bei Anpassungen wirklich den plexmediaserver-Prozess zu beenden und neu zu starten.

VG,
Alex
VDR1: Asus Z87, 8GB Ram, MSI GT210, 3 x Cinergy 1200 DVB-C, Ubuntu 14.04. + yaVDR 0.61, Plex+vdrstuff
VDR2: QNAP TS-251+, 6TB, via Sat>IP mit VDR1

72

Donnerstag, 28. Juli 2016, 22:19

Hi,

kann mir mal jemand verraten, wie ich das Plugin verwende? Also installiert habe ich es, aber wie wähle ich das im Webinterface des Plex Media Centers aus?

Claus
MLD 5.1 mit vdr 2.2 - lirc yaUSBir - Octopus NET S2 - SCR - XFX GeForce 9300 mit Intel E3200 - 2GB RAM -
WD Green 6TB HDD - SanDisk 64GB SSD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.3 mit vdr 2.3.4 - Raspberry Pi 3 - rpihddevice
MLD 5.1 mit vdr 2.2 - Banana Pi - softhddevice
MLD 5.0 mit Squeeze Play - Raspberry Pi 2 - 32GB SD - 7" Touch TFT
MLD 2.0 mit vdr 1.6 - SMT-7020s - 80GB HDD

73

Donnerstag, 28. Juli 2016, 23:31

Hi,

kann mir mal jemand verraten, wie ich das Plugin verwende? Also installiert habe ich es, aber wie wähle ich das im Webinterface des Plex Media Centers aus?

Claus
Hi Claus,

Du musst das .bundle in den Plug-ins Ordner schmeissen, dann plexmediaserver durchstarten. Danach sollte es unter "Channels" (oder Kanäle) ein VDR Icon geben. Da Trägst Du dann mit einem Klick auf das Zahnrad die Daten für Streamdev, RestfulAPI und "TS" als Stream ein. Danach sollte es die channels.conf in Gruppen anzeigen und Live TV anbieten.

Hilft Dir das?

VG,
Alex
VDR1: Asus Z87, 8GB Ram, MSI GT210, 3 x Cinergy 1200 DVB-C, Ubuntu 14.04. + yaVDR 0.61, Plex+vdrstuff
VDR2: QNAP TS-251+, 6TB, via Sat>IP mit VDR1

74

Freitag, 29. Juli 2016, 10:25

*hüstel* Wenn wir schonmal dabei sind: Wäre super, wenn irgendwann mal die Channellogos in der Info-Bar (während der Wiedergabe) zu sehen wären.
In der Senderliste sind sie ja schon
VDR 2.2.0, PMS, iStreamdev
Ubuntu 14.04 64bit
alles 'headless' auf Intel(R) Core(TM) i5-4440 CPU @ 3.10GHz, 8GB RAM, 5 x 3TB im RAID5 (12TB)
zzgl. diverse SH4 Sat-Boxen mit NeutrinoMP

75

Freitag, 29. Juli 2016, 10:30

*hüstel* Wenn wir schonmal dabei sind: Wäre super, wenn irgendwann mal die Channellogos in der Info-Bar (während der Wiedergabe) zu sehen wären.
In der Senderliste sind sie ja schon
*grins* .. auf dem Hüstel Ohr bin ich taub ;-)

Hab keine Ahnung wie das geht, aber schaue mal ... Erst mal muss das mit den Logos bei mir wieder gehen, hab irgendwas kaput konfiguriert. Wo liegen die bei Dir im Dateisystem?

VG,
Alex
VDR1: Asus Z87, 8GB Ram, MSI GT210, 3 x Cinergy 1200 DVB-C, Ubuntu 14.04. + yaVDR 0.61, Plex+vdrstuff
VDR2: QNAP TS-251+, 6TB, via Sat>IP mit VDR1

76

Freitag, 29. Juli 2016, 10:57

Hi,

Danke schon mal für die Beschreibung.
Also bei mir gibt es unter "Kanäle" kein VDR Icon. Demnach habe ich das Plugin wohl an der falschen Stelle in den Plugin Ordner gepackt (/root/Plex Media Server/Plug-ins/). Wo sucht plex denn überall nach den Plugins? Kann man das irgendwo konfigurieren?
(Ich bin neu in dem Thema Plex, weshalb ich da noch etwas mehr Hilfestellungen brauche...)

Claus
MLD 5.1 mit vdr 2.2 - lirc yaUSBir - Octopus NET S2 - SCR - XFX GeForce 9300 mit Intel E3200 - 2GB RAM -
WD Green 6TB HDD - SanDisk 64GB SSD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.3 mit vdr 2.3.4 - Raspberry Pi 3 - rpihddevice
MLD 5.1 mit vdr 2.2 - Banana Pi - softhddevice
MLD 5.0 mit Squeeze Play - Raspberry Pi 2 - 32GB SD - 7" Touch TFT
MLD 2.0 mit vdr 1.6 - SMT-7020s - 80GB HDD

77

Freitag, 29. Juli 2016, 13:43

*hüstel* Wenn wir schonmal dabei sind: Wäre super, wenn irgendwann mal die Channellogos in der Info-Bar (während der Wiedergabe) zu sehen wären.
In der Senderliste sind sie ja schon
*grins* .. auf dem Hüstel Ohr bin ich taub ;-)

Hab keine Ahnung wie das geht, aber schaue mal ... Erst mal muss das mit den Logos bei mir wieder gehen, hab irgendwas kaput konfiguriert. Wo liegen die bei Dir im Dateisystem?

VG,
Alex

Die Logos sind da, wo sie das Rest-API erwartet und auch ausliefert.
In der Senderübersicht sind sie ja auch da. (Bild 1)
Nur eben bei der Fortschrittsanzeige nicht. Da grüßt munter der VDR Tux (Bild 2)

Wie Du schon sagst, das hat keine Prio.
Btw. ich hab oftmals das Problem, dass der erste Kanal in der Kanalliste (bei mir Das Erste HD) nicht angezeigt wird. Kann natürlich auch mit dem Rest-API zu tun haben. EPG Daten sind jedenfalls vorhanden.
»sh4« hat folgende Bilder angehängt:
  • plexvdr1.png
  • plexvdr2.png
VDR 2.2.0, PMS, iStreamdev
Ubuntu 14.04 64bit
alles 'headless' auf Intel(R) Core(TM) i5-4440 CPU @ 3.10GHz, 8GB RAM, 5 x 3TB im RAID5 (12TB)
zzgl. diverse SH4 Sat-Boxen mit NeutrinoMP

78

Freitag, 29. Juli 2016, 16:14

Wo sucht plex denn überall nach den Plugins?
Bei mir liegt alles in

Quellcode

1
/var/lib/plexmediaserver/Library/Application Support/Plex Media Server/Plug-ins

Ob Du einen anderen Ort für Plugins angeben kannst - glaube ich nicht, denn da installieren sich die Plugins via UI auch hin.

Denk dran den User auf plex:plex umzusetzen, falls Du mit dem Standard User arbeitest.

VG,
Alex
VDR1: Asus Z87, 8GB Ram, MSI GT210, 3 x Cinergy 1200 DVB-C, Ubuntu 14.04. + yaVDR 0.61, Plex+vdrstuff
VDR2: QNAP TS-251+, 6TB, via Sat>IP mit VDR1

79

Dienstag, 2. August 2016, 09:56

Wie Du schon sagst, das hat keine Prio.
Moin,

Ich hab das jetzt mal rein-"gehackt" ... Also es wird das Thumbnail gefüllt mit dem Kanallog. Die passen allerdings von den Abmassen her nicht. Wie ich das "size" oder "croppe" muss ich erstmal nachlesen ... sieht nicht sehr gut aus finde ich.

Aber ein Anfang. Ist im Git eingecheckt.

Das andere Thema, das z.Bsp. die ARD (bei mir Kanal 1) manchmal fehlt schaue ich mir auch noch mal an, evtl. Ein Schleifenzähler der nicht stimmt nach mehrmaliger Benutzung des Plugins.

VG,
Alex
VDR1: Asus Z87, 8GB Ram, MSI GT210, 3 x Cinergy 1200 DVB-C, Ubuntu 14.04. + yaVDR 0.61, Plex+vdrstuff
VDR2: QNAP TS-251+, 6TB, via Sat>IP mit VDR1

80

Dienstag, 2. August 2016, 18:47

Ob Du einen anderen Ort für Plugins angeben kannst - glaube ich nicht, denn da installieren sich die Plugins via UI auch hin.


Hi Alex,

Danke für den Tipp.
Unter /etc/default/plexmediaserver kann man einstellen wo plex seine Daten ablegt. Dort gibt es dann auch den Plug-ins Unterordner.

Claus
MLD 5.1 mit vdr 2.2 - lirc yaUSBir - Octopus NET S2 - SCR - XFX GeForce 9300 mit Intel E3200 - 2GB RAM -
WD Green 6TB HDD - SanDisk 64GB SSD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.3 mit vdr 2.3.4 - Raspberry Pi 3 - rpihddevice
MLD 5.1 mit vdr 2.2 - Banana Pi - softhddevice
MLD 5.0 mit Squeeze Play - Raspberry Pi 2 - 32GB SD - 7" Touch TFT
MLD 2.0 mit vdr 1.6 - SMT-7020s - 80GB HDD

Immortal Romance Spielautomat