You are not logged in.

Dear visitor, welcome to VDR Portal. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

61

Friday, February 5th 2010, 5:06pm

Probleme beim Beenden von xine(-liboutput)

Erstmal ein dickes Dankeschön für das xine Plugin! Echt super, daß das Atmolight nun auch mit xine spielt.

Nun aber zu meinem Problem:
Ich habe einen neuen VDR mit Ubuntu 9.10 und den Paketen des vdr-teams aufgesetzt. Bei meinen ganzen Konfigurationsorgien ist mir nun aufgefallen, daß sich xine (auch bei xineliboutput) nicht mehr ordentlich beendet, wenn das atmo-post-plugin mit geladen wird. Ohne das Plugin funktioniert das Beenden ganz normal.

Normalerweise wird beim Rechnerstart xine über nodm gestartet. Beende ich nodm mit "/etc/init.d/nodm stop", dann bleibt der xine Prozess als Zombie übrig. Starte ich hingegen xine nicht automatisch, sondern nachträglich von der Konsole und beende es dann mit Strg-C, dann passiert an der Konsole garnix. Der Prozess bleibt ebenfalls mit Status defunct hängen.

Zur Hardware: ich habe eine atmo-Platine von Slime mit USB-Anschluß. Im Aufruf gebe ich /dev/ttyUSB0 als device an.

Da ich mal so wirklich garkeine Fehlermeldung im syslog gefunden habe, weiß ich leider nicht, wo ich ansetzen soll. Hilft da gdb weiter? Ich hab noch nie mit einem Debugger gearbeitet, wäre also für eine kurze Anleitung dankbar.

Gruß,
Saxman2k
Hardware: Gigabyte GA-970A-D3, AMD Athlon II X2 235e, 4GB RAM, Zotac GeForce 210 Synergy Edition 1GB, Corsair Force3 60GB SSD, Mystique SaTiX-S2 Dual, 6.4" TFT, Atric IR Einschalter Rev.5, Logitech Harmony 900, Samsung LE46A789 full HD LCD, Denon AVR-1910, USB Atmo-Light von Slime
Software: yaVDR 0.5
Streaming Client 1: Hauppauge MediaMVP
Streaming Client 2: Telegant TG100 (wenn ich mal irgendwann die Zeit finde das UPnP-Plugin zu testen)

62

Saturday, February 6th 2010, 1:50pm

RE: Probleme beim Beenden von xine(-liboutput)

*push*

Bin ich wirklich der einzige mit dem Problem?

[edit]
Anscheinend gibt es ein Problem, wenn xine mit dem Parameter "-V vdpau" gestartet wird. Sobald ich den weglasse kann sich xine auch normal beenden. Also lass ich den einfach weg und vdpau wird über die config automatisch ausgewählt. Aber ist schon seltsam...
Hardware: Gigabyte GA-970A-D3, AMD Athlon II X2 235e, 4GB RAM, Zotac GeForce 210 Synergy Edition 1GB, Corsair Force3 60GB SSD, Mystique SaTiX-S2 Dual, 6.4" TFT, Atric IR Einschalter Rev.5, Logitech Harmony 900, Samsung LE46A789 full HD LCD, Denon AVR-1910, USB Atmo-Light von Slime
Software: yaVDR 0.5
Streaming Client 1: Hauppauge MediaMVP
Streaming Client 2: Telegant TG100 (wenn ich mal irgendwann die Zeit finde das UPnP-Plugin zu testen)

This post has been edited 1 times, last edit by "Saxman2k" (Feb 6th 2010, 2:10pm)


63

Saturday, February 6th 2010, 6:02pm

Neue Version 0.3

Hallo,

im ersten Artikel dieses Thread steht jetzt die Version 0.3 des Plugin zum Download bereit mit folgenden Erweiterungen:

- Unterstützung für den neuen DF10CH Atmolight Controller

- Es gibt jetzt neben top,bottom,left,right die neuen Sektionen center,topLeft,topRight,bottomLeft,bottomRight

- Der neue Center-Kanal wird jetzt auch bei dem "classic" Kontroller ausgegeben

- Die Ausgabe der Daten an die Controller erfolgt jetzt erst um 1 sec. verzögert wenn ein neuer Stream startet. Das sorgt für weniger Flackerei beim umschalten der TV-Kanäle sowie für dunkle LED's beim "NoSignal" Standbild.

- Unterstützung zum direkten bauen von debian Paketen. Vielen dank für die Vorlage dafür an das "the-vdr-team"

Viel Spass damit!

Gruss
durchflieger
Server: Asus M3N-H/HDMI, AMD X2 5600+, 4GB RAM, 500GB+1,5TB Samsung HD, 2xTevii S470, 1xTT-S3200, Ubuntu/V12.04, vdr 1.7.27
Client1: ZOTAC ION-ITX B, 2GB RAM, Diskless/Netboot per PXE, Xubuntu/V12.04, vdr 1.7.27+softhddevice, XBMC V12.1, LG42LC2R LCD-TV
Client2: Wie 1 aber ZOTAC ION-ITX E , DFAtmo, 2xDF10CH 19 Kanal Atmolight, LG37LC2R LCD-TV


64

Sunday, February 7th 2010, 10:01am

RE: Probleme beim Beenden von xine(-liboutput)

Quoted

Original von Saxman2k
*push*

Bin ich wirklich der einzige mit dem Problem?

[edit]
Anscheinend gibt es ein Problem, wenn xine mit dem Parameter "-V vdpau" gestartet wird. Sobald ich den weglasse kann sich xine auch normal beenden. Also lass ich den einfach weg und vdpau wird über die config automatisch ausgewählt. Aber ist schon seltsam...


Ich glaube dein Problem ist bei den Tests zur Version 0.3 bei mir auch aufgetreten. Irgendwie kamen nicht alle erwarteten Log-Meldungen beim beenden.
Werde mir das in den nächsten Tagen mal näher anschauen.

Gruss
durchflieger
Server: Asus M3N-H/HDMI, AMD X2 5600+, 4GB RAM, 500GB+1,5TB Samsung HD, 2xTevii S470, 1xTT-S3200, Ubuntu/V12.04, vdr 1.7.27
Client1: ZOTAC ION-ITX B, 2GB RAM, Diskless/Netboot per PXE, Xubuntu/V12.04, vdr 1.7.27+softhddevice, XBMC V12.1, LG42LC2R LCD-TV
Client2: Wie 1 aber ZOTAC ION-ITX E , DFAtmo, 2xDF10CH 19 Kanal Atmolight, LG37LC2R LCD-TV


65

Sunday, February 7th 2010, 5:02pm

RE: Probleme beim Beenden von xine(-liboutput)

Mittlerweile bin ich total verwirrt, was das Problem angeht. :schiel
Denn gestern trat es schon wieder auf. Sogar ohne den -V Parameter. Scheint also doch an irgendwas anderem zu liegen. Ich kann sogar nicht mehr mit Bestimmtheit sagen, daß Dein Post-Plugin die Ursache ist. Ich meine, daß gestern auch ohne das atmo hin und wieder xine hängen blieb. Das muß ich aber nochmal genauer untersuchen.

Hast Du vielleicht Tipps zum Debuggen?
Hardware: Gigabyte GA-970A-D3, AMD Athlon II X2 235e, 4GB RAM, Zotac GeForce 210 Synergy Edition 1GB, Corsair Force3 60GB SSD, Mystique SaTiX-S2 Dual, 6.4" TFT, Atric IR Einschalter Rev.5, Logitech Harmony 900, Samsung LE46A789 full HD LCD, Denon AVR-1910, USB Atmo-Light von Slime
Software: yaVDR 0.5
Streaming Client 1: Hauppauge MediaMVP
Streaming Client 2: Telegant TG100 (wenn ich mal irgendwann die Zeit finde das UPnP-Plugin zu testen)

66

Monday, February 8th 2010, 10:36pm

Projektumzug

Hallo,

Das Projekt hat jetzt ein neues Zuhause auf vdr-devloper.org gefunden. Die Downloads sowie ein git Repository stehen ab jetzt hier zur Verfügung: xine-lib-atmolight

Gruss
durchflieger
Server: Asus M3N-H/HDMI, AMD X2 5600+, 4GB RAM, 500GB+1,5TB Samsung HD, 2xTevii S470, 1xTT-S3200, Ubuntu/V12.04, vdr 1.7.27
Client1: ZOTAC ION-ITX B, 2GB RAM, Diskless/Netboot per PXE, Xubuntu/V12.04, vdr 1.7.27+softhddevice, XBMC V12.1, LG42LC2R LCD-TV
Client2: Wie 1 aber ZOTAC ION-ITX E , DFAtmo, 2xDF10CH 19 Kanal Atmolight, LG37LC2R LCD-TV


67

Thursday, February 11th 2010, 11:15am

Atmo Parameter

Hallo,

habe bei mir nun erfolgreich dein natives Atmo Xine Plugin zum laufen gebracht. Funktioniert soweit ganz gut, doch leider verwirrt mich die Readme noch etwas.
Wie müssen weitere Parameter wie Linker und rechter Kanal, sowie weißabgleich (Farben stimmen noch net wirklich) angegeben werden.
Danke für deine Info schonmal im Voraus...

MFG

68

Thursday, February 11th 2010, 12:20pm

RE: Atmo Parameter

Quoted

Original von jamju
Hallo,

habe bei mir nun erfolgreich dein natives Atmo Xine Plugin zum laufen gebracht. Funktioniert soweit ganz gut, doch leider verwirrt mich die Readme noch etwas.
Wie müssen weitere Parameter wie Linker und rechter Kanal, sowie weißabgleich (Farben stimmen noch net wirklich) angegeben werden.
Danke für deine Info schonmal im Voraus...

MFG


in dem du beim Aufruf des xine player Kommandozeilenparameter mit gibts:

Source code

1
--post=atmo:driver=classic,driver_param=/dev/ttyS0,top=1,bottom=1,left=1,right=1,center=1
Server: Asus M3N-H/HDMI, AMD X2 5600+, 4GB RAM, 500GB+1,5TB Samsung HD, 2xTevii S470, 1xTT-S3200, Ubuntu/V12.04, vdr 1.7.27
Client1: ZOTAC ION-ITX B, 2GB RAM, Diskless/Netboot per PXE, Xubuntu/V12.04, vdr 1.7.27+softhddevice, XBMC V12.1, LG42LC2R LCD-TV
Client2: Wie 1 aber ZOTAC ION-ITX E , DFAtmo, 2xDF10CH 19 Kanal Atmolight, LG37LC2R LCD-TV


69

Thursday, February 11th 2010, 6:21pm

Atmo

Guten abend,

@durchflieger Danke für die Hilfe hat prima geklappt...

Nur leider habe ich jetzt das Problem, dass statt der schwarzen Farbe --> Weiß angezeigt wird. Habe schon das darkness_limit und brightness... probiert, hat aber nix gebracht:(

Hat jemand eine Lösung für dieses Problem...?

Danke

70

Thursday, February 11th 2010, 11:04pm

RE: Atmo

Quoted

Original von jamju
Guten abend,

@durchflieger Danke für die Hilfe hat prima geklappt...

Nur leider habe ich jetzt das Problem, dass statt der schwarzen Farbe --> Weiß angezeigt wird. Habe schon das darkness_limit und brightness... probiert, hat aber nix gebracht:(

Hat jemand eine Lösung für dieses Problem...?

Danke


Ja ich habe eine Lösung! Dass ist die neue Version 0.4 die jetzt zum Download bereit steht.

Das Problem hat schon mal jemand anderes in diesem Thread vor längerer Zeit gemeldet.

Endlich bin ich jetzt selber dank einer neuen Testumgebung (mit df10ch) mal in der Lage diesen Fehlern nachzugehen.

Der Fehler lag in den Berechnung der mittleren Helligkeit und ist eigentlich schon ziemlich schwerwiegend.
Mit dieser Fehlerkorrektur ist bei mir auch dass ab und zu auftretene "blitzen" verschwunden das hier im Thread ja auch schon erwähnt wurde.

Den Standardwert für das darkness limit habe ich von 50 auf 10 geändert. Damit bekomme ich bei mir eine sichere Schwarzwerterkennung.
Mit dieser Version solltet ihr eure evt. krummen Einstellungen für brighness und darkness limit aufgrund des Fehlers erstmal wieder auf standard Werte setzen.
Bei mir steht brightness jetzt auf 120 womit ich eine gute Helligkeit ohne Übersteuerung erhalte.

Bin auf euer Feedback gespannt...

Gruss
durchflieger
Server: Asus M3N-H/HDMI, AMD X2 5600+, 4GB RAM, 500GB+1,5TB Samsung HD, 2xTevii S470, 1xTT-S3200, Ubuntu/V12.04, vdr 1.7.27
Client1: ZOTAC ION-ITX B, 2GB RAM, Diskless/Netboot per PXE, Xubuntu/V12.04, vdr 1.7.27+softhddevice, XBMC V12.1, LG42LC2R LCD-TV
Client2: Wie 1 aber ZOTAC ION-ITX E , DFAtmo, 2xDF10CH 19 Kanal Atmolight, LG37LC2R LCD-TV

This post has been edited 2 times, last edit by "durchflieger" (Feb 11th 2010, 11:06pm)


mapovi

Intermediate

Posts: 406

Location: Köln

  • Send private message

71

Saturday, February 27th 2010, 2:13pm

RE: Atmo

Ich nutze seit einiger Zeit auch das Atmo POST Plugin. (Danke an durchflieger :) ) Jetzt möchte ich auf die neue xinelib umsteigen. Dafür ist der Vdpau extension Patch nicht mehr notwendig/vorhanden. Wie habt ihr das gelöst? Gibt es den Extension-Patch auch für die neue xinelib (ich habe nichts gefunden)? Ohne die GRAB Funktion kompiliert das POST Plugin ja nicht.

EDIT: Sorry, habe es gefunden:
Extensionspatch für xine-lib
2.6.29-gentoo-r5, vdr-1.7.9, xine-vdpau-284, vdr-xine 0.93 - 5050e, M3A78-EM, Postville, 2xTTS21600
PearlHD text2skin

This post has been edited 1 times, last edit by "mapovi" (Feb 27th 2010, 3:07pm)


72

Wednesday, March 10th 2010, 10:24pm

Neue Version 0.5 released

Hallo,

auf vdr-developers steht die Version 0.5 zum download bereit.

Aus der HISTORY:

Added storage of actual plugin parameters into xine configuration key 'post.atmo.parameters'.
Added support for 'on the fly' parameter changes.
Added 'start_delay' plugin parameter for individual adjustment of start delay after start of new stream.
Changed start delay default from 1000ms to 250ms
Added 'enable' plugin parameter for switching the atmolight on/off on the fly.
DF10CH configuration parameters are now mandatory.
Improved calculation of weights for border area
Improved calculation of average brightness
Add support for DF10CH config version 2 (overscan, edge weighting, analyze size are now read from controller)
Improved DF10CH driver error logging
Added 'hue_threshold' parameter.
Modify 'edge weighting' parameter. Value is now divided by 10 to reach more fine control
Changed 'edge weighting' default from 80 to 60
Changed 'darkness limit' default from 10 to 1

Mehr Informationen zu den Erweiterungen findet Ihr in der README-Datei.

Gruss
durchflieger
Server: Asus M3N-H/HDMI, AMD X2 5600+, 4GB RAM, 500GB+1,5TB Samsung HD, 2xTevii S470, 1xTT-S3200, Ubuntu/V12.04, vdr 1.7.27
Client1: ZOTAC ION-ITX B, 2GB RAM, Diskless/Netboot per PXE, Xubuntu/V12.04, vdr 1.7.27+softhddevice, XBMC V12.1, LG42LC2R LCD-TV
Client2: Wie 1 aber ZOTAC ION-ITX E , DFAtmo, 2xDF10CH 19 Kanal Atmolight, LG37LC2R LCD-TV


73

Thursday, March 11th 2010, 10:37am

RE: Neue Version 0.5 released

Hallo,

nochmal ein Hinweis bezüglich des "overscan" Parameter des Plugin:
Vermutlich werden hier viele Ihren LCD-TV mit nativer Displayauflösung betreiben so dass der TV selber keinen Overscan mehr durchführt. In diesem Fall solltet Ihr das Parameter overscan auch auf 0 setzen.

Falls Ihr euch nicht sicher seit was euer TV macht, könnt Ihr auch das DF10CH Setup-Program einsetzen um den optimalen Wert für den overscan (und weitere) zu bestimmen. Eine Anleitung dazu findet Ihr hier:
VDR-Wiki

Gruss
durchflieger
Server: Asus M3N-H/HDMI, AMD X2 5600+, 4GB RAM, 500GB+1,5TB Samsung HD, 2xTevii S470, 1xTT-S3200, Ubuntu/V12.04, vdr 1.7.27
Client1: ZOTAC ION-ITX B, 2GB RAM, Diskless/Netboot per PXE, Xubuntu/V12.04, vdr 1.7.27+softhddevice, XBMC V12.1, LG42LC2R LCD-TV
Client2: Wie 1 aber ZOTAC ION-ITX E , DFAtmo, 2xDF10CH 19 Kanal Atmolight, LG37LC2R LCD-TV


74

Monday, March 22nd 2010, 5:27pm

Hallo,

erstmal möchte ich mich herzlich bedanken - mein Atmolight läuft wieder ;)

Nun habe ich aber das Gefühl (das Atmo lag lange funktionslos rum), dass die Helligkeit nicht mehr so hoch ist, wie früher (da hatte ich die 300 nichtmal ausgenutzt).
Jetzt übergebe ich den brightness=300 Parameter und meine, dass es immer noch zu dunkel ist, kann das jemand bestätigen oder entkräften?
Ich benutze einen "Slime"-Controller mit Ikea-Dioderstreifen.

MfG
Stubi
VDR: yaVDR 0.5, Asus P5N7A-VN, Intel Pentium E2220, 2GB, 1x Satelco Easywatch DVB-C, 1x DD Cine C/T, NVIDIA GT-610

75

Monday, March 22nd 2010, 5:40pm

Oh Mann, Kommando zurück.
Wer zu dämlich ist, brightness richtig zu schreiben, hat es auch nicht verdient, dass das Atmolight hell genug ist...

MfG
Stubi
VDR: yaVDR 0.5, Asus P5N7A-VN, Intel Pentium E2220, 2GB, 1x Satelco Easywatch DVB-C, 1x DD Cine C/T, NVIDIA GT-610

DrBoon

Intermediate

Posts: 409

Location: de/bayern/hof

Occupation: Systemintegrator

  • Send private message

76

Tuesday, April 13th 2010, 2:14am

und noch ne dumme Fragel:

Gibt es eine Möglichkeit per kommandozeile das postplugin Atmo "stumm"=aus und wieder einzuschalten, ohne xine neu zu starten? Also quasi im laufenden Betrieb?

Oder halt dem Controller mitzuteilen, das er mal pause machen soll.


Grüße
VDR1.7.12 + ExtPatch on openSuSE 11.1 2.6.27.45-0.1-default (x86_64) gcc 4.3.2 r141291
1xNexus (fw:f12623) ** 3xTeVii S650 ** Alphacrypt/SKY ** DVB-Treiber 7.6.09cvs ** 7" GraphTFT ** VOMP on MediaMVP ** zendeb 0.4.0.b1 on S100 ** 4ch Atmolight
Xine-lib-1.2 20100412(vdpau) +DFextPatch ** XINE-UI ** Nvidia GT240 (260.19.36) ** Samsung LE46C650 ** istreamdev-git_20110216 to IPhone

77

Tuesday, April 13th 2010, 9:31am

Quoted

Originally posted by DrBoon
und noch ne dumme Fragel:

Gibt es eine Möglichkeit per kommandozeile das postplugin Atmo "stumm"=aus und wieder einzuschalten, ohne xine neu zu starten? Also quasi im laufenden Betrieb?

Oder halt dem Controller mitzuteilen, das er mal pause machen soll.


Grüße

Per Komandozeile geht das nicht. Im xine-ui player geht es per Mousebedienung (siehe README)

Gruss
durchflieger
Server: Asus M3N-H/HDMI, AMD X2 5600+, 4GB RAM, 500GB+1,5TB Samsung HD, 2xTevii S470, 1xTT-S3200, Ubuntu/V12.04, vdr 1.7.27
Client1: ZOTAC ION-ITX B, 2GB RAM, Diskless/Netboot per PXE, Xubuntu/V12.04, vdr 1.7.27+softhddevice, XBMC V12.1, LG42LC2R LCD-TV
Client2: Wie 1 aber ZOTAC ION-ITX E , DFAtmo, 2xDF10CH 19 Kanal Atmolight, LG37LC2R LCD-TV


DrBoon

Intermediate

Posts: 409

Location: de/bayern/hof

Occupation: Systemintegrator

  • Send private message

78

Tuesday, April 13th 2010, 9:47am

Klar, nur hab ich am VDR keine Maus, und will auch kein GUI auf dem TV ( dann isses ja kein htpc mehr, sondern ne Workstation auf der man auch tv gucken kann ) :)


Mein Problem ist folgendes:

Mein VDR läuft 24/7 durch, da der Server auch andere Aufgaben miterledigt, lediglich die Anlage und der TV werden stromfrei gemacht wenn keiner davor sitzt.
Nun will ich den TV um Atmo erweitern, hab aber ja jetzt das Problem das die RGB-Leds weiterhin befeuert werden würden, da ja Xine weiterhin daten dahin schickt. ( Also alles dunkel im Wohnzimmer, aber Atmolight feuert bunte Farben an die Wand. ).
Wenn ich den Controller auch stromfrei mache, ist zwar das Atmo-licht aus, aber die Schnittstelle verschwindet -> wird wohl ein xine- und damit auch ein vdr-crash. selbst wenn nicht ist das anstecken im Betrieb wohl auch eher unzuverlässig.

Hast du hierzu ne Idee?

PS: Würde sowas wie ne Repeater-Fifo das problem zur not fixen? ( xine->pipe->usb? ) oder wäre das keine Option?
Mit Pipe mein ich einfach ein Programm das per fifo die datenpakete vom atmo-plugin entgegennimmt, und wenn es den "aus"-befehl bekommt einfach nicht weitergibt bzw. "stumm"-pakete schickt. Ich hoff du verstehst was ich mein.
VDR1.7.12 + ExtPatch on openSuSE 11.1 2.6.27.45-0.1-default (x86_64) gcc 4.3.2 r141291
1xNexus (fw:f12623) ** 3xTeVii S650 ** Alphacrypt/SKY ** DVB-Treiber 7.6.09cvs ** 7" GraphTFT ** VOMP on MediaMVP ** zendeb 0.4.0.b1 on S100 ** 4ch Atmolight
Xine-lib-1.2 20100412(vdpau) +DFextPatch ** XINE-UI ** Nvidia GT240 (260.19.36) ** Samsung LE46C650 ** istreamdev-git_20110216 to IPhone

This post has been edited 1 times, last edit by "DrBoon" (Apr 13th 2010, 9:51am)


79

Tuesday, April 13th 2010, 10:00am

Quoted

Originally posted by DrBoon
Klar, nur hab ich am VDR keine Maus, und will auch kein GUI auf dem TV ( dann isses ja kein htpc mehr, sondern ne Workstation auf der man auch tv gucken kann ) :)


Mein Problem ist folgendes:

Mein VDR läuft 24/7 durch, da der Server auch andere Aufgaben miterledigt, lediglich die Anlage und der TV werden stromfrei gemacht wenn keiner davor sitzt.
Nun will ich den TV um Atmo erweitern, hab aber ja jetzt das Problem das die RGB-Leds weiterhin befeuert werden würden, da ja Xine weiterhin daten dahin schickt. ( Also alles dunkel im Wohnzimmer, aber Atmolight feuert bunte Farben an die Wand. ).
Wenn ich den Controller auch stromfrei mache, ist zwar das Atmo-licht aus, aber die Schnittstelle verschwindet -> wird wohl ein xine- und damit auch ein vdr-crash. selbst wenn nicht ist das anstecken im Betrieb wohl auch eher unzuverlässig.

Hast du hierzu ne Idee?

PS: Würde sowas wie ne Repeater-Fifo das problem zur not fixen? ( xine->pipe->usb? ) oder wäre das keine Option?
Mit Pipe mein ich einfach ein Programm das per fifo die datenpakete vom atmo-plugin entgegennimmt, und wenn es den "aus"-befehl bekommt einfach nicht weitergibt bzw. "stumm"-pakete schickt. Ich hoff du verstehst was ich mein.

Dazu fällt mir folgendes ein:
1. Wenn du sowieso ein Kommando am VDR abschicken willst wieso beendest du dann nicht einfach den xine player. Würde auch noch Strom am Rechner sparen.
2. Falls du planst den DF10CH Kontroller zu verwenden dann ist das ganz einfach. Hier bekommen Kontroller und LED's ihren Strom sowieso aus zwei getrennten Kreisen. Der Kontroller über USB, also deinem Rechner der ja durchläuft. Die LED's per separaten Netzteil. Das kannst du problemlos stromlos machen.

Gruss
durchflieger
Server: Asus M3N-H/HDMI, AMD X2 5600+, 4GB RAM, 500GB+1,5TB Samsung HD, 2xTevii S470, 1xTT-S3200, Ubuntu/V12.04, vdr 1.7.27
Client1: ZOTAC ION-ITX B, 2GB RAM, Diskless/Netboot per PXE, Xubuntu/V12.04, vdr 1.7.27+softhddevice, XBMC V12.1, LG42LC2R LCD-TV
Client2: Wie 1 aber ZOTAC ION-ITX E , DFAtmo, 2xDF10CH 19 Kanal Atmolight, LG37LC2R LCD-TV


DrBoon

Intermediate

Posts: 409

Location: de/bayern/hof

Occupation: Systemintegrator

  • Send private message

80

Tuesday, April 13th 2010, 10:22am

Quoted

2. Falls du planst den DF10CH Kontroller zu verwenden dann ist das ganz einfach. Hier bekommen Kontroller und LED's ihren Strom sowieso aus zwei getrennten Kreisen. Der Kontroller über USB, also deinem Rechner der ja durchläuft. Die LED's per separaten Netzteil. Das kannst du problemlos stromlos machen.

^^ Ich plan das zwar für "irgendwann in der Zukunft", gönn aber meinem VDR jetzt auf die schnelle mal nen 4Kanal. Mal sehen sobald man den DF10CH sammt Leisten dann auch irgendwo leistbar bestellen kann ( Für's selbserbauen bin ich leider zu ungeschickt ).

Quoted

1. Wenn du sowieso ein Kommando am VDR abschicken willst wieso beendest du dann nicht einfach den xine player. Würde auch noch Strom am Rechner sparen.

^^ mit dem Gedanken hatte ich auch schon gespielt... hatte aber damals beim Versuch öfter das Problem, das nach dem X'ten start des X-Servers der TV "BLAU" bleibt bis man den Rechner neu startet. ( keine ahnung, hab den Fehler nie gefunden. )
VDR1.7.12 + ExtPatch on openSuSE 11.1 2.6.27.45-0.1-default (x86_64) gcc 4.3.2 r141291
1xNexus (fw:f12623) ** 3xTeVii S650 ** Alphacrypt/SKY ** DVB-Treiber 7.6.09cvs ** 7" GraphTFT ** VOMP on MediaMVP ** zendeb 0.4.0.b1 on S100 ** 4ch Atmolight
Xine-lib-1.2 20100412(vdpau) +DFextPatch ** XINE-UI ** Nvidia GT240 (260.19.36) ** Samsung LE46C650 ** istreamdev-git_20110216 to IPhone