You are not logged in.

Dear visitor, welcome to VDR Portal. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

horchi

Professional

  • "horchi" started this thread

Posts: 1,616

Location: Friedberg Hessen

  • Send private message

81

Saturday, November 1st 2008, 12:41pm

Quoted

Original von brabax22
Ich hatte im themes-Verzeichnis zusätzlich zu den beiden Verzeichnissen nur die *.bz2 der beiden Themes liegen... Die habe ich jetzt gelöscht und es scheint was gebracht zu haben ;-)


Die bz2 Files werden vom Plugin nicht gelesen, dann war es etwas anderes.

horchi

meine VDRs

Bastel VDR - Kubuntu Natty mit yaVDR 0.5 (testing) Paketen, Intel Core2 Quad (Q6600) 2.40GHz, 4GB Ram,
Wohnzimmer VDR - yaVDR 0.5 (testing) mit softhddevice, Cine S2, Athlon II X2 240e, 4GB Ram, 64GB SSD, INTEL IRC, 2TB NFS und einer Harmony 700

Entwicklungen:
ipod - graphtft - pin - seduatmo - epgd - epg2vdr - squeezebox


brabax22

Intermediate

Posts: 234

Location: Leipzig

  • Send private message

82

Saturday, November 1st 2008, 1:25pm

Quoted

Original von data
in welchem Theme und bei welcher Anzeige (Standard Kanalansicht oder vielleicht music oder Menü)?

Sowohl im Deepblue als auch im AVP-Theme, Standard-Anzeige. Jeweils ein relativ schmaler orangener Balken bei "svdrpsend MESG xyz".

data

Intermediate

Posts: 360

Location: Stadt Dorfen / Bayern

  • Send private message

83

Saturday, November 1st 2008, 1:33pm

Hi brabax22,

oranger Balken ist klar - nur sollte da die Message (xyz) drin sein. Ist sie jedenfalls bei mir.
Was hast Du denn für eine graphTFT Auflösung?

@horchi:
Wird die Message event.weg skalliert?

gruß
data
VDR: easyVDR 0.8.0 - VDR 1.7.0
CPU: Athlon 4850e; MB: Gigabyte GA-MA78GM-S2H; RAM: 2 GB DDR2; HDD: 2TB SATA; DVD-Brenner; DVB-C: Hauppauge WinTV DVB-C 4MB Mod; STB AVBoard 1.3; Case: Thermaltake DH 202

horchi

Professional

  • "horchi" started this thread

Posts: 1,616

Location: Friedberg Hessen

  • Send private message

84

Saturday, November 1st 2008, 1:34pm

Quoted

Original von data
Hi brabax22,

oranger Balken ist klar - nur sollte da die Message (xyz) drin sein. Ist sie jedenfalls bei mir.
Was hast Du denn für eine graphTFT Auflösung?

@horchi:
Wird die Message event.weg skalliert?

gruß
data


unwahrscheinlich, ein Screenshot könnte helfen

Grüße
horchi

meine VDRs

Bastel VDR - Kubuntu Natty mit yaVDR 0.5 (testing) Paketen, Intel Core2 Quad (Q6600) 2.40GHz, 4GB Ram,
Wohnzimmer VDR - yaVDR 0.5 (testing) mit softhddevice, Cine S2, Athlon II X2 240e, 4GB Ram, 64GB SSD, INTEL IRC, 2TB NFS und einer Harmony 700

Entwicklungen:
ipod - graphtft - pin - seduatmo - epgd - epg2vdr - squeezebox


googles

Professional

Posts: 1,025

Location: Österreich

Occupation: Elektriker

  • Send private message

85

Saturday, November 1st 2008, 1:44pm

RE: [ANNOUNCE] graphtft 0.2.1

Quoted

Originally posted by horchi

Quoted

Original von googles
Hallo
habe grad diese version getestet gefällt mir sehr gut.
Aber ein bug ist mir noch aufgefallen war aber auch schon in vorherigen versionen.
Das display zeigt nicht immer die aktuellen Informationen, wenn z.b. eine Aufnahme auf der primären karte startet stehen im display die Informationen zu diesem Sender der VDR Läuft aber auf einen anderen Sender oder im Wiedergabe modus.

mfg Thomas


Hi,

ich hatte diesen Effekt bislang noch nicht.
Aktualisiert sich die Anzeige wieder richtig wenn du umschaltest?

Ich habe auch keine Idee wie ich im Plugin darauf Einfluss nehmen kann. Das Plugin verwendet die OSD Methoden der VDR Status Schnittstelle, was da rüberkommt wird für die Anzeige aufbereitet. Ggf. werden diese in der von dir beschriebenen Situation mit den Daten der 'anderen' Karte aufgerufen (nur eine Vermutung).

Grüße
horchi


Hallo
Ich verwende eine FF als ausgabe device mit VDR1.6.0-2 und die FF verursacht das Problem glaube ich denn wenn die karte auf einen kanal schaltet egal ob streaming client oder aufnahme dann ändert sich die anzeige im display unabhängig davon was vorher angezeigt wurde wenn ich wieder umschalte passt die anzeige wieder. Ich glaube mit VDR 1.4.7 hatte ich dieses Problem noch nicht.

mfg Thomas
VDR:
Hardware: Thermaltake DH102, Zotac ION ITX-F-E, 2Gig Ram, TechnoTrend
dual DVB-S2 6400, TechnoTrend Connect CT-3650,

Software: EasyVDR 1.0

brabax22

Intermediate

Posts: 234

Location: Leipzig

  • Send private message

86

Saturday, November 1st 2008, 1:45pm

Quoted

Original von data
Hi brabax22,

oranger Balken ist klar - nur sollte da die Message (xyz) drin sein. Ist sie jedenfalls bei mir.
Was hast Du denn für eine graphTFT Auflösung?


Die Auflösung ist 800x600, Screenshot anbei (da sieht man auch man ein paar Refresh-Fehler am Rand).

(Screenshot aktualisiert)
brabax22 has attached the following image:
  • graphTFT.jpg

This post has been edited 2 times, last edit by "brabax22" (Nov 1st 2008, 1:49pm)


data

Intermediate

Posts: 360

Location: Stadt Dorfen / Bayern

  • Send private message

87

Saturday, November 1st 2008, 1:50pm

Hi brabax22,
das hab ich auch noch nicht gesehen.
Sind event. die Einstellungen für 800x600 und die entsprechenden Seitenränder im garphTFT Setup nicht richtig gesetzt??

gruß
data
VDR: easyVDR 0.8.0 - VDR 1.7.0
CPU: Athlon 4850e; MB: Gigabyte GA-MA78GM-S2H; RAM: 2 GB DDR2; HDD: 2TB SATA; DVD-Brenner; DVB-C: Hauppauge WinTV DVB-C 4MB Mod; STB AVBoard 1.3; Case: Thermaltake DH 202

brabax22

Intermediate

Posts: 234

Location: Leipzig

  • Send private message

88

Saturday, November 1st 2008, 1:53pm

Quoted

Original von data
Hi brabax22,
das hab ich auch noch nicht gesehen.
Sind event. die Einstellungen für 800x600 und die entsprechenden Seitenränder im garphTFT Setup nicht richtig gesetzt??

gruß
data
Denke schon:
brabax22 has attached the following image:
  • graphTFT.jpg

data

Intermediate

Posts: 360

Location: Stadt Dorfen / Bayern

  • Send private message

89

Saturday, November 1st 2008, 1:56pm

Hi brabax22,

setz doch mal die Border to... auf 0.

gruß
data
VDR: easyVDR 0.8.0 - VDR 1.7.0
CPU: Athlon 4850e; MB: Gigabyte GA-MA78GM-S2H; RAM: 2 GB DDR2; HDD: 2TB SATA; DVD-Brenner; DVB-C: Hauppauge WinTV DVB-C 4MB Mod; STB AVBoard 1.3; Case: Thermaltake DH 202

brabax22

Intermediate

Posts: 234

Location: Leipzig

  • Send private message

90

Saturday, November 1st 2008, 2:00pm

Quoted

setz doch mal die Border to... auf 0.

Hat nix gebracht. Im Screenshot siehts - bis auf den Balken ohne Text - normal aus, allerdings fehlt mir jetzt auf dem Display rechts ein Teil des Inhalts.

This post has been edited 1 times, last edit by "brabax22" (Nov 1st 2008, 2:00pm)


horchi

Professional

  • "horchi" started this thread

Posts: 1,616

Location: Friedberg Hessen

  • Send private message

91

Saturday, November 1st 2008, 2:19pm

Hi,

du hat ein 600x800er Display?

Grüße
horchi

meine VDRs

Bastel VDR - Kubuntu Natty mit yaVDR 0.5 (testing) Paketen, Intel Core2 Quad (Q6600) 2.40GHz, 4GB Ram,
Wohnzimmer VDR - yaVDR 0.5 (testing) mit softhddevice, Cine S2, Athlon II X2 240e, 4GB Ram, 64GB SSD, INTEL IRC, 2TB NFS und einer Harmony 700

Entwicklungen:
ipod - graphtft - pin - seduatmo - epgd - epg2vdr - squeezebox


brabax22

Intermediate

Posts: 234

Location: Leipzig

  • Send private message

92

Saturday, November 1st 2008, 2:21pm

Quoted

Original von horchi
Hi,

du hat ein 600x800er Display?

Grüße
horchi

Nein, ein 800x600 - zumindest ist so die FB-Einstellung.

horchi

Professional

  • "horchi" started this thread

Posts: 1,616

Location: Friedberg Hessen

  • Send private message

93

Saturday, November 1st 2008, 2:23pm

sorry, meinte ich auch ;)

meine VDRs

Bastel VDR - Kubuntu Natty mit yaVDR 0.5 (testing) Paketen, Intel Core2 Quad (Q6600) 2.40GHz, 4GB Ram,
Wohnzimmer VDR - yaVDR 0.5 (testing) mit softhddevice, Cine S2, Athlon II X2 240e, 4GB Ram, 64GB SSD, INTEL IRC, 2TB NFS und einer Harmony 700

Entwicklungen:
ipod - graphtft - pin - seduatmo - epgd - epg2vdr - squeezebox


horchi

Professional

  • "horchi" started this thread

Posts: 1,616

Location: Friedberg Hessen

  • Send private message

94

Saturday, November 1st 2008, 2:28pm

Quoted

Original von brabax22

Quoted

setz doch mal die Border to... auf 0.

Hat nix gebracht. Im Screenshot siehts - bis auf den Balken ohne Text - normal aus, allerdings fehlt mir jetzt auf dem Display rechts ein Teil des Inhalts.


Ok, dann ist der komische Rand nun weg? Wenn ja kannst du mit den BorderTo und den Offset-Einstellungen nochmal rumspielen bis es passt und auch rechts nichts mehr fehlt. ich habe das bei meinem Display alles auf 0, ggf. reagiert der FB für dein Display oder die HW anders ...

Das die OSD Messages fehlen hat m.E. damit nichts zu tun. Da sich an dem Aufbau der OSD-Message im neuen Release (sicher noch heute) eh was ändert würde ich das gen noch abwarten bevor wir auf die Suche gehen.

Grüße
horchi

meine VDRs

Bastel VDR - Kubuntu Natty mit yaVDR 0.5 (testing) Paketen, Intel Core2 Quad (Q6600) 2.40GHz, 4GB Ram,
Wohnzimmer VDR - yaVDR 0.5 (testing) mit softhddevice, Cine S2, Athlon II X2 240e, 4GB Ram, 64GB SSD, INTEL IRC, 2TB NFS und einer Harmony 700

Entwicklungen:
ipod - graphtft - pin - seduatmo - epgd - epg2vdr - squeezebox


brabax22

Intermediate

Posts: 234

Location: Leipzig

  • Send private message

95

Saturday, November 1st 2008, 2:35pm

Quoted

Original von horchi
Ok, dann ist der komische Rand nun weg?

Der Rand ist weg, weil ich zur Sicherheit vdr zwischendurch noch einmal neu gestartet habe...

Quoted

Original von horchi
Das die OSD Messages fehlen hat m.E. damit nichts zu tun. Da sich an dem Aufbau der OSD-Message im neuen Release (sicher noch heute) eh was ändert würde ich das gen noch abwarten bevor wir auf die Suche gehen

Dann warte ich mal ;-)

brabax22

Intermediate

Posts: 234

Location: Leipzig

  • Send private message

96

Saturday, November 1st 2008, 2:44pm

Anbei noch ein Beispiel (per Handy, weil der eigene Screenshot war ok!) von den Refresh-Problemen:
brabax22 has attached the following image:
  • IMAG0005.jpg

data

Intermediate

Posts: 360

Location: Stadt Dorfen / Bayern

  • Send private message

97

Saturday, November 1st 2008, 2:55pm

Hi barbax22,

ich habe auch das DH-102 Gehäuse und somit das gleiche Display, was bei mir keine Probleme macht.
Das einfachste wird sein, Du wartest auf die nächste graphtft Version. Zu der wird es dann auch gleich neue DeepBlue und AvP Themes geben.
Vor dem Einspielen der neuen Themes bitte alles unter /etc/vdr/plugins/graphTFT/themes löschen.

Meine Einstellungen im graphTFT Plugin sind folgende:

Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
grep graphtft /etc/vdr/setup.conf

graphtft.DumpImage = 1
graphtft.DumpImageX = 800
graphtft.DumpImageY = 600
graphtft.DumpRefresh = 5
graphtft.DvbRefresh = 100
graphtft.flipOSD = 0
graphtft.Height = 600
graphtft.HideMainMenu = 0
graphtft.Iso2Utf = 1
graphtft.JpegQuality = 90
graphtft.Level = 3
graphtft.LogDevice = 0
graphtft.Logger = 0
graphtft.normalMode = Standard
graphtft.OSDMessageTime = 30
graphtft.OSDOffsetX = 50
graphtft.OSDOffsetY = 400
graphtft.ScrollCount = 0
graphtft.ScrollTime = 50
graphtft.ShowMutePermanent = 1
graphtft.snapshotHeight = 180
graphtft.snapshotPath = /tmp
graphtft.snapshotQuality = 90
graphtft.snapshotWidth = 240
graphtft.SpectrumAnalyzer = 1
graphtft.Theme = Alien vs. Predator
graphtft.UseStillPicture = 1
graphtft.VdrHeight = 5
graphtft.VdrWidht = 25
graphtft.VdrX = 0
graphtft.VdrY = 0
graphtft.ViewLength = 10
graphtft.ViewType = 0
graphtft.Width = 800
graphtft.XBorder = 0
graphtft.XOffset = 0
graphtft.YBorder = 0
graphtft.YOffset = 0

Dann sollte es auch gehen.

gruß
data
VDR: easyVDR 0.8.0 - VDR 1.7.0
CPU: Athlon 4850e; MB: Gigabyte GA-MA78GM-S2H; RAM: 2 GB DDR2; HDD: 2TB SATA; DVD-Brenner; DVB-C: Hauppauge WinTV DVB-C 4MB Mod; STB AVBoard 1.3; Case: Thermaltake DH 202

This post has been edited 1 times, last edit by "data" (Nov 1st 2008, 2:56pm)


98

Saturday, November 1st 2008, 4:02pm

Refresh-Probleme mit FB

Hallo zusammen,

ich kann brabax22' Probleme mit dem Refresh bei Nutzung eines FB-devices nachvollziehen.
Vorher habe ich 0.0.21 verwendet, da hatte ich bei gleichen Framebuffer-Einstellungen keine Probleme.

Gibt es jemand, bei dem die Ausgabe über FB reibungslos funktioniert?

Danke, viele Grüße
Matthias
VDR1: X2 245e | Gainward G210 | S2-3200 | openSuSE12.2 x64 | vdr-2.0.1 | nvidia 304.43 | softhddevice
VDR2: Celeron@2000 | Zotac GT610 PCI | S2-3200 | openSuSE12.3 x32 | vdr-2.0.1 | nvidia 304.43 | softhddevice
VDR3: A4850e | Zotac GT220 | S2-3200 | openSuSE12.2 x64 | vdr-2.0.1 | nvidia 304.43 | softhddevice

googles

Professional

Posts: 1,025

Location: Österreich

Occupation: Elektriker

  • Send private message

99

Saturday, November 1st 2008, 4:24pm

Hallo Horchi

Nochmals zu dem Problem mit der Kanal info.
Hab mir mal den source code angesehen und eine patch gebaut der nochmals den CurrentChannel überprüft damit solche Fehler wie bei mir ausgeschlossen sind.
Wäre super wenn du ihn einbaust.
mfg Thomas
googles has attached the following file:
VDR:
Hardware: Thermaltake DH102, Zotac ION ITX-F-E, 2Gig Ram, TechnoTrend
dual DVB-S2 6400, TechnoTrend Connect CT-3650,

Software: EasyVDR 1.0

horchi

Professional

  • "horchi" started this thread

Posts: 1,616

Location: Friedberg Hessen

  • Send private message

100

Saturday, November 1st 2008, 4:26pm

RE: Refresh-Probleme mit FB

Hi,

es gibt eine neue Version und, Dank data, auch angepasste und erweiterte Themes:

http://www.jwendel.de/vdr/vdr-graphtft-0.2.2.tar.bz2
http://www.jwendel.de/vdr/alien-vs-predator-0.0.11.tar.bz2
http://www.jwendel.de/vdr/DeepBlue-horchi-0.0.11.tar.bz2

Aus dem Changelog:

Source code

1
2
3
4
5
6
7
Version 0.2.2
      - bugfix: Fixed problem with empty events
      - added:  New format instruction 'tologo' for theme variables
      - change: Renamed svdrp command NORMALVIEW to VIEW (scripts/dia.sh ported)
      - bugfix: Fixed refresh of OSD message
      - change: Improved Makefile
      - added:  Warning if theme version does not match


Das makefile ist nun entsprechend Ronnys Vorschlag erweitert. Nun sollten die verfügbaren Libs automatisch gefunden werden. Ansonsten werden entspr. Warnungen ausgeben.

Grüße
horchi

meine VDRs

Bastel VDR - Kubuntu Natty mit yaVDR 0.5 (testing) Paketen, Intel Core2 Quad (Q6600) 2.40GHz, 4GB Ram,
Wohnzimmer VDR - yaVDR 0.5 (testing) mit softhddevice, Cine S2, Athlon II X2 240e, 4GB Ram, 64GB SSD, INTEL IRC, 2TB NFS und einer Harmony 700

Entwicklungen:
ipod - graphtft - pin - seduatmo - epgd - epg2vdr - squeezebox