You are not logged in.

Dear visitor, welcome to VDR Portal. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Monday, July 2nd 2007, 3:49pm

[gelöst] BURN brennt nicht

Hallo,

ich hab hier ein paar Schwierigkeiten mit dem Burn-Plugin. Aus dem dvd.log werde ich leider nicht schlau. Irgendwie scheint das Plugin kurz vor dem Brennen abzubrechen. Vielleicht hat jemand eine Idee?!
mj-crawl has attached the following file:
  • dvd.log.zip (13.45 kB - 96 times downloaded - latest: Mar 3rd 2014, 4:58pm)

This post has been edited 2 times, last edit by "mj-crawl" (Jul 2nd 2007, 7:30pm)


derTHOMMESisses

Intermediate

Posts: 197

Location: Münster

  • Send private message

2

Monday, July 2nd 2007, 3:52pm

Hi,

Quoted

Photo.iso: No such file or directory




Entweder ist das Directory tatsächlich nicht da oder die Schreib / Zugriffrechte (CHOWN) sind nicht richtig gesetzt.

Mit MidnightCommander (mc) kommst Du dahinter...

hilft das?


Besten Gruß,

thommes
kann nich jeder nen leisen videoflüsterer haben: VDR1: fette 19"fujitsu-pIII-Büro-Kiste mit lautem Netzteil, TT 1.5, 80GB HDD: VDR2: Standard-PC mit TT 1.6, 250 + 80 GB PATA-HDD und 2*340 GB-SATA-HDD; Celeron - auch laut.

3

Monday, July 2nd 2007, 4:05pm

Quoted

Original von derTHOMMESisses
Entweder ist das Directory tatsächlich nicht da oder die Schreib / Zugriffrechte (CHOWN) sind nicht richtig gesetzt.


Da gehts ja schon los.... In welches Verzeichniss will er die iso-Datei denn schreiben?!

Edit:

Das Problem scheint das fehlende IsoDir (='null') im Aufruf zu sein (in vdrburn.sh):

Source code

1
vdrburn.sh MKISO_BURN '/video0/.vdr-burn.3hwXMo' '/dev/dvd' '(null)' 'One Hour Photo' '/video0/.vdr-burn.3hwXMo/fifo'


Hat jemand eine Idee, wo ich die Variable setzen kann?

Bye!

This post has been edited 2 times, last edit by "mj-crawl" (Jul 2nd 2007, 4:30pm)


mblaster4711

Professional

Posts: 719

Location: Baden-Würtemberg

  • Send private message

4

Monday, July 2nd 2007, 4:32pm

RE: BURN brennt nicht

Ausgabe-Ordner werden über die Parameter definiert (ggf über das Setup):
http://www.vdr-wiki.de/wiki/index.php/Burn-plugin#Parameter

Du hast "Abblid erzeugen und Brennne" ausgewählt.

Das ISO erstellt er nicht wei ihm der ISO-Pfad fehlt (null).

Das mit dem Brennen habe ich auch immer dann, wenn ich Rohlinge verwende die die Brennerfirmware nicht kennt.

PS: infos zum verwendeten VDR und Plugin-Version wären auch sehr nützlich.
VDR1: FSC Esprimo P59xx, TT S-2300, TT S-1500, HD 4TB EasyVDR 0.6.10
VDR2: Lenevo ThinkCentre M55p, Core2Duo 1,8GHz, TT S-2300, HDD 160GB, DVD-RW EasyVDR 0.6.10
VDR3: Compaq Deskpro EN, PIII-800 , 256MB, TT S-2300, HDD 250GB, DVD-RW EasyVDR 0.6.10
VDR4: HP Compaq Evo d510, Celeron 2 GHz, 256MB, TT S-2300, HDD 250GB, DVD-RW EasyVDR 0.8.06
VDR5: HP Compaq Evo d510, Celeron 2 GHz, 256MB, TT S-2300, HDD 250GB, DVD-RW EasyVDR 0.6.10
* von 08.2007 bis 02.2010 auf altem VDR1 und altem VDR2: LinVDR0.7 mit Dr.Seltsam Kernel 2.6.20.1 & Toxic-Tonic VDR-1.4.7-ext34 :respekt

Zu meinen LinVDR HowTo's und Downloads

This post has been edited 1 times, last edit by "mblaster4711" (Jul 2nd 2007, 4:33pm)


5

Monday, July 2nd 2007, 4:41pm

RE: BURN brennt nicht

Quoted

Original von mblaster4711
PS: infos zum verwendeten VDR und Plugin-Version wären auch sehr nützlich.


VDR ist ein verpanschtes LinVDR 0.7 mit mittlerweile

vdr (1.4.7-tt-ext30/1.4.5) - The Video Disk Recorder

und Burn-Plugin

burn (0.0.10)

Bye!

This post has been edited 1 times, last edit by "mj-crawl" (Jul 2nd 2007, 5:47pm)


Posts: 91

Location: Hessen

Occupation: Dipl.-Ing.

  • Send private message

6

Monday, July 2nd 2007, 5:43pm

RE: BURN brennt nicht

Bei meiner Installation findet sich unter:
/etc/vdr/plugins
die Datei: plugin.burn.conf

Hier müssen die entsprechenden Pfade angegeben werden. Mein Beispiel sieht so aus (Achtung: Nicht Standard !!):

Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
#
# Command line parameters for vdr-plugin-burn
#
# For more details see /usr/share/doc/vdr-plugin-burn/README.gz
#

# use DIR for temporary files
# MUST be on UNIX filesystem
# (default is /var/cache/vdr-plugin-burn)
#
# --tempdir=DIR


# use DIR for temporary datafiles
# (default is VDR's video directory)
#
--datadir=/media/sdc1/video.00


# use DEV as DVD Writer
# (default is /dev/dvd)
#
--dvd=/dev/dvdrw


# use DIR to store ISO images
# (default: /video/iso)
#
--iso=/media/sdb1/iso

Burn funktioniert bei mir einwandfrei.
ASRock P67 Extreme6, Intel core i7-2600, 16GB DDR-3 RAM, Ubuntu 13.04, VDR 2.0.2, Mystique SaTiX - S2 Sky CI Xpress, Mystique SaTiX-S2 Sky Xpress DUAL, 2 x SATELCO EasyWatch HDTV PCI (DVB-C).

7

Monday, July 2nd 2007, 7:14pm

Nach ein wenig Hin & Her habe das Burn-Plugin zum Laufen gebracht.

Mit dem dirkkten Aufruf des Burn-Plugins

Source code

1
... -P'burn -i /pub/export' ...


in /etc/init.d/runvdr klappt es nun. Merkwürdig ist nur, dass es ohne die Angabe des IsoDir (-i) nicht funktioniert. Denn laut vdr-wiki.de ist '/pub/export' bereits der Default-Pfad für das IsoDir.

Danke für Eure Hilfe!

Bye!