Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: VDR Portal. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Samstag, 9. Dezember 2006, 02:48

Nova-SE2 Modell 92500 will nicht

Hallo,

meine relativ neu gekaufte Hauppauge WinTV Nova-SE2 möchte nicht so wie ich will.

Sie wird erfolgreich erkannt. dvbscan, szap und dvbdate funktionieren. Alles, was auf den MPEG-Datenstrom zugreift dagegen nicht - die Karte schweigt, z.B. bei dvbtraffic oder dvbstream.

Unter Windows - mit der mitgelieferten Software - funktioniert alles einwandfrei.

Habe schon sehr viele Stunden mittlerweile mit dem Problem verbracht. Googlen hilft nicht wirklich (habe zahlreiche Hinweise zu der Karte gefunden, die aber fast alle darauf hinzielen, daß sie von vorneherein gar nicht erkannt wird). Jede Hilfe wäre sehr nett.

Hier einige harte Fakten:

Erkennung funktioniert ("modprobe cx88_dvb"):

Dec 9 01:50:10 frodo CORE cx88[0]: subsystem: 0070:9200, board: Hauppauge Nova-SE2 DVB-S [card=38,autodetected]
Dec 9 01:50:10 frodo TV tuner 4 at 0x1fe, Radio tuner -1 at 0x1fe
Dec 9 01:50:10 frodo tveeprom 0-0050: Hauppauge model 92500, rev B1B1, serial# 577328
Dec 9 01:50:10 frodo tveeprom 0-0050: MAC address is 00-0D-FE-08-CF-30
Dec 9 01:50:10 frodo tveeprom 0-0050: tuner model is Conexant_CX24109 (idx 111, type 4)
Dec 9 01:50:10 frodo tveeprom 0-0050: TV standards ATSC/DVB Digital (eeprom 0x80)
Dec 9 01:50:10 frodo tveeprom 0-0050: audio processor is CX883 (idx 32)
Dec 9 01:50:10 frodo tveeprom 0-0050: decoder processor is CX883 (idx 22)
Dec 9 01:50:10 frodo tveeprom 0-0050: has no radio, has no IR receiver, has no IR transmitter
Dec 9 01:50:10 frodo cx88[0]: warning: unknown hauppauge model #92500
Dec 9 01:50:10 frodo cx88[0]: hauppauge eeprom: model=92500
Dec 9 01:50:10 frodo input: cx88 IR (Hauppauge Nova-SE2 DVB as /class/input/input3
Dec 9 01:50:10 frodo cx88[0]/2: cx2388x 8802 Driver Manager
Dec 9 01:50:10 frodo ACPI: PCI Interrupt 0000:02:0d.2[A] -> GSI 21 (level, low) -> IRQ 21
Dec 9 01:50:10 frodo cx88[0]/2: found at 0000:02:0d.2, rev: 5, irq: 21, latency: 32, mmio: 0xd2000000
Dec 9 01:50:10 frodo cx2388x dvb driver version 0.0.6 loaded
Dec 9 01:50:10 frodo cx8802_register_driver() ->registering driver type=dvb access=shared
Dec 9 01:50:10 frodo CORE cx88[0]: subsystem: 0070:9200, board: Hauppauge Nova-SE2 DVB-S [card=38]
Dec 9 01:50:10 frodo cx88[0]/2: cx2388x based dvb card
Dec 9 01:50:10 frodo DVB: registering new adapter (cx88[0]).
Dec 9 01:50:10 frodo DVB: registering frontend 0 (Conexant CX24123/CX24109)...

Liest man den Quelltext, so erscheint es, daß die Meldung "warning: unknown hauppauge model #92500" tatsächlich nur eine Warnung ist. Die entsprechende Funktion "macht" nichts weiter, außer eben dies zu prüfen.


szap funktioniert, aber dvbtraffic nicht:

frodo linux # szap "Das Erste" -r -x ; dvbtraffic
reading channels from file '/root/.szap/channels.conf'
zapping to 664 'Das Erste':
sat 0, frequency = 11836 MHz H, symbolrate 27500000, vpid = 0x0065, apid = 0x0066 sid = 0x6dca
using '/dev/dvb/adapter0/frontend0' and '/dev/dvb/adapter0/demux0'
status 03 | signal 0800 | snr e733 | ber 00000000 | unc fffffffe |
status 1f | signal 0800 | snr fc10 | ber 00000000 | unc fffffffe | FE_HAS_LOCK


In /var/log/messages findet man dabei:



Dec 9 01:50:50 frodo cx8802_start_dma() Failed. Unsupported value in .mpeg (0x00000001)
Dec 9 01:50:50 frodo cx88[0]/2-mpeg: cx8802_timeout
(wiederholt)


Ein strace auf dvbtraffic liefert:

open("/dev/dvb/adapter0/dvr0", O_RDONLY) = 3
ioctl(3, 0x6f2d, 0x100000) = 0
open("/dev/dvb/adapter0/demux0", O_RDWR) = 4
ioctl(4, 0x40146f2c, 0xbfb213e0) = 0
gettimeofday({1165630558, 458133}, NULL) = 0
read(3,

(an dieser Stelle passiert nichts mehr).


dvbscan -c funktioniert:

using '/dev/dvb/adapter0/frontend0' and '/dev/dvb/adapter0/demux0'
0x0000 0x6de2: pmt_pid 0x07d0 ARD -- Test-R (running)
0x0000 0x6dcb: pmt_pid 0x00c8 ARD -- Bayerisches FS (running)
0x0000 0x6dcf: pmt_pid 0x0258 ARD -- WDR Köln (running)
0x0000 0x6dcd: pmt_pid 0x0190 ARD -- arte (running)
0x0000 0x6dca: pmt_pid 0x0064 ARD -- Das Erste (running)
0x0000 0x6dcc: pmt_pid 0x012c ARD -- hr-fernsehen (running)
0x0000 0x6dd0: pmt_pid 0x02bc ARD -- BR-alpha (running)
0x0000 0x6dd1: pmt_pid 0x0320 ARD -- SWR Fernsehen BW (running)
0x0000 0x6dd2: pmt_pid 0x0384 ARD -- Phoenix (running)
dumping lists (9 services)
Das Erste (0x6dca) 01: PCR == V V 0x0065 A 0x0066 (deu) TT 0x0068 AC3 0x006a
Bayerisches FS (0x6dcb) 01: PCR == V V 0x00c9 A 0x00ca (deu) TT 0x00cc
hr-fernsehen (0x6dcc) 01: PCR == V V 0x012d A 0x012e (deu) TT 0x0130
arte (0x6dcd) 01: PCR == V V 0x0191 A 0x0192 (deu) 0x0193 (fra) TT 0x0194
WDR Köln (0x6dcf) 01: PCR == V V 0x0259 A 0x025a (deu) TT 0x025c
BR-alpha (0x6dd0) 01: PCR == V V 0x02bd A 0x02be (deu) TT 0x02c0
SWR Fernsehen BW (0x6dd1) 01: PCR == V V 0x0321 A 0x0322 (deu) TT 0x0324
Phoenix (0x6dd2) 01: PCR == V V 0x0385 A 0x0386 (deu) TT 0x0388
Test-R (0x6de2) 01: PCR == V V 0x02bd A 0x02be TT 0x00cc
Done.


Folgende Version von v4l-dvb ist installiert (gentoo). Aber auch mit den Kernel-Treibern direkt (ohne separates v4l-dvb) erscheint das gleiche Resultat.

* media-tv/v4l-dvb-hg
Latest version available: 0.1-r2
Latest version installed: 0.1-r2
Size of files: 0 kB
Homepage: http://www.linuxtv.org
Description: live development version of v4l&dvb-driver for Kernel 2.6
License: GPL-2


frodo video # uname -a
Linux frodo 2.6.18-gentoo-r3 #6 Wed Dec 6 22:45:08 Local time zone must be set--see zic manua i686 Intel(R) Pentium(R) 4 CPU 2.26GHz GenuineIntel GNU/Linux

2

Mittwoch, 13. Dezember 2006, 01:50

RE: Nova-SE2 Modell 92500 will nicht

Hat jemand von euch einen Tip, wo ich die Frage (ggf. auf englisch) noch stellen könnte? In der Mailingliste von linuxtv.org habe ich es versucht, dort wußte auch niemand rat...

Papablues

Fortgeschrittener

Beiträge: 206

Wohnort: Lower franconia

Beruf: SDevel

  • Nachricht senden

3

Mittwoch, 13. Dezember 2006, 15:36

RE: Nova-SE2 Modell 92500 will nicht

Hmm ich habe das gleiche modell in 3 facher ausführung in meinem Keller VDR mit Mahlzeit 3.2.

Hat auf anhieb alles funktioniert .....

Eventuell benutzt Dr. Seltsam andere Treiber ?

Ich würde es an deiner Stelle mal damit versuchen ( evtl. nur den Dr. Seltsam kernel )
Debian server [ AMD Athlon(tm) 64 Processor 3000+ 3*Nova SE2 1* FF muss nachschauen CI + alphacrypt Soft raid5 549G]
Clients [2 * MVP mit vomp 1 * MacBook Pro VLC streaming 1 * VOMP for windows]

4

Mittwoch, 13. Dezember 2006, 20:06

RE: Nova-SE2 Modell 92500 will nicht

Hm ok, danke. LinVDR direkt einzusetzen ist bei mir nicht möglich, da es die einzige DVB-Karte im System ist (es gibt keine Full-Featured-Karte darin)... aber gut zu wissen, daß es prinzipiell geht.

Hast Du auch wirklich die Modell-Bezeichnung 92500? Das scheint eine neuere Hardware-Version zu sein.

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »nova-se2-owner« (13. Dezember 2006, 20:09)


Chupa

Fortgeschrittener

Beiträge: 201

Wohnort: Griesheim/Dst.

  • Nachricht senden

5

Donnerstag, 14. Dezember 2006, 00:27

Hi,

also ich lade für meine TT-Budget die Module: budget bzw. budget_ci, warum sollte das bei den baugleichen Hauppauge anders sein.
Bist Du Dir sicher mit cx88_dvb.

Gruß Jens.
Athlon 1800+ - KT3 Ultra2 - 512 MB
Samsung 200 GB - NEC 1300A
Atric IR-Einschalter - GLCD 128x64
Hauppauge Nexus + 2 x TT-Budget
Debian/Etch - 2.6.22-6 - VDR-1.4.7 - Bigpatch

Von Fachidioten für Fachidioten, 5 Buchstaben.
LINUX?

sparkie

Erleuchteter

Beiträge: 3 046

Wohnort: a child of the universe

Beruf: duct tape programmer

  • Nachricht senden

6

Donnerstag, 14. Dezember 2006, 00:46

also ich habe genau eine 'Hauppauge Nova-SE2, Hauppauge model 92500, rev B1B1, serial# 559917' ohne Probleme am laufen. Aber nur mit VDR - dvbtraffic, dvbstream etc. habe ich nie getestet. Ich benutze genau diese Module in genau dieser Ladereihenfolge (insmod):

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
video-buf
v4l1-compat
v4l2-common
videodev

dvb-core
video-buf-dvb

i2c_algo_bit
ir-common
tveeprom

dvb-pll
btcx-risc
cx88xx
cx8802
cx24123
isl6421
cx88-vp3054-i2c
cx88-dvb
DVB Stand ist vom 24. August (ist nicht die Kiste in der Signatur). Kann diesen Sourcestand wo hinkopieren - da man den (glaube ich) nicht so ohne weiteres direkt aus dem DVB Repos rekonstruieren kann.

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »sparkie« (14. Dezember 2006, 07:28)


Papablues

Fortgeschrittener

Beiträge: 206

Wohnort: Lower franconia

Beruf: SDevel

  • Nachricht senden

7

Donnerstag, 14. Dezember 2006, 10:33

RE: Nova-SE2 Modell 92500 will nicht

Zitat

Original von nova-se2-owner
Hast Du auch wirklich die Modell-Bezeichnung 92500? Das scheint eine neuere Hardware-Version zu sein.


Folgenden Hinweis : Dec 9 01:50:10 frodo cx88[0]: warning: unknown hauppauge model #92500

Bekomme ich auch ...
Debian server [ AMD Athlon(tm) 64 Processor 3000+ 3*Nova SE2 1* FF muss nachschauen CI + alphacrypt Soft raid5 549G]
Clients [2 * MVP mit vomp 1 * MacBook Pro VLC streaming 1 * VOMP for windows]

Papablues

Fortgeschrittener

Beiträge: 206

Wohnort: Lower franconia

Beruf: SDevel

  • Nachricht senden

8

Donnerstag, 14. Dezember 2006, 10:34

Zitat

Original von Chupa
also ich lade für meine TT-Budget die Module: budget bzw. budget_ci, warum sollte das bei den baugleichen Hauppauge anders sein.


Ist dei Karte denn baugleich ??
ich habe bei mir das cx88_dvb erfolgreich im einsatz ( ist auch das empfohlene modul für die Nova SE2 )
Debian server [ AMD Athlon(tm) 64 Processor 3000+ 3*Nova SE2 1* FF muss nachschauen CI + alphacrypt Soft raid5 549G]
Clients [2 * MVP mit vomp 1 * MacBook Pro VLC streaming 1 * VOMP for windows]

Papablues

Fortgeschrittener

Beiträge: 206

Wohnort: Lower franconia

Beruf: SDevel

  • Nachricht senden

9

Donnerstag, 14. Dezember 2006, 10:35

alle module in meiner runvdr :

evdev
videodev
v4l1_compat
v4l2_common
video_buf
cx88_dvb

Mehr braucht es für die NovaSE2 nicht !
Debian server [ AMD Athlon(tm) 64 Processor 3000+ 3*Nova SE2 1* FF muss nachschauen CI + alphacrypt Soft raid5 549G]
Clients [2 * MVP mit vomp 1 * MacBook Pro VLC streaming 1 * VOMP for windows]

Chupa

Fortgeschrittener

Beiträge: 201

Wohnort: Griesheim/Dst.

  • Nachricht senden

10

Donnerstag, 14. Dezember 2006, 12:19

alle module in meiner runvdr:

dvb-ttpci
budget_ci

Mehr braucht es bei mir nicht ! ;D

Ich habe nur kürzlich eine neue TT-Budget verbaut, welche das Modul 'budget' benötigt. Da Hauppauge und TT die Welt nicht jedesmal neu erfinden, wollte ich nur mal den Anstoss geben, das Modul auszuprobieren.

Gruß Jens.
Athlon 1800+ - KT3 Ultra2 - 512 MB
Samsung 200 GB - NEC 1300A
Atric IR-Einschalter - GLCD 128x64
Hauppauge Nexus + 2 x TT-Budget
Debian/Etch - 2.6.22-6 - VDR-1.4.7 - Bigpatch

Von Fachidioten für Fachidioten, 5 Buchstaben.
LINUX?

Papablues

Fortgeschrittener

Beiträge: 206

Wohnort: Lower franconia

Beruf: SDevel

  • Nachricht senden

11

Donnerstag, 14. Dezember 2006, 14:48

Nur zur info wie ich auf dei Idee mit dem cx88_dvb modul gekommen bin:

http://www.linuxtv.org/wiki/index.php/NOVA-SE2
Debian server [ AMD Athlon(tm) 64 Processor 3000+ 3*Nova SE2 1* FF muss nachschauen CI + alphacrypt Soft raid5 549G]
Clients [2 * MVP mit vomp 1 * MacBook Pro VLC streaming 1 * VOMP for windows]

12

Donnerstag, 14. Dezember 2006, 15:28

bin auch gerade dabei die karte unter gentoo zum laufen zu bekommen. also vom system scheint sie erkannt zu werden, da ich die oberen meldungen aus diesem thread auch bekomme. nur leider wird bei mir die karte keinem adapter zugeweisen.

wenn ich unter /dev/dvb/ schaue, bekomme ich immer nur einen adapter0 und dieser ist meiner FF TT2300 zugewiesen.

müsste die nova nicht als adapter1 erkannt werden? wenn ja, was muss ich noch ändern, damit dies gemacht wird?
AMD64 3000+, ASUS A8N-VM CSM, TT-S2300, HP NOVA-SE2, 512 MB RAM
Gentoo, VDR 1.4.7, Kernel 2.6.18-gentoo-r2

Papablues

Fortgeschrittener

Beiträge: 206

Wohnort: Lower franconia

Beruf: SDevel

  • Nachricht senden

13

Donnerstag, 14. Dezember 2006, 23:43

@Blacktiger:

Welchen Kernel setzt du ein und welche version der DVB Treiber ?

Wahrscheinlich wird sie erkannt, aber funktioniert mit deinem Treiber nicht.
Debian server [ AMD Athlon(tm) 64 Processor 3000+ 3*Nova SE2 1* FF muss nachschauen CI + alphacrypt Soft raid5 549G]
Clients [2 * MVP mit vomp 1 * MacBook Pro VLC streaming 1 * VOMP for windows]

14

Freitag, 15. Dezember 2006, 01:31

Lieber Blacktiger,

sehe du hast auch eine TT 2300 im Einsatz, die bei Dir scheinbar funktioniert, da du nur von Problemen der zweiten Karte schreibst. Hat die Karte unter Gentoo gleich funktioniert?
Siehe mein Beitrag, wo ich von einer TT S-2300 (FF) und einer Hauppauge Nova S-plus mit Problemen unter dem Mahlzeit ISO und anderen schreibe. Wäre für Hilfe sehr dankbar, da sich bis jetzt noch niemand auf meinen Beitrag gemeldet hat (siehe Link: Problem mit Technotrend S-2300 Rev.2.3 modded (Full Feature) und Hauppauge Nova-S Plus (Budget))

Grüsse
Christoph
Hardware: ECS Elitegroup K7S5A Rev.1.X, Netzteil 300 W, 256MB RAM, 80GB Seagate HDD, TT Premium S-2300 Rev: 2.3 modded, Hauppauge Nova-S plus
Software: Mahlzeit ISO 3.2

15

Dienstag, 13. Februar 2007, 11:39

Ich habe bei mir das gleiche Problem mit dem Debian testing Kernel 2.6.18-3

Quellcode

1
2
eowyn:~# uname -a
Linux eowyn 2.6.18-3-686 #1 SMP Mon Dec 4 16:41:14 UTC 2006 i686 GNU/Linux


Scan und szap laufen :

Quellcode

1
2
3
4
5
6
7
8
9
eowyn:~# szap ProSieben
reading channels from file '/root/.szap/channels.conf'
zapping to 8 'ProSieben':
sat 0, frequency = 12480 MHz V, symbolrate 27500000, vpid = 0x00ff, apid = 0x0100
using '/dev/dvb/adapter0/frontend0' and '/dev/dvb/adapter0/demux0'
status 01 | signal f700 | snr ffdc | ber 00000000 | unc 00000000 |
status 1f | signal f700 | snr ffdc | ber 00000000 | unc 00000000 | FE_HAS_LOCK
status 1f | signal f700 | snr ffdc | ber 00000000 | unc 00000000 | FE_HAS_LOCK
status 1f | signal f700 | snr ffdc | ber 00000001 | unc 00000001 | FE_HAS_LOCK


Wenn ich dann mit dvbstream ein paar Sekunden den Datenstrom in eine Datei auf meine Platte umleite gibt es erstmal auch keine Probleme oder Fehlermeldungen.

Quellcode

1
2
3
4
5
6
7
8
9
eowyn:/export/maxtor_6Y080P0/Tausch# dvbstream 255 256 -o > test.mpeg
dvbstream v0.5 - (C) Dave Chapman 2001-2004
Released under the GPL.
Latest version available from http://www.linuxstb.org/
Setting filter for PID 255
Setting filter for PID 256
Output to stdout
Streaming 2 streams
Caught signal 2 - closing cleanly.


Aber die resultierende Datei ist leer!!! :(

Quellcode

1
2
eowyn:/export/maxtor_6Y080P0/Tausch# ls -l te*
-rw-r--r--  1 root root 0 2007-02-12 02:33 test.mpeg


Gibt es mittlerweile eine Abhilfe???
Liegt das an dvbstream aber VDR läuft??? (hab ich nämlich bisher noch nicht probiert)
Ist der Dr. Seltsam Kernel der Schlüssel???
VDR-Box: Supermicro P3TDE6, 2x P-IIIS 1.4GHz, 2GB, diverse SCSI und IDE Platten, Nova-SE2
Debian Squeeze 2.6.32-5-686, VDR 1.7.18, streamdev-server 0.5.1

16

Dienstag, 13. Februar 2007, 21:46

Zitat

Originally posted by gekkoo
Gibt es mittlerweile eine Abhilfe???


Keine Ahnung. Ich habe meine Pläne mit VDR bzw. MythTV bzw. Sat im PC erstmal begraben. Ich hab's versucht, wirklich, auf zahlreichen Foren inkl. dem Hauppauge Support Forum; habe stundenlang Kernel debuggt - nichts. Es geht halt einfach nicht. Vmtl. braucht man irgendwelche Infos über die Hardware, muß sie irgendwie anders initialisieren o.ä. - auf jeden Fall für mich nicht herauszubekommen.

17

Mittwoch, 14. Februar 2007, 10:03

Aber bei Papablues scheint es ja zu laufen:

Zitat

Hmm ich habe das gleiche modell in 3 facher ausführung in meinem Keller VDR mit Mahlzeit 3.2.

Hat auf anhieb alles funktioniert .....


Ich wollte aber eben kein LinVDR oder Mahlzeit installieren, weil ich vermeiden will meinen Server ganz neu aufzusetzen...
VDR-Box: Supermicro P3TDE6, 2x P-IIIS 1.4GHz, 2GB, diverse SCSI und IDE Platten, Nova-SE2
Debian Squeeze 2.6.32-5-686, VDR 1.7.18, streamdev-server 0.5.1

18

Montag, 26. Februar 2007, 12:33

Also unter VDR läuft meine Nova-SE2 jetzt ohne Probleme und quasi out of the box.
Betreibe den VDR unter nem Debian Etch/testing Kernel 2.6.18-3 mit den darin enthaltenen Treibern...
Selbst die runvdr habe ich noch nicht mal angepasst.

Warum die Karte unter dvbstream oder dvbtraffic nichts ausspuckt weiß ich nicht, stört mich aber jetzt nicht wirklich, weil sie unter VDR ja einwandfrei läuft.

Bei Fragen zu meiner Installation helfe ich gerne weiter...
VDR-Box: Supermicro P3TDE6, 2x P-IIIS 1.4GHz, 2GB, diverse SCSI und IDE Platten, Nova-SE2
Debian Squeeze 2.6.32-5-686, VDR 1.7.18, streamdev-server 0.5.1

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »gekkoo« (26. Februar 2007, 12:34)


19

Dienstag, 10. April 2007, 12:47

Unter c´t-VDR5 läuft die Karte nachdem man
die "/etc/modules" ergänzt mit:
cx88_dvb

Die Karte läuft bei mir mit Kernel 2.6.20.6.
esprimo, yavdr 0.5a

Immortal Romance Spielautomat