You are not logged in.

Dear visitor, welcome to VDR Portal. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Mettwursty

Intermediate

  • "Mettwursty" started this thread

Posts: 185

Location: NRW

  • Send private message

1

Thursday, November 30th 2006, 9:09pm

Update von VDRAdmin

Ich möchte gerne meinen VDRAdmin updaten.
Leider habe ich keine Erfahrung wie das geht.
Ich habe im Internet schon mal gesucht und habe mir die aktuelle VDRAdmin Versin heruntergeladen (3.5.1 aktuell habe ich die Version 3.4.4beta2).

Eine Installationsanleitung habe ich unter:

http://www.vdr-wiki.de/wiki/index.php/Vd…AM#Installation

gefunden.

Aber leider verstehe ich nicht was die da genau meinen bzw. was ich genau machen muss um ein Update erfolgreich duchzuführen.

Kann mir einer die einzelnen Schritte (Schritt für Schritt) erklären?
VDR:Netzteil: Fortron 350W (Passivkühlung duch Öl) Mainboard: ASUS P4N8-X Speicher: 512MB HDD: 80GB Segate + 160GB Maxtor Prozessor: Intel Celeron 2.1Ghz (Passivkühlung duch Thermaltake Sonic-Tower) TV Karte: Technotrend S2300 Premium (Rev2.3) modded + Hauppauge Nova-S-Plus Software: LinVDR Mahlzeit 3.2

This post has been edited 1 times, last edit by "Mettwursty" (Dec 1st 2006, 1:15pm)


amair

Master

Posts: 2,302

Location: Schrobenhausen

Occupation: Software-Entwicklung und -Support

  • Send private message

2

Friday, December 1st 2006, 9:18am

RE: Update von VDRAdmin

Hallo,

was ist daran nicht zu verstehen?

Source code

1
2
3
4
cd $SOURCEDIR
tar jxvf vdradmin-am-<VERSION>.tar.bz2
cd vdradmin-am-<VERSION>
LANG=de_DE ./make.sh install

Nun nur noch den VDRAdmin-AM neu starten oder den VDR-PC neu starten und mit VDRAdmin-AM verbinden. Auf der Über/Hilfe-Seite findest Du dann die aktuelle Versionsnummer.

Gruß,
Andreas

Mettwursty

Intermediate

  • "Mettwursty" started this thread

Posts: 185

Location: NRW

  • Send private message

3

Friday, December 1st 2006, 1:21pm

Ich habe nun die Datei vdradmin-am-3.5.1.tar.bz2 nach pub/export kopiert.

danach habe ich das ganze entpackt und LANG=de_DE ./make.sh install eingegeben.

Nach der Installation habe ich den VDR neugestartet aber leider funktioniert die Web-Oberfläche jetzt nicht mehr.

Muss ich da noch etws zusätzlich einstellen?
VDR:Netzteil: Fortron 350W (Passivkühlung duch Öl) Mainboard: ASUS P4N8-X Speicher: 512MB HDD: 80GB Segate + 160GB Maxtor Prozessor: Intel Celeron 2.1Ghz (Passivkühlung duch Thermaltake Sonic-Tower) TV Karte: Technotrend S2300 Premium (Rev2.3) modded + Hauppauge Nova-S-Plus Software: LinVDR Mahlzeit 3.2

This post has been edited 1 times, last edit by "Mettwursty" (Dec 1st 2006, 1:21pm)


amair

Master

Posts: 2,302

Location: Schrobenhausen

Occupation: Software-Entwicklung und -Support

  • Send private message

4

Friday, December 1st 2006, 1:30pm

Hallo,

Quoted

Original von Mettwursty
Ich habe nun die Datei vdradmin-am-3.5.1.tar.bz2 nach pub/export kopiert.

danach habe ich das ganze entpackt und LANG=de_DE ./make.sh install eingegeben.

Nach der Installation habe ich den VDR neugestartet aber leider funktioniert die Web-Oberfläche jetzt nicht mehr.

Muss ich da noch etws zusätzlich einstellen?

Ohne Information wird Dir da wohl keiner helfen (können).
"funktioniert nicht mehr" ist ein großer Begriff...

Zum Testen schlage ich vor Du gehst in das neu angelegte Verzeichnis und startest VDRAdmin-AM aus diesem Verzeichnis. INSTALL beschreibt das.

Source code

1
2
./vdradmind.pl -c
./vdradmind.pl


Gruß,
Andreas

Mettwursty

Intermediate

  • "Mettwursty" started this thread

Posts: 185

Location: NRW

  • Send private message

5

Friday, December 1st 2006, 3:03pm

Nach der Installation habe ich jetzt mit der vdradmind.pl den VDR-Admin gestartet.

dabei erhalte ich folgende Nachricht:

linvdr:/pub/export/vdradmin-am-3.5.1# ./vdradmind.pl
"bind_textdomain_codeset" is not exported by the Locale::gettext module at ./vdr admind.pl line 53
Not using bind_textdomain_codeset(). Please update your Locale::gettext perl mod ule!
vdradmind.pl 3.5.1 started with pid 1633.
Press any key to continue...

Danach sollte der VDR-Admin ja theoretisch funktionieren das ist aber noch nicht der Fall.

nachdem ich den Befehl ./vdradmind.pl -c eingegeben habe habe ich flogende konfigurationen vorgenommen:

linvdr:/pub/export/vdradmin-am-3.5.1# ./vdradmind.pl
"bind_textdomain_codeset" is not exported by the Locale::gettext module at ./vdr admind.pl line 53
Not using bind_textdomain_codeset(). Please update your Locale::gettext perl mod ule!
vdradmind.pl 3.5.1 started with pid 1633.
linvdr:/pub/export/vdradmin-am-3.5.1# ./vdradmind.pl -c
"bind_textdomain_codeset" is not exported by the Locale::gettext module at ./vdradmind.pl line 53
Not using bind_textdomain_codeset(). Please update your Locale::gettext perl module!
What's your VDR hostname (e.g video.intra.net)? [linvdr]: linvdr
On which port does VDR listen to SVDRP queries? [2001]: 2001
On which address should VDRAdmin-AM listen (0.0.0.0 for any)? [192.168.0.4]: 0.0.0.0.0
On which port should VDRAdmin-AM listen? [8001]: 8001
Username? [linvdr]: linvdr
Password? [linvdr]: linvdr
Where are your recordings stored? [/video]: /video
Where are your VDR's configuration files located? [/video]: /video
Config file written successfully.
Press any key to continue...

Was kann man da noch machen?
(Die konfigurationen meines Systems stehen unten)
VDR:Netzteil: Fortron 350W (Passivkühlung duch Öl) Mainboard: ASUS P4N8-X Speicher: 512MB HDD: 80GB Segate + 160GB Maxtor Prozessor: Intel Celeron 2.1Ghz (Passivkühlung duch Thermaltake Sonic-Tower) TV Karte: Technotrend S2300 Premium (Rev2.3) modded + Hauppauge Nova-S-Plus Software: LinVDR Mahlzeit 3.2

amair

Master

Posts: 2,302

Location: Schrobenhausen

Occupation: Software-Entwicklung und -Support

  • Send private message

6

Friday, December 1st 2006, 3:10pm

Hi,

Du hast statt "0.0.0.0" "0.0.0.0.0" eingegeben (ein".0" zu viel), ansonsten schaut es in Ordnung aus.

Wie greifst Du auf die Weboberfläche zu?
"http://192.168.0.4:8001" sollte klappen...

Gruß,
Andreas

Mettwursty

Intermediate

  • "Mettwursty" started this thread

Posts: 185

Location: NRW

  • Send private message

7

Friday, December 1st 2006, 8:06pm

Wunderbar.

Es hat alles geklappt und ich kann nun die 3.5.1 nutzen.

Allerdings sind mir noch 3 Dinge aufgefallen:

1. Ich kann die Sprache nicht auf Deutsch umstellen (unter Configuration > Language)

2. Wie bekomme ich es hin das der VDR-Admin mit dem LinVDR zusammen gestartet wird (ich meinen einen Autostart von VDR-Admin).

3. Mir ist aufgefallen das der Autotimer gegen EPG Search getauscht ist.
Leider ist meine EPG Search Version zu veraltet.
Wie kann ich eine neue Version installieren (habe mir schon die neuste Version heruntergeladen).
VDR:Netzteil: Fortron 350W (Passivkühlung duch Öl) Mainboard: ASUS P4N8-X Speicher: 512MB HDD: 80GB Segate + 160GB Maxtor Prozessor: Intel Celeron 2.1Ghz (Passivkühlung duch Thermaltake Sonic-Tower) TV Karte: Technotrend S2300 Premium (Rev2.3) modded + Hauppauge Nova-S-Plus Software: LinVDR Mahlzeit 3.2

amair

Master

Posts: 2,302

Location: Schrobenhausen

Occupation: Software-Entwicklung und -Support

  • Send private message

8

Monday, December 4th 2006, 9:48am

Hallo,

Quoted

Original von Mettwursty
1. Ich kann die Sprache nicht auf Deutsch umstellen (unter Configuration > Language)

Vermutlich setzt Du beim vdradmind.pl Aufruf die LANGUAGE und/oder LC_* Umgebungsvariablen oder sie sind in der aufrufenden Shell bereits gesetzt.
Ich denke, das wurde aber im VDR-Portal speziell für LinVDR schon mehrfach diskutiert. Einfach mal suchen...

Quoted

2. Wie bekomme ich es hin das der VDR-Admin mit dem LinVDR zusammen gestartet wird (ich meinen einen Autostart von VDR-Admin).

Indem Du den Aufruf in ein Startskript z.B. vom VDR einträgst. Bei LinVDR sollte das aber eigentlich schon so sein.

Quoted

3. Mir ist aufgefallen das der Autotimer gegen EPG Search getauscht ist.
Leider ist meine EPG Search Version zu veraltet.
Wie kann ich eine neue Version installieren (habe mir schon die neuste Version heruntergeladen).

Da selber kompilieren auf LinVDR normalerweise nicht geht mußt Du Dir entweder ein fertiges Paket für LinVDR besorgen oder eine Entwicklungsumgebung aufsetzen.
Dies war sicher schon Thema mehrerer Threads. Einfach mal suchen...

Da ich kein LinVDR nutze kann ich Dir nicht weiterhelfen.

Gruß,
Andreas