You are not logged in.

Dear visitor, welcome to VDR Portal. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

  • "Torsten73" started this thread

Posts: 1,773

Occupation: Radio Fernsehtechniker

  • Send private message

21

Friday, June 17th 2011, 2:30pm

möglich das da noch irgendwelche Dienste ihre Aktualisierungen am abarbeiten waren, hast Du noch Kopfgeräusche gehört? 6-10W sind für eine 3,5" Platte üblich. Deshalb schicke ich die ja schlafen und boote von SSD. bringt 5W Ersparniss bei der Seagate 5900 2TB.
Das Meßgerät von Dir hat eine ähnliche Genauigkeit wie mein ELV EnergyMaster, ab 1,5W 1%. Das passt schon.
Womit Du noch vielleicht spürbar was rausholen kannst ist beim Netzteil. Selbst beim Enermax 500W pro 82% im Vergleich zum 200W 82% Seasonic SFX sind es gut 5W. Die Netzteile knicken in der Effizienz im unteren Lastbereich zum Teil deutlich ein.
Momentan pausiert der Vergleich bei mir, da ich den anderen Stromfressern (Mainboard & Garaka) auf die Schliche gekommen bin. Ich stelle aktuell auf ein anderes Mainboard um, das Asus ist im Vergleich zum Intel über 10W verschwenderischer und auch die GT430 ist keine gute Wahl, die taktet ständig auf PowerState 0 hoch und zieht dann locker 20-25W. Was geigentlich gar nicht zu sein bräuchte. Siehe mein SandyBridge System.
Das hat aber nichts mit dem Kernel zu tun.

Momentan frage ich mich ob Phoronics da nicht ein wenig hoch gegriffen hat. Ich zweifel nicht deren Meßergebnisse an, aber so eindeutig festhalten woran es liegt kann man nicht, und ofensichtlich ist dies nicht grundsätzlich bei allen SandyBridge Systemen der Fall.

In meinem Fall habe ich zum Beispiel den Verdacht, dass bei Nutzung externer Grafikkarten möglicherweise der integrierte Grafikcore nicht deaktiviert wird (bei Asus P8h61-m) Denn >20W Unterschied fällt mir schwer nur auf Bauteilqualitäten abzuwälzen die ich als Differenz zwischen Asus + GT430 und Intel + GT520 gemessen habe. Im Idel Desktop mit Intel Grafik habe ich noch nicht gemessen, aber die GT520/430 hat im Idle (PowerState GT520 =1 /bei GT430 = 2) rund 8W Eigenverbrauch.
Soweit ich weiß hat die Intel GPU rund 15-30W je nach Last. Sieht doch beim Asus P8H61-m sehr stark nach nicht abgeschalteter Graka aus. Ist aber nur ein Verdacht, ich wüsste nicht wie man das Beweisen kann und Asus wird einen Teufel tun das zuzugeben.

Realistisch erreichbar ist auf jeden Fall ein SandyBridge System mit TwinSat+SSD+3,5" HDD+8GB+DVDRW+GT520 für max 55W. Viel anders ist der Verbrauch bei HD mit Intel auch nicht, denn unter Windows7 Youtube 1080i zieht auch das Intel auf gut 50W hoch (mit gleicher Bestückung)

Wenn das Intel Board System läuft werde ich noch mal meine letzten Werte vergleichen. Bei Intel kann nur den Vddr undervolten nicht die VCore, aber das bringt bei 8GB locker 3W.
Yavdr 0.5: KVM Server mit YAVDR als Host, Tyan Xeon Server, Virtualbox + KVM
Yavdr 0.5: Asus AT5iont-t, ION2, 4GB Ram, Momentus 2,5" 500GB, HEX TFX 300W 82+, Cine S2 V6.2 , 38W max.
Yavdr 0.5:
Zotac D2550ITXS-A-E mit GT610 OB, TT S2-4100 PCI-e ,Joujye NU-0568I-B
Yavdr 0.5:
Sandy Bridge G840, Tests und Energieverbrauch , CoHaus CIR, Cine S2 V6.2

Posts: 2,948

Location: Isen

Occupation: System Manager

  • Send private message

22

Friday, June 17th 2011, 3:13pm

möglich das da noch irgendwelche Dienste ihre Aktualisierungen am abarbeiten waren, hast Du noch Kopfgeräusche gehört? 6-10W sind für eine 3,5" Platte üblich. Deshalb schicke ich die ja schlafen und boote von SSD. bringt 5W Ersparniss bei der Seagate 5900 2TB.

Die Platte war nichts am tun (das hört man bei dem Dinosaurier), ich hatte den Verbrauch ja gestern Abend über einen längeren Zeitraum hinweg ohne Schwankung.
Und die Platte braucht deutlich mehr als die 6-7W (Idle) der 3,5" 2TB Platte im USB Gehäuse (bei der ja auch die Elektronik vom S-ATA/USB Wandler noch mit versorgt werden will, nebst Steckernetzteil).

Quoted

Das Meßgerät von Dir hat eine ähnliche Genauigkeit wie mein ELV EnergyMaster, ab 1,5W 1%. Das passt schon.

So wurde es mir ja auch verkauft ("nehmse das, das ist genauer..."). ;)

Quoted

Womit Du noch vielleicht spürbar was rausholen kannst ist beim Netzteil. Selbst beim Enermax 500W pro 82% im Vergleich zum 200W 82% Seasonic SFX sind es gut 5W. Die Netzteile knicken in der Effizienz im unteren Lastbereich zum Teil deutlich ein.

Momentan ist das noch das Digitainer Netzteil, mit dem beQuiet erwarte ich schon noch eine Verringerung. Aber es geht da ja um den absoluten Unterschied von gestern Abend und heute Morgen. Und das würde ich vermutlich auch mit einem besseren Netzteil messen.

Quoted

Momentan frage ich mich ob Phoronics da nicht ein wenig hoch gegriffen hat. Ich zweifel nicht deren Meßergebnisse an, aber so eindeutig festhalten woran es liegt kann man nicht, und ofensichtlich ist dies nicht grundsätzlich bei allen SandyBridge Systemen der Fall.

Ich hab das jetzt nicht näher verfolgt, aber *welche* Sandy Bridge Systeme sind davon betgroffen? Es muss da doch fast eine Gemeinsamkeit (BIOS, CPU, Stepping etc.) geben. Ich hab ja eher den Verdacht (nachdem es 1. lange nicht aufgefallen ist und 2. nur wenige Systeme betroffen sind), dass es ein "Hardware"-Problem sein könnte... Unsauberes BIOS (verschlimmbessert auf Windows o.ä.) oder sowas... ;)

cu
Markus
:mahlzeit

Klick hier für "Aktuelle Verkaufsthreads"

Klick hier für "Meine Systeme"


  • yaVDR 0.5 headless Server in ProxMox VM, Digital Devices Cine S2 6.5 mit DuoFlex Erweiterung (Quad Tuner) per vt-d durchgereicht.
  • yaVDR 0.5 deviceless Client auf Zotac D2550 ITX Wifi Supreme am 42" LG
  • MLD RPI Edition mit vompclient


Dirk

Super Moderator

Posts: 4,791

Location: am Rande der Zivilisation

Occupation: DvD -> Depp vom Dienst

  • Send private message

23

Monday, June 20th 2011, 5:58pm

Hi

@Mahlzeit:

Soweit ich das gerade verstanden habe, geht es um Sandy Bridge Systeme MIT zusätzlicher NVidia-Grafikkarte!

Deine Messungen sind mit IGP ohne NVidia-Karte!

@Torsten73

Gibts über die IGP noch ne Videoausgabe? Evtl. wird die nicht richtig abgeschaltet(oder ungewollt aktiviert) und das System braucht dadurch mehr Strom!
Für mich wäre das zumindest eine Erklärung.

Meine Signatur

:]Heute ist nicht alle Tage, ich schreib wieder, keine Frage :]
VDR1: Silverstone LC14M, AMD X2-BE2350,2GB/1,5TB,DVB-s/s2/c,Gentoo,Kernel 3.8.5,VDR-2.0.0
VDR2: Silverstone GD05B, Intel G2020, Asrock B75-Pro3M, Asus GT610/2G, 8GB/1TB, YAVDR 0.5
VDR3: [Im Aufbau)Silverstone ML03, Intel G2020, Asrock B75-R2, 8GB/1TB

Posts: 2,948

Location: Isen

Occupation: System Manager

  • Send private message

24

Monday, June 20th 2011, 6:22pm

Hi

@Mahlzeit:

Soweit ich das gerade verstanden habe, geht es um Sandy Bridge Systeme MIT zusätzlicher NVidia-Grafikkarte!

Deine Messungen sind mit IGP ohne NVidia-Karte!.

Laut der Aussage hier liegt es nicht an der Grafikkarte... Und auch in der Bugmeldung liest man davon nichjts. Hier mischen sich grad ein paarThemen, die eigentlich nix miteinander zu tun haben (Mehrverbrauch von natty und Mehrverbrauch von ner GT430 im Gegensatz zu dem IGP und überhaupt die Verbrauchsunterschiede zwischen einzelnen Mainboardherstellern)

cU
Markus
:mahlzeit

Klick hier für "Aktuelle Verkaufsthreads"

Klick hier für "Meine Systeme"


  • yaVDR 0.5 headless Server in ProxMox VM, Digital Devices Cine S2 6.5 mit DuoFlex Erweiterung (Quad Tuner) per vt-d durchgereicht.
  • yaVDR 0.5 deviceless Client auf Zotac D2550 ITX Wifi Supreme am 42" LG
  • MLD RPI Edition mit vompclient


  • "Torsten73" started this thread

Posts: 1,773

Occupation: Radio Fernsehtechniker

  • Send private message

25

Monday, June 20th 2011, 7:19pm

richtig. Ich sehe im Moment auch keinen Beleg bei mir dafür, dass es mit dem Kernel einen solchen Zusammenhang gibt.
Aber ich kann einen eindeutigen Mehrverbrauch IGP -> GT430 belegen, der liegt zwischen 12W (SD) und 23W (1080i) für eine für mich gleich aussehende Bildqualität Mediaportal (IGP) vs VDR (VDPAU).
Ledigliche mit der GT520 läßt sich das nochmal etwas reduzieren, da diese nur 2 Performance Level hat und im höchsten Level immer noch fast 10W weniger braucht.
Die GT520 Werte muß ich noch nachliefern, die sind im meinem Thread noch nicht enthalten.

Im Moment versuche ich herauszufinden, ob eventuell ein unnötiger Mehrverbrauch durch falsche / ungünstige Prozessortaktstufen verursacht werden. Denn das Systeminfo-plugin zeigt mir ständig 1,6Ghz an für die core i5-2400t. Dies dürfte eigentlich doch bei max. 1200Mhz sein, oder nicht?
Habe das was interessantes zu gefunden: http://grano.la/software/download_granola.php nimmt einem die Einstellungen per webgui ab.
Yavdr 0.5: KVM Server mit YAVDR als Host, Tyan Xeon Server, Virtualbox + KVM
Yavdr 0.5: Asus AT5iont-t, ION2, 4GB Ram, Momentus 2,5" 500GB, HEX TFX 300W 82+, Cine S2 V6.2 , 38W max.
Yavdr 0.5:
Zotac D2550ITXS-A-E mit GT610 OB, TT S2-4100 PCI-e ,Joujye NU-0568I-B
Yavdr 0.5:
Sandy Bridge G840, Tests und Energieverbrauch , CoHaus CIR, Cine S2 V6.2

This post has been edited 1 times, last edit by "Torsten73" (Jun 20th 2011, 7:50pm)


Dirk

Super Moderator

Posts: 4,791

Location: am Rande der Zivilisation

Occupation: DvD -> Depp vom Dienst

  • Send private message

26

Monday, June 20th 2011, 8:22pm

Hmm, also ich versteh da gerade 2 sachen nicht!

1. IGP und GT430/520 kann man nicht beim Stromverbrauch vergleichen
Warum?
- gibts genauere Angaben, was die IGP verbraucht?
- GT430 -> GPU GF108 -> 7-48W
- GT520 -> GPU GF119 -> ?-29W <- damit ist auch klar, warum die weniger verbraucht

2. IGP und GT430/520 kann man nicht beim Decodieren vergleichen
Warum?
- IGP
-> es gibt 2 verschieden HD2000/HD3000
-> dein i5-2400s hat HD2000 Grafik und damit nur 6 "Execution Units" (HD3000 hat 12)
-> ich konnte nichts finden, wieviel der Arbeit die GPU übernehmen kann (vermutlich wesentlich weniger)
- GT430/GT520 haben beide VP4, damit kann die Graka das komplette Videodecoding machen

Für mich ist eigentlich klar, das HD2000 nicht mit einer GT430/520 mithalten kann.

Du kannst ja mal mit powertop vergleichen, wie sich die Prozessorlast und Taktung verhält. Ich denke das dürfe es deutlich zeigen.

Meine Signatur

:]Heute ist nicht alle Tage, ich schreib wieder, keine Frage :]
VDR1: Silverstone LC14M, AMD X2-BE2350,2GB/1,5TB,DVB-s/s2/c,Gentoo,Kernel 3.8.5,VDR-2.0.0
VDR2: Silverstone GD05B, Intel G2020, Asrock B75-Pro3M, Asus GT610/2G, 8GB/1TB, YAVDR 0.5
VDR3: [Im Aufbau)Silverstone ML03, Intel G2020, Asrock B75-R2, 8GB/1TB

  • "Torsten73" started this thread

Posts: 1,773

Occupation: Radio Fernsehtechniker

  • Send private message

27

Monday, June 20th 2011, 10:07pm

Ich vergleiche hier nicht die maximale Leistungsfähigkeit der Grafikeinheiten, sondern deren Stromaufnahme beim Fernsehen auf SD und HD.
Das ganze unter Windows vs. Linux. Ist halt eine anwendungsorientierte Betrachtungsweise.
Dabei bin ich mir nicht sicher, dass die von mir gemessenen Werte einen Rückschluss auf einen Anstieg durch den Kernel darstellen, sondern ich vermute in der Tat, dass dies irgendwo anders drin ergründet liegt. Aber wäre dann OT. Deshalb sollten wir vielleicht das hier nicht weiter erörtern?

Was sich mir aber auch nicht erklärt, wieso unter Openbox mit beendetem Openbox und VDR ich immer noch rund 64 Watt verbrauche, während unter Windows dies nur rund 45W sind! lt. Top ist alles idle. Da bin ich gerade dran.

Oder übersehe ich das was?

Edit: Intel Powertop ist ein interesantes Tool. Es schlägt sogar Änderungen zur Energieeinsparung vor und kann die anwenden. Mal sehen ...
Yavdr 0.5: KVM Server mit YAVDR als Host, Tyan Xeon Server, Virtualbox + KVM
Yavdr 0.5: Asus AT5iont-t, ION2, 4GB Ram, Momentus 2,5" 500GB, HEX TFX 300W 82+, Cine S2 V6.2 , 38W max.
Yavdr 0.5:
Zotac D2550ITXS-A-E mit GT610 OB, TT S2-4100 PCI-e ,Joujye NU-0568I-B
Yavdr 0.5:
Sandy Bridge G840, Tests und Energieverbrauch , CoHaus CIR, Cine S2 V6.2

This post has been edited 1 times, last edit by "Torsten73" (Jun 20th 2011, 10:13pm)


Dirk

Super Moderator

Posts: 4,791

Location: am Rande der Zivilisation

Occupation: DvD -> Depp vom Dienst

  • Send private message

28

Tuesday, June 21st 2011, 10:15pm

Quoted

Was sich mir aber auch nicht erklärt, wieso unter Openbox mit beendetem Openbox und VDR ich immer noch rund 64 Watt verbrauche, während unter Windows dies nur rund 45W sind! lt. Top ist alles idle. Da bin ich gerade dran.


Hast du unter windoof auch alle TV-Karten aktiv? Die 19W sehen mir verdächtig danach aus!

beende mal vdr und entlade die dvb-module und schau dann mal, ich denke du wirst dich dann deutlich den die 45W annähern.
Zum Gegencheck kannst du ja auch mal bei Windoof die TV-Software starten und messen. Du wirst zwar vermutlich nicht an die 64W kommen. Zumindest kenne ich keine TV-Software unter Win, die mit 3 Tunern gleichzeitig umgehen kann.

PS: Powertop ist nicht auf Intel fixiert, das funzt auch mit AMD-CPUs (nur als info).
Aktuell ist 1.1.3 bzw, 1.98(beta), wobei du evtl. letztere nehmen solltest (kann mehr :D)

http://www.kernel.org/pub/linux/status/powertop/

Meine Signatur

:]Heute ist nicht alle Tage, ich schreib wieder, keine Frage :]
VDR1: Silverstone LC14M, AMD X2-BE2350,2GB/1,5TB,DVB-s/s2/c,Gentoo,Kernel 3.8.5,VDR-2.0.0
VDR2: Silverstone GD05B, Intel G2020, Asrock B75-Pro3M, Asus GT610/2G, 8GB/1TB, YAVDR 0.5
VDR3: [Im Aufbau)Silverstone ML03, Intel G2020, Asrock B75-R2, 8GB/1TB

29

Monday, June 27th 2011, 7:29pm

Bei Heise war heute auch etwas dazu zu lesen, Kernel-Log: Höherer Stromverbrauch durch BIOS-Bugs.
Scheint mir also doch kein Intel spezifisches Problem zu sein.
HW I: Thermaltake DH 202, Intel DH67BL, Intel Pentium G630, TT Premium S2-6400, Crucial m4 SSD,
Fortron Source Aurum Gold 400W, Scythe Big Shuriken, LG DVD-RW GH22NS50, Kingston ValueRAM 4GB

HW II: A+case Cupid 2, Intel D945GSEJT, 512 MB RAM, 2x PCI Riser, Atric IR-Einschalter Rev. 5,
Hauppauge Nexus Rev 2.2, 60W 12V/DC, Slimline Samsung DVD-RW, CF/SATA-Adapter, 4 GB CF Card

  • "Torsten73" started this thread

Posts: 1,773

Occupation: Radio Fernsehtechniker

  • Send private message

30

Monday, June 27th 2011, 7:46pm

beende mal vdr und entlade die dvb-module und schau dann mal, ich denke du wirst dich dann deutlich den die 45W annähern.
Zum Gegencheck kannst du ja auch mal bei Windoof die TV-Software starten und messen. Du wirst zwar vermutlich nicht an die 64W kommen. Zumindest kenne ich keine TV-Software unter Win, die mit 3 Tunern gleichzeitig umgehen kann.

Alle Tests waren mit identischen Baugruppen und vollständig installierten Treibern. Wobei ich erstaunlicherweise die Tage erst festgestellt habe, dass bei der S480 das Laden der Firmware den Verbrauch nochmals um gut 2,5W ansteigen lässt. Unter Win 7 haben ich mit Mediaportal getestet. Dieses Programm kann mit beliebigen Tunern und Mischbestückungen umgehen :D und beherscht auch DVB-S2 im Gegensatz zur Mediacenter Version von MS.

In meinen letzten Versuchen bin ich bei manueller Installation vom VDR und Xineausgabe mit gleichen VDPAU Settings auf praktisch identische Werte gekommen. Warum mit beendetem Openbox und VDR beim Yavdr der Verbrauch nicht auf Windows oder Xubuntu Niveau im Leerlauf zurückfällt weiß ich leider immer noch nicht. Ist aber für die Praxis egal, weil da kommt es auf den realen Verbrauch an, wenn der VDR läuft.
Yavdr 0.5: KVM Server mit YAVDR als Host, Tyan Xeon Server, Virtualbox + KVM
Yavdr 0.5: Asus AT5iont-t, ION2, 4GB Ram, Momentus 2,5" 500GB, HEX TFX 300W 82+, Cine S2 V6.2 , 38W max.
Yavdr 0.5:
Zotac D2550ITXS-A-E mit GT610 OB, TT S2-4100 PCI-e ,Joujye NU-0568I-B
Yavdr 0.5:
Sandy Bridge G840, Tests und Energieverbrauch , CoHaus CIR, Cine S2 V6.2

Dirk

Super Moderator

Posts: 4,791

Location: am Rande der Zivilisation

Occupation: DvD -> Depp vom Dienst

  • Send private message

31

Monday, June 27th 2011, 8:50pm

Quoted

Warum mit beendetem Openbox und VDR beim Yavdr der Verbrauch nicht auf Windows oder Xubuntu Niveau im Leerlauf zurückfällt weiß ich leider immer noch nicht.


Das kannst du denke ich nur über powertop rausfinden, brauchst aber Zeit dafür :D

Meine Signatur

:]Heute ist nicht alle Tage, ich schreib wieder, keine Frage :]
VDR1: Silverstone LC14M, AMD X2-BE2350,2GB/1,5TB,DVB-s/s2/c,Gentoo,Kernel 3.8.5,VDR-2.0.0
VDR2: Silverstone GD05B, Intel G2020, Asrock B75-Pro3M, Asus GT610/2G, 8GB/1TB, YAVDR 0.5
VDR3: [Im Aufbau)Silverstone ML03, Intel G2020, Asrock B75-R2, 8GB/1TB

32

Monday, June 27th 2011, 9:40pm

Abend,

Also "pcie_aspm=force" bringt im Idle, wenn die Cine S2 nicht verwendet wird, bei mir 3 Watt Ersparnis.

Johns
Sag mir, wo die Developer sind. Wo sind sie geblieben? . . . . . . . . . . . . . . . . . . . . SoftHdDevice - A software and GPU emulated HD output device plugin.
Sag mir, wo die Developer sind. Was ist geschehn?

Client0: Crown CW02 MSI_C847MS-E33 Zotac_GT640_passiv Cine-S2 iMon-MCE / streamdev softhddevice
Client1: Lian_Li_PC-Q09FB ASRock_H67M-ITX/HT I3-2100 ASUS_ENGT520_passiv / streamdev softhddevice
Test: Lian_Li_PC-Q09R Asus C60M1-I / streamdev
Server0: Dockstar TT-S2-3600-USB / streamdev
Server2: Lian_Li_PC-Q07R Intel_DH61DL G620 WD20EARX LC75ITX Cine-S2+DuoFlex-S2 / streamdev / 22 Watt Verbrauch

  • "Torsten73" started this thread

Posts: 1,773

Occupation: Radio Fernsehtechniker

  • Send private message

33

Tuesday, June 28th 2011, 11:54pm

Aktuell ist 1.1.3 bzw, 1.98(beta), wobei du evtl. letztere nehmen solltest (kann mehr :D)
würde ich gerne, nur dummerweise gehts momentan nicht unter 64 bit (siehe Todo Liste)
Yavdr 0.5: KVM Server mit YAVDR als Host, Tyan Xeon Server, Virtualbox + KVM
Yavdr 0.5: Asus AT5iont-t, ION2, 4GB Ram, Momentus 2,5" 500GB, HEX TFX 300W 82+, Cine S2 V6.2 , 38W max.
Yavdr 0.5:
Zotac D2550ITXS-A-E mit GT610 OB, TT S2-4100 PCI-e ,Joujye NU-0568I-B
Yavdr 0.5:
Sandy Bridge G840, Tests und Energieverbrauch , CoHaus CIR, Cine S2 V6.2

  • "Torsten73" started this thread

Posts: 1,773

Occupation: Radio Fernsehtechniker

  • Send private message

34

Wednesday, June 29th 2011, 11:15pm

Aus dem PPA von Thomas C. die Lucid 64bit läuft auch unter Natty: https://launchpad.net/~thomas-creutz/+ar…Eppa1_amd64.deb
Yavdr 0.5: KVM Server mit YAVDR als Host, Tyan Xeon Server, Virtualbox + KVM
Yavdr 0.5: Asus AT5iont-t, ION2, 4GB Ram, Momentus 2,5" 500GB, HEX TFX 300W 82+, Cine S2 V6.2 , 38W max.
Yavdr 0.5:
Zotac D2550ITXS-A-E mit GT610 OB, TT S2-4100 PCI-e ,Joujye NU-0568I-B
Yavdr 0.5:
Sandy Bridge G840, Tests und Energieverbrauch , CoHaus CIR, Cine S2 V6.2

35

Thursday, June 30th 2011, 11:04pm

Also ich hab jetzt mal mein Sandy Bridge System mit Ubuntu 11.04 x86_64 gemessen.

Alle Empfehlungen von powertop (1.98-1ubuntu1~ppa1) standen auf good,
das 7" Touchscreen am Gehäuse war aus, VDR lief und es wurde ARD HD angezeigt:
~ 38,x Watt

Werde morgen oder die Tage noch mal einen Test mit der Option pcie_aspm=force machen.
Vielleicht schaffe ich es ja dann noch die 35 W Marke zu knacken...
HW I: Thermaltake DH 202, Intel DH67BL, Intel Pentium G630, TT Premium S2-6400, Crucial m4 SSD,
Fortron Source Aurum Gold 400W, Scythe Big Shuriken, LG DVD-RW GH22NS50, Kingston ValueRAM 4GB

HW II: A+case Cupid 2, Intel D945GSEJT, 512 MB RAM, 2x PCI Riser, Atric IR-Einschalter Rev. 5,
Hauppauge Nexus Rev 2.2, 60W 12V/DC, Slimline Samsung DVD-RW, CF/SATA-Adapter, 4 GB CF Card

  • "Torsten73" started this thread

Posts: 1,773

Occupation: Radio Fernsehtechniker

  • Send private message

36

Thursday, June 30th 2011, 11:34pm

Kannst Du feststellen wie hoch der Anteil der S2-6400 ist?
Offenbar ist für die Energiebillanz die FF sehr von Vorteil.

Wenn ich alle Optionen von Powertop aktiviere kommen dabei gerade mal 1,3W raus und auch nur wenn der VDR gestoppt ist. Außerdem bekomme ich dann input Lags von Maus und Tastatur, weswegen ich nicht empfehlen kann für USB Eingabegeräte das zu aktivieren.

Das traurige bei mir ist, dass sobald die Kiste was zu tun bekommt (vdr aktiv) steigt der Verbrauch auf 62-68W momentan. Die CPU hat keine Last, aber die Nvidia Karte macht trotz GT520 vieles zunichte. Außerdem bleibt sie auch bei SD permanent auf der 2. Taktstufe (maximaler Takt), was selbst ohne Videoausgabe fast 7W ausmacht. Mit Videoausgabe ist es kaum mehr, außer bei 1080i
Der PCIe_espm force kann man ganz leicht temporär aktivieren:
http://www.techytalk.info/2011/06/linux-…ion-workaround/
Wenn ich das richtig verstanden habe bringt aber nur was, wenn die PCIe Geräte im Leerlauf sind.

Wie sind Deine Settings für ARDHD? Normalerweise braucht es da keinen Deinterlacer, von daher ist 720p Ausgabe geringer im Verbrauch als SD mit Deinterlacing oder vor allem 1080i wie bei ServusTV.

PS schau mal im meine Energieverbrauchsumfrage rein ;D
Yavdr 0.5: KVM Server mit YAVDR als Host, Tyan Xeon Server, Virtualbox + KVM
Yavdr 0.5: Asus AT5iont-t, ION2, 4GB Ram, Momentus 2,5" 500GB, HEX TFX 300W 82+, Cine S2 V6.2 , 38W max.
Yavdr 0.5:
Zotac D2550ITXS-A-E mit GT610 OB, TT S2-4100 PCI-e ,Joujye NU-0568I-B
Yavdr 0.5:
Sandy Bridge G840, Tests und Energieverbrauch , CoHaus CIR, Cine S2 V6.2

37

Saturday, July 2nd 2011, 2:41pm

Kannst Du feststellen wie hoch der Anteil der S2-6400 ist?
Offenbar ist für die Energiebillanz die FF sehr von Vorteil.

Mit gestoppten VDR und entladenem DVB Treiber (saa716x_ff) liege ich ziemlich genau bei 23 Watt.
Mit geladenem DVB Treiber bei 31 Watt.

Der PCIe_espm force kann man ganz leicht temporär aktivieren:
http://www.techytalk.info/2011/06/linux-…ion-workaround/
Wenn ich das richtig verstanden habe bringt aber nur was, wenn die PCIe Geräte im Leerlauf sind.

Cool, danke dir, die Option pcie_aspm=force bringt bei mir aber nur 1 Watt, d.h. auf 37,x W.

Wie sind Deine Settings für ARDHD? Normalerweise braucht es da keinen Deinterlacer, von daher ist 720p Ausgabe geringer im Verbrauch als SD mit Deinterlacing oder vor allem 1080i wie bei ServusTV.

Da sehe ich hinsichtlich des Stromverbrauches keinen Unterschied zwischen Pro7 SD, ARD HD und ServusTV HD, liegt immer bei 37,x W.
HW I: Thermaltake DH 202, Intel DH67BL, Intel Pentium G630, TT Premium S2-6400, Crucial m4 SSD,
Fortron Source Aurum Gold 400W, Scythe Big Shuriken, LG DVD-RW GH22NS50, Kingston ValueRAM 4GB

HW II: A+case Cupid 2, Intel D945GSEJT, 512 MB RAM, 2x PCI Riser, Atric IR-Einschalter Rev. 5,
Hauppauge Nexus Rev 2.2, 60W 12V/DC, Slimline Samsung DVD-RW, CF/SATA-Adapter, 4 GB CF Card

  • "Torsten73" started this thread

Posts: 1,773

Occupation: Radio Fernsehtechniker

  • Send private message

38

Saturday, July 16th 2011, 9:16pm

Nun habe ich Gewissheit, ein Test mit Lucid 2.6.32 (easyvdr 0.9) mit identischen Einstellungen und Hardware ergibt folgende Messungen:

Der Yavdr Kernel 2.6.38 verbraucht bei identischen Deinterlacern mit aktiver HDD (temporal_spatial):
SD = 69,5W
720P = 66,3W
1080i = 73,7W
http://www.vdr-portal.de/board18-vdr-hardware/board84-allgemein/p1010148-sandy-bridge-projektvorstellung-tests-und-energieverbrauch/#post1010148



Nun der Test mit easyvdr 0.9 Kernel 2.6.32 Lucid
SD = 52,8W
720P = 51,9W
1080i = 54,8W




Dies sind rund 30% weniger. Mit HDD im Sleep Mode sind es sogar 48-50W.
Da ich alles andere ausgeschlossen habe, bleibt tatsächlich nur noch der Kernel als Ursache übrig. Ich werde nun beginnen mal mit neueren Mainline Kernel experimentieren.
Aufgrund meiner geringen Sachkenntnisse und cronischem Zeitmangel, wird es natürlich ein wenig dauern.
Yavdr 0.5: KVM Server mit YAVDR als Host, Tyan Xeon Server, Virtualbox + KVM
Yavdr 0.5: Asus AT5iont-t, ION2, 4GB Ram, Momentus 2,5" 500GB, HEX TFX 300W 82+, Cine S2 V6.2 , 38W max.
Yavdr 0.5:
Zotac D2550ITXS-A-E mit GT610 OB, TT S2-4100 PCI-e ,Joujye NU-0568I-B
Yavdr 0.5:
Sandy Bridge G840, Tests und Energieverbrauch , CoHaus CIR, Cine S2 V6.2

39

Monday, July 18th 2011, 7:34am

Diesen Kernel probieren:
https://bugs.launchpad.net/ubuntu/+sourc…131/comments/61

Dann wäre noch dieser kernel Parameter (pcie_aspm=force) :
https://bugs.launchpad.net/ubuntu/+sourc…131/comments/99

Wenn du einen lucid kernel in 0.4 installierst, dürftest du den gleichen Verbrauch sehen (wenn das geht).

So wie es aussieht, ist es eine Kombination von Ursachen - nicht alle sind gefunden. Phoronix macht da ein Riesen Tam-Tam draus, aber wenn es hilft das bisecting zu finanzieren um die Ursache zu finden warum nicht.

Mal schauen wo die Reise dann hingeht.
VDR User: 87 - LaScala LC14B - LG/Phillipps 6,4" VGA Display | Asrock H61/U3S3 | G630T | 1x 16GB Mobi Mtron 3035 1x WD 750GB 2,5" |1x L4m DVB-S2 Version 5.4

Treito

Professional

Posts: 1,439

Location: Bremen

  • Send private message

40

Monday, July 18th 2011, 9:06am

Nun habe ich Gewissheit, ein Test mit Lucid 2.6.32 (easyvdr 0.9) mit identischen Einstellungen und Hardware ergibt folgende Messungen:


100% Gewissheit hast Du damit ehrlich gesagt nicht. Weißt Du denn, welche Dienste im Hintergrund gestartet werden? Gewissheit hättest Du erst, wenn Du in easyVDR einen neueren Kernel installierst oder umgekehrt (in yaVDR 0.4Pre1 einen älteren).
Jetzt, wo ich das hier gerade schreibe, hätte ich noch eine Idee, was sein könnte: der Grafikkern. Evtl. liegt es an der Intel-Grafik, dass diese einmal leerläuft und einmal abgeschaltet ist, oder einmal leerläuft und einmal hoch getaktet ist.
Asus AT3N7A-I (Dualcore Intel Atom 330), Nvidia GeForce 9400 (onBoard), Pinnacle PCTV 452e, Mystique Satix S2 Sky USB Rev.2, AverTV Green Volar HD, X-Tensions DVB-T-380U, 2GB RAM, Xubuntu 12.04 mit yaVDR stable-Paketen, gepatchter Kernel 3.6.7, yaVDR 0.4, linux-media-dkms bzw. media-match 3.3, USB-IR-Einschalter (igorplug-kompatibel)
Gehäuse: Maxdata Favorit 5000i, Antennen: Strong SRT Ant 15 Eco, Selfsat HD30D4