Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: VDR Portal. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

Dirk

Super Moderator

  • »Dirk« ist der Autor dieses Themas

Beiträge: 5 059

Wohnort: am Rande der Zivilisation

Beruf: DvD -> Depp vom Dienst

  • Nachricht senden

1

Mittwoch, 15. Januar 2003, 14:35

vdr-time-0.0.1

Hi

Kam gerade über die Liste :D

Keine Ahnung, ob das überhaupt einen Interressiert ;)
----------------------------------------------
My Humax Receiver has a Clock Function that I enjoy very much. So I decided
to write a Plugin for VDR which allows me to see a small clock in the Top
right corner.

The Idea is to set a unused key from your remote control (for example the key
User1) to show the clock.

This can easily be done by adding the following line to your keymacros.conf

User1 @time

The clock will be disabled as soon as you press any other button. Otherwise
there would be a mess in the OSD.



Known issues:
A known issue of this plugin is that you can just adjust the position of the
clock from the top middle to the top right. Because this is my first plugin
for VDR I am writing and I am not a perfect C (C++) writer, I could not find
out jet how I can get the current resolution of the OSD that is stored in the
setup.conf. Hopefully I will find that out soon or I get a hint from somebody
;-)

Homepage:
http://vdr.humpen.at/

Download:
http://vdr.humpen.at/download/vdr-time-0.0.1.tgz
--
mfg
Mario "Charly" Aistleitner
Dirk

Meine Signatur

:]Heute ist nicht alle Tage, ich schreib wieder, keine Frage :]
VDR1: Silverstone LC14M, AMD X2-BE2350,2GB/1,5TB,DVB-s/s2/c,Gentoo,Kernel 3.8.5,VDR-2.0.0
VDR2: Silverstone GD05B, Intel G2020, Asrock B75-Pro3M, Asus GT610/2G, 8GB/1TB, YAVDR 0.5
VDR3: Silverstone ML03, Intel G2020, Asrock B75-R2, 8GB/1TB

2

Mittwoch, 15. Januar 2003, 17:06

RE: vdr-time-0.0.1

hi,

interressant wäre es, die uhr im vollbild dazustellen.
vielleicht beim mp3 hören...

J
MFG
JACOBSEN
------------------------------------------->
Microsoft ist nicht die Antwort!
Microsoft ist die Frage!
Und die Antwort lautet:
NEIN
------------------------------------------->

Dirk

Super Moderator

  • »Dirk« ist der Autor dieses Themas

Beiträge: 5 059

Wohnort: am Rande der Zivilisation

Beruf: DvD -> Depp vom Dienst

  • Nachricht senden

3

Mittwoch, 15. Januar 2003, 17:14

RE: vdr-time-0.0.1

Hi

Hab es selber noch nicht getestet!!!
Nur gelesen :D :D :D
Dirk

Meine Signatur

:]Heute ist nicht alle Tage, ich schreib wieder, keine Frage :]
VDR1: Silverstone LC14M, AMD X2-BE2350,2GB/1,5TB,DVB-s/s2/c,Gentoo,Kernel 3.8.5,VDR-2.0.0
VDR2: Silverstone GD05B, Intel G2020, Asrock B75-Pro3M, Asus GT610/2G, 8GB/1TB, YAVDR 0.5
VDR3: Silverstone ML03, Intel G2020, Asrock B75-R2, 8GB/1TB

marioais

Anfänger

Beiträge: 33

Wohnort: Oberösterreich

Beruf: Student

  • Nachricht senden

4

Mittwoch, 15. Januar 2003, 20:43

RE: vdr-time-0.0.1

Hi!

@jacobsen
Ich werde auf jeden Fall versuchen einen Vollbildmodus einzubauen, aber im Moment habe ich leider etwas wenig Zeit. Sobald ich wieder etwas mehr Zeit habe, werde ich das in mein Plugin einbauen.

mfg
Mario Aistleitner

maz

Profi

Beiträge: 1 204

Wohnort: NRW, Münster

Beruf: Dipl.-Ing.

  • Nachricht senden

5

Mittwoch, 15. Januar 2003, 21:08

Hi,

das plugin ist schon gar nicht schlecht, weißer Hintergrund ist sinnvoll für die Zahlen. Mich würde interessieren, ob man auch eine analoge Uhr einbauen könnte! Fände ich sehr schön, eine runde Uhr oben in der Ecke zu haben, ist aber - wie ich mir vorstellen kann - wahrscheinlich schon etwas schwiereiger zu realisieren; aber ist ja auch erst Version 0.0.1...
»maz« hat folgendes Bild angehängt:
  • Uhr2.jpg
Meine VDRs:
>>>Mac mini 2010 mit 2x Sundtek SkyTV Ultimate III, Logitech Harmony 300i, yavdr-0.5a mit softhddevice<<< >>>ZOTAC D2550 ITX-WIFI Supreme mit DD Cine S2, Gehäuse OrigenAE M10, Logitech Harmony 300i, yavdr-0.5a mit softhddevice<<< >>>Raspberry Pi
2 mit Sundtek SkyTV Ultimate IV, raspbian, rpihddevice-Plugin, Logitech Harmony 200<<<

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »maz« (15. Januar 2003, 21:17)


marioais

Anfänger

Beiträge: 33

Wohnort: Oberösterreich

Beruf: Student

  • Nachricht senden

6

Mittwoch, 15. Januar 2003, 21:17

An so einer Analogen Uhr habe ich selbst auch schon mal überlegt, aber dazu muss ich noch einiges dazulernen, wie ich mit dem OSD zeichnen kann. Ich bin leider auch kein Profi-Programmierer. Deshalb wirst Du da noch etwas Geduld haben müssen und wie 2 Beiträge weiter oben geschrieben habe ich im Moment gerade ziemlichen Stress mit Klausuren und so. Aber ich bin zuversichtlich, dass das irgendwie noch in mein Plugin reinkommen wird....

mfg
Mario Aistleitner

maz

Profi

Beiträge: 1 204

Wohnort: NRW, Münster

Beruf: Dipl.-Ing.

  • Nachricht senden

7

Mittwoch, 15. Januar 2003, 21:24

Hi, mann bist du schnell...

Zitat

Original von marioais
An so einer Analogen Uhr habe ich selbst auch schon mal überlegt, aber dazu muss ich noch einiges dazulernen, wie ich mit dem OSD zeichnen kann. Ich bin leider auch kein Profi-Programmierer. Deshalb wirst Du da noch etwas Geduld haben müssen und wie 2 Beiträge weiter oben geschrieben habe ich im Moment gerade ziemlichen Stress mit Klausuren und so.

so gehts mir auch, deshalb mein volles Verständnis...

Zitat

Original von marioais
Aber ich bin zuversichtlich, dass das irgendwie noch in mein Plugin reinkommen wird....

cool :)

mat
Meine VDRs:
>>>Mac mini 2010 mit 2x Sundtek SkyTV Ultimate III, Logitech Harmony 300i, yavdr-0.5a mit softhddevice<<< >>>ZOTAC D2550 ITX-WIFI Supreme mit DD Cine S2, Gehäuse OrigenAE M10, Logitech Harmony 300i, yavdr-0.5a mit softhddevice<<< >>>Raspberry Pi
2 mit Sundtek SkyTV Ultimate IV, raspbian, rpihddevice-Plugin, Logitech Harmony 200<<<

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »maz« (15. Januar 2003, 21:30)


marioais

Anfänger

Beiträge: 33

Wohnort: Oberösterreich

Beruf: Student

  • Nachricht senden

8

Montag, 20. Januar 2003, 21:35

Hi!

Ich melde mich wieder zurück! Es hat mir keine Ruhe gelassen. Deshalb habe ich den Vollbildmodus und die Analoge Uhr schon eingebaut.

Ich habe es mal gleich hier angehängt, oder Ihr schaut einfach auf meiner Seite vorbei:
http://vdr.humpen.at

Jede Art von Kritik ist natürlich herzlich willkommen!

mfg
Mario Aistleitner
»marioais« hat folgende Datei angehängt:
  • vdr-time-0.0.2.tgz (14,69 kB - 92 mal heruntergeladen - zuletzt: 3. Dezember 2016, 18:40)

maz

Profi

Beiträge: 1 204

Wohnort: NRW, Münster

Beruf: Dipl.-Ing.

  • Nachricht senden

9

Dienstag, 21. Januar 2003, 09:16

Hi,

ich hab Dein plugin sofort getestet; ich hab glaub ich noch nie so viele Änderungen von einer Version zur nächsten gesehen... :]
Ich finds wirklich ziemlich geil, nahezu alles lässt sich konfigurieren, und die analoge Uhr gefällt mir auch gut! Sehr gute Arbeit!
Leider gibt es manchmal noch Abstürze, wenn man bei angezeigter Uhr eine Taste drückt.

mfg

mat
Meine VDRs:
>>>Mac mini 2010 mit 2x Sundtek SkyTV Ultimate III, Logitech Harmony 300i, yavdr-0.5a mit softhddevice<<< >>>ZOTAC D2550 ITX-WIFI Supreme mit DD Cine S2, Gehäuse OrigenAE M10, Logitech Harmony 300i, yavdr-0.5a mit softhddevice<<< >>>Raspberry Pi
2 mit Sundtek SkyTV Ultimate IV, raspbian, rpihddevice-Plugin, Logitech Harmony 200<<<

marioais

Anfänger

Beiträge: 33

Wohnort: Oberösterreich

Beruf: Student

  • Nachricht senden

10

Dienstag, 21. Januar 2003, 23:23

Hi!

Das freut mich natürlich, wenn Dir die neue Version gefällt ;-)

Mit den Abstürzen tu ich mir ziemlich schwer das ganze nachzuvollziehen. Vielleicht kannst mir ja mal bescheid geben, bei welchen Tasten (-kombinationen) diese Abstürze passieren

mfg
Mario

11

Dienstag, 21. Januar 2003, 23:26

Hi

@mario
Wollte gerade mal das Plugin testen, sorry komme garade erst dazu :D Welchen Kompiler hast du? Ich habe GCC 3.2.1 , es läßt sich leider nicht kompilieren. Ich finde den "Fehler" aber selber. Wieder mal bool :) Ich wollte es nur gesagt haben. Hab gerade nicht viel Zeit.

Danke
Martini

marioais

Anfänger

Beiträge: 33

Wohnort: Oberösterreich

Beruf: Student

  • Nachricht senden

12

Dienstag, 21. Januar 2003, 23:33

Hi!
Ich verwende die Version 2.95.3.
Wann hast Du den das ganze heruntergeladen? Ich bin vorhin auf einen kleinen Fehler aufmerksam gemacht worde, nach dem ich ein "include" vergessen habe. Bei mir hat es ohne diesem funktioniert, aber anscheinend nicht bei allen. Ich habe es vor ca. einer halben Stunde hochgeladen. Allerdings unter der selben Versionsnummer, da es ja eigentlich keine wirkliche Veränderung ist.
Wenn es nicht daran gelegen ist kannst Du Dich gerne nochmal bei mir melden, damit wir den Fehler in den Griff bekommen.

mfg
Mario

13

Mittwoch, 22. Januar 2003, 17:40

@marioais & martini:

hi,

ich habe auch gcc 3.2 und scheitere am kompilieren:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
n file included from enhancedbitmap.c:1:
enhancedbitmap.h:35:7: warning: no newline at end of file
enhancedbitmap.c:9: default argument given for parameter 4 of `
   cEnhancedBitmap::cEnhancedBitmap(int, int, int, bool = true)'
enhancedbitmap.h:17: after previous specification in `
   cEnhancedBitmap::cEnhancedBitmap(int, int, int, bool = true)'
enhancedbitmap.c: In member function `void cEnhancedBitmap::DrawLine(int, int,
   int, int, eDvbColor, bool)':
enhancedbitmap.c:39: `abs' undeclared (first use this function)
enhancedbitmap.c:39: (Each undeclared identifier is reported only once for each
   function it appears in.)
enhancedbitmap.c: In member function `void cEnhancedBitmap::FillTriangle(int,
   int, int, int, int, int, eDvbColor, bool)':
enhancedbitmap.c:137: warning: passing `double' for argument 1 of `void
   cEnhancedBitmap::DrawLine(int, int, int, int, eDvbColor, bool)'
enhancedbitmap.c:137: warning: passing `double' for argument 3 of `void
   cEnhancedBitmap::DrawLine(int, int, int, int, eDvbColor, bool)'
make[1]: *** [enhancedbitmap.o] Error 1


vielleicht kann das ja behoben werden.
MFG
JACOBSEN
------------------------------------------->
Microsoft ist nicht die Antwort!
Microsoft ist die Frage!
Und die Antwort lautet:
NEIN
------------------------------------------->

14

Mittwoch, 22. Januar 2003, 19:15

HI

OK und Danke erstmal. Ich werde es nachher nochmal laden und testen. Ich melde mich dann nochmal.

Martini

15

Mittwoch, 22. Januar 2003, 20:00

Hallo

So, gerade nochmal getestet. Läßt sich aber nicht übersetzen, gleicher Fehler wie bei jacobsen. Kann mir auch mit meinen Standart-Nichtprogrammierer-Kenntnissen :D nicht weiterhelfen. ?(

Martini

marioais

Anfänger

Beiträge: 33

Wohnort: Oberösterreich

Beruf: Student

  • Nachricht senden

16

Mittwoch, 22. Januar 2003, 21:09

@jacobsen & martini

Der Fehler und die Warnings sollten jetzt beseitigt sein (Version 0.0.2a). Ich verwende noch einen älteren gcc (siehe weiter oben) und habe deshalb diese Fehler nicht bekommen. Jetzt sollte alles soweit funktionieren. Wenn nicht, meldet euch bitte einfach wieder.

Zum download wieder unter http://vdr.humpen.at

mfg
Mario

17

Mittwoch, 22. Januar 2003, 21:16

hallooo

Danke Mario. Kann erst später testen, habe gerade etwas Chaos verursacht :D . Ich sage dir dann bescheid wenns funzt. Hast du jetzt auf gcc 3.2 geupdatet oder wie hast du das gemacht ?

Vielen Dank
martini

marioais

Anfänger

Beiträge: 33

Wohnort: Oberösterreich

Beruf: Student

  • Nachricht senden

18

Mittwoch, 22. Januar 2003, 21:22

Bitte!

Ich habe nicht upgedatet! Ich habe einfach anhand der Fehlermeldungen die Fehler (Warnings) behoben. Aber es sollte jetzt alles funktionieren. Wenn doch nicht, dann bitte einfach wieder melden!

mfg
Mario

19

Mittwoch, 22. Januar 2003, 22:40

hi.
bekomme zwar noch eine Meldung

Quellcode

1
enhancedbitmap.h:35:7: warning: no newline at end of file

aber es funktioniert.
Vielen Dank.
MfG

marioais

Anfänger

Beiträge: 33

Wohnort: Oberösterreich

Beruf: Student

  • Nachricht senden

20

Mittwoch, 22. Januar 2003, 22:45

Das kann schon mal vorkommen! Habe einfach in der letzten Zeile kein return mehr gemacht! Aber jetzt sollte auch das behoben sein. ;-)

Immortal Romance Spielautomat