You are not logged in.

Dear visitor, welcome to VDR Portal. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

41

Saturday, July 29th 2006, 9:30am

Ich hab das jetzt nochmals mit dem anderen Beitrag verglichen. holger schreibt aber auch was von einem patch...des kann ich leider aber nicht zuordnen bei x-vdr.

irgend wo muss wohl der avcodec fest mit rein?????

Zulu, kannst bitte nochmal einen blick in den thread werfen. DANKE
<font color="#0000ff">Gigabyte P35-DS3, Pentium E2140, GT220, 2 x DVB-C im Thermaltake DH101<br>gen2vdr V3 &amp; yaVDR 0.3.0a <br></font>

42

Saturday, July 29th 2006, 4:48pm

...und bei muggle scheitere ich mit:
Jul 29 16:33:48 vdr vdr: [2634] info: mysql_server_init failed

habe mysql in die rcconf eingetragen.
<font color="#0000ff">Gigabyte P35-DS3, Pentium E2140, GT220, 2 x DVB-C im Thermaltake DH101<br>gen2vdr V3 &amp; yaVDR 0.3.0a <br></font>

duc

Professional

Posts: 733

Location: Erlangen

Occupation: IT consultant

  • Send private message

43

Saturday, July 29th 2006, 5:40pm

graphtft

hallo,

hab ne weile gesucht und jetzt hab ichs endlich gefunden.
bezüglich des graphtft problems via dvb. schaut euch mal diesen thread an, da steht die lösung eures problems oder besser mchrisz' problem.

[edit]
wegen muggle:
wenn du muggle nicht mit dem embedded sql betreiben willst, musst du irgendwo im makefile von muggle HAVE_MYSQL=1 angeben. oder so ähnlich, musst mal im readme nachschauen.
falls du das nicht schon berücksichtigt hast, hab jetzt nicht den ganzen thread genau durchgelesen.
[edit/]

grüße
frank
Board: ASUS AT5IONT-I, 4 GB Ram
DVB Karte: Tevii S480
40 GB ssd als boot/systemplatte (2,5" Wechelrahmen, um auf einer anderen Platte ein Testsystem zu installieren)
3x2TB hdd für /media
Medion X10 Fernbedienung
yaVDR 0.5
Samsung UE46D5700

This post has been edited 1 times, last edit by "duc" (Jul 29th 2006, 5:43pm)


44

Sunday, July 30th 2006, 12:21am

danke duc,
jetzt läuft es! 8)
<font color="#0000ff">Gigabyte P35-DS3, Pentium E2140, GT220, 2 x DVB-C im Thermaltake DH101<br>gen2vdr V3 &amp; yaVDR 0.3.0a <br></font>

45

Sunday, July 30th 2006, 1:09pm

Hi,
nun klappt es auch mit graphtft über vdr/1 :)

Ich habe nur Tabs und Pfade angepasst.
Der Patch muss nach x-vdr/plugins/graphtft/patches/p4
und in graphtft-ffmpeg-0.4.9.patch umbenannt werden.

Könnt ihr zu muggle noch ein bisschen mehr erzählen?

Gruss
Marc
zulu has attached the following file:
>>>> x-vdr <<<< Installations-Skript für einen VDR mit Debian als Basis

duc

Professional

Posts: 733

Location: Erlangen

Occupation: IT consultant

  • Send private message

46

Sunday, July 30th 2006, 10:30pm

Quoted

Original von zulu
Könnt ihr zu muggle noch ein bisschen mehr erzählen?


mal schaun. wo klemmts denn ?
bei mir läuft muggle prima, bis auf die coveranzeige wie mir neulich erst aufgefallen ist. hab das allerdings schon mit einer älteren version von x-vdr installiert. war glaub ich sogar noch ne 0.4-er version.

grüße
frank
Board: ASUS AT5IONT-I, 4 GB Ram
DVB Karte: Tevii S480
40 GB ssd als boot/systemplatte (2,5" Wechelrahmen, um auf einer anderen Platte ein Testsystem zu installieren)
3x2TB hdd für /media
Medion X10 Fernbedienung
yaVDR 0.5
Samsung UE46D5700

47

Sunday, July 30th 2006, 10:40pm

Bei mir läufts nicht.

Ist mir aber auch nicht so wichtig zulu. Ich habs jeweils mit mysql und sqlite probiert.

Installiert sind bei mir beide pakete. Da im log nichts erscheint, weiss ich auch nicht mehr wo ich suchen soll...

Bin sehr froh dass graftft jetzt funktioniert und für die mucke gibts ja immer noch den mp3ng.
<font color="#0000ff">Gigabyte P35-DS3, Pentium E2140, GT220, 2 x DVB-C im Thermaltake DH101<br>gen2vdr V3 &amp; yaVDR 0.3.0a <br></font>

This post has been edited 1 times, last edit by "MChrisZ" (Jul 31st 2006, 8:07am)


48

Monday, July 31st 2006, 8:15pm

muggle

Hi Frank,
ich bekomme das mit der Datenbank und SQL nicht ans laufen. Installiert werden libmysqlclient15-dev, mysql-server und mysql-client. Da ich aber muggle selber nicht benutze, bin ich auch nicht richtig motiviert.
Von Amtswegen wäre es natürlich schöner, es würde sofort nach der Installation laufen.

Gruss
Marc
>>>> x-vdr <<<< Installations-Skript für einen VDR mit Debian als Basis

49

Monday, July 31st 2006, 10:32pm

ich bekomms gerade gar nicht mehr hin:
Plugin muggle:
make[1]: Entering directory `/usr/local/src/vdr-1.4.1/PLUGINS/src/muggle-0.1.11'
make[1]: Leaving directory `/usr/local/src/vdr-1.4.1/PLUGINS/src/muggle-0.1.11'
make[1]: Entering directory `/usr/local/src/vdr-1.4.1/PLUGINS/src/muggle-0.1.11'
g++ -g -O2 -Wall -Woverloaded-virtual -fPIC -D_GNU_SOURCE -DPLUGIN_NAME_I18N='"muggle"' -DHAVE_MYSQL -I../DVB/include -I../../../ -I../../..//include -I../DVB/include -I/usr/include/taglib -I/usr/include/mysql -DBIG_JOINS=1 -c muggle.c
muggle.c:21:24: error: vdr/getopt.h: Datei oder Verzeichnis nicht gefunden
/usr/include/taglib/fileref.h:89: warning: 'class TagLib::FileRef::FileTypeResolver' has virtual functions but non-virtual destructor
make[1]: *** [muggle.o] Fehler 1
make[1]: Leaving directory `/usr/local/src/vdr-1.4.1/PLUGINS/src/muggle-0.1.11'

hab auch by the way die neue version genommen. die ist käfergereinigt ;-)

muss dieses /getopt.h in mal ausklammern in muggle.c...

meld mich dann nochmal

so da hab ich nun:
ganz oft immer wieder sowas:
(.text+0x340): undefined reference to `SSL_load_error_strings'
/usr/lib/mysql/libmysqld.a(viosslfactories.o): In function `new_VioSSLAcceptorFd':
(.text+0x358): undefined reference to `SSL_library_init'
/usr/lib/mysql/libmysqld.a(viosslfactories.o): In function `new_VioSSLAcceptorFd':
(.text+0x35d): undefined reference to `OpenSSL_add_all_algorithms'
/usr/lib/mysql/libmysqld.a(viosslfactories.o): In function `vio_verify_callback':
(.text+0x38c): undefined reference to `X509_STORE_CTX_get_current_cert'
/usr/lib/mysql/libmysqld.a(viosslfactories.o): In function `vio_verify_callback':
(.text+0x396): undefined reference to `X509_STORE_CTX_get_error'
/usr/lib/mysql/libmysqld.a(viosslfactories.o): In function `vio_verify_callback':
(.text+0x39e): undefined reference to `X509_STORE_CTX_get_error_depth'

und am ende:

(.text+0x568): undefined reference to `SSL_load_error_strings'
/usr/lib/mysql/libmysqld.a(viosslfactories.o): In function `new_VioSSLConnectorFd':
(.text+0x579): undefined reference to `SSL_library_init'
/usr/lib/mysql/libmysqld.a(viosslfactories.o): In function `new_VioSSLConnectorFd':
(.text+0x57e): undefined reference to `OpenSSL_add_all_algorithms'
collect2: ld returned 1 exit status
make: *** [mugglei] Fehler 1
<font color="#0000ff">Gigabyte P35-DS3, Pentium E2140, GT220, 2 x DVB-C im Thermaltake DH101<br>gen2vdr V3 &amp; yaVDR 0.3.0a <br></font>

This post has been edited 1 times, last edit by "MChrisZ" (Jul 31st 2006, 10:59pm)


50

Tuesday, August 1st 2006, 12:20am

Acpi=1

Hi nochmal,

ich hab noch probs mit dem wakeup. Mit linvdr läuft auf der mühle acpi problemlos.

jetzt hab ich es auch in der shutdown.conf mit ACPI=1 aktiviert, doch leider ist er bisher noch nicht aufgewacht. Wo gibts weitere einstellungen dazu?

danke
<font color="#0000ff">Gigabyte P35-DS3, Pentium E2140, GT220, 2 x DVB-C im Thermaltake DH101<br>gen2vdr V3 &amp; yaVDR 0.3.0a <br></font>

This post has been edited 1 times, last edit by "MChrisZ" (Aug 1st 2006, 12:20am)


duc

Professional

Posts: 733

Location: Erlangen

Occupation: IT consultant

  • Send private message

51

Tuesday, August 1st 2006, 12:37am

Quoted

Original von MChrisZ
ich bekomms gerade gar nicht mehr hin:
Plugin muggle:
make[1]: Entering directory `/usr/local/src/vdr-1.4.1/PLUGINS/src/muggle-0.1.11'
make[1]: Leaving directory `/usr/local/src/vdr-1.4.1/PLUGINS/src/muggle-0.1.11'
make[1]: Entering directory `/usr/local/src/vdr-1.4.1/PLUGINS/src/muggle-0.1.11'
g++ -g -O2 -Wall -Woverloaded-virtual -fPIC -D_GNU_SOURCE -DPLUGIN_NAME_I18N='"muggle"' -DHAVE_MYSQL -I../DVB/include -I../../../ -I../../..//include -I../DVB/include -I/usr/include/taglib -I/usr/include/mysql -DBIG_JOINS=1 -c muggle.c
muggle.c:21:24: error: vdr/getopt.h: Datei oder Verzeichnis nicht gefunden
/usr/include/taglib/fileref.h:89: warning: 'class TagLib::FileRef::FileTypeResolver' has virtual functions but non-virtual destructor


das ist klar, da fehlt die taglib. ich würde die taglib und die taglib-devel nachistallieren. steht aber im readme von muggle auch drin.

error: vdr/getopt.h: Datei oder Verzeichnis nicht gefunden

ist mir auch nicht klar, auch beim rest mit den SQL fehlern. das würde ich mal im muggle thread posten. lars ist normalerweise sehr hilfsbereit.

@ marc:
ich verstehe das ganze sowieso nicht. hast du was an dem teil, der muggle installiert geändert? wie obern schon erwähnt, bei mir läuft es prima und ich habe es ausschliesslich mit deinem script installiert und nichts nachgebessert.
ich hab nur leider meinen vdr grad nicht im hause (bin unterwegs, hab urlaub), sonst könnte ich mal nachschauen. muggle war bisher noch nie ein problem. du solltest übrigens ruhig mal ausprobieren, ist ein klasse plugin. wenn man seine id3 tags in den mp3 gut gepflegt hat, kann man dank der datenbank geniale sachen machen. eben mal schnell ne playlist zusammenklicken, die alles an hardrock aus den 70ern spielt und sowas.

ok, ich wünsche weiterhin viel erfolg.
frank
Board: ASUS AT5IONT-I, 4 GB Ram
DVB Karte: Tevii S480
40 GB ssd als boot/systemplatte (2,5" Wechelrahmen, um auf einer anderen Platte ein Testsystem zu installieren)
3x2TB hdd für /media
Medion X10 Fernbedienung
yaVDR 0.5
Samsung UE46D5700

This post has been edited 1 times, last edit by "duc" (Aug 1st 2006, 12:38am)


52

Tuesday, August 1st 2006, 10:56am

Hi,
muggle-0.1.11 kompiliert bei mir auch nicht (taglib ist vorhanden).
Dafür läuft nun die 0.1.10 mit sqlite. Allerdings musste ich die Datenbank mit mugglei erstellen. Mit dem Plugin selber bekomme ich die nachwievor nicht angelegt. Aber mal sehen...

Gruss
Marc
>>>> x-vdr <<<< Installations-Skript für einen VDR mit Debian als Basis

53

Tuesday, August 1st 2006, 11:04am

re: acpi

Zum ACPI Wakeup habe ich leider schlechte Nachrichten:
Wie es aussieht hat kano im rc4 kein /proc/acpi/alarm mit drinne.

Das heisst wohl Kernel neu übersetzen oder Update auf kernel-2.6.17.7-slh-up-1, da ist /proc/acpi/alarm wieder dabei.
Ob der Alarm es damit auch wirklich tut, kann ich allerdings noch nicht sagen.

Ich teste das aber...

Gruss
Marc
>>>> x-vdr <<<< Installations-Skript für einen VDR mit Debian als Basis

54

Tuesday, August 1st 2006, 11:15am

dann sollte ich es mal mit nvram probieren oder geht das auch nichT?

reicht dort das setzen der "nvram=1" ?

gibts eigentlich auch ne art standby oder ist es das schon. das würde die bootzeiten ja extrem beschleunigen ;-)
<font color="#0000ff">Gigabyte P35-DS3, Pentium E2140, GT220, 2 x DVB-C im Thermaltake DH101<br>gen2vdr V3 &amp; yaVDR 0.3.0a <br></font>

55

Tuesday, August 1st 2006, 11:33am

Quoted

dann sollte ich es mal mit nvram probieren oder geht das auch nichT?

Das kommt auf dein MB an.

Quoted

reicht dort das setzen der "nvram=1" ?

Nein! /usr/lib/vdr/scripts/vdrshutdown ist für einen poweroff-kernel konfiguriert.

Wenn du einen poweroff-kernel für dein MB benötigst, muss du den installieren und dann lilo einrichten. Falls du keinen brauchst, musst du Line 82 und 83 in der vdrshutdown anpassen.

Source code

1
2
3
#sudo $VDRSCRIPTDIR/vdr2root lilo
#sudo $VDRSCRIPTDIR/vdr2root reboot
sudo $VDRSCRIPTDIR/vdr2root shutdown


Die vdrschutdown aus < 0.6.1hat in Line 67 noch einen kleinen Fehler

Source code

1
2
-WAKEUPTIME= $(($WAKEUPTIME -$BOOT_TIME))
+WAKEUPTIME=$(($WAKEUPTIME - $BOOT_TIME))


Gruss
Marc
>>>> x-vdr <<<< Installations-Skript für einen VDR mit Debian als Basis

pat

Master

Posts: 1,950

Location: Alsace/France

Occupation: Informatique

  • Send private message

56

Tuesday, August 1st 2006, 9:49pm

playlist als plugin dazu

Hallo Zulu,

Diesmal hat da Update super geklapt bei mir . Danke. :)

Könntest du das plugin playlist dazu nehmen Danke .

Ich habe auch schon zum teil drin das plugins gelinkt auf /usr/lib/vdr/plugins/ kopiert leider und die /etc/default/vdr erweitert. Fehlt noch was ??
Ja die /usr/bin/runvdr

Ein Paar Start Probleme wenn der vdr neu gestart wird dann geht es nicht mehr mit xine. Neustart System . :(

Gruss Pat

Diskless Client: SMT 7020S und S100 128SDRAM 32DOM zendeb 0.4.0 beta1 mit MMS 1.0.8.5
Hardware: Pundit-R Celeron 2.4 256DDRAM Samsung SATA 400 Gbyte Festplatte Hauppage Nexus-S Rev 2.3 Nova-S Plus DVD-RAM LG
Software: EasyVDR 0.6.0 (vdr-1.6.0-2-ext64), LinVDR 0.7 1.4.7 Mahlzeit, SUSE-Server 10.2 1.6.0-1
Test System: Shuttel AMD Athlon 2.6 Ghz 256DDRAM Samsung 250Gbyte Hauppage Nexus-S Rev 2.3 DVD-RAM LG ......

:fans :welle

This post has been edited 2 times, last edit by "pat" (Aug 1st 2006, 10:14pm)


57

Tuesday, August 1st 2006, 10:21pm

hi,
echt mies mit dem acpi X(

naja, hab noch nie was mit nvram gemacht.

guess-helper hab ich alles nach wiki gemacht
den poweroff-kernel bekommt man wo? komplett neuer kernel..?
<font color="#0000ff">Gigabyte P35-DS3, Pentium E2140, GT220, 2 x DVB-C im Thermaltake DH101<br>gen2vdr V3 &amp; yaVDR 0.3.0a <br></font>

This post has been edited 1 times, last edit by "MChrisZ" (Aug 1st 2006, 10:22pm)


58

Tuesday, August 1st 2006, 10:58pm

Hi Pat,
ich kann dein Problem nicht nachvollziehen. Xine startet hier einwandfrei, auch nach mehreren VDR Neustarts.

Gruss
Marc
>>>> x-vdr <<<< Installations-Skript für einen VDR mit Debian als Basis

duc

Professional

Posts: 733

Location: Erlangen

Occupation: IT consultant

  • Send private message

59

Tuesday, August 1st 2006, 11:08pm

ich hab mal für dich gegoogelt, der dritte trefferwar der richtige, dort habe ich folgendes gelesen:

Download the reboot package from http://sourceforge.net/projects/nvram-wakeup/

also hol dir das paket rebbot von dem angegebenen link und pack es aus, darin ist die der kernel enthalten (bzImage.2.4.20.poweroff).

grüße
frank
Board: ASUS AT5IONT-I, 4 GB Ram
DVB Karte: Tevii S480
40 GB ssd als boot/systemplatte (2,5" Wechelrahmen, um auf einer anderen Platte ein Testsystem zu installieren)
3x2TB hdd für /media
Medion X10 Fernbedienung
yaVDR 0.5
Samsung UE46D5700

This post has been edited 1 times, last edit by "duc" (Aug 1st 2006, 11:08pm)


60

Tuesday, August 1st 2006, 11:21pm

Hi Chris,

Quoted

echt mies mit dem acpi

Ja, finde ich auch bescheuert. Selber benutze ich nur den nvram-wakeup, deswegen ist mir das garnicht aufgefallen.

Ich habe den kernel-2.6.17.7-slh-up-1 auf meinem Testrechner installiert. Da ist der alarm dabei. Ob es damit funktioniert kann ich im Moment leider nicht testen.
Kano packt für die neuen Kernel einen Installer dabei. Also nur runterladen, entpacken und starten.

Allerdings muss dann nochh gcc-4.1 installiert und damit Lirc neu erstellt werden.


Den bzImage.2.6.9.poweroff bekommst du hier .

Entpacken und nach /boot kopieren.
/etc/lilo.conf anpassen (ein Beispiel liegt in x-vdr/extra)
Wichtig -> label=PowerOff , append kann jenach MB abweichen

Quoted

image=/boot/bzImage.2.6.9.poweroff
append="apm=power-off acpi=off"
label=PowerOff
read-only

und lilo ausführen.

Gruss
Marc
>>>> x-vdr <<<< Installations-Skript für einen VDR mit Debian als Basis