You are not logged in.

Dear visitor, welcome to VDR Portal. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

maverick-me

Professional

  • "maverick-me" started this thread

Posts: 659

Location: Berlin

  • Send private message

1

Monday, March 16th 2009, 10:28am

Noad für 1.7.4 TS-Aufnahmen

Hi, gibt es einen Patch, um noad mit TS-Aufnahmen nutzen zu können?

Habe hier zwar etwas gefunden, eine noad Version für Drembox, die mit TS funktionieren soll, aber es läuft nicht.

Hat da schon jemand eine funktionierende Version?

Gruß Patrick
Server: 2 GB RAM; 8TB HDD; Ubuntu 10.04

Client 1: Intel Dual E2200, 2GB RAM, 250GB HDD, NOVA T 500, TT 1500 DVB-C, 2 x TT S3200 Ubuntu 12.04

Client 2: AMD AM2 E1650, 1GB RAM, 200GB HDD, TT 1500 DVB-C, YaVDR-0.5.0

2 x SMT mit Ubuntu 10.04 + Xineliboutput

This post has been edited 1 times, last edit by "maverick-me" (Mar 16th 2009, 10:34am)


maverick-me

Professional

  • "maverick-me" started this thread

Posts: 659

Location: Berlin

  • Send private message

2

Monday, March 16th 2009, 8:57pm

Keiner?

Oder gibt es mittlerweile etwas anderes / besseres als NOAD?
Server: 2 GB RAM; 8TB HDD; Ubuntu 10.04

Client 1: Intel Dual E2200, 2GB RAM, 250GB HDD, NOVA T 500, TT 1500 DVB-C, 2 x TT S3200 Ubuntu 12.04

Client 2: AMD AM2 E1650, 1GB RAM, 200GB HDD, TT 1500 DVB-C, YaVDR-0.5.0

2 x SMT mit Ubuntu 10.04 + Xineliboutput

3

Monday, March 16th 2009, 9:06pm

so wie ich das sehe nutzt so gut wie keiner vdr 1.7.4 weil fast keine plugins und hilfsprogramme damit tun.
dazu zaehlt natuerlich auch noad.
2003 - 2011 - R.I.P.

SHF

Sage

Posts: 3,861

Location: hessische Bergstrasse

  • Send private message

4

Tuesday, March 17th 2009, 12:22am

Was passiert denn, wenn du Noad (den "normalen") auf eine TS-Aufnahme loslässt?
Ein paar Fehlermeldungen oder so könnten hilfreich sein.

Welche Noad-Version setzt du ein?
Sind alle Patchesdrin?
Gruss
SHF


Mein VDR:

vdr-1.4.3-4 mit BigPatch und Plugin BigPack, SuSE 9.0, Kernel 2.4.21, DVB Treiber 06.07.2005 FullTS-Patch, noad 0.6.1
auf HP Vectra VLi8 (PIII 500, 256MB), 16GB 2,5" SSD (Sytem und Swap), 2TB HDD* (Video), 1x TT FF DVB-S 1.5 FullTS-Mod, 1x TT Budget DVB-S

(* Weil ich das inzwischen öfters gefragt wurde: Nein, das BIOS erkennt die grossen Platten nicht vollständig, das stört Linux aber nicht!)

maverick-me

Professional

  • "maverick-me" started this thread

Posts: 659

Location: Berlin

  • Send private message

5

Tuesday, March 17th 2009, 1:21pm

Hi,

Also natürlich hab ich es mit dem original Noad probiert, aber der findet natürlich keine Aufnahme
in dem Ordner, da alle Dateien ander heißen als bei den PES Aufnahmen
(001.vdr ist jetzt 00001.ts, index.vdr wurde zu index).

Auch nach dem einfachen anpassen der Dateinamen im Quelltext, kann er mit den Aufnahmedateien nichts anfangen.

Dann hab ich mal die Noad Version aus dem Link in meinem ersten Post ausprobiert, in der der TS-Support
mit drin sein soll, ist aber für die Dreambox angepasst.
Leider sucht auch auch diese Version nach xxx.vdr Dateien. Also dort auch die Dateiname und Endungen
im Quelltext geändert, und siehe da er probiert wenigstens. Hört aber nach 2 Sekunden wieder auf
mit der Meldung kein Logo gefunden.

Hier bin ich dann erstmal nicht weitergekommen.

Logmeldungen kann ich erst heute abend liefern.

Bin ich wirklich der einzige, der entweder
A: Probiert noad mit der 1.7.4'er, mit TS-Aufnhamen zum laufen versucht zubekommen, oder
B: zu doof ist den richtigen Patch zu finden :-)

Gruß Patrick
Server: 2 GB RAM; 8TB HDD; Ubuntu 10.04

Client 1: Intel Dual E2200, 2GB RAM, 250GB HDD, NOVA T 500, TT 1500 DVB-C, 2 x TT S3200 Ubuntu 12.04

Client 2: AMD AM2 E1650, 1GB RAM, 200GB HDD, TT 1500 DVB-C, YaVDR-0.5.0

2 x SMT mit Ubuntu 10.04 + Xineliboutput

6

Tuesday, March 17th 2009, 7:17pm

zu A: ja
zu B: nein. Es gibt derzeit vermutlich nicht viele, die VDR 1.7.4 einsetzen. Das ganze ist bleeding edge und sollte ja sowieso nur in Entwicklungsumgebungen eignesetzt werden, nicht im produktiven Umfeld. Das schreibt Klaus ja auch immer wieder in die Ankündigungen. Es ist auch nicht ganz auszuschleßen, dass sich das TS-Format nochmal etwas ändert wenn es notwendig ist. Deshalb hat wohl momentan keiner großartig Lust, dort Aufwand reinzustecken ...

lostinspc

Intermediate

Posts: 562

Location: Stuttgart

  • Send private message

7

Tuesday, March 17th 2009, 8:56pm

Quoted

Originally posted by maverick-me
.....
Bin ich wirklich der einzige, der entweder
A: Probiert noad mit der 1.7.4'er, mit TS-Aufnhamen zum laufen versucht zubekommen, oder
B: zu doof ist den richtigen Patch zu finden :-)


zu A: nein (Habe ich auch schon versucht, tut natürlich nicht)
zu B: Ehrlich: Habe noch nicht danach gesucht, schneide wieder "von Hand". Kann aber manchmal ganz schon lästig sein, wäre mal Zeit für nen patch ;-)

Ansonsten läuft die 1.7.4 hier bei mir seit es sie gibt völlig problemlos, maximal ein kosmetisches Problem (nach dem Spulen ist bei ner FF der Ton manchmal nicht lippensyncron, aber das Problem gabs früher ja auch schon mal)
Was die Plugins betrifft: "Meine" laufen fast alle: mp3/mplayer, epgsearch, skinenigmang, live, femon. Nur extrecmenu läuft nicht mehr, dafür nehme ich jetzt liemikuutio

Umwandeln in DVD mit externen Tools (ProjectX und DeVeDe) ist auch problemlos.

Grüße, Peter
SW: vdr-latest, softhddevice -git, nvidia 331.38 , arch x86_64
HW: 1x Cine C/T V6, 1x Satelco Budget DVB-C, Asus P5G41-M, 2 GB, Pentium 6300, Asus G210 passiv, 60 GB Samsung SSD 470, 3TB WD AV GP (WD30EURS) , Silverstonetek LaScala 10M, LG LM 669S, 1920x1080@50
VDR-User #81

SHF

Sage

Posts: 3,861

Location: hessische Bergstrasse

  • Send private message

8

Wednesday, March 18th 2009, 12:08am

Quoted

Original von maverick-me
Also natürlich hab ich es mit dem original Noad probiert, aber der findet natürlich keine Aufnahme
in dem Ordner, da alle Dateien ander heißen als bei den PES Aufnahmen
(001.vdr ist jetzt 00001.ts, index.vdr wurde zu index).

Auch nach dem einfachen anpassen der Dateinamen im Quelltext, kann er mit den Aufnahmedateien nichts anfangen.
Da hast du ja schon das naheliegenste probiert.

Quoted

Dann hab ich mal die Noad Version aus dem Link in meinem ersten Post ausprobiert, in der der TS-Support
mit drin sein soll, ist aber für die Dreambox angepasst.
Leider sucht auch auch diese Version nach xxx.vdr Dateien. Also dort auch die Dateiname und Endungen
im Quelltext geändert, und siehe da er probiert wenigstens. Hört aber nach 2 Sekunden wieder auf
mit der Meldung kein Logo gefunden.
War das eine HDTV Aufnahme?
Evtl. sollte man mal versuchen die Änderungen zum Standard-Noad nachvollziehen (diff, die Frage ist nur, gegen welche Version) und diese dann übertragen.
Gruss
SHF


Mein VDR:

vdr-1.4.3-4 mit BigPatch und Plugin BigPack, SuSE 9.0, Kernel 2.4.21, DVB Treiber 06.07.2005 FullTS-Patch, noad 0.6.1
auf HP Vectra VLi8 (PIII 500, 256MB), 16GB 2,5" SSD (Sytem und Swap), 2TB HDD* (Video), 1x TT FF DVB-S 1.5 FullTS-Mod, 1x TT Budget DVB-S

(* Weil ich das inzwischen öfters gefragt wurde: Nein, das BIOS erkennt die grossen Platten nicht vollständig, das stört Linux aber nicht!)

maverick-me

Professional

  • "maverick-me" started this thread

Posts: 659

Location: Berlin

  • Send private message

9

Wednesday, March 18th 2009, 10:37am

RE: Noad für 1.7.4 TS-Aufnahmen

OK,

Jetzt hab ich mal etwas experimentiert, und es sieht so aus, als ob
ich mit etwas abgucken von der Dreambox Version einen Patch erstellen konnte, der auch soweit funktioniert.

Jetzt das große ABER:

es wird jeweils nur die erste Datei (also 00001.ts) der Aufnahme gescannt.

Da komm ich jetzt erstmal nicht weiter.

Jemand anderes noch eine Idee, wie man Noad jetzt noch überredet bekommt alle Datein durchzuscannen?

hier mal die erste Testversion des Patches gegen Noad 0.6.0.
Wie schon geschrieben wird aber nur die erste ts Datei gescannt.
maverick-me has attached the following file:
Server: 2 GB RAM; 8TB HDD; Ubuntu 10.04

Client 1: Intel Dual E2200, 2GB RAM, 250GB HDD, NOVA T 500, TT 1500 DVB-C, 2 x TT S3200 Ubuntu 12.04

Client 2: AMD AM2 E1650, 1GB RAM, 200GB HDD, TT 1500 DVB-C, YaVDR-0.5.0

2 x SMT mit Ubuntu 10.04 + Xineliboutput

This post has been edited 1 times, last edit by "maverick-me" (Mar 18th 2009, 10:38am)


maverick-me

Professional

  • "maverick-me" started this thread

Posts: 659

Location: Berlin

  • Send private message

10

Wednesday, March 18th 2009, 10:40am

RE: Noad für 1.7.4 TS-Aufnahmen

achso, hab ich noch vergessen.

der Dateiname, also "00001.ts" ist fest im Quelltext (ts.cpp) eingetragen,
weiß aber nicht wie ich es hinbekomme alle verfügbaren TS-Dateien einzutragen.

Gruß PAtrick
Server: 2 GB RAM; 8TB HDD; Ubuntu 10.04

Client 1: Intel Dual E2200, 2GB RAM, 250GB HDD, NOVA T 500, TT 1500 DVB-C, 2 x TT S3200 Ubuntu 12.04

Client 2: AMD AM2 E1650, 1GB RAM, 200GB HDD, TT 1500 DVB-C, YaVDR-0.5.0

2 x SMT mit Ubuntu 10.04 + Xineliboutput

SHF

Sage

Posts: 3,861

Location: hessische Bergstrasse

  • Send private message

11

Wednesday, March 18th 2009, 11:16pm

Die Funktion, die die Dateien durchschaltet seint auskommentiert zu sein (vdr_cl.h).
Ob es reicht den Kommentar zu entfernen bezweifele ich nach diesem Kommentar:

Quoted

(von Hier )
[...] Daher muß die 7025 Aufzeichnung, die im TS-Format vorliegt in das VDR-Format konvertiert werden. D.h. es wird auf der Harddisk für die Berechnung der Werbeunterbrechungen eine temporäre Kopie der Aufzeichnung angelegt, damit wird für die Berechnung je nach Aufzeichung 2-5GB freier Speicher benötigt.
Irgendwie sieht das mir nicht nach einer sauberen Lösung aus. Das zum laufen zu bringen dürfte eine menge Frickelei werden, da kann man das wahrscheinlich gleich gescheit neu schreiben.

Ich denke man sollte sich eher nach einer Lib umsehen mit der man die PES-Daten aus dem TS quasi transparent beim einlesen extrahieren kann. Das müsste es eigentlich irgendwo bei den DVB-Toools oder so geben.

Quoted

Original von maverick-me
es wird jeweils nur die erste Datei (also 00001.ts) der Aufnahme gescannt.
Da setzt er dann aber auch die Schnittmarken?

Wo du es schon am laufen hast, was passiert denn mit HD-Aufnahmen?
Gruss
SHF


Mein VDR:

vdr-1.4.3-4 mit BigPatch und Plugin BigPack, SuSE 9.0, Kernel 2.4.21, DVB Treiber 06.07.2005 FullTS-Patch, noad 0.6.1
auf HP Vectra VLi8 (PIII 500, 256MB), 16GB 2,5" SSD (Sytem und Swap), 2TB HDD* (Video), 1x TT FF DVB-S 1.5 FullTS-Mod, 1x TT Budget DVB-S

(* Weil ich das inzwischen öfters gefragt wurde: Nein, das BIOS erkennt die grossen Platten nicht vollständig, das stört Linux aber nicht!)

12

Saturday, September 12th 2009, 11:43pm

Hallo, hab ein neues Patch angelegen, das das alles von maverick gemachten beinhaltet, jetzt aber auch alle die .ts Dateien scannt. Ausserdem sind ein paar Korrektierungen drin die wohl bei mir (?) nötig beim Übersetzen sind. Jetzt scheint noad wirklich wie vorher mit den PES funktionieren.
antoine- has attached the following file:

Brougs78

Master

Posts: 2,452

Location: Tirol (A)

  • Send private message

13

Sunday, September 13th 2009, 3:51pm

Hi!

Habe das mal bei Schlag den Raab von gestern probiert und das Ergebnis sah sehr gut aus. Allerdings scheint das Springen zwischen den Marken nicht mehr einwandfrei zu funktionieren.
D.h. wenn man z.B. 9 drückt und auf eine Marke kommt, kann man davon nicht mehr wegspringen (mit 7 oder 9) und diese auch nicht verschieben. Mit Play oder einem Minutensprung kommt man dann schon weg.
Kann es sein, dass die Timecodes keine I-Frames mehr angeben oder sowas in der Richtung?

Test unter vdr-1.7.8.

Gruß,
Brougs78
- -- --- ================================================================ --- -- -
VDR-Konfig: Antec Fusion, Intel E5200, Asus P5N7A-VM (VDPAU), 2xDVB-s2 // yavdr-0.2
- -- --- ================================================================ --- -- -

» Mein VDR-Zeugs (OSDImage-Plugin, Enigma-Skin): brougs78.vdr-developer.org «

This post has been edited 2 times, last edit by "Brougs78" (Sep 13th 2009, 3:52pm)


14

Sunday, September 13th 2009, 4:24pm

Quoted

Original von Brougs78
D.h. wenn man z.B. 9 drückt und auf eine Marke kommt, kann man davon nicht mehr wegspringen (mit 7 oder 9) und diese auch nicht verschieben. Mit Play oder einem Minutensprung kommt man dann schon weg.

Sowas habe ich gestern auch bei 1.7.9 beobachtet, allerdings ohne noad.

15

Sunday, September 13th 2009, 4:29pm

Hm, das problem kenn ich aber schon länger. Zur zeit läuft 1.7.7.
- VDR: Thermaltake DH 102 mit 7" TouchTFT * Mystique SaTiX-S2 Dual * Debian Wheezy/vdr-2.1.5/graphtft/MainMenuHooks-Patch * Intel Petium G3220 * DH87RL * Zotac GT630 * 1 TB System HDD * 4 GB Corsair Vegance * Harmony 900 (39-44W)
- Server: Zotac H55-ITX WiFi, Core i3 540, 4GB RAM, 4x4TB 3.5" WD RED + 1x500GB 2.5", Cine S2, vdr-2.1.6
- vdr-theme-darkred: https://github.com/TheChief79/vdr-theme-darkred

Brougs78

Master

Posts: 2,452

Location: Tirol (A)

  • Send private message

16

Sunday, September 13th 2009, 4:40pm

Hi!

Hatte ich sonst eigentlich selten. Ab und zu hatte ich mit älteren noad-Versionen den Effekt, dass es eine Marke ganz am Anfang erstellt hat die nicht gelöscht werden konnte.

Bei einer Folge "Two and a Half Men" waren die Marken einwandfrei anzuspringen.

Gruß,
Brougs78
- -- --- ================================================================ --- -- -
VDR-Konfig: Antec Fusion, Intel E5200, Asus P5N7A-VM (VDPAU), 2xDVB-s2 // yavdr-0.2
- -- --- ================================================================ --- -- -

» Mein VDR-Zeugs (OSDImage-Plugin, Enigma-Skin): brougs78.vdr-developer.org «

17

Monday, September 14th 2009, 10:27am

schnittmarken nicht anspringbar

Moinmoin !
Ich weiss nicht, ob mein Problem auch damit zusammenhängt, aber bei meiner vdr-1.7.8 Version funktioniert die Eingabe einer 2 beim Springen zu einer bestimmten Position in der Aufnahme (Taste rot) nicht.
Ein Sprung zu z.B. 1:59 funktioniert einwandfrei, wenn man aber zu 2:00 springen möchte, wird sofort der Schnitt gestartet, wenn man die Taste 2 drückt.

18

Tuesday, September 15th 2009, 10:53am

RE: noad für TS-Patch

Nochmal moinmoin !

Ich habe jetzt in der Gen2VDR 3 das noad mit emerge --unmerge noad deinstalliert, die plain noad-0.6.0 gezogen, den TS-Patch angewendet (eine Wanung, dass die config.h bereits existiert wurde angezeigt), ./configure, make und make install ausgeführt. Bis dahin sah alles gut aus.

Allerdings wird das noad nicht fertig.

Es laufen jetzt inzwischen (nach ca 20 Stunden Betriebsdauer) 4 noad-Prozesse mit je ca. 20% CPU-Last.

Fehlt mir noch ein Patch?

This post has been edited 1 times, last edit by "fraenk" (Sep 15th 2009, 11:01am)


19

Sunday, November 29th 2009, 11:48pm

Hallo,

ich habe den hier geposteten patch mit diesen:

http://git.gekrumbel.de/?p=noad.git

Patches verbunden. Leider in 2 Dateien, wegen maximaler erlaubter Dateigröße für Dateianhänge im Forum. Also die Dateien verbinden, das Ergebnis mit bzip2 entpacken und auf noad-0.6.0 anwenden.

Erste Tests mit TS sehen gut aus. Muss aber natürlich noch weiter getestet werden, ist also im Moment noch alpha.

Markus
MarkusE has attached the following files:
VDR1: ASUS P5QC, Dual Core 3G, Cine S2, Ext. Board von TBE, Ubuntu 12.04, VDR 2.0x
VDR2: ASUS P4B533, Celeron 2.4G, FF 1.5, Ubuntu 10.10, VDR 1.6 (SS2 Rev 2.6B)
VDR Server: sheeva-plug

Posts: 5,027

Location: Main-Spessart

  • Send private message

20

Saturday, December 19th 2009, 10:56am

Kann noad mit diesem Patch weiterhin auch mit PES umgehen?
VDR4Arch-Next --> Lian-Li PC-C37B | ASRock Q1900M | 4GB RAM | SanDisk SDSSDP064G | Samsung HD155UI | DD Cine S2 V6.2 | ZOTAC GT630 (Rev. 2) Zone Edition