Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: VDR Portal. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Montag, 1. Dezember 2008, 15:05

mplayer: "pts after filters MISSING"

Hi,

bei der Einrichtung von Vodcatcher bin ich darauf gestossen, daß ich mit mplayer keine m4v-Dateien abspielen kann.

Die Filme rasen in affenartiger Geschwindigkeit ohna Sound durch und ich bekommen unendlich viele:

Quellcode

1
pts after filters MISSING


solange bis der mplayer offenbar genug hat und die Aktion mit:

Quellcode

1
2
3
4
Too many audio packets in the buffer: (4096 in 1048122 bytes).
Maybe you are playing a non-interleaved stream/file or the codec failed?
For AVI files, try to force non-interleaved mode with the -ni option.
pts after filters MISSING


abbricht.

Hat jemand eine Idee woran das liegen kann ?

steffx

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »steffx« (1. Dezember 2008, 15:05)


2

Montag, 1. Dezember 2008, 15:16

So sieht das Ganze dann im Log aus:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
resume: resume file is '/mnt/movies/.mplayer.resume'
resume: successfully opened resume file
resume: searching resume  position for 'wdr_fernsehen_quarks_und_co_20080108.mp4'
resume: found resume position 32.0%
logger: *** Starting mplayer.sh Version 0.8.7
logger: *** DEBUG: Variable CFGFIL has value "/vdr/conf/plugins/mplayer/mplayer.sh.conf"
logger: *** Use Option USERDEF at your own risk!
logger: *** INFO: Source Video has Resolution of 320 x 240 ...
logger: *** INFO: For Sqare Pixels we would scale to 384 x 288 ...
MPlayer dev-SVN-r28045-4.3 (C) 2000-2008 MPlayer Team
CPU: AMD Duron(tm)  (Family: 6, Model: 8, Stepping: 1)
CPUflags:  MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 0
Compiled for x86 CPU with extensions: MMX MMX2 3DNow 3DNowEx SSE
130 audio & 258 video codecs

PLAYING /mnt/movies/wdr_fernsehen_quarks_und_co_20080108.mp4

libavformat file format detected.
[lavf] Video stream found, -vid 0
[lavf] Audio stream found, -aid 1
VIDEO:  [avc1]  320x240  24bpp  25.000 fps    0.0 kbps ( 0.0 kbyte/s)
Clip info:
 name: 08.01.2008, Was Mumien verraten
 author: Quarks & Co
Opening /dev/dvb/adapter0/video0+audio0
Opening video filter: [lavc=5000:25]
Opening video filter: [expand w=352 h=288 x=-1 y=-1 osd=1]
Expand: 352 x 288, -1 ; -1, osd: 1, aspect: 0.000000, round: 1
Opening video filter: [scale w=352 h=288]
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)
==========================================================================
==========================================================================
Opening audio decoder: [faad] AAC (MPEG2/4 Advanced Audio Coding)
FAAD: compressed input bitrate missing, assuming 128kbit/s!
AUDIO: 48000 Hz, 2 ch, s16le, 128.0 kbit/8.33% (ratio: 16000->192000)
Selected audio codec: [faad] afm: faad (FAAD AAC (MPEG-2/MPEG-4 Audio) decoder)
==========================================================================
Opening /dev/dvb/adapter0/audio0
Opening /dev/dvb/adapter0/audio0
AO: [mpegpes] 48000Hz 2ch s16be (2 bytes per sample)
PLAYBACK STARTED
mplayer: slave cmd: seek 32.0 1
mplayer: slave cmd: mute
mplayer: volume=0 mpVolume=100 mpMute=1
mplayer: slave cmd: get_time_length
mplayer: slave cmd: get_percent_pos
[h264 @ 0x8d425f0]AVC: Consumed only 10 bytes instead of 18
VDec: vo config request - 320 x 240 (preferred colorspace: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is undefined - no prescaling applied.
SwScaler: reducing / aligning filtersize 5 -> 4
SwScaler: reducing / aligning filtersize 5 -> 4
SwScaler: reducing / aligning filtersize 5 -> 4
SwScaler: reducing / aligning filtersize 5 -> 4
[swscaler @ 0x8e18d70]BICUBIC scaler, from yuv420p to yuv420p using MMX2
[swscaler @ 0x8e18d70]using 4-tap MMX scaler for horizontal luminance scaling
[swscaler @ 0x8e18d70]using 4-tap MMX scaler for horizontal chrominance scaling
[swscaler @ 0x8e18d70]using n-tap MMX scaler for vertical scaling (YV12 like)
[swscaler @ 0x8e18d70]320x240 -> 352x288
[mpeg1video @ 0x8d41d60]removing common factors from framerate
VO: [mpegpes] 352x288 => 384x288 Mpeg PES
pts after filters MISSING
pts after filters MISSING
mplayer: slave cmd: get_time_length
mplayer: slave cmd: get_percent_pos
pts after filters MISSING
pts after filters MISSING
pts after filters MISSING
pts after filters MISSING
pts after filters MISSING
pts after filters MISSING
pts after filters MISSING
pts after filters MISSING
pts after filters MISSING
pts after filters MISSING
pts after filters MISSING
pts after filters MISSING
pts after filters MISSING

... usw


steffx

3

Mittwoch, 4. Februar 2009, 10:11

Hab die Tage auch fummeln müssen bis es ging:

Quellcode

1
2
3
4
5
6
# Workaround for mp4 / mov
if test "${SUFFIX}" == ".mov" -o "${SUFFIX}" == ".MOV" -o "${SUFFIX}" == ".mp4" || `echo "$VIDEO_FORMAT"| egrep -q "avc1"` || `echo "$VIDEO_FORMAT"| egrep -q "jpeg"`; then
   CMDLINE="$MPLAYER -vo $VO $AOUT -demuxer mov -vf scale=656:492${DETC},expand=720:576:-1:-1:0,$VOP:$NEW_FPS $SPEED $FDSTR $CACHESTR $REMOTE $SUBTITLES $USERDEF $FORCEIDX"
else
   CMDLINE="$MPLAYER -vo $VO $AOUT -vf scale=$NEW_X:${NEW_Y}${DETC},expand=$NEW_X:$REAL_Y:-1:-1:0,$VOP:$NEW_FPS $SPEED $FDSTR $CACHESTR $REMOTE $SUBTITLES $USERDEF $FORCEIDX"
fi


Wichtig ist das ' -demuxer mov'. Mit 4/3 Filmchen und 4/3 TV passt die Skalierung so aber auch ganz gut.

Bye
>>>> x-vdr <<<< Installations-Skript für einen VDR mit Debian als Basis

4

Sonntag, 20. Februar 2011, 13:07

^^ wo fügeich denn die Zeilen ein...
die player.sh finde ich nicht auf dem ctvdr7

wo trage ich das ein?
yavdr .4 & msi MA 785 GMT UD2H & amd cpu & 4GB RAM & GF210 & 240 GB HD & HP WIN NOVA S2 HD & RC Sony RM0082 & Wireless MS Keys&Mouse

5

Samstag, 16. April 2011, 18:59

Hallo,
wo fügeich denn die Zeilen ein...
die player.sh finde ich nicht auf dem ctvdr7

wo trage ich das ein?
wenn ich das richtig sehe, müsstest Du in /usr/share/vdr-plugin-mplayer/mplayer in ca. Zeile 589 das finden, was in der beschriebenen Anleitung im ELSE steht und diese Zeile genau durch den oben genannten Code ersetzen. Scheint bei mir zu funktionieren...

Tschööö
rfu
:vdr2 Server: vdr 2.2.0 auf Ubuntu 14.04, Client: vdr 2.2.0 auf RPi (raspbian)

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »rfu« (17. April 2011, 15:02)


Immortal Romance Spielautomat