You are not logged in.

Dear visitor, welcome to VDR Portal. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Saturday, August 16th 2008, 4:44pm

VDR wacht mit acpi-wakup nicht mehr auf (nach Kernelupdate)

Habe auf den Kernel 2.6.26.2 upgedatet. Alle Konfigurationsdatein sind angepasst. Ich habe allerdings schon ein Problem, wenn ich mit

echo 0 > /sys/class/rtc/rtc0/wakealarm
echo `date '+%s' -d '+ 30 minutes'` > /sys/class/rtc/rtc0/wakealarm

eine Zeit setze. Diese ist korrekt mit

cat /proc/driver/rtc

abfragbar und stimmt. Die korrekte "Sekundenzahl" steht in der Datei

/sys/class/rtc/rtc0/wakealarm

allerdings nur bis zu einem Durchstarten des Systems. Nach dem Neustart stimmt die Zeit mit cat /proc/driver/rtc immer noch, die Datei wakealarm ist allerdings leer. Ist das normal oder zeigt dies auf einen Fehler?

Wer wiess Rat?

Hier noch die Ausgabe von /proc/driver/rtc:

Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
cat /proc/driver/rtc
rtc_time        : 16:47:01
rtc_date        : 2008-08-16
alrm_time       : 18:16:59
alrm_date       : 2008-08-16
alarm_IRQ       : yes
alrm_pending    : no
24hr            : yes
periodic_IRQ    : no
update_IRQ      : no
HPET_emulated   : no
DST_enable      : no
periodic_freq   : 1024
batt_status     : okay


Stimmen hier alle Parameter? Was bedeudet speziell alram_IRQ? Nach korrekter Einstellung der Weckzeit steht dieser auf yes, nach einem Reeboot (auch vor der Aufwachzeit) auf no. Kommt hier ein anderer Prozess in die Quere?
VDR: c't-VDR 6.1 - Gigabyte GA-MA69GM-S2H - Gainward 9400GT - 2GB

This post has been edited 1 times, last edit by "thomas_slrot" (Aug 16th 2008, 4:48pm)


heinzelrumpel

Professional

Posts: 1,237

Location: Grenzach

Occupation: Admin

  • Send private message

2

Saturday, August 16th 2008, 5:57pm

RE: VDR wacht mit acpi-wakup nicht mehr auf (nach Kernelupdate)

Hi,

Bios Zeit steht auf UTC?
VDR No 1:
T-Online Vision S100 mit streamdev-client auf 2GB OCZ Rally USB-Stick

VDR No 2:
T-Online Vision S100 mit streamdev-client auf 2GB OCZ Rally USB-Stick


3

Sunday, August 17th 2008, 12:07pm

RE: VDR wacht mit acpi-wakup nicht mehr auf (nach Kernelupdate)

Alle Zeiten sind nach meiner Erkenntnis rchtig eingestellt. Hatte auch schon andere Varianten probiert. Der rechner wacht auch nicht 2 Stunden früher/später auf.

Eine weitere Frage: Wie kann ich eigentlich die installierte Version von vdr-addon-acpiwakeup abfragen? Gibt es hier vielleicht auch eine Neuere? Wo bekomme ich die am esten her?
VDR: c't-VDR 6.1 - Gigabyte GA-MA69GM-S2H - Gainward 9400GT - 2GB

This post has been edited 1 times, last edit by "thomas_slrot" (Aug 17th 2008, 12:12pm)


4

Sunday, August 17th 2008, 12:50pm

Hallo,

ich habe bei mir das gleiche Problem.

Mit Kernel 2.6.25.15 funktioniert das Aufwachen einwandfrei, bei 2.6.26.x geht es nicht.

Vielleicht haben die Kernel Entwickler etwas verschlimmbessert?

Gruß,
Farseer
Streaming server: SuSE 11.0, Skystar2-budget, Scenic Pro D7, vdr-1.6.0-1 selber compiliert
Wohnzimmer: SuSE 11.0, TT 1.6, ASUS M2A-VM HDMI in Scenic 600 Gehäuse, vdr 1.6.0-1 selber compiliert

5

Sunday, August 17th 2008, 1:25pm

Quoted

Original von Farseer
Hallo,

ich habe bei mir das gleiche Problem.

Mit Kernel 2.6.25.15 funktioniert das Aufwachen einwandfrei, bei 2.6.26.x geht es nicht.

Vielleicht haben die Kernel Entwickler etwas verschlimmbessert?

Gruß,
Farseer


Und ich dachte schon es liegt an mir, dass ich das mit 2.6.26.2 nicht zum laufen kriege ;)
Vielleicht sollte ich beim 2.6.25.15 dann nochmal ausprobieren mit rtc enabled zu compilieren, denn da nutze ich nach wie vor /proc/acpi/alarm (also rtc disabled).
Server: Athlon II X2 250 - Asus M3N-H HDMI - 2x1GB RAM - 3TB HDDs -
1 x Digital Devices Cine S2 V6 DVB-S2 (SD Sender im Highband funktionieren mit der Karte nach wie vor unter Linux nicht, unter Windows schon)
3 x Nova Budget (die ich eigentlich durch die Cine S2 mit Erweiterungsmodul ersetzen wollte, leider aber für die SD Sender immer noch brauche)
mit yavdr 0.4.0

e9hack

Professional

Posts: 1,641

Location: BW in der Nähe von Esslingen

  • Send private message

6

Sunday, August 17th 2008, 3:39pm

Hi,

der PC kann beim Schreiben einer Weckzeit nach /sys/class/rtc/rtc0/wakealarm nicht aus dem Power-Down aufwachen, da der ACPI Alarm-Event nicht aktiviert wird. Die meisten BIOSe benutzen auch nicht die Alarmdatumsregister der normalen Uhr, um ein Weckdatum zu setzen. Das neue RTC-Interface ist damit eigentlich komplett nutzlos.

Gruß
e9hack

7

Sunday, August 17th 2008, 6:39pm

Vielen Dank für die Tipps. Ich bin zurück zum kernel 2.6.25.15, dieser funktioniert einwandfrei (mit /proc/acpi/alarm).

Die letzte Aussage habe ich allerdings nicht ganz verstanden. Es gibt wohl mehrere Möglichkeite, einen rechner zu starten, warum aber gerade das RTC-Interface nicht funktionieren sollte, verstehe ich nicht. Dachte, das sei das gleiche wie das, das ich jetzt benutze (mit Datei /proc/acpi/alarm)?
VDR: c't-VDR 6.1 - Gigabyte GA-MA69GM-S2H - Gainward 9400GT - 2GB

8

Sunday, August 17th 2008, 6:45pm

@e9hack

bei mir funktioniert mit Kernel 2.6.25.15 das rtc Interface (/sys/class/rtc/rtc0/wakealarm) problemlos.

Nur eben nicht bei 2.6.26.x.

Gruß,
Farseer
Streaming server: SuSE 11.0, Skystar2-budget, Scenic Pro D7, vdr-1.6.0-1 selber compiliert
Wohnzimmer: SuSE 11.0, TT 1.6, ASUS M2A-VM HDMI in Scenic 600 Gehäuse, vdr 1.6.0-1 selber compiliert

e9hack

Professional

Posts: 1,641

Location: BW in der Nähe von Esslingen

  • Send private message

9

Sunday, August 17th 2008, 10:06pm

Quoted

Original von Farseer
@e9hack

bei mir funktioniert mit Kernel 2.6.25.15 das rtc Interface (/sys/class/rtc/rtc0/wakealarm) problemlos.

Nur eben nicht bei 2.6.26.x.


Stimmt, hast recht. Was mir auffällt, bei 2.6.25.x ist alarm_IRQ no und bei 2.6.26.2 yes. Ich mache es mir beim testen mit der Zeit auch einfacher: echo "+300" > /sys/../wakealarm setzt die Zeit auf in 5min.

Gruß
e9hack

e9hack

Professional

Posts: 1,641

Location: BW in der Nähe von Esslingen

  • Send private message

10

Tuesday, August 19th 2008, 7:54pm

Mit einem kleinen Patch gehts auch mit Kernel 2.6.26.2. Was man noch beachten sollte: Wenn die CMOS-Uhr auf Lokalzeit läuft, muß man bei allen absoluten Zeitangaben 2h addieren:

echo `date +'%s' -d '+ 2 hours + 4 minutes'` > /sys/class/rtc/rtc0/wakealarm

Ab Kernel 2.6.26 kann man auch Offsetzeiten angeben:

echo "+240" /sys/class/rtc/rtc0/wakealarm

Der Patch hat bei meinem Board (MSI K8NGM2-FID) auch noch den Vorteil, daß RTC-Wakeup im BIOS nicht mehr aktiviert werden muß.

Gruß
e9hack
e9hack has attached the following file:

11

Saturday, August 23rd 2008, 1:28pm

Hallo,

da das Problem den Kernel-Entwicklern anscheinend noch unbekannt ist, würde ich gerne eine Mail an die LKML bzw. einen Bugzilla-Eintrag schreiben, um das zu beseitigen.

Deshalb erstmal eine Liste mit Boards, bei denen ACPI-Wakeup mit 2.6.26 nicht mehr läuft:
Gigabyte GA-6OXM7
MSI K8NGM2-FID

@thomas_slrot, Farseer, Egalus: Könntet ihr bitte eure Boards ergänzen?

Ich habe ein git bisect durchgeführt und rausbekommen, dass commit ACPI: Disable Fixed_RTC event when installing RTC handler die Regression verursacht.

Quoted

Original von e9hack
Mit einem kleinen Patch gehts auch mit Kernel 2.6.26.2.


Ich habe deinen Patch mit diesem Stand getestet, und er funktioniert bei mir nicht.
Könntest du bitte kurz erläutern, was der Patch macht?

MfG, Stefan
Asus P4B533, Northwood 2,8 GHz, Mystique CaBiX
Gentoo
nvram-wakeup

This post has been edited 1 times, last edit by "estebe" (Aug 23rd 2008, 1:30pm)


e9hack

Professional

Posts: 1,641

Location: BW in der Nähe von Esslingen

  • Send private message

12

Saturday, August 23rd 2008, 2:16pm

Quoted

Original von estebe

Quoted

Original von e9hack
Mit einem kleinen Patch gehts auch mit Kernel 2.6.26.2.


Ich habe deinen Patch mit diesem Stand getestet, und er funktioniert bei mir nicht.

Der Patch funktioniert dummerweise nicht, da bei mir noch eine andere Änderung aktiv war und die Shutdown-Routinen vom RTC-Treiber nie aufgerufen werden. Fogender Patch sollte funktionieren:

Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
--- drivers/rtc/rtc-cmos.c.save	2008-08-20 20:11:37.000000000 +0200
+++ drivers/rtc/rtc-cmos.c	2008-08-23 10:51:41.000000000 +0200
@@ -213,6 +213,8 @@
 	sec = t->time.tm_sec;
 	sec = (sec < 60) ? BIN2BCD(sec) : 0xff;
 
+	if (cmos->wake_off)
+		cmos->wake_off(dev);
 	hpet_set_alarm_time(t->time.tm_hour, t->time.tm_min, t->time.tm_sec);
 	spin_lock_irq(&rtc_lock);
 
@@ -247,6 +249,8 @@
 	}
 
 	spin_unlock_irq(&rtc_lock);
+	if (t->enabled && cmos->wake_on)
+		cmos->wake_on(dev);
 
 	return 0;
 }
Damit wacht mein K8NGM2-FID und Kernel 2.6.26.3 wieder auf.

Laut ACPI-Spec darf ein Aufwachen aus dem S5-State (Shutdown) eigentlich nicht funktionieren. Das Aufwachen darf nur aus Sleep-Modes (S1 bis S4) funktionieren. Bei Wechsel nach S5 muß das BIOS alle Wake-Events (RTC, PCI-Devices, ...) deaktivieren.

Gruß
e9hack

13

Saturday, August 23rd 2008, 3:27pm

Quoted

Originally posted by estebe

@thomas_slrot, Farseer, Egalus: Könntet ihr bitte eure Boards ergänzen?


Ist mein Wohnzimmerrechner, also ASUS M2A-VM HDMI.

Gruß,
Farseer
Streaming server: SuSE 11.0, Skystar2-budget, Scenic Pro D7, vdr-1.6.0-1 selber compiliert
Wohnzimmer: SuSE 11.0, TT 1.6, ASUS M2A-VM HDMI in Scenic 600 Gehäuse, vdr 1.6.0-1 selber compiliert

14

Saturday, August 23rd 2008, 3:48pm

Quoted

Original von e9hack
Der Patch funktioniert dummerweise nicht, da bei mir noch eine andere Änderung aktiv war und die Shutdown-Routinen vom RTC-Treiber nie aufgerufen werden. Fogender Patch sollte funktionieren:

[snip]

Damit wacht mein K8NGM2-FID und Kernel 2.6.26.3 wieder auf.


Jap, nun funktionierts hier auch. Vielen Dank!

Quoted

Original von e9hack
Laut ACPI-Spec darf ein Aufwachen aus dem S5-State (Shutdown) eigentlich nicht funktionieren. Das Aufwachen darf nur aus Sleep-Modes (S1 bis S4) funktionieren. Bei Wechsel nach S5 muß das BIOS alle Wake-Events (RTC, PCI-Devices, ...) deaktivieren.


Ja, dass er laut Spec eigentlich nicht aufwachen darf wusste ich. Mir ist nur die Semantik der Funktionszeiger wake_on und wake_off im struct cmos_rtc nicht klar. Ist deren Aufruf nach dem Freigeben / vor dem Belegen von rtc_lock ok?

Ich habe mittlerweile einen Bugzilla-Eintrag erstellt. @e9hack: Wenn du meinst dein Patch ist so ok (s.o.) würde ich ihn gern mit anhängen, was sagst du dazu?

MfG, Stefan
Asus P4B533, Northwood 2,8 GHz, Mystique CaBiX
Gentoo
nvram-wakeup

e9hack

Professional

Posts: 1,641

Location: BW in der Nähe von Esslingen

  • Send private message

15

Saturday, August 23rd 2008, 4:34pm

Quoted

Original von estebe
Mir ist nur die Semantik der Funktionszeiger wake_on und wake_off im struct cmos_rtc nicht klar. Ist deren Aufruf nach dem Freigeben / vor dem Belegen von rtc_lock ok?

Ich habe das bei cmos_suspend() abgeschrieben. Da wird das auch außerhalb vom Lock aufgerufen. In 2.6.27.rc4 ist es dann wieder innerhalb des Lock.

Quoted


Ich habe mittlerweile einen Bugzilla-Eintrag erstellt. @e9hack: Wenn du meinst dein Patch ist so ok (s.o.) würde ich ihn gern mit anhängen, was sagst du dazu?

Du kannst das als Lösungsvorschlag schon mit anhängen. OK ist es aus meiner Sicht nicht da

1) das alles im Shutdown-Händler gemacht werden sollte, dieser aber beim Runterfahren nie aufgerufen wird.

2) man möglicherweise enable/disable_irq_wake() aufrufen muß, wenn wake_on/off nicht verfügbar ist.

Gruß
e9hack

Frodo

Professional

Posts: 1,649

Location: Hessen

  • Send private message

16

Sunday, August 24th 2008, 5:51pm

@e9hack
Ich habe den Patch bei mir bereits beim Kernel 2.6.25.11-0.1-default von openSUSE 11 anwenden müssen.

Nun funktioniert es aber endlich mit meinem M3A-H/HDMI und openSUSE11 + eHD. Das gleiche gilt für das Asus M2A-VM/HDMI.

Den Kernel 2.6.26.3 konnte ich leider nicht verwenden da sich hiermit der multiproto-plus DVB-Treiber nicht übersetzen lässt den ich für meine Hardware Kombination benötige:

TT FF-DVB-S mit TS-MOD
TT 3200 DVB-S2
Reel eHD

Vielen Dank für den Patch. :sonne
Gruß
Frodo

Meine VDR Hardware


YaVDR 0.5: TT S2-6400 und Sundtek SkyTV Ultimate (DVB-S/S2), Zotac H77ITX-C-E, Geforce 620, SilverStone ML02B-MXR, IMON LCD, softhddevice / dvbhddevice
YaVDR 0.5: Sat>IP (OctopusNet) über vtunerc, Zotac D2550ITX, Geforce 610, IMON VFD, softhddevice
YaVDR 0.5: Cine S2 V6, Intel DQ67SW, Geforce 210, SilverStone LC16M, IMON VFD, softhddevice
YaVDR 0.5: TT S2-3200, Intel DH67BL, Geforce 430, softhddevice
YaVDR 0.5: TT S2-6400, Intel DH67CF, dvbhddevice
Test HD TV-Karten: TT S2-3200, Sundtek SkyTV Ultimate (DVB-S/S2) , TeVii S480, TT-connect CT-3650 CI

This post has been edited 1 times, last edit by "Frodo" (Aug 25th 2008, 10:11am)


17

Sunday, August 24th 2008, 11:50pm

Quoted

Original von estebe
@thomas_slrot, Farseer, Egalus: Könntet ihr bitte eure Boards ergänzen?


Meins ist das Asus M3N-H HDMI

Den Patch habe ich noch nicht ausprobiert, da ich es trotz workaround aus dem Forum nicht geschafft habe lirc mit 2.6.26 zu compilieren - und ohne lirc kein WAF ;)
Server: Athlon II X2 250 - Asus M3N-H HDMI - 2x1GB RAM - 3TB HDDs -
1 x Digital Devices Cine S2 V6 DVB-S2 (SD Sender im Highband funktionieren mit der Karte nach wie vor unter Linux nicht, unter Windows schon)
3 x Nova Budget (die ich eigentlich durch die Cine S2 mit Erweiterungsmodul ersetzen wollte, leider aber für die SD Sender immer noch brauche)
mit yavdr 0.4.0

18

Wednesday, August 27th 2008, 10:01pm

Hallo,

kann mir jemand bei meinem ASUS M2A-VM HDMI Nachhilfe geben?

Ich bekomme kein ACPI Wakeup hin. Auch kein WakeOnLAN.

Bios ist Version 2001
Bios ACPI Suspend Type S1&S3 ist eingestellt
Bios APM Power on Schalter sind alle auf Disabled eingestellt
(um WoL zu testen war PCI/PCIe mal eingeschaltet, klappte aber nicht)

(gepatched habe ich nix)

Ich habe soeben das folgende ausgeführt und warte nun auf das Wunder:

Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
vdr:~# hwclock --systohc --utc
vdr:~#
vdr:~# 
vdr:~# hwclock --show
Mi 27 Aug 2008 21:56:09 CEST  -0.000669 seconds 
vdr:~# echo 0 > /sys/class/rtc/rtc0/wakealarm
vdr:~#
vdr:~#  echo `date '+%s' -d '+ 5 minutes'` > /sys/class/rtc/rtc0/wakealarm
vdr:~# cat /proc/driver/rtc
rtc_time        : 19:56:49
rtc_date        : 2008-08-27
alrm_time       : 20:01:45
alrm_date       : 2008-08-27
alarm_IRQ       : yes
alrm_pending    : no
24hr            : yes
periodic_IRQ    : no
update_IRQ      : no
DST_enable      : no
periodic_freq   : 1024
batt_status     : okay
vdr:~#
vdr:~# poweroff  



....das Wunder blieb aus :-(

This post has been edited 2 times, last edit by "Hottenmax" (Aug 27th 2008, 10:07pm)


19

Wednesday, August 27th 2008, 10:18pm

Ich habe das Board Gigabyte GA-MA69GM-S2H mit aktuellem BIOS im Einsatz.
VDR: c't-VDR 6.1 - Gigabyte GA-MA69GM-S2H - Gainward 9400GT - 2GB

20

Wednesday, August 27th 2008, 10:34pm

Quoted

Original von Hottenmax
Hallo,

kann mir jemand bei meinem ASUS M2A-VM HDMI Nachhilfe geben?

Ich bekomme kein ACPI Wakeup hin. Auch kein WakeOnLAN.

Bios ist Version 2001
Bios ACPI Suspend Type S1&S3 ist eingestellt
Bios APM Power on Schalter sind alle auf Disabled eingestellt
(um WoL zu testen war PCI/PCIe mal eingeschaltet, klappte aber nicht)


Hast du denn vor dem Runterfahren das passende Device für die Nic in /proc/acpi/wakeup auf enabled gesetzt damit WOL auch funktionieren kann?
Server: Athlon II X2 250 - Asus M3N-H HDMI - 2x1GB RAM - 3TB HDDs -
1 x Digital Devices Cine S2 V6 DVB-S2 (SD Sender im Highband funktionieren mit der Karte nach wie vor unter Linux nicht, unter Windows schon)
3 x Nova Budget (die ich eigentlich durch die Cine S2 mit Erweiterungsmodul ersetzen wollte, leider aber für die SD Sender immer noch brauche)
mit yavdr 0.4.0