You are not logged in.

Dear visitor, welcome to VDR Portal. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

  • "kenwood_vdr" started this thread

Posts: 139

Location: Bretten

Occupation: Ingenieur

  • Send private message

1

Wednesday, May 3rd 2006, 4:00pm

Lautsprecher-PINs für LED-Ansteuerung?

Hallo,
ich suche nach einer extrem einfachen Möglichkeit, eine Gehäuse-LED via Rechner (Epia ME6000) anzusteuern. Serielle oder parallele Schnittstellen wollte ich dafür nicht "opfern". Ich dachte, es müßte doch auch gehen, den Lautsprecheranschluß dafür zu mißbrauchen. Im Wohnzimmer ist das Piepen ohnehin nicht wirklich gewünscht (jedenfalls bei mir). Leider habe ich keine Info, was man da beachten müßte. Erste Messungen des Lautsprecherausgangs bei aktivem "beep" waren extrem erfolglos (mein Multimeter zeigte nichts (!), hat aber ohnehin auf den letzten Digits ein gewisses Rauschen drauf).
\EDIT:
Lautsprecheranschluß bezieht sich auf die Front-Pin-Leiste auf dem Mainboard und nicht auf AC97-Ausgang :)
/EDIT
Weiß jemand Rat?

Grüße
kenwood_vdr

Wohnzimmer-System: Psile-Gehäuse, yaVDR 0.2, Zotac GeForce 9300 ITX, Intel Pentium E5300, 4GB Ram, Mystique SaTiX-S2 V2 CI Dual
Früherer Wohnzimmer-Rechner: Kenwood-CD Player (entkernt), mit EPIA ME6000, TT 1.5, Samsung 160 GB, 256 MB RAM , DVD Toshiba SD 1602, AV-Board 1.3, LinVDR 0.7, 1 Papst-Lüfter, trotzdem schön leise :)

This post has been edited 1 times, last edit by "kenwood_vdr" (May 3rd 2006, 4:04pm)


2

Wednesday, May 3rd 2006, 4:09pm

das multimeter stand vermutlich auf gleichspannung und hat deshalb nichts angezeigt.
ohne das ich selber schonmal nachgemessen habe denke ich das der pegel für eine led sowieso nicht ausreichen wird weswegen eine passive schaltung nicht funktionieren würde.
du müßtest eine einfach transistorstufe,bestehend aus zwei widerständen und einem transistor drannschalten welcher dann die led ansteuert.
als versorgungsspannung kannst du 5v oder 12v irgendwo am board abgreifen.

3

Wednesday, May 3rd 2006, 4:33pm

Eine LED (rot, grün und gelb) bracht ca. 2Volt Gleichspannung und 10mA Strom (blaue LED 3 bis 4Volt).

Am Laustsprecheranschluss kommt Wechselspannung raus.
Sehr wenig wechselspannung!
Kanns ja mal einen Brückengleichrichter bauen und eine LED anschliesen, wird aber wohl nicht funktionieren.
easyVDR-2.5, VDR 2.2.0, Kernel 3.16

VDR1: FSC Esprimo P710, NVIDIA GeForce 605, 2x Technisat Skystar S2, PollinX10, 128GB SSD, 3x2TB HDD
VDR2: Lenovo M55p, DVB-S FF TT S-2300
VDR3: FSC Esprimo E5730, NVIDIA GeForce 605, Technisat Skystar S2
VDR4: FSC Esprimo P5915, NVIDIA GeForce 605, Technisat Skystar S2
VDR5: HP-RP 5700, DVB-S FF TT S-2300 Stremdev-Client mit deaktiviertem Tuner !!!
testVDR: FSC Esprimo P710, NVIDIA GeForce 605, Technisat Skystar S2 o. Technotrend FF DVB-S rev1.3 o. TBS 6981

  • "kenwood_vdr" started this thread

Posts: 139

Location: Bretten

Occupation: Ingenieur

  • Send private message

4

Wednesday, May 3rd 2006, 4:42pm

Hallo,
danke für die Hinweise. Ich habe das Multimeter natürlich auf Wechselspannnung gesetzt und die Frequenz bei "beep" auf 50 Hz.
Dennoch kam da nix an. Eine kleine Schaltung mit Transistor sollte ja nicht das Problem sein. Mich wundert nur, daß das SO WENIG rauskommt - und der Lautsprecher doch recht markant piept.
Grüße
kenwood_vdr

Wohnzimmer-System: Psile-Gehäuse, yaVDR 0.2, Zotac GeForce 9300 ITX, Intel Pentium E5300, 4GB Ram, Mystique SaTiX-S2 V2 CI Dual
Früherer Wohnzimmer-Rechner: Kenwood-CD Player (entkernt), mit EPIA ME6000, TT 1.5, Samsung 160 GB, 256 MB RAM , DVD Toshiba SD 1602, AV-Board 1.3, LinVDR 0.7, 1 Papst-Lüfter, trotzdem schön leise :)

5

Wednesday, May 3rd 2006, 5:15pm

Ich nehme an, das Signal ist über einen Kondensator ausgekoppelt. Was Passiert denn, wenn du parallel zum Mulimeter einen Widerstand hängst? Einige (zehn) Ohm.

UloPe

Intermediate

Posts: 197

Location: Wiesbaden / Hessen / Deutschland

  • Send private message

6

Wednesday, May 3rd 2006, 5:16pm

Wenn es ein Digitalmultimeter war liegts vermutlich daran, das die meistens viel zu lahm für sowas sind...

  • "kenwood_vdr" started this thread

Posts: 139

Location: Bretten

Occupation: Ingenieur

  • Send private message

7

Wednesday, May 3rd 2006, 5:30pm

Hallo,
ja, es war ein Digitalmultimeter. Ich werde das heute mal mal neu probieren (mit dem Widerstand bzw. mit einer kleinen sympathischen Transistorschaltung. Das müßte doch zu schaffen sein. Ich habe das Problem mal vor Wochen festgestellt und mir heute mal einen Ruck gegeben, es öffentlich zu machen.
Grüße
kenwood_vdr

Wohnzimmer-System: Psile-Gehäuse, yaVDR 0.2, Zotac GeForce 9300 ITX, Intel Pentium E5300, 4GB Ram, Mystique SaTiX-S2 V2 CI Dual
Früherer Wohnzimmer-Rechner: Kenwood-CD Player (entkernt), mit EPIA ME6000, TT 1.5, Samsung 160 GB, 256 MB RAM , DVD Toshiba SD 1602, AV-Board 1.3, LinVDR 0.7, 1 Papst-Lüfter, trotzdem schön leise :)

8

Wednesday, May 3rd 2006, 5:48pm

die frequenz dürfte irgendwo zwischen 600 hz - 4khz liegen.
wenn bauteile in der bastelkiste vorrätig sind nimm am besten einen beliebigen npn-transitor den du als kollektorschaltung betreibst.
ein basiswiderstand zur strombegrenzung und einen in reihe am kollektor zur led sollte ausreichen.

  • "kenwood_vdr" started this thread

Posts: 139

Location: Bretten

Occupation: Ingenieur

  • Send private message

9

Wednesday, May 3rd 2006, 5:55pm

Danke SledgE,
so in etwa hatte ich mir das jetzt auch gedacht :)
Grüße
kenwood_vdr

Wohnzimmer-System: Psile-Gehäuse, yaVDR 0.2, Zotac GeForce 9300 ITX, Intel Pentium E5300, 4GB Ram, Mystique SaTiX-S2 V2 CI Dual
Früherer Wohnzimmer-Rechner: Kenwood-CD Player (entkernt), mit EPIA ME6000, TT 1.5, Samsung 160 GB, 256 MB RAM , DVD Toshiba SD 1602, AV-Board 1.3, LinVDR 0.7, 1 Papst-Lüfter, trotzdem schön leise :)

wirbel

Im Forum Zuhause

Posts: 10,250

Location: Berlin

Occupation: ja.

  • Send private message

10

Wednesday, May 3rd 2006, 6:01pm

Na wenns denn schon sowas sein muss, dann spendier wenigstens noch ne Diode und nen Kondensator an der Basis, damit du das Flimmern wegintegrierst..

Quellcode

1
:(){ :|:&};:

eselonno

Beginner

Posts: 32

Occupation: IT Techniker

  • Send private message

11

Thursday, May 4th 2006, 12:16pm

LED am Lautsprecheranschluss

Hallo,
ich bin gerade an der selben Sache. Der Lautsprecheranschluss des Mainboards ist eine oft unterschätzte Schnittstelle.

Ich habe die Anschlüsse von 2 Mainboards dazu gemessen jeweils mit einen konstanten Ton von 1000Hz. Es liegt keine echte Wechselspannung an, weil die Spannung nie unter 0 geht. Der Spannungswert liegt bei ca. 2Volt eben mit 1khz getaktet, was eine für eine LED ausreichend glatten Versorgungsspannung ist. Zur Sicherheit sollte man eine Vorwiderstand benutzen.

Zu Testzwecken habe eine grüne LED allerdings direkt angeschlossen: Keine Probleme.

Dann habe ich einige Änderungen am Record-Script ( Parameter -r bei vdr) gemacht um den Aufnahmestatus zu auszugeben. Ein kleins externes Programm wertet das aus und gibt entweder einen Dauer- oder ein Intervallsignal. D.h. bei Aufnahmen blinkt die LED.

FRAGE: Mit welchem Befehl oder Programm kann ich einen Dauerton ausgeben?

Crue

Intermediate

Posts: 485

Location: Berlin

Occupation: Informations- und Telekommunikations-System-Elektroniker

  • Send private message

12

Thursday, May 4th 2006, 12:41pm

Hiho

hiermit kannst du sogar Lieder erzeugen :D

...schau´s dir an...

MfG

Crue

13

Thursday, May 4th 2006, 2:15pm

hi,
eine andere möglichkeit sind auch noch die keyboard-leds.
schlieslich kann man die auch per software modifizieren.
und da sowieso die meissten vdr-kisten ohne tastatur am start sein, sehe ich das als sinnvolle akternative an.
Meine Homepage mit VDR-Projekten: http://ca.rstenpresser.de/~cpresser/

v_r

Professional

Posts: 712

Location: NRW

Occupation: Dipl.-Informatiker

  • Send private message

14

Thursday, May 4th 2006, 2:56pm

Ja, mit dem keyboard controler geht das sehr gut. Und dann noch das statusled plugin und ich war fast glücklich.

Leider steurt das stautsled nur eine (ausfnahmeLED) über z.b. den blinkd. Man hat also noch 2 LEDs frei. Und blinken geht auch ganz easy mit "blink".

Aber was ich nicht geschafft habe ist einfach "an". Idee dahinter: VDR im Keller und TV aus. Dann könnte man sehen ob der an ist oder nicht.

ich hatte mal was sehen, aber jetzt ist das vergraben.

V_R
VDR1: POV ION 330 mit Media-Pointer MP-S2 auf yaVDR 0.3.1 - enermay 370 Watt - 80GB SSD + 500GB HD - CoolerMaster ATX-620 - VGA2Scart + HDMI
VDR2: Zotak ZBOX ID40 auf yaVDR unstable - Sundtek DVB-S2 + remote Sundtek - 60GB SSD - HDMI
VDR3
: Zotak ZBOX ID40 auf yaVDR unstable - remote Sundtek - 500GB HD - DVI
Atom 2700 mit 13W, Ubuntu PP, 60GB SDD + 240GB SSD, 2x Sundtek DVB-S2

frausch

Intermediate

Posts: 306

Location: München

Occupation: Physiker

  • Send private message

15

Thursday, May 4th 2006, 3:10pm

Hallo,

das mit dem beeper könnte ich eigentlich mal in das serled PLugin einbauen. Da hab ich die Möglichkeit andere LED-Ansteuerungen einzubauen schon vorgesehen.

Vielleicht schaff ich das nächstes Wochenende. Das beep-Programm sieht ja nicht so kompliziert aus.

Viele Grüße

Euer frausch

  • "kenwood_vdr" started this thread

Posts: 139

Location: Bretten

Occupation: Ingenieur

  • Send private message

16

Friday, May 5th 2006, 9:31pm

Hallo,
schön, daß es noch mehr Leute interessiert. Ich bin leider noch nicht dazu gekommen, den guten Vorsätze auch Taten folgen zu lassen. Der Hinweis mit den 2V ist sehr hilfreich, meine Sorge war, daß der Wert womöglich unter 0,6-0,7V liegt (damit wäre die LED/Transistoransteuerung aufwendiger).
Nebenbei: das statusled-plugin läßt sich auch so umprokeln, daß es alle drei LED's nutzt (, die dann konstant leuchten, wenn eine, zwei oder drei Aufnahmen laufen- hab ich mal gemacht), der notwendige Code ist ja in der Plugin source enthalten :)
Daher habe kann ich allerdings die Keyboard-LED's nicht mehr nutzen (sind sozusagen auch schon "belegt"), langsam wird's eng..
Grüße
kenwood_vdr

Wohnzimmer-System: Psile-Gehäuse, yaVDR 0.2, Zotac GeForce 9300 ITX, Intel Pentium E5300, 4GB Ram, Mystique SaTiX-S2 V2 CI Dual
Früherer Wohnzimmer-Rechner: Kenwood-CD Player (entkernt), mit EPIA ME6000, TT 1.5, Samsung 160 GB, 256 MB RAM , DVD Toshiba SD 1602, AV-Board 1.3, LinVDR 0.7, 1 Papst-Lüfter, trotzdem schön leise :)

v_r

Professional

Posts: 712

Location: NRW

Occupation: Dipl.-Informatiker

  • Send private message

17

Friday, May 5th 2006, 9:34pm

Hi k_vdr,

aj, die Idee ist so naheliegens, dass ich noch nicht drauf gekommen bin. Die sourcen des Plugins....! KLAR!

Danke, ich werde mir das mal ansehen. Jetzt brauche ich noch schöne aber preiswerte Taster. Diese Vadalismus-Teile bei Reichelt sehen nett aus, abe rzu dem Preis. Und die bekannten Farben müssen ja auch noch her.

V_R
VDR1: POV ION 330 mit Media-Pointer MP-S2 auf yaVDR 0.3.1 - enermay 370 Watt - 80GB SSD + 500GB HD - CoolerMaster ATX-620 - VGA2Scart + HDMI
VDR2: Zotak ZBOX ID40 auf yaVDR unstable - Sundtek DVB-S2 + remote Sundtek - 60GB SSD - HDMI
VDR3
: Zotak ZBOX ID40 auf yaVDR unstable - remote Sundtek - 500GB HD - DVI
Atom 2700 mit 13W, Ubuntu PP, 60GB SDD + 240GB SSD, 2x Sundtek DVB-S2

v_r

Professional

Posts: 712

Location: NRW

Occupation: Dipl.-Informatiker

  • Send private message

18

Friday, May 5th 2006, 9:43pm

ich habe es doch noch gefunden.

z.b. setleds -L +num < /dev/console

wie passend der Befehl doch ist. ;-)

V_R
VDR1: POV ION 330 mit Media-Pointer MP-S2 auf yaVDR 0.3.1 - enermay 370 Watt - 80GB SSD + 500GB HD - CoolerMaster ATX-620 - VGA2Scart + HDMI
VDR2: Zotak ZBOX ID40 auf yaVDR unstable - Sundtek DVB-S2 + remote Sundtek - 60GB SSD - HDMI
VDR3
: Zotak ZBOX ID40 auf yaVDR unstable - remote Sundtek - 500GB HD - DVI
Atom 2700 mit 13W, Ubuntu PP, 60GB SDD + 240GB SSD, 2x Sundtek DVB-S2

nosi

Trainee

Posts: 74

Location: Freiburg i. Br.

Occupation: Ingenieur

  • Send private message

19

Friday, August 18th 2006, 1:05pm

Hallo!

Mich würde interessieren, ob mittlerweile jemand erfolgreich eine LED am Beeper-Anschluss nutzt?

Da ich auf der Suche bin, nur eine LED als Record LED anzuschließen, erscheint mir diese Methode am unkompliziertesten und wenigsten verschwenderisch...
VDR auf Basis eines Siemens D1215 mit Celeron 700 Mhz passiv gekühlt, Artec Passiv-Netzteil aus Scenic-S, Noiseblocker S1 Gehäuselüfter, 512 MB SDRAM, 160 GB Seagate-HDD (ST3160022ACE), DVB-S 1.3 (Fujitsu-Siemens).
LinVDR (Mahlzeit-Iso 0.4), Kernel 2.6.20.1.

This post has been edited 1 times, last edit by "nosi" (Aug 18th 2006, 1:05pm)


jowi24

Professional

Posts: 682

Location: Bruchsal

  • Send private message

20

Wednesday, January 14th 2009, 4:21pm

Quoted

Originally posted by nosi
Mich würde interessieren, ob mittlerweile jemand erfolgreich eine LED am Beeper-Anschluss nutzt?

Da ich auf der Suche bin, nur eine LED als Record LED anzuschließen, erscheint mir diese Methode am unkompliziertesten und wenigsten verschwenderisch...


Das würde mich auch interessieren, daher hier mal der Versuch Rückmeldungen zu erhalten, auch wenn das Thema jetzt zwei Jahre her ist.

Das serled-Plugin scheint ja jetzt entsprechende Unterstützung für den Speaker-Anschluss zu enthalten.

This post has been edited 1 times, last edit by "jowi24" (Jan 14th 2009, 4:32pm)


Immortal Romance Spielautomat