You are not logged in.

Dear visitor, welcome to VDR Portal. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

hjt4vdr

Professional

  • "hjt4vdr" started this thread

Posts: 1,239

Location: Austria

  • Send private message

1

Wednesday, April 13th 2005, 12:27pm

[ANNOUNCE] xine-0.7.3 plugin via Netzwerk

Hi,

Habe xine-0.7.3-network auf meine Hompage gestellt.
http://mitglied.lycos.de/peterweber69/


Nicht vergessen, alte Versionen sauber deinstallieren:
cd ......./xine-lib
make uninstall
make clean

Gleiches bei xine-ui

Anmerkung:
Ich konnte die neue xine-lib nur mit der Option --disable-opengl übersetzen.
cd ......./xine-lib
./autogen.sh --disable-opengl
...
Ihr könnt das DVB-Device jetzt wieder auf 1 stellen. Xine schaltet jetzt automatsch um. Ein HOCH auf Reinhard. :prost2

Infos auch im xine-0.7.3 thread:
http://www.vdr-portal.de/board/thread.ph…adid=32712&sid=

Unbedigt dvbplayer3 Patch verwenden!!!

Viel Erfolg
Peter


sidux mit VDR-1.6 + xineliboutput
sidux c't-vdr Installscript
sidux auf distrowatch
__________________
VDR-Server: IBM Netvista PIII 800MHz, sidux/Sid Package, DVB: Nexus-s
VDR-Client: Laptop, sidux xineliboutput

This post has been edited 7 times, last edit by "hjt4vdr" (Apr 13th 2005, 1:12pm)


skan!

Intermediate

Posts: 523

Location: Main-Rheiner

  • Send private message

2

Wednesday, April 13th 2005, 1:47pm

RE: [ANNOUNCE] xine-0.7.3 plugin via Netzwerk

Quoted

Ich konnte die neue xine-lib nur mit der Option --disable-opengl übersetzen.


Hmm, bei mir sauber auch ohne. Liegt vielleicht eher an deiner OpenGL-Installation (oder an der mangelnden ;) ).


hjt4vdr

Professional

  • "hjt4vdr" started this thread

Posts: 1,239

Location: Austria

  • Send private message

3

Wednesday, April 13th 2005, 2:05pm

RE: [ANNOUNCE] xine-0.7.3 plugin via Netzwerk

Hi,

klar, die Frage ist, zahlt sich opengl aus. Soll ich mir die Arbeit antun?

lg
peter

sidux mit VDR-1.6 + xineliboutput
sidux c't-vdr Installscript
sidux auf distrowatch
__________________
VDR-Server: IBM Netvista PIII 800MHz, sidux/Sid Package, DVB: Nexus-s
VDR-Client: Laptop, sidux xineliboutput

skan!

Intermediate

Posts: 523

Location: Main-Rheiner

  • Send private message

4

Wednesday, April 13th 2005, 3:40pm

RE: [ANNOUNCE] xine-0.7.3 plugin via Netzwerk

Sicherlich nicht.

Geht eben auch so. Summa summarum wollt ich halt sagen, dass man es erst ohne das '--disable-opengl' probieren könnte :). Aber egal.

Funzt auf jeden Fall prima bei mir !!!

DANKE !


hjt4vdr

Professional

  • "hjt4vdr" started this thread

Posts: 1,239

Location: Austria

  • Send private message

5

Wednesday, April 13th 2005, 5:19pm

RE: [ANNOUNCE] xine-0.7.3 plugin via Netzwerk

Quoted

Original von skan!
Funzt auf jeden Fall prima bei mir !!!

DANKE !


Bitte gern,
Lobeshymnen per pn.

Spass beiseite, mich würde interessieren wer die Netzwerk Technik benutzt.
Also pn an mich um zu zählen!

bye
peter

sidux mit VDR-1.6 + xineliboutput
sidux c't-vdr Installscript
sidux auf distrowatch
__________________
VDR-Server: IBM Netvista PIII 800MHz, sidux/Sid Package, DVB: Nexus-s
VDR-Client: Laptop, sidux xineliboutput

MR42HH

Intermediate

Posts: 438

Location: Schleswig-Holstein

Occupation: Ingenieur Verfahrenstechnik

  • Send private message

6

Wednesday, April 13th 2005, 7:38pm

Hallo Peter,
würde die Netzwerktechnik liebend gern benutzen ;) klaingt alles sehr gut. Allerdings verwende ich einen Mac. Prinzipiell spräche sicherlich nichts dagegen, die Mac-version von xine entsprechend zu patchen - leider bin ich wohl zu blöd dazu ...
Naja, kommt Zeit, kommt xine!

Gruß,

Mirko

mein VDR:
Siemens Gigaset 740AV, Buffalo Linkstation NAS
in meiner Bastelkiste:
2x Activy 300, 1x MediaPortal mit GLCD, 1x Fujitsu-Siemens Jetson, 1xDVB-C Rev.2.1, Airstar2, neue Nova-T, Linksys NSLU2, defekte 2300C

B-Tronic

Intermediate

Posts: 168

Location: Waibstadt

Occupation: Energieanlagenelektroniker

  • Send private message

7

Wednesday, April 13th 2005, 8:19pm

Hi,

leider bricht ./autogen.sh bei der xine-lib
mit diesem Fehler ab :

using included ffmpeg
checking for X... no
checking for socket in -lsocket... no
checking for gethostbyname in -lnsl... yes
checking for socklen_t... socklen_t
IPv6 is disabled
checking for gzsetparams in -lz... no
configure: error: zlib needed


was benötige ich noch ?? ?(

VDR 1.2.6-27
Kernel 2.4.27
VDR 1: AVG 2, externer Netceiver ,2x Dual DVB-S2 + 1x Dual DVB-S über Gigabit Lan mit Dell Topconnect 2724 Dist: ReelVDR Stable

VDR 2: MSI Mega 180, Sempron 2800,120gb HD,Reel eHD
Dist: ReelVDR Stable

VDR 3: EPIA EN15000 als DVB-Radio Empfänger

Client: 2 Netclients

burki

Professional

Posts: 1,654

Location: Oberbayern

  • Send private message

8

Wednesday, April 13th 2005, 8:24pm

Hi,
sorry aber:

Quoted

configure: error: zlib needed

und

Quoted

was benötige ich noch ?? verwirrt

manchmal muss man schon irgendwie :wand machen ...
Gruss
Burkhardt

B-Tronic

Intermediate

Posts: 168

Location: Waibstadt

Occupation: Energieanlagenelektroniker

  • Send private message

9

Wednesday, April 13th 2005, 8:33pm

@ burki

Danke für die nette Antwort. X(

@ all others

lt. apt ist zlib1g schon die neueste Version.
Deshalb meine Frage was ich noch benötige ??? ?(

MfG B-Tronic
VDR 1: AVG 2, externer Netceiver ,2x Dual DVB-S2 + 1x Dual DVB-S über Gigabit Lan mit Dell Topconnect 2724 Dist: ReelVDR Stable

VDR 2: MSI Mega 180, Sempron 2800,120gb HD,Reel eHD
Dist: ReelVDR Stable

VDR 3: EPIA EN15000 als DVB-Radio Empfänger

Client: 2 Netclients

andreash

Professional

Posts: 582

Location: Regensburg

  • Send private message

10

Wednesday, April 13th 2005, 8:43pm

zlib-devel (oder wie das ding auch immer heisst unter debian, ich bin ein fedora-juenger :-)
VDR: ASUS AT3ION-T, 2GB, Satix S2 Dual, 1TB 2.5", yavdr 0.4
Server: Intel DH67CF, Pentium G620, 8GB, 2x1000GB 2.5" Raid1, WLAN, Ubuntu 12.04 @22W
TV: Panasonic P50G30

hjt4vdr

Professional

  • "hjt4vdr" started this thread

Posts: 1,239

Location: Austria

  • Send private message

11

Thursday, April 14th 2005, 8:12am

RE: [ANNOUNCE] xine-0.7.3 plugin via Netzwerk

Hi,

Quoted


Also pn an mich um zu zählen!


Nun, da es anscheinend nur skan! benutzt werde ich mir das in Zukunft sparen!

bye

sidux mit VDR-1.6 + xineliboutput
sidux c't-vdr Installscript
sidux auf distrowatch
__________________
VDR-Server: IBM Netvista PIII 800MHz, sidux/Sid Package, DVB: Nexus-s
VDR-Client: Laptop, sidux xineliboutput

TheAlamo

Intermediate

Posts: 270

Location: Frankfurt/M.

  • Send private message

12

Thursday, April 14th 2005, 12:42pm

RE: [ANNOUNCE] xine-0.7.3 plugin via Netzwerk

Quoted

Original von peter_weber69
Nun, da es anscheinend nur skan! benutzt werde ich mir das in Zukunft sparen!
Das war jetzt nicht Dein Ernst, oder?

hjt4vdr

Professional

  • "hjt4vdr" started this thread

Posts: 1,239

Location: Austria

  • Send private message

13

Thursday, April 14th 2005, 12:46pm

RE: [ANNOUNCE] xine-0.7.3 plugin via Netzwerk

Sicher :D

sidux mit VDR-1.6 + xineliboutput
sidux c't-vdr Installscript
sidux auf distrowatch
__________________
VDR-Server: IBM Netvista PIII 800MHz, sidux/Sid Package, DVB: Nexus-s
VDR-Client: Laptop, sidux xineliboutput

14

Sunday, April 17th 2005, 5:52pm

@peter_weber69: ich glaube es schreibt keiner was weil dein patch funktioniert, wenn du fehler reinbauen würdest bekämst du vielleicht mehr feedback.... ;-)

ich habe zwar die neue version aus zeitgründen noch nicht drauf, aber mit der alten bin ich sehr zufrieden
ich benutze es auf meiner xbox um da nicht auch noch eine vdr installlation pflegen zu müssen und das menü auf der xbox keine hänger hat


ach ja, ich würde mich auch über einen mac-xine patch freuen

Posts: 2,765

Location: Dormagen (NRW, bei Köln)

Occupation: Bürotippse bei nem Klempner

  • Send private message

15

Sunday, April 17th 2005, 7:45pm

Geht irgendwie nicht bei mir...

Tach Peter...

also bei mir klappt das net, aber ich will auch nicht abstreiten, dass ich irgendwo nen Fehler gemacht hab oder was nicht vollständig installiert habe. Ich denke mal, dass es stark bei mir und nicht an deinen Versionen bzw. Patches liegt.

Ich wollte nur drauf hinweisen, dass sich dieser dvbplayer3.patch mit dem jumplay-Patch überhaupt nicht so richtig verträgt.

Und da die Versionen von Reinhard auf Anhieb liefen und deine nicht und ich Netzwerk erst ma nicht brauche (jedenfalls nicht, bevor ich auch mal nen gescheiten Laptop hab), hab ich erst mal wieder die "alte" Fassung installiert.

Könntest du dir dann ggf. mal den Patch ansehen ??? Immer von Hand da rumorgeln, kann es ja auch nicht sein :()

Greets Olaf

NACHTRAG...bereits knapp zwei Stunden später spricht mich Reinhard im Chat an und ne weitere halbe Stunde später gibbet dann auch nen dvbplayer-Patch, der nicht mehr mit dem jumpplay kollidiert.

WICHTIG: Die Reihenfolge des Aufspielens... erst den Jumpplay-Patch, dann den dvbplayer-Patch vom Xine-Plugin.

An dieser Stelle Danke an Reinhard für den schenllen Support und den angepassten Patch, den ich hier gerne an die Allgemeinheit weiterreiche.
olafhenkel has attached the following file:
Ollie jetzt auch im Internet !!! ->> www.ohms.ws << VDR mit ASUS A7V8X-X, Athlon XP 2 Ghz, 512 MB DDR-RAM und gentoo 2008.0 Linux, ner Menge Platten (1 TB), 2 Brennern und Karten-Vollausstattung (1 X Nexus 4 MB Mod, 3 x Nova, 1 PVR 350) , TFT/Sony PSOne, Nvidia Graka und und und * Linux - wir geben ihrem Computer das Leben zurück *

This post has been edited 2 times, last edit by "olafhenkel" (Apr 17th 2005, 11:54pm)


hjt4vdr

Professional

  • "hjt4vdr" started this thread

Posts: 1,239

Location: Austria

  • Send private message

16

Tuesday, April 19th 2005, 10:29am

neuer wiki Beitrag

Hi,

max4vdr hat freundlicherweise bei der Installation dieses Plugins mitprotokolliert und seine Erfahrungen im wiki zusammengefaßt.

Linux wird mit kanotix hd-installation am PC installiert.
VDR samt plugin händisch übersetzt.

Bitte bringt Eure Erkenntnisse mit ein !!!

http://www.vdr-wiki.de/wiki/index.php/Ho…mit_Xine-Player

:wow

lg
Peter

sidux mit VDR-1.6 + xineliboutput
sidux c't-vdr Installscript
sidux auf distrowatch
__________________
VDR-Server: IBM Netvista PIII 800MHz, sidux/Sid Package, DVB: Nexus-s
VDR-Client: Laptop, sidux xineliboutput

This post has been edited 1 times, last edit by "hjt4vdr" (Apr 22nd 2005, 8:28am)


17

Tuesday, April 19th 2005, 5:58pm

xine-plugin & gcc-4.1

Hallo,

mit gcc-4.1 compiliert das xine-plugin-0.7.3 nicht, egal ob nun die normale oder die Netzwerk Version:

make[1]: Entering directory `/tmp/VDR/PLUGINS/src/xine-0.7.3'
g++-4.1 -g -O3 -mtune=athlon-xp -Wall -Woverloaded-virtual -c -D_GNU_SOURCE -DPLUGIN_NAME_I18N='"xine"' -DFIFO_DIR=\"/tmp/vdr-xine\" `xine-config --cflags` -I../../../include -I../../../../DVB/include xineDevice.c
xineLib.h:31: Warnung: 'class PluginXine::cXineLibEvents' has virtual functions but non-virtual destructor
xineLib.h:89: Fehler: ISO C++ forbids declaration of 'cPlugin' with no type
xineLib.h:89: Fehler: expected ';' before '*' token
xineLib.h:183: Fehler: expected `)' before '*' token
xineDevice.h:102: Fehler: expected `)' before '*' token
xineDevice.h:117: Fehler: 'cPlugin' has not been declared
xineDevice.c:2437: Fehler: expected `)' before '*' token
xineDevice.c:2456: Fehler: 'bool PluginXine::cXineDevice::Create' is not a static member of 'class PluginXine::cXineDevice'
xineDevice.c:2456: Fehler: 'cPlugin' was not declared in this scope
xineDevice.c:2456: Fehler: expected primary-expression before 'const'
xineDevice.c:2456: Fehler: expected primary-expression before '&' token
xineDevice.c:2456: Fehler: 'settings' was not declared in this scope
xineDevice.c:2456: Fehler: expected primary-expression before '*' token
xineDevice.c:2456: Fehler: 'remote' was not declared in this scope
xineDevice.c:2456: Fehler: initializer Ausdrucksliste als zusammengesetzten Ausdruck behandelt
xineDevice.c:2457: Fehler: expected ',' or ';' before '{' token
make[1]: *** [xineDevice.o] Fehler 1
make[1]: Leaving directory `/tmp/VDR/PLUGINS/src/xine-0.7.3'
make: *** [plugins] Fehler 2

Gruß, Ollo

rnissl

Intermediate

Posts: 555

Location: Kulz / Thanstein

Occupation: Software-Entwickler

  • Send private message

18

Tuesday, April 19th 2005, 9:36pm

RE: xine-plugin & gcc-4.1

Hi,

Quoted

Original von ollo
mit gcc-4.1 compiliert das xine-plugin-0.7.3 nicht, egal ob nun die normale oder die Netzwerk Version.


Ergänze mal xineLib.h behelfsmäßig wie folgt:

Source code

1
2
3
4
5
#include "xineSettings.h"

class cPlugin;

namespace PluginXine


Der gcc-4.1 ist ja richtig gut. Schade, dass das mit dem gcc-3.3.4 nicht aufgefallen ist.

Bye.
--
Dipl.-Inform. (FH) Reinhard Nissl
mailto:rnissl@gmx.de

19

Thursday, April 21st 2005, 9:18pm

zlib needed

Hi B-Tronic,

ich habe das selbe Problem: Leider kann ich kein Paket zlib-devel oder ähnlich
finden ? (bzw. apt-get und RPM-seek finden nichts )
Bei Xine-ui komme ich nicht mal bis einer configure datei. autogen bricht schon einer weile ab mit:

Quoted

./autogen.sh
+ Running aclocal: ./autogen.sh: line 1: xine-config: command not found
/usr/share/aclocal/avifile.m4:21: warning: underquoted definition of AM_PATH_AVIFILE
run info '(automake)Extending aclocal'
or see http://sources.redhat.com/automake/autom…nding%20aclocal
aclocal: configure.ac: 128: macro `AM_PATH_XINE' not found in library
done.
+ Running libtoolize: done.
+ Running autoheader: autoheader: error: AC_CONFIG_HEADERS not found in configure.ac

Hast du bereits eine Lösung ?

Mir scheint, dieses Xine plugin bzw. Xine-lib und Xine-ui sind wohl nur was für echte
"Spezies" !

Es wird wohl auch ohne gehen müssen....
Gruß,
Dietmar

Client: Shuttle XPc SK43G - VIAKM400 Sempron 2500+ 512MB - SATA 120GB - TT Rev. 1.3 Yamaha RX V350 Gen2vdr 1.2 , pico-AV Board mit AC3, ACPI
Server: Athlon 1GHz 512MB ACPI TT Rev. 2.3 + Nova S Gen2vdr 1.2 sowie MVP(H4) & vompserver

This post has been edited 1 times, last edit by "dietmar" (Apr 21st 2005, 9:18pm)


rnissl

Intermediate

Posts: 555

Location: Kulz / Thanstein

Occupation: Software-Entwickler

  • Send private message

20

Thursday, April 21st 2005, 9:37pm

RE: zlib needed

Hi,

Quoted

Original von dietmar
ich habe das selbe Problem: Leider kann ich kein Paket zlib-devel oder ähnlich
finden ? (bzw. apt-get und RPM-seek finden nichts )

Kannst du mal configure.log (oder war's config.log?) posten, oder mal nachsehen, warum die libz nicht gefunden wird. Evtl. wird sie ja gefunden, aber das Problem liegt woanders.

Quoted

Original von dietmar
Bei Xine-ui komme ich nicht mal bis einer configure datei. autogen bricht schon einer weile ab mit:

Quoted

./autogen.sh
+ Running aclocal: ./autogen.sh: line 1: xine-config: command not found


Nun, ein dezenter Hinweis, dass xine-lib noch nicht (übersetzt und) installiert wurde.

Bye.
--
Dipl.-Inform. (FH) Reinhard Nissl
mailto:rnissl@gmx.de