Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: VDR Portal. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Samstag, 15. Januar 2011, 20:31

[geloest] [yaVDR 0.3] Kein Sound

Hallo,
trotz langer Suche in den vielen Threads zu diesem Thema bin ich noch nicht fündig geworden.
Ich versuche erstmal nach einer Neuinstallation den analogen Sound zu aktivieren, da ich mit SPDIF noch Verbindungprobleme habe (siehe anderer Beitrag).
Ausgangslage:
Mobo Gigabyte M68M-S2P
Kopfhörer an grüner Ausgangsbuchse angeschlossen.
update und dist-upgrade durchgeführt
von der yavdr-Seite die Einrichtung für HDMI durchgeführt (war wahrscheinlich unnötig, da ich eine Geforce 9500 GT habe)
Im BIOS ist onboard Sound aktiviert.

Ich höre aber keinen Sound. Warum findet er keine Soundkarte (mehr)? Vor einigen Stunden hatte er noch eine gefunden (aber kein Sound). Inzwischen habe ich aber viel ausprobiert.

Quellcode

1
2
aplay -l
aplay: device_list:223: keine Soundkarten gefunden ...

Quellcode

1
2
3
aplay -L
null
    Discard all samples (playback) or generate zero samples (capture)

Quellcode

1
2
sudo alsamixer
 Fehler beim Öffen des Mixer-Gerätes: No such file or directory

Quellcode

1
2
3
4
5
6
7
8
9
lsmod  | grep snd
snd_hda_intel          20799  0
snd_hda_codec          87096  1 snd_hda_intel
snd_hwdep               5668  1 snd_hda_codec
snd_pcm                71646  2 snd_hda_intel,snd_hda_codec
snd_timer              18710  1 snd_pcm
snd                    56687  5 snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_timer
soundcore               6620  1 snd
snd_page_alloc          7140  2 snd_hda_intel,snd_pcm
DVB-S2 TT 1600, GIGABYTE GA-M68M-S2P, AMD-BE2400, Antec Fusion Black, MCE IR-Fernbedienung
yaVDR 0.5

gilt nur für alte Beiträge vor 2011: DVB-S Siemens FF 1.3 (bis 03.10.09 / ab 01.03.10) DVB-S2 TT 1600, GIGABYTE GA-MA78GM-S2H, AMD-BE2400, Antec Fusion Black, MCE IR-Fernbedienung
ab 01.03.10 yaVDR 1.7.10 / Debian 2.6.31 [bis 1.3.10: 2.6.30.5, 11.07.09: 2.6.18, bis 12.09.09: 2.6.26-2-amd64, vdr1.6.0 (keine Distri!)]

Dieser Beitrag wurde bereits 5 mal editiert, zuletzt von »ctvdrnoob« (6. Februar 2011, 20:57)


2

Sonntag, 16. Januar 2011, 12:27

RE: [yaVDR 0.3] Kein Sound

Ich habe yaVDR neu installiert. Jetzt findet er die Soundkarte. Ich bekomme aber noch keine Ausgabe.
Hier die neuen Analysen:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
root@VDR1:~# cat /proc/asound/cards
 0 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xfe024000 irq 22
root@VDR1:~# cat /proc/asound/card0/codec#* | grep Codec
Codec: Realtek ALC887
root@VDR1:~# modprobe -l | grep snd | grep intel
kernel/sound/pci/snd-intel8x0.ko
kernel/sound/pci/snd-intel8x0m.ko
kernel/sound/pci/hda/snd-hda-codec-intelhdmi.ko
kernel/sound/pci/hda/snd-hda-intel.ko
root@VDR1:~# aplay /usr/share/sounds/alsa/Front_Center.wav
Wiedergabe: WAVE '/usr/share/sounds/alsa/Front_Center.wav' : Signed 16 bit Little Endian, Rate: 48000 Hz, mono
root@VDR1:~# alsamixer
Fehler beim Laden der Mixer-Regler: Invalid argument
root@VDR1:~# aplay -l
**** Liste der Hardware-Geräte (PLAYBACK) ****
Karte 0: NVidia [HDA NVidia], Gerät 0: ALC887 Analog [ALC887 Analog]
  Sub-Geräte: 0/1
  Sub-Gerät #0: subdevice #0
Karte 0: NVidia [HDA NVidia], Gerät 1: ALC887 Digital [ALC887 Digital]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0
root@VDR1:~# aplay -L
null
    Discard all samples (playback) or generate zero samples (capture)
default:CARD=NVidia
    HDA NVidia, ALC887 Analog
    Default Audio Device
front:CARD=NVidia,DEV=0
    HDA NVidia, ALC887 Analog
    Front speakers
surround40:CARD=NVidia,DEV=0
    HDA NVidia, ALC887 Analog
    4.0 Surround output to Front and Rear speakers
surround41:CARD=NVidia,DEV=0
    HDA NVidia, ALC887 Analog
    4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=NVidia,DEV=0
    HDA NVidia, ALC887 Analog
    5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=NVidia,DEV=0
    HDA NVidia, ALC887 Analog
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=NVidia,DEV=0
    HDA NVidia, ALC887 Analog
    7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
iec958:CARD=NVidia,DEV=0
    HDA NVidia, ALC887 Digital
    IEC958 (S/PDIF) Digital Audio Output
root@VDR1:~# cat /proc/asound/devices
  2:        : timer
  3: [ 0- 2]: digital audio capture
  4: [ 0- 1]: digital audio playback
  5: [ 0- 1]: digital audio capture
  6: [ 0- 0]: digital audio playback
  7: [ 0- 0]: digital audio capture
  8: [ 0- 0]: hardware dependent
  9: [ 0]   : control
Im Webfrontend ist Analog angekreuzt.
Kann mir noch jemand weiterhelfen?
Welches argument ist invalid beim Aufruf von alsamixer?
DVB-S2 TT 1600, GIGABYTE GA-M68M-S2P, AMD-BE2400, Antec Fusion Black, MCE IR-Fernbedienung
yaVDR 0.5

gilt nur für alte Beiträge vor 2011: DVB-S Siemens FF 1.3 (bis 03.10.09 / ab 01.03.10) DVB-S2 TT 1600, GIGABYTE GA-MA78GM-S2H, AMD-BE2400, Antec Fusion Black, MCE IR-Fernbedienung
ab 01.03.10 yaVDR 1.7.10 / Debian 2.6.31 [bis 1.3.10: 2.6.30.5, 11.07.09: 2.6.18, bis 12.09.09: 2.6.26-2-amd64, vdr1.6.0 (keine Distri!)]

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »ctvdrnoob« (16. Januar 2011, 12:32)


3

Sonntag, 16. Januar 2011, 18:03

Ja ich hab seit heute das selbe problem, update und schwupps ging kein sound mehr.


Bei mir ist es allerdings so das meine kernelmodule für sound nicht laden.

Zitat


root@TV-2:~# modprobe snd-hda-intel
WARNING: Deprecated config file /etc/modprobe.conf, all config files belong into /etc/modprobe.d/.
WARNING: Error inserting soundcore (/lib/modules/2.6.32-27-generic/kernel/sound/soundcore.ko): Invalid module format
WARNING: Error inserting snd (/lib/modules/2.6.32-27-generic/updates/dkms/snd.ko): Invalid module format
WARNING: Error inserting snd_timer (/lib/modules/2.6.32-27-generic/updates/dkms/snd-timer.ko): Invalid module format
WARNING: Error inserting snd_pcm (/lib/modules/2.6.32-27-generic/updates/dkms/snd-pcm.ko): Invalid module format
WARNING: Error inserting snd_hwdep (/lib/modules/2.6.32-27-generic/updates/dkms/snd-hwdep.ko): Invalid module format
WARNING: Error inserting snd_hda_codec (/lib/modules/2.6.32-27-generic/updates/dkms/snd-hda-codec.ko): Invalid module format
FATAL: Error inserting snd_hda_intel (/lib/modules/2.6.32-27-generic/updates/dkms/snd-hda-intel.ko): Invalid module format


Ich werde weiter nach einer lösung suchen, vllt bringt es dich ja weiter.
VDR: yaVDR 0.3, Intel Core2Duo E7200, WinTV Nova-S2

4

Sonntag, 16. Januar 2011, 18:23

ich hab eine lösung für mein problem gefunden.

Zitat


apt-get remove alsa-dkms
apt-get install linux-backports-modules-alsa-2.6.32-27-generic



Ich hoff dir wird dies auch helfen.
VDR: yaVDR 0.3, Intel Core2Duo E7200, WinTV Nova-S2

5

Dienstag, 18. Januar 2011, 22:03

Leider hat es bei mir nicht funktioniert.
Beim Deinstallieren hat er nichts gefunden.
Beim Installieren hat er dann das Paket installiert.

Hat noch jemand eine Idee?
DVB-S2 TT 1600, GIGABYTE GA-M68M-S2P, AMD-BE2400, Antec Fusion Black, MCE IR-Fernbedienung
yaVDR 0.5

gilt nur für alte Beiträge vor 2011: DVB-S Siemens FF 1.3 (bis 03.10.09 / ab 01.03.10) DVB-S2 TT 1600, GIGABYTE GA-MA78GM-S2H, AMD-BE2400, Antec Fusion Black, MCE IR-Fernbedienung
ab 01.03.10 yaVDR 1.7.10 / Debian 2.6.31 [bis 1.3.10: 2.6.30.5, 11.07.09: 2.6.18, bis 12.09.09: 2.6.26-2-amd64, vdr1.6.0 (keine Distri!)]

6

Freitag, 21. Januar 2011, 21:15

Hat noch jemand einen Tip für mich, wie ich die Fehlersuche weiter durchführen kann?
DVB-S2 TT 1600, GIGABYTE GA-M68M-S2P, AMD-BE2400, Antec Fusion Black, MCE IR-Fernbedienung
yaVDR 0.5

gilt nur für alte Beiträge vor 2011: DVB-S Siemens FF 1.3 (bis 03.10.09 / ab 01.03.10) DVB-S2 TT 1600, GIGABYTE GA-MA78GM-S2H, AMD-BE2400, Antec Fusion Black, MCE IR-Fernbedienung
ab 01.03.10 yaVDR 1.7.10 / Debian 2.6.31 [bis 1.3.10: 2.6.30.5, 11.07.09: 2.6.18, bis 12.09.09: 2.6.26-2-amd64, vdr1.6.0 (keine Distri!)]

XThunder

Anfänger

Beiträge: 52

Wohnort: Langen (Hessen)

Beruf: Softwareentwickler

  • Nachricht senden

7

Freitag, 21. Januar 2011, 21:33

Hallo!

Nur um sicher zu gehen:

1. Ist irgendetwas gemutet? Schau doch mal im alsamixer.
2. Mit aplay alle devices ausprobiert?

Gruß,
XThunder
Antec Fusion Remote Silver, Nvidia G210, XUbuntu 10.04, yavdr (stable-vdr), XBMC 10.0 Dharma+pvr+imonpatch

Once you eliminate the impossible, whatever remains, no matter how improbable, must be the truth. (Arthur Conan Doyle)

8

Freitag, 21. Januar 2011, 21:54

Alsamixer funktioniert ja nicht (siehe oben).
"alsamixer
Fehler beim Laden der Mixer-Regler: Invalid argument"
DVB-S2 TT 1600, GIGABYTE GA-M68M-S2P, AMD-BE2400, Antec Fusion Black, MCE IR-Fernbedienung
yaVDR 0.5

gilt nur für alte Beiträge vor 2011: DVB-S Siemens FF 1.3 (bis 03.10.09 / ab 01.03.10) DVB-S2 TT 1600, GIGABYTE GA-MA78GM-S2H, AMD-BE2400, Antec Fusion Black, MCE IR-Fernbedienung
ab 01.03.10 yaVDR 1.7.10 / Debian 2.6.31 [bis 1.3.10: 2.6.30.5, 11.07.09: 2.6.18, bis 12.09.09: 2.6.26-2-amd64, vdr1.6.0 (keine Distri!)]

XThunder

Anfänger

Beiträge: 52

Wohnort: Langen (Hessen)

Beruf: Softwareentwickler

  • Nachricht senden

9

Samstag, 22. Januar 2011, 13:38

Hi,

sorry, hatte ich übersehen.

Kann es sein, dass du mit diesem Bug zu tun hast? https://bugs.launchpad.net/ubuntu/+sourc…ver/+bug/669092

Gruß,
XThunder
Antec Fusion Remote Silver, Nvidia G210, XUbuntu 10.04, yavdr (stable-vdr), XBMC 10.0 Dharma+pvr+imonpatch

Once you eliminate the impossible, whatever remains, no matter how improbable, must be the truth. (Arthur Conan Doyle)

10

Freitag, 28. Januar 2011, 21:10

Ich habe die .deb (siehe Link von XThunder, dann #8) installiert und rebootet. Leider funktioniert der Aufruf von alsamixer immer noch nicht.
Hat noch jemand einen Tip?
DVB-S2 TT 1600, GIGABYTE GA-M68M-S2P, AMD-BE2400, Antec Fusion Black, MCE IR-Fernbedienung
yaVDR 0.5

gilt nur für alte Beiträge vor 2011: DVB-S Siemens FF 1.3 (bis 03.10.09 / ab 01.03.10) DVB-S2 TT 1600, GIGABYTE GA-MA78GM-S2H, AMD-BE2400, Antec Fusion Black, MCE IR-Fernbedienung
ab 01.03.10 yaVDR 1.7.10 / Debian 2.6.31 [bis 1.3.10: 2.6.30.5, 11.07.09: 2.6.18, bis 12.09.09: 2.6.26-2-amd64, vdr1.6.0 (keine Distri!)]

11

Sonntag, 30. Januar 2011, 10:09

Ich habe jetzt auf die aktuelle alsa-Version geupdatet. Jetzt wird die Soundkarte mit cat /proc/asound/cards wieder nicht erkannt, sondern nur noch mit

Quellcode

1
2
lspci | grep -i audio
00:05.0 Audio device: nVidia Corporation MCP61 High Definition Audio (rev a2)
(sieht aber anders aus als die vorige Ausgabe!).

In der /etc/modprobe.d/alsa-base.conf habe ich am Ende "options snd-hda-intel model=3stack-dig" und in /etc/modules "snd-hda-intel model=3stack-dig" eingetragen laut Anleitung.
Aber es funktioniert immer noch nicht.

Quellcode

1
2
3
sudo modprobe snd-hda-intel model=3stack-die
WARNING: All config files need .conf: /etc/modprobe.d/sound, it will be ignored in a future release.
FATAL: Error inserting snd_hda_intel (/lib/modules/2.6.32-28-generic/updates/dkms/snd-hda-intel.ko): Unknown symbol in module, or unknown parameter (see dmesg)

Was kann ich machen?
DVB-S2 TT 1600, GIGABYTE GA-M68M-S2P, AMD-BE2400, Antec Fusion Black, MCE IR-Fernbedienung
yaVDR 0.5

gilt nur für alte Beiträge vor 2011: DVB-S Siemens FF 1.3 (bis 03.10.09 / ab 01.03.10) DVB-S2 TT 1600, GIGABYTE GA-MA78GM-S2H, AMD-BE2400, Antec Fusion Black, MCE IR-Fernbedienung
ab 01.03.10 yaVDR 1.7.10 / Debian 2.6.31 [bis 1.3.10: 2.6.30.5, 11.07.09: 2.6.18, bis 12.09.09: 2.6.26-2-amd64, vdr1.6.0 (keine Distri!)]

12

Sonntag, 30. Januar 2011, 13:38

habe eben auch ein Update gemacht => kein Sound mehr :-(

Quellcode

1
2
/etc/modprobe.d$ aplay -l
**** Liste der Hardware-Geräte (PLAYBACK) ****


Quellcode

1
2
/etc/modprobe.d$ lspci | grep -i audio
01:00.1 Audio device: nVidia Corporation High Definition Audio Controller (rev a1)


in /etc/modprobe.d/alsa-base.conf:
options snd-hda-intel model=auto probe_mask=1

in /etc/modules:
snd-hda-intel model=auto

alsamixer Version 1.0.23:
Gerät: HDA NVidia
Chip: Nvidia ID b
"Dieses Gerät hat keine Regler"

Was kann ich nun machen??

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »BigT« (30. Januar 2011, 13:40)


13

Samstag, 5. Februar 2011, 22:45

Ich habe jetzt einen Teilerfolg. Der PCI-Soundkarte habe ich im Terminal Geräusche entlocken können mit speaker-test.
Aber in yavdr funktioniert sie nicht. In der asound.conf habe ich

Quellcode

1
2
3
4
5
6
pcm.analog {
type hw
card 0
device 0
channels 2
}
eingetragen.

Was kann ich machen, um den Sound analog auszugeben?
DVB-S2 TT 1600, GIGABYTE GA-M68M-S2P, AMD-BE2400, Antec Fusion Black, MCE IR-Fernbedienung
yaVDR 0.5

gilt nur für alte Beiträge vor 2011: DVB-S Siemens FF 1.3 (bis 03.10.09 / ab 01.03.10) DVB-S2 TT 1600, GIGABYTE GA-MA78GM-S2H, AMD-BE2400, Antec Fusion Black, MCE IR-Fernbedienung
ab 01.03.10 yaVDR 1.7.10 / Debian 2.6.31 [bis 1.3.10: 2.6.30.5, 11.07.09: 2.6.18, bis 12.09.09: 2.6.26-2-amd64, vdr1.6.0 (keine Distri!)]

14

Sonntag, 6. Februar 2011, 14:19

Ich hab es jetzt hinbekommen.
In der Gruppe audio fehlte mein Benutzername. Es war nur vdr eingetragen.
Hier nochmal zum Nachvollziehen:
sudo vi /etc/groups
dort in der Zeile mit audio steht vdr am Ende. Da habe ich mit Komma getrennt meinen Benutzernamen hinzugefügt.
Neustart, und es läuft.

Ein weiteres Problem ist jetzt, daß der Sony Bravia auf HDMI5 keinen Ton ausgibt. Wenn ich die Cinch-Buchsen an den AV6 Anschluß stecke, kommt Ton (dann hab ich aber kein Bild).
Wenn jemand dazu noch Tipps hat, immer her damit.
DVB-S2 TT 1600, GIGABYTE GA-M68M-S2P, AMD-BE2400, Antec Fusion Black, MCE IR-Fernbedienung
yaVDR 0.5

gilt nur für alte Beiträge vor 2011: DVB-S Siemens FF 1.3 (bis 03.10.09 / ab 01.03.10) DVB-S2 TT 1600, GIGABYTE GA-MA78GM-S2H, AMD-BE2400, Antec Fusion Black, MCE IR-Fernbedienung
ab 01.03.10 yaVDR 1.7.10 / Debian 2.6.31 [bis 1.3.10: 2.6.30.5, 11.07.09: 2.6.18, bis 12.09.09: 2.6.26-2-amd64, vdr1.6.0 (keine Distri!)]

15

Sonntag, 6. Februar 2011, 16:11

Ich habe im alsamixer spdif un-muted. Danach ging der Ton nicht mehr.
Danach habe ich die Einstellung wieder zurückgenommen, aber Ton ging immer noch nicht.
Im WF dann nochmal analog ausgewählt und "Setze Ton Einstellung". Danach war die asound.conf weg.
Wieder neu erstellt mit:
pcm.!default {
type hw
card 0
device 0
}
half auch nichts. Nach jeder Änderung hab ich rebootet.
Die Rechte stimmen in audio auch noch.
Beim speaker-test kommt Ton.

Wie überrede ich yavdr den Ton auszugeben?
DVB-S2 TT 1600, GIGABYTE GA-M68M-S2P, AMD-BE2400, Antec Fusion Black, MCE IR-Fernbedienung
yaVDR 0.5

gilt nur für alte Beiträge vor 2011: DVB-S Siemens FF 1.3 (bis 03.10.09 / ab 01.03.10) DVB-S2 TT 1600, GIGABYTE GA-MA78GM-S2H, AMD-BE2400, Antec Fusion Black, MCE IR-Fernbedienung
ab 01.03.10 yaVDR 1.7.10 / Debian 2.6.31 [bis 1.3.10: 2.6.30.5, 11.07.09: 2.6.18, bis 12.09.09: 2.6.26-2-amd64, vdr1.6.0 (keine Distri!)]

zaubi4u

Profi

Beiträge: 877

Wohnort: Schöneiche bei Berlin

Beruf: Fachgutachter

  • Nachricht senden

16

Sonntag, 6. Februar 2011, 16:26

RE: [doch nicht geloest] [yaVDR 0.3] Kein Sound

hi ctvdrnoob,

aplay -l und aplay -L musst du auch als root ausführen :)

Gruß Micha

Meine vdr's

vdr 1 | yavdr 0.5a (vdr 2.06) | GA-G41M-Combo | Pentium E6700 | GT220 | 4GB | 40 GB Intel SSD + 10,5 TB auf 4 HDD's | Mystique SaTIX-S2 sky express dual | Keysonic KSK-3200RF | Harmony 650 | Onkyo TX-NR616 | 42" Philips LCD, Acer Beamer H6520BD
vdr 2 | yavdr 0.5 | GA-870A-USB3 | AMD II X2 270 | NVidia GT630 | 8GB (Testclient, z.Z. inaktiv)
vdr 3 | yavdr 0.5 | ASUS Pundit P2-M2A690G | AMD Dual core | NVidia GT610 | DVB-S2 (TeVii S464) | 2GB | 42" Philips LCD
vdr 4 | yavdr 0.6-frodo (vdr 2.20, Kernel 4.4) | Nvidia MCP79/7A/N330 ION (mini-ITX) | 2GB | 500GB HDD | MCE FB (USB)
vdr 5 | linvdr 0.7 (vdr 1.4.7) |
vdr client: vdr-live mit vlc-plugin auf PC unter Windows und UBUNTU
vdr user #714

17

Sonntag, 6. Februar 2011, 16:37

RE: [doch nicht geloest] [yaVDR 0.3] Kein Sound

Das verstehe ich nicht.
aplay funktioniert doch (siehe letzter Beitrag). Bloß von yavdr wird nichts ausgegeben.
Hier noch ein paar Ausgaben:

Quellcode

1
2
3
4
sudo aplay -Dplughw:0,0 -fcd /usr/share/sounds/alsa/Noise.wav
Wiedergabe: WAVE '/usr/share/sounds/alsa/Noise.wav' : Signed 16 bit Little Endian, Rate: 48000 Hz, mono
@VDR1:~$ sudo aplay -Dplughw:0,0 -fcd /usr/share/sounds/alsa/Noise.wav
Wiedergabe: WAVE '/usr/share/sounds/alsa/Noise.wav' : Signed 16 bit Little Endian, Rate: 48000 Hz, mono

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
sudo aplay -L
null
    Discard all samples (playback) or generate zero samples (capture)
front:CARD=AudioPCI,DEV=0
    Ensoniq AudioPCI, ES1371 DAC2/ADC
    Front speakers
rear:CARD=AudioPCI,DEV=0
    Ensoniq AudioPCI, ES1371 DAC1
    Rear speakers
surround40:CARD=AudioPCI,DEV=0
    Ensoniq AudioPCI, ES1371 DAC2/ADC
    4.0 Surround output to Front and Rear speakers
iec958:CARD=AudioPCI,DEV=0
    Ensoniq AudioPCI, ES1371 DAC2/ADC
    IEC958 (S/PDIF) Digital Audio Output

Quellcode

1
2
3
4
5
6
7
8
sudo aplay -l
**** Liste der Hardware-Geräte (PLAYBACK) ****
Karte 0: AudioPCI [Ensoniq AudioPCI], Gerät 0: ES1371/1 [ES1371 DAC2/ADC]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0
Karte 0: AudioPCI [Ensoniq AudioPCI], Gerät 1: ES1371/2 [ES1371 DAC1]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0
DVB-S2 TT 1600, GIGABYTE GA-M68M-S2P, AMD-BE2400, Antec Fusion Black, MCE IR-Fernbedienung
yaVDR 0.5

gilt nur für alte Beiträge vor 2011: DVB-S Siemens FF 1.3 (bis 03.10.09 / ab 01.03.10) DVB-S2 TT 1600, GIGABYTE GA-MA78GM-S2H, AMD-BE2400, Antec Fusion Black, MCE IR-Fernbedienung
ab 01.03.10 yaVDR 1.7.10 / Debian 2.6.31 [bis 1.3.10: 2.6.30.5, 11.07.09: 2.6.18, bis 12.09.09: 2.6.26-2-amd64, vdr1.6.0 (keine Distri!)]

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »ctvdrnoob« (6. Februar 2011, 16:38)


18

Sonntag, 6. Februar 2011, 17:30

RE: [doch nicht geloest] [yaVDR 0.3] Kein Sound

Ich kenne mich zwar nicht sonderlich aus mit alsa, aber dein aplay statement benutzt plughw, deine asound.conf aber nicht. Um Vergleichbar zu sein müsste das wohl eher so aussehen:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
pcm.digital
        {
        type hw
        card 0
        device 0
}

pcm.!default {
        type plug
        slave.pcm digital
}
.
Du kannst das ja mal ausprobieren.


Davon mal abgesehen, was hast du eigentlich im Webfrontend eingestellt?

Gerald

HP Proliant MicroServer Gen8, Xeon E3-1230, 12 GB RAM, 3xWD red 2TB im RAID 5, 2xSundtek MediaTV Home DVB-C/T, L4M TWIN-C/T, Ubuntu Server 14.04.1, Plex Media Server
Samsung UE55H6470

19

Sonntag, 6. Februar 2011, 18:51

RE: [doch nicht geloest] [yaVDR 0.3] Kein Sound

@gda:
Ich habe deinen Vorschlag ausprobiert. Hat nicht funkioniert.

Im WF habe ich analog eingestellt. Da der onboard Sound nicht funktionierte, habe ich eine alte Soundkarte eingebaut und wollte erstmal analog den Ton ausgeben. Hat ja auch kurzzeitig (bis zu meiner Spielerei mit spdif) funktioniert.

Ziel ist aber den onboard Sound über die Grafikkarte an HDMI zu übergeben.

Ich habe jetzt meine ursprüngliche asound.conf wieder drin. Auf Konsole funktioniert auch das:

Quellcode

1
2
sudo aplay -D hw:0,0 /usr/share/sounds/alsa/Noise.wav
Wiedergabe: WAVE '/usr/share/sounds/alsa/Noise.wav' : Signed 16 bit Little Endian, Rate: 48000 Hz, mono


edit//: nach Hard-Reset ist jetzt auch der yaVDR Ton wieder auf der Buchse.
DVB-S2 TT 1600, GIGABYTE GA-M68M-S2P, AMD-BE2400, Antec Fusion Black, MCE IR-Fernbedienung
yaVDR 0.5

gilt nur für alte Beiträge vor 2011: DVB-S Siemens FF 1.3 (bis 03.10.09 / ab 01.03.10) DVB-S2 TT 1600, GIGABYTE GA-MA78GM-S2H, AMD-BE2400, Antec Fusion Black, MCE IR-Fernbedienung
ab 01.03.10 yaVDR 1.7.10 / Debian 2.6.31 [bis 1.3.10: 2.6.30.5, 11.07.09: 2.6.18, bis 12.09.09: 2.6.26-2-amd64, vdr1.6.0 (keine Distri!)]

Dieser Beitrag wurde bereits 5 mal editiert, zuletzt von »ctvdrnoob« (6. Februar 2011, 20:59)


Immortal Romance Spielautomat