Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: VDR Portal. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

wirbel

Im Forum Zuhause

  • »wirbel« ist der Autor dieses Themas

Beiträge: 10 364

Wohnort: Berlin

Beruf: ja.

  • Nachricht senden

21

Freitag, 15. Februar 2008, 13:08

v4l-hg verwenden.

Quellcode

1
:(){ :|:&};:

22

Sonntag, 17. Februar 2008, 12:11

Zitat

Originally posted by pomper
Die Fernbedienung der HVR-1300 bzw der PVR-350 funktioniert nicht, aber das mag an meiner mangelnder Kenntniss der Materie liegen.
Guck mal hier, neuerdings soll sie laufen, mit neuem v4l-hg tree und Patches, ich werde es bald auprobieren.
@wirbel:
Wie sieht es denn mittlerweile aus mit pvrinput und der HVR1300? Wenn der analoge Teil in VDR mal geht, wie wird er sich die Hardwareresourcen der Karte mit dem DVB-T Teil teile, gibt es denn schon einen Mechanismus im Treiber, der das steuert?

8)

VDR 1: Asus M3N78-EM, Athlon X2 5050e, 4GB RAM, SSD 128G + HDD 1TB + 1.5TB, ZOTAC GeForce GT630 ZONE Edition 1GB DDR3, Linux4Media-Twin S2 ver 5.5, jeweils 4 Sat-Positionen an T90, Pollin X10, Sabayon gespickt mit Gentoo ~amd64, vdr-2.2.0, softhddevice-git, kodi-15.2, eventlircd
VDR 2: Wetek Play OpenELEC Edition
AV-Komponenten: VDPAU 1080p -> HDMI -> Pioneer VSX-920-K -> LG 42LH4000

Gentoo overlay mit VDR (und nicht nur) ebuilds, vdrcm, GLCDprocDriver

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Zoolook« (17. Februar 2008, 12:12)


wirbel

Im Forum Zuhause

  • »wirbel« ist der Autor dieses Themas

Beiträge: 10 364

Wohnort: Berlin

Beruf: ja.

  • Nachricht senden

23

Sonntag, 17. Februar 2008, 12:23

Ich kann z.Z. TV sehen per analog. Meine aktuelle Testversion von pvrinput schließt alle Zugriffe auf die Karte wieder, wenn sie nicht gerade benötigt wird.

Das gilt leider nicht für dvb devices in VDR, die bleiben geöffnet. Mit andren Worten: entweder jmd. schreibt einen Patch für dvbdevice.c, der dafür sorgt, dass die devices dort nur zugreifen, wenn auf einen dvb Kanal zugegriffen wird oder aber man muss sich beim VDR Start entscheiden was man nutzen möchte: analog oder dvb-t via hvr1300.

Von der Treiberseite aus kann immer nur ein device geöffnet werden: dvb-t oder analog.

PS: externe Eingänge gehn noch nicht, Radio geht noch nicht, Videotext geht noch nicht (und wird nicht gehen).

Quellcode

1
:(){ :|:&};:

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »wirbel« (17. Februar 2008, 12:26)


24

Sonntag, 17. Februar 2008, 15:50

Zitat

Original von Zoolook

Zitat

Originally posted by pomper
Die Fernbedienung der HVR-1300 bzw der PVR-350 funktioniert nicht, aber das mag an meiner mangelnder Kenntniss der Materie liegen.
Guck mal hier, neuerdings soll sie laufen, mit neuem v4l-hg tree und Patches, ich werde es bald auprobieren.


Ich seh schon, das scheint hier doch einiges komplexer zu sein, als einen Mail-, Fax- und wasweisichnichtnoch Server unter Linux zu installieren .... also dann werd ich mal in die (Un)tiefen von Linux absteigen ....
Greetings ..... Pomper

25

Donnerstag, 5. Februar 2009, 16:01

Hi wirbel,

Wollt mal fragen, wie denn so der aktuelle Stand von pvrinput für die HVR 1300 aussieht. Hab seit einiger Zeit auch so eine hier rumliegen und würde sie gern für den VDR verwenden.
Ist deine Testversion denn soweit lauffähig, dass man es vernünftig einsetzen kann?
Wäre außerdem selbst daran interessiert, evtl. beim rumbasteln mitzuhelfen. Müsste mich dazu nur etwas in die Materie einarbeiten.

Wenn möglich würde ich deine Version mal selbst ausprobieren. Könntest du die mir schicken?

Gruß,
Nostradani
HW: Asus AT3N7A-I, 2GB RAM, Nvidia ION, Technisat CableStar HD2 DVB-C, SW: yaVDR 0.2 mit XBMC als primäres Frontend

wirbel

Im Forum Zuhause

  • »wirbel« ist der Autor dieses Themas

Beiträge: 10 364

Wohnort: Berlin

Beruf: ja.

  • Nachricht senden

26

Samstag, 7. Februar 2009, 23:15

Der Stand ist folgender:

- audio geht nicht, nur Rauschen, video geht - zumindest genau so lange wie man keine controls auf die Karte loslässt (ich hatte schon eine Treiber Version, bei der wenigstens DAS ging, aber leider haben mich ein paar Daten bei einem HD-Crash verlassen) - genau die Steuerung mit den controls ist aber unumgänglich

- alle controls lassen sich in pvrinput steuern (helligkeit, hue, contrast, video-format, lautstärke...) ohne Fehlermeldung vom Treiber ; aber wenn die Karte dann initialisiert ist hängt sich das mpeg device auf und kein einziges byte kommt mehr raus. :-(, nicht einmal auf der Konsole mit 'cat'. Einzige Möglichkeit dann: Treiber ent- und neu laden.

- die Karte kann zum Sendersuchen verwendet werden (wirbelscan/w_pvrscan), aber danach hängt wieder das mpeg device und nix geht mehr -> Treiber neu laden.

Fazit: die Karte hat nen wunderbaren mpeg encoder drauf und die Bildquali ist wie bei den andren pvr Karten; aber mangels brauchbaren Treibern ist bis heute nichts nutzbar mit vdr.

Quellcode

1
:(){ :|:&};:

Immortal Romance Spielautomat